Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Bolquear Cliente Com pppoe e o cliente receber pagina de aviso de pagina de pendecia

    Boa noite amigos do forum.
    Tenho uma inadiplencia muito grande para um provedor do porte do meu, e ando tendo dificuldade com clientes pois corto eles desativando no secrets do pppoe e eles não navegam, Mais gostaria de rebloquea-los de uma forma que eles fossem redirecionados para uma pagina de aviso de pendecia financeira onde talvez ficasse mais facil para eles entenderem talvez mais rapido ou algo assim pra eles pagarem mais rapido sei la. Algo assim.
    Desde ja eu agradeço e pesso a colaboração de vcs amigos mais experientes do forum.
    espero que vocês possam me ajudar e quando puder ajudarei tambem.

  2. #2

    Padrão

    chain=dstnat action=dst-nat to-addresses=ip_seu_site_inadimplentes=80
    protocol=tcp src-address=10.10.10.1-10.10.10.255 dst-port=80
    = pool clientes bloqueados=porta http

    chain=dstnat action=dst-nat to-addresses=ip_seu_site_inadimplentes to-ports=80
    protocol=tcp src-address=10.10.10.1-10.10.10.255 dst-port=8080
    = pool clientes bloqueados=porta http proxy



  3. #3

    Thumbs up

    Citação Postado originalmente por ElonPJr Ver Post
    Boa noite amigos do forum.
    Tenho uma inadiplencia muito grande para um provedor do porte do meu, e ando tendo dificuldade com clientes pois corto eles desativando no secrets do pppoe e eles não navegam, Mais gostaria de rebloquea-los de uma forma que eles fossem redirecionados para uma pagina de aviso de pendecia financeira onde talvez ficasse mais facil para eles entenderem talvez mais rapido ou algo assim pra eles pagarem mais rapido sei la. Algo assim.
    Desde ja eu agradeço e pesso a colaboração de vcs amigos mais experientes do forum.
    espero que vocês possam me ajudar e quando puder ajudarei tambem.
    Olá amigo!

    Bom, vamos lá!

    Você vai precisar de um servidor que rode Apache para colocar sua pagina de aviso ou hospedar seu aviso em um servidor externo! Eu prefiro interno mesmo!
    Vou explicar mais ou menos como funciona o interno!

    Crie uma regra em IP>Firewall>NAT

    /ip firewall nat
    add action=netmap chain=dstnat comment=Bloqueados disabled=no dst-port=0-65535 protocol=tcp src-address-list=ipsBloqueados to-addresses=192.26.0.1 to-ports=83


    Esta regra tem que vir antes dos dstnat que faz o roteamento dos seus clientes!

    Onde o ip do Server do apache é 192.168.0.1 e a porta que destinei ao aviso é a 83, no seu caso se for externo pode se usar a porta 80 é o ip externo do Server ou da forma que preferir!

    Também como pode ver não tem ip de entrada do cliente pois eles eu coloco na lista em anddress list

    Então vamos ao anddress list

    /ip firewall address-list
    add address=174.25.0.4 comment=Giovani disabled=yes list=ipsBloqueados


    Quando você coloca o cara na lista e habilita ele e bloqueado e redirecionado para seu aviso!

    Você pode adaptar da maneira que achar melhor!

    Por exemplo tenho duas regras diferentes uma é esta e outra e um de aviso que de 10 em 10 minutos vai o aviso pro inadimplente

    Esta de tempo em tempo você cria a regra do Nat e coloca o cara na lista e vai no script cria duas regras , uma para ativar o redirecionamento do Nat e outra para desativar e depois vai em Schedule e coloque dois intervalos de tempo onde um vai rodar o script que vai ativar a regra de redirecionamento onde vai pegar o cara que tiver na lista e vai mandar o aviso e a outra faz o inverso liberando o acesso!

    Qualquer duvida coloca ai!

    Abraços

  4. #4

    Padrão

    tem como fazer isso pelo squid?
    tipow..
    os clientes que eu colocar em uma certa lista, serao direcionados para tal pagina qdo tentarem navegar???



  5. #5

    Padrão

    1- ip > pool -> crie um pool
    2- ip firewall nat -> crie uma regra desviando o pool criado para um servidor na porta 80.. onde sera mostrada tela de advertencia..

    quando bloquear o cliente.. seta pra ele pegar o ip do pool criado..

  6. #6

    Padrão

    creio que eu nao tenha sido claro.

    gostaria de saber se tem como bloquear o cliente, e ele receber pagina de aviso.. sendo que, nao uso mk!
    gostaria de fazer isso ou pelo iptables ou pelo squid... creio que o squid seja mais facil... tinha visto isso em algum lugar, mas nao consegui encontrar.



  7. #7

    Padrão

    mesmo assim.. sem usar mikrotik..

    cria um pool no radius.. e seta o ip diferente para estes clientes bloqueados... deppis:


    iptables -t nat -A PREROUTING -s 10.15.20.0/24 -j DNAT --to-destination 192.168.0.1:80

    assim ele direciona o bloco 10.15.20.0/24 para o servidor web.. onde deta pagina de aviso

  8. #8

    Padrão

    Você também pode usar o hotspot.



  9. #9

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    1- ip > pool -> crie um pool
    2- ip firewall nat -> crie uma regra desviando o pool criado para um servidor na porta 80.. onde sera mostrada tela de advertencia..

    quando bloquear o cliente.. seta pra ele pegar o ip do pool criado..

    Grande alexandre, deixa eu ver se eu entendi esse bloqueio vai ser necessario o servidor apache, ou eu conseguirei direto pelo mikrotik, desculpe a ignorância como criar a regra, obrigado pela sua enorme contribuiçao pois contigo ja aprendi muito!


    Desde já agradeço!

  10. #10

    Padrão

    sim precisa de um servidor apache, o bom de montar um é que voce pode montar um sistema para o seu usuario digitar login e senha, o cliente podera emitir as vias atrasadas etc etc...

    nao tentei colocar arquivos html no mikrotik, mas tambem deve dar certo..



  11. #11

    Padrão

    ahh.. obrigado pelas boas palavras

  12. #12

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    ahh.. obrigado pelas boas palavras
    Alexandre sei de fato devo a muito a você o Catv, entre outro que sempre contribui muito com excelente forum, passando o conhecimento que na verdade são horas ou até mesmo dias, semanas de dedicação para nos se não fosse essa enorme contribuição seria dificil ter esse conhecimento, e com um detalhe sem nunca mensionar valor, somente pela união e o prazer de ajudar o proximo, o que hoje está ficando cada vez mais dificil no mundo onde vivemos cada vez mais capitalista!

    Desculpe ao criador do topico estar um pouco desvirtuando o tópico, mas é que de fato o Alexandre, não tem como não deixar de agradecer pois o que eu já aprendi com ele, acho q seria dificil pagar, pois a experencia, é uma coisa dificil de colocar o valor!

    Agradeço a vc em especial, e a todos!

    Um forte abraço!

    Que deus abençõe a todos!



  13. #13

    Padrão Não deucerto o redirecionamento.

    Citação Postado originalmente por Giovani.couto Ver Post
    Olá amigo!

    Bom, vamos lá!

    Você vai precisar de um servidor que rode Apache para colocar sua pagina de aviso ou hospedar seu aviso em um servidor externo! Eu prefiro interno mesmo!
    Vou explicar mais ou menos como funciona o interno!

    Crie uma regra em IP>Firewall>NAT

    /ip firewall nat
    add action=netmap chain=dstnat comment=Bloqueados disabled=no dst-port=0-65535 protocol=tcp src-address-list=ipsBloqueados to-addresses=192.26.0.1 to-ports=83


    Esta regra tem que vir antes dos dstnat que faz o roteamento dos seus clientes!

    Onde o ip do Server do apache é 192.168.0.1 e a porta que destinei ao aviso é a 83, no seu caso se for externo pode se usar a porta 80 é o ip externo do Server ou da forma que preferir!

    Também como pode ver não tem ip de entrada do cliente pois eles eu coloco na lista em anddress list

    Então vamos ao anddress list

    /ip firewall address-list
    add address=174.25.0.4 comment=Giovani disabled=yes list=ipsBloqueados


    Quando você coloca o cara na lista e habilita ele e bloqueado e redirecionado para seu aviso!

    Você pode adaptar da maneira que achar melhor!

    Por exemplo tenho duas regras diferentes uma é esta e outra e um de aviso que de 10 em 10 minutos vai o aviso pro inadimplente

    Esta de tempo em tempo você cria a regra do Nat e coloca o cara na lista e vai no script cria duas regras , uma para ativar o redirecionamento do Nat e outra para desativar e depois vai em Schedule e coloque dois intervalos de tempo onde um vai rodar o script que vai ativar a regra de redirecionamento onde vai pegar o cara que tiver na lista e vai mandar o aviso e a outra faz o inverso liberando o acesso!

    Qualquer duvida coloca ai!

    Abraços
    Fiz, conforme esta acima, mas não deu certo redirecionamnto, o bloqueio sim funcionou...

    Obs: uso mac-ip.

    Att,
    Ney Dourado
    Última edição por neydourado; 04-05-2009 às 19:14.

  14. #14

    Padrão

    Esta parte do redirecionamento não é 100% pois o cliente terá que está usando no momento em que o scheduler é executado. Uma coisa a se fazer é um script para verificar os bytes transferidos pelo cliente. Caso seje uma valor menor que 200bits, por exemplo, a address list dele fica ativa e só é desativado quando o tráfego dele passe dos 200bits. Isto eu não tenho em funcionamento pois uso hotspot, mas você pode testar aí e nos informar.



  15. #15

    Thumbs up

    Citação Postado originalmente por Raniel Ver Post
    Esta parte do redirecionamento não é 100% pois o cliente terá que está usando no momento em que o scheduler é executado. Uma coisa a se fazer é um script para verificar os bytes transferidos pelo cliente. Caso seje uma valor menor que 200bits, por exemplo, a address list dele fica ativa e só é desativado quando o tráfego dele passe dos 200bits. Isto eu não tenho em funcionamento pois uso hotspot, mas você pode testar aí e nos informar.



    Olá Raniel !

    Como vai?

    Quanto a está função a qual se referiu eu já tente usar em outra opção ! "tela de boas vindas " não deu muito certo ! Então a maneira que consegui fazer funcionar foi assim!

    E pelo que percebo todo mundo recebe as minhas mensagens, pois dão um jeito ligeirinho de acertar as contas ...pois eles se enchem quando a net fica caindo de tempo em tempo e mostrando a mensagens!


    Você conseguiu fazer funcionar a mensagem de boas vindas ou viu alguém que tenha conseguido?

    Pois aquelas regras de limit enche os clientes, pois fica aparecendo toda hora ou só aparece para um e nunca mais aparece!


    Abração ai !

  16. #16

    Thumbs up

    Citação Postado originalmente por neydourado Ver Post
    Fiz, conforme esta acima, mas não deu certo redirecionamnto, o bloqueio sim funcionou...

    Obs: uso mac-ip.

    Att,
    Ney Dourado
    A regra de aviso é a mesma do bloqueio !
    Só o que muda e que a regra é ativada e desativada por determinação de tempo !

    Se for a questão de tempo que não ta conseguindo poe ser algum erro nos seus scripts !

    Qual a versão do seu MK ?



  17. #17

    Padrão Conseguir, em parte...

    Citação Postado originalmente por Giovani.couto Ver Post
    A regra de aviso é a mesma do bloqueio !
    Só o que muda e que a regra é ativada e desativada por determinação de tempo !

    Se for a questão de tempo que não ta conseguindo poe ser algum erro nos seus scripts !

    Qual a versão do seu MK ?

    Giovani, boa noite,

    Conseguir fazer o bloqueio, eh aparecer a pagina direcionada... mas só conseguir com servidor externo, mas quero mesmo eh por em um servidor local. Não sei o q pode ser? pois no servidor local não tah rolando...

    Uso a 3.23 e 2.27.

  18. #18

    Padrão

    desenvolvi um sistema de 'portal' de notificação que faz isso, é todo sincronizado .. se der problema no mk ou no radius ... nao importa. nao vai dar problema.. esta funcionando aqui desde outubro de 2008..

    funciona assim:

    cliente conecta, é verificado se ha debitos, se houver, o ip que ele recebeu é adicionado em uma lista que redireciona para um portal de aviso com opção para que ele veja as faturas/mensagens e/ou clique em um botao "NAVEGAR", quando clica em navegar o ip dele é removido da lista.. caso ele desconecte .. o ip tambem eh removido (caso esteja na lista)...

    o sistema tem como voce inserir notificações sem derrubar o usuario, ele possui um "schedule" interno que de 5 em 5 minutos verifica uma base de dados com notificações para os usuarios.. caso existam notificações .. esta é apresentada... as notificações sao configuradas da seguinte maneira:

    - mostrar o aviso de x em x minutos
    - mostrar apenas uma vez
    - mostrar apenas na uma vez a cada conexao


    obs:
    - nao é free
    - vou comercializar a solução, estou montando uma area de configuração para o sistema..



  19. #19
    Avatar de stevens144
    Ingresso
    Oct 2007
    Localização
    Campo Grande MS
    Posts
    313
    Posts de Blog
    3

    Padrão

    é amigo se sua inadimplencia é alta... nada melhor do que pagar por algo que realmente funcione... nao se esqueça apesar de vc ter um provedor nao pode dar jeito em td... negocio necessita de investimento... e ninguem consegue oferecer serviço de alta qualidade sem investimento... isso vai te dar um retorno mto melhor do que fikar adaptando... te falo por experiencia propria... conversa com o alexandre, nao sabia dessa solução dele, isso pode ajudar mto nas futuras inadimplencias, mas a minha foi mandar cobrador na cola do povo mais de 10k de inadimplencia.
    boa sorte
    abraços

  20. #20

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    desenvolvi um sistema de 'portal' de notificação que faz isso, é todo sincronizado .. se der problema no mk ou no radius ... nao importa. nao vai dar problema.. esta funcionando aqui desde outubro de 2008..

    funciona assim:

    cliente conecta, é verificado se ha debitos, se houver, o ip que ele recebeu é adicionado em uma lista que redireciona para um portal de aviso com opção para que ele veja as faturas/mensagens e/ou clique em um botao "NAVEGAR", quando clica em navegar o ip dele é removido da lista.. caso ele desconecte .. o ip tambem eh removido (caso esteja na lista)...

    o sistema tem como voce inserir notificações sem derrubar o usuario, ele possui um "schedule" interno que de 5 em 5 minutos verifica uma base de dados com notificações para os usuarios.. caso existam notificações .. esta é apresentada... as notificações sao configuradas da seguinte maneira:

    - mostrar o aviso de x em x minutos
    - mostrar apenas uma vez
    - mostrar apenas na uma vez a cada conexao


    obs:
    - nao é free
    - vou comercializar a solução, estou montando uma area de configuração para o sistema..
    Tudo feito em php. Creio