Página 16 de 16 PrimeiroPrimeiro ... 111213141516
+ Responder ao Tópico



  1. #301

    Padrão

    Citação Postado originalmente por Barone10 Ver Post
    Olá grande Roberto , no meu caso já tenho o servidor ubuntu 9.0 server todo configurado já com thunder e os pacotes que necessitam pra uso dele ok ! , meu cenário e o seguinte hoje uso um servidor MK 2.9 com Hotspot+Dhcp+stático e Cache+proxy , Mk ip 192.168.10.1 , e faixa dos clientes referente ip mk 10.1 , eu configurei o Thunder com ip 192.168.10,2 , o problema e o seguinte , servidor MK com 3 placas de redes 1 link adsl 6 megas 192.168.254.254 , a outra Faixa do mk 10.1 e a 3 placa coloquei pra interligar o SRV thunder . Minha duvida e que vi em outro post que posso ligar o thunder >>> mk por cabo cross ou até mesmo no switch , qual seria melhor solução e qual e o nat que eu faria pra todos meus clientes passar pelo thunder cache ? com as regras queue ? , uma coisa eu sei que terei que desabilitar o cache do mk pra não ficar confuso o proxy . abraços se puder dar essa dica ficarei grato .
    Olá amigo.. quanto a usar cabo cross-over dá uma lida neste tudo aqui: TMSoft
    O autor, em dado momento fala o seguinte:
    "O emprego dos switchs corretamente é vital para evitar os seguintes problemas:
    - Colisão, perda por CRC e perda de retorno, comuns no emprego de cabo cross-over"
    Gostaria de saber do pessoal com mais experiência se esta informação referente ao cabo cross procede...
    Abraços

  2. #302

    Padrão

    Roberto tenho uma duvida referente a configuraçao do apache2.conf referente ao Maxclientes no meu caso estou deixando em 150 e MaxRequestsPeerChild está em 0, desculpe mas não conseguiu entender corretamente essa configuraçao, então tenho percebido qdo tenho um numero de clientes a internet fica lenta na abertura de paginas, será relacionado a essas configuraçoes, pois estou usando somente um hd, agora estou pensando em por um pro squid e outro para thunder, será que vai ficar melhor?

    Desde já agradeço sua atenção

    Obrigado.



  3. #303

  4. #304

    Padrão Re: Mikrotik + thunderCache= perfeito...

    Roberto21
    olá amigo, gostaria de saber se poderia me ajudar com isso :
    Código :
    The requested URL could not be retrieved
     
    While trying to process the request:
     
    GET  /membercheck?path=ap3918/streaming/&fname=ap3918500k.wmv&fd=1&dontstream=1  HTTP/1.1
    Host: assparade.members.bangbros.com
    User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; pt-BR; rv:1.9.2.3)  Gecko/20100401 Firefox/3.6.3
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: pt-br,pt;q=0.8,en-us;q=0.5,en;q=0.3
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 115
    Connection: keep-alive
    Referer: [URL]http://members.bangbros.com/intro.htm?episode=ap3918[/URL]
    Cookie: __utma=246606488.1817798747.1273374748.1273439302.1273444803.3;  __utmz=246606488.1273374748.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none);   ps7_oneclick=%7Bv7%7Dp3c1c0SWuzqsei6Qw9bpKErQKBY4M9Zl9c5yGfSG63Kz%2FVgkez2Fam9qSjFSbwitiQTiMc1spPI7pV7JgkiHsILH7C96zfoMVGQ7IVk90dgaueGhUpjzNRcIk8o1AcaGFmg0m%2BV8Rx%2Bme31JyeIIikBZVRSWjqymbcTxuCyMeCX2NVMDTq8jg4yCYaI3n8CNtrYt6FZ3ba65eXJ7EwumPw%3D%3D;   bb_support=s%2BSamgj1XhsXL2Yn3GlPcj2rWp4ra68CN1e22SrhQgWe3A1xKX4lJOovgfBuey6FBFpP89Ih%2FhmH0Do%2FUEXXc5miVPFPZdZXhcCFKs0n1HAob1CZlNuaMecTguE6ZkHvgSSIyZXSMTcuu%2F0tsUsSK%2BnikgQu%2FEMYP931WmQ2vKadAZfxl2faER%2F3%2FxOwFAVzIusJDx1cdYv8ADNlZr4wXeeQSlEMw%2BlKHo9Vwpy42mPJf%2FoRYmyFjXoTcjldF5itNr%2BQAV7u1ZmTNMtRFK7fuv4QVMMe%2B0QPVyERaVuJhZz6GA0z3WvZ1s37sf6PwpI7%2B9CLAJEzrQjoxRT5CemFrg%3D%3D;  primeauth=c3BlbmNlcjg6OGpheWpheQ==; landed=1; __utmc=246606488;  __utmb=246606488.22.10.1273444803
     
     
    The following error was encountered:
     
    * Invalid Response 
     
    The HTTP Response message received from the contacted server could not  be understood or was otherwise malformed. Please contact the site  operator. Your cache administrator may be able to provide you with more  details about the exact nature of the problem if needed.
    depois de uns dias começou a aparecer isso quando um cliente vai fazer um download nesse site que o mesmo é assinante, quando retido o redirecionamento para o proxy, abri normal sem problemas, o que poderia ser???

    desde já obrigado!



  5. #305

    Padrão Re: Mikrotik + thunderCache= perfeito...

    Olá colega!

    Me diz qual versão do thunder você está usando ?

  6. #306

    Padrão Re: Mikrotik + thunderCache= perfeito...

    estou usando 3.0

    Citação Postado originalmente por Roberto21 Ver Post
    Olá colega!

    Me diz qual versão do thunder você está usando ?



  7. #307

    Padrão Re: Mikrotik + thunderCache= perfeito...

    teria como me mostrar suas regras ? estou aqui com ele normal tudo mais, mas ele não entrega na velocidade mesmo total!


    Citação Postado originalmente por darklinux3 Ver Post
    Aqui eu não estava conseguindo fazer o cache full dos arquivos do thunder, por algum motivo nao consegui fazer o dst-nat para o servidor proxy em paralelo (fazia mas nao funcionava) e entao estava utilizando o proxy parent. Utilizo algumas vlans em meu mk depois de um tempo as vlans travavam junto com a navegacao e o mk só respondia se fosse reiniciado. Mudei o sistema, retirei o webproxy do mikrotik, fiz um redirecionamento através de rotas estaticas para o servidor squid com thunder cache, está perfeito e ainda utilizo o sarg já que os ips que aparecem no access.log são dos proprios clientes.

    Mikrotik + Squid 3.0-STABLE8 Paralelo(Rota Estática) + Thunder Cache + Sarg

    Ainda deixei 4mb compartilhado de cache full para os clientes. Está perfeito.

    []´s

  8. #308

    Padrão Re: Mikrotik + thunderCache= perfeito...

    porq o queue é thunder, se não tem nenhum criado, no exemplo que passou? porq ai no caso teria que criar um queue type com name= thunder para que o mesmo fosse usado na regra! No caso vc usa o padrão mesmo?


    Citação Postado originalmente por neydourado Ver Post
    Pessoal, favor seguuir a risca o que o Roberto postou anteriomente no post, eh depois no MK 3.23, essa eh a minha versão.

    Depois no MK, poe essas regras...

    Conf MK
    #
    / ip firewall mangle
    add chain=forward protocol=tcp content="X-Cache: HIT" action=mark-connection new-connection-mark=forward-hits \
    passthrough=yes comment="CACHE FULL" disabled=no
    add chain=forward connection-mark=forward-hits action=mark-packet new-packet-mark=cache-hits passthrough=yes comment="" \
    disabled=no
    add chain=postrouting dscp=48 action=mark-connection new-connection-mark=proxy-hits passthrough=yes comment="" disabled=no
    add chain=postrouting connection-mark=proxy-hits action=mark-packet new-packet-mark=proxy-squid passthrough=yes comment=""
    disabled=no
    add chain=forward protocol=tcp content="THUNDER: THUNDER" action=mark-connection new-connection-mark=thunder-connection \
    passthrough=yes comment="THUNDER CACHE FULL" disabled=no
    add chain=forward protocol=tcp connection-mark=thunder-connection action=mark-packet new-packet-mark=thunder-packs \
    passthrough=yes comment="" disabled=no

    / queue tree
    add name="cache_hits" parent=global-out packet-mark=proxy-squid limit-at=1000000 queue=thunder priority=8 \
    max-limit=3000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
    add name="cache-antigo" parent=global-out packet-mark=cache-hits limit-at=1000000 queue=default priority=8 \
    max-limit=2000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
    add name="ThunderCache" parent=global-out packet-mark=thunder-packs limit-at=1000000 queue=thunder priority=8 \
    max-limit=3000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no


    /ip firewall nat

    add action=masquerade chain=srcnat comment=NAT-HadNet disabled=no \
    out-interface=pppoe-out1


    add action=masquerade chain=srcnat comment="NAT DEBIAN-SERVER" disabled=no \
    src-address=!192.168.10.250

    add action=dst-nat chain=dstnat comment="proxy for HTTP requests" disabled=no \
    dst-address=!192.168.10.250 dst-port=80 protocol=tcp src-address=\
    172.16.0.0/16 to-addresses=192.168.10.250 to-ports=3128

    Em vermelho negrito eh o NAT do meu DSL. então caso ja tenha o seu NAT. não use esta regra.

    Importante: Não use Ctrl C + Ctrl V



  9. #309

    Padrão Re: Mikrotik + thunderCache= perfeito...

    lendo...e acompanhando perfeito topico. parabens Roberto.

    hoje estou montando meu primeiro mk + thunder .

    Sua Ajuda esta sento otima

    ainda bem que tem pessoas iguais a voce no forum. vlw.

  10. #310

    Padrão Re: Mikrotik + thunderCache= perfeito...

    ola boa tarde.. eu li as 31 paginas do forum e nao achei minha duvida entao vo perguntar ne.

    meu thunder-cache esta rodando ip 192.168.10.250 mk 192.168.10.253 ai ai normal mas preciso usar ele com PPPEO quendo coloco pppeo em acao navega mas nao passa pelo thunder alguem pode me ajudar por favor.

    desde ja obrigado.



  11. #311

    Padrão Re: Mikrotik + thunderCache= perfeito...

    Fucei bastante sobre Squid+Thunder 3, montei um server com duas placas (Link e Rede), instalei tudo conforme as dicas de vários colegas.
    Está funcionando o 3.0, tudo beleza, testei colocando o link Internet e saíndo pela rede para meu micro. está fazendo cache tanto no Squid como no Thunder. O Thunder está como transparent. Tenho relatórios do Sarg, do Thunder, tudo pronto pra funcionar na prática.
    Mas tenho algumas dúvidas...

    Primeiro, quanto à colocação dele, se seria melhor colocar em "PARENT PROXY" no Mikrotik com (3 placas de rede), que seria assim:

    Internet ----> Mikrotik ----> Clientes
    |
    Thunder (Parent Proxy) do Mikrotik

    ou se poderia colocar assim:
    Internet -> Thunder -> Mikrotik -> Clientes,

    1 - Qual seria a diferença destas disposições?

    2 - Como deixar fazendo a limpeza automática do Thunder sem que o mesmo sobrecarregue e fique lento como relatado por alguns colegas? No Squid tudo ok, mas no Thunder? Será que na versão 3 acontece também?

    3 - Com relação aos vídeos, também li por aí que o cara abre 10 vídeos e sobrecarrega, estoura o link pois o Thunder fica salvando tudo (o link vai pro brejo)! Não sei se na versão 3 acontece isso?

    4 - Se o cara cancelar o vídeo? O Thunder continua salvando? Li por aí que sim! Na versão 3 acontece isso?

    Já esquentei o juízo pesquisando, mas não li respostas muito precisas, pelo menos para meu entendimento.

    Pois bem, para colocar da bancada para uso na prática tenho que tirar essas dúvidas, entre outras tantas, mas estas dão pra começar.

    Até doei para o projeto Thundercache e estou fuçando por lá na área de donators, mas preciso da ajuda dos colegas para estas questões básicas e desde já humildemente agradeço a atenção dispensada.

    Obrigado e fiquem todos com Deus.

  12. #312

    Padrão Re: Mikrotik + thunderCache= perfeito...

    Olá Amigo se possivel Gostaria da sua ajuda aqui.
    eu montei un thundercache seguindo o tutorial que vc colocou nesse forum aqui funcionou tudo ok só o youtube que fica dando uma mensagem de erro... mas o que eu quero saber mesmo é que o meu link vem por uma conexão via satelite e eu tenho que usar um proxy 193.251.135.101 com porta 8080 em todos os computadores que estão na rede se não eles não navegam com a velocidade do link o que acontece é que se eu deixo com as configurações do proxy no meu navegador o thunder não funciona e se eu desativo as configurações funciona mais a internet fica muito lenta pois ai não estou usando o link via satelete... vc sabe me dizer onde devo mexer pra o thunder fazer cache com as minhas configurações de proxy no navegador ou alguma solução desse tipo ?



  13. #313

    Padrão Re: Mikrotik + thunderCache= perfeito...

    bom gente ai vai a opinião de quem ja testou e sinceramente não tive sorte com nenhuma verção do thunderCache não testei a 4 mais digo trava muito na hora que funfa não tem para ninguen mais trava muitooooooooooooooooo

  14. #314

    Padrão Re: Mikrotik + thunderCache= perfeito...

    Citação Postado originalmente por boneco Ver Post
    bom gente ai vai a opinião de quem ja testou e sinceramente não tive sorte com nenhuma verção do thunderCache não testei a 4 mais digo trava muito na hora que funfa não tem para ninguen mais trava muitooooooooooooooooo

    Boa noite, estou com uma buxa, meu thundercache é cliente do meu mikrotik, pois não consegui colocar ele em minha DMZ, o detalhe é o seguinte, o meu cliente desse mikrotik quando vai para o cache blz, agora quando ele vai para internet, sai com metade da banda, acredito que o server mikortik está fazendo o controle de banda 2x, mas não sei fazer a regra no mangle para que tudo que ir para o thunder e voltar, voltar sem pegar o controle de banda novamente. Bom gente, não sei se expliquei bem, só sei que to apanhando e quebrando a cabeça com esse trem aqui. Mas sei que vou resolver. Um abraço a todos, fiquem com Deus.

    Fábio Napolitano



  15. #315
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão Re: Mikrotik + thunderCache= perfeito...