+ Responder ao Tópico



  1. #1

    Padrão Mais Um problema com DNS Reverso

    Galera eu sei que este assunto é muito batido neste e em diversos outros sites mas mesmo assim vou postar aqui (a se for mandar procurar no google passei das 8 as 14:15 fazendo isto rsrsrrs).

    Seguinte eu configurei meu bind9 através de um tutorial do morimoto que aparentemente funcionou legal pois meu dns este resolvendo nomes normalmente consiguo acessar o meu site e meu server de mail mas ai que esta o problema meu DNS reverso aparentemente esta configurado normal mais nao funciona já briguei com a BRT hj e me convenci que lá esta tudo OK e que o problema é no meu server mesmo vou postar minhas confs para que vocês possam ver e se possivel me ajudar

    /etc/resolv.conf
    Código :
    cat /etc/resolv.conf
    search cambira.pr.gov.br
    #nameserver 201.10.120.2
    #nameserver 201.10.128.3
    nameserver 189.11.9.28
    nameserver 189.11.9.26

    /etc/hosts
    Código :
    cat /etc/hosts
    127.0.0.1       localhost
    189.11.9.28     pmc01.cambira.pr.gov.br pmc01
     
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    127.0.0.1               cambira.pr.gov.br

    /etc/hostname
    Código :
    cat /etc/hostname
    pmc01

    /etc/named.conf
    Código :
    cat /etc/bind/named.conf
    // This is the primary configuration file for the BIND DNS server named.
    //
    // Please read /usr/share/doc/bind9/README.Debian.gz for information on the
    // structure of BIND configuration files in Debian, *BEFORE* you customize
    // this configuration file.
    //
    // If you are just adding zones, please do that in /etc/bind/named.conf.local
     
    include "/etc/bind/named.conf.options";
     
    #IP da Operadora
    #allow-transfer { 201.10.120.2; 201.10.128.2; };
     
    #query-source address * port 53;
     
    // prime the server with knowledge of the root servers
    zone "." {
            type hint;
            file "/etc/bind/db.root";
    };
     
    // be authoritative for the localhost forward and reverse zones, and for
    // broadcast zones as per RFC 1912
     
    zone "localhost" {
            type master;
            file "/etc/bind/db.local";
    };
     
    zone "127.in-addr.arpa" {
            type master;
            file "/etc/bind/db.127";
    };
     
    zone "0.in-addr.arpa" {
            type master;
            file "/etc/bind/db.0";
    };
     
    zone "255.in-addr.arpa" {
            type master;
            file "/etc/bind/db.255";
    };
     
    // zone "com" { type delegation-only; };
    // zone "net" { type delegation-only; };
     
    // From the release notes:
    //  Because many of our users are uncomfortable receiving undelegated answers
    //  from root or top level domains, other than a few for whom that behaviour
    //  has been trusted and expected for quite some length of time, we have now
    //  introduced the "root-delegations-only" feature which applies delegation-only
    //  logic to all top level domains, and to the root domain.  An exception list
    //  should be specified, including "MUSEUM" and "DE", and any other top level
    //  domains from whom undelegated responses are expected and trusted.
    // root-delegation-only exclude { "DE"; "MUSEUM"; };
     
    include "/etc/bind/named.conf.local";
     
    zone "cambira.pr.gov.br" IN {
    type master;
    file "/etc/bind/db.cambira.pr.gov.br";
    allow-transfer { 189.11.9.26; };
    };
     
    zone "9.11.189.in.addr.arpa" IN {
    type master;
    file "/etc/bind/db.cambira.pr.gov.br.rev";
    allow-transfer { 189.11.9.26; };
    };

    /etc/bind/db.cambira.pr.gov.br
    Código :
    cat /etc/bind/db.cambira.pr.gov.br
    $TTL 86400
    @       IN SOA  pmc01.cambira.pr.gov.br. hostmaster.cambira.pr.gov.br. (
            2009032501;serial
            28800;refresh
            7200;retry
            1209600;expire
            24h );minimum
            NS pmc01.cambira.pr.gov.br.
            NS pmc02.cambira.pr.gov.br.
            IN MX 10 pmc01.cambira.pr.gov.br.
     
    pmc01   IN A  189.11.9.28
    pmc02   IN A  189.11.9.26
     
    ;Localhost              IN A    127.0.0.1
    cambira.pr.gov.br.      IN A    189.11.9.28
    ns                      IN A    189.11.9.28
    www                     IN A    189.11.9.26
    ftp                     IN A    189.11.9.26
    ssh                     IN A    189.11.9.26
    mail                    IN A    189.11.9.28
    pmc01                   IN A    189.11.9.28

    /etc/bind/db.cambira.pr.gov.br.rev
    Código :
    cat /etc/bind/db.cambira.pr.gov.br.rev
    $TTL 86400
    @       IN SOA  pmc01.cambira.pr.gov.br. hostmaster.cambira.pr.gov.br. (
            2009032501;serial
            28800;refresh
            7200;retry
            1209600;expire
            24h );minimum
            NS pmc01.cambira.pr.gov.br.
            NS pmc02.cambira.pr.gov.br.
            IN MX 10 pmc01.cambira.pr.gov.br.
     
    pmc01   IN A  189.11.9.28
    pmc02   IN A  189.11.9.26
     
    ;Localhost              IN A    127.0.0.1
    cambira.pr.gov.br.      IN A    189.11.9.28
    ns                      IN A    189.11.9.28
    www                     IN A    189.11.9.26
    ftp                     IN A    189.11.9.26
    ssh                     IN A    189.11.9.26
    mail                    IN A    189.11.9.28
    pmc01                   IN A    189.11.9.28


    Estas são minhas confs mas quando eu dou um
    host 189.11.9.28
    a resposta é:
    Host 28.9.11.189.in-addr.arpa not found: 2(SERVFAIL)

    e o mesmo acontece com nslookup e com dig

    fico no aguardo desesperado por uma ajuda de vcs

    Valew

  2. #2

    Padrão

    fernandop,

    Pelo que estou vendo você tem uma classe C inteira a ser utilizada correto?

    Cabeçalho é igual o db normal, mas o restante:

    1 IN PTR host.domain.com.br.
    100 IN PTR host.domain.com.br.
    200 IN PTR host.domain.com.br.
    254 IN PTR host.domain.com.br.


    Se for uma subrede, por exemplo com 8 IPs 189.11.9.24 ao 189.11.9.31 (sendo 6 validos) que normalmente é uma rede /29 (mask 255.255.255.248) vc deve criar no named.conf a zone da seguinte forma:

    zone "24-31.9.11.189.in.addr.arpa" IN {

    Att,
    Marcelo



  3. #3

    Padrão

    O seu problema esta no arquivo reverso.

    TTL 86400
    $ORIGIN 9.11.189.in-addr.arpa. ( se for toda classe)
    @ IN SOA pmc01.cambira.pr.gov.br. hostmaster.cambira.pr.gov.br. (
    2009041501 ; serial
    3H ; refresh
    15M ; retry
    1W ; expiry
    2D ) ; minimum
    IN NS pmc01.cambira.pr.gov.br.
    IN NS pmc02.cambira.pr.gov.br.



    1 IN PTR 189-11-9-1.arpa.cambira.pr.gov.br.
    2 IN PTR 189-11-9-2.arpa.cambira.pr.gov.br.
    3 IN PTR 189-11-9-3.arpa.cambira.pr.gov.br.
    4 IN PTR 189-11-9-4.arpa.cambira.pr.gov.br.
    5 IN PTR 189-11-9-5.arpa.cambira.pr.gov.br.
    6 IN PTR 189-11-9-6.arpa.cambira.pr.gov.br.
    ( e assim por diante até atingir todo bloco, substituindo os IPs utilizados pelo reverso que deseja)
    28 IN PTR pmc01.cambira.pr.gov.br.










    Outro fator importante é você adicionar aos seus servidores DNS o dnssec e separar servidores autoritarios de servidores recursivos.

  4. #4

    Padrão

    Galera postei o conf errado do reverso eu postei dois iguais o conf certo segue abaixo

    Código :
    cat db.cambira.pr.gov.br.rev
    $TTL 86400
    @ IN SOA pmc01.cambira.pr.gov.br. hostmaster.cambira.pr.gov.br. (
    2009032501;serial
    28800;refresh
    7200;retry
    1209600;expire
    24h );minimum
     
    NS pmc01.cambira.pr.gov.br.
    NS pmc02.cambira.pr.gov.br.
     
    28 PTR cambira.pr.gov.br.
    26 PTR pmc02.cambira.pr.gov.br.
    mas mesmo assim eu fiz o que os dois camaradas falaram mas não obtive sucesso.

    Marcelo isso da zone lá no named eu ja tinha feito mas tirei agora coloquei de novo mas mesmo assim não deu, e esta certo minha classe é /29 mesmo.

    herlon2008 acredito que com o novo post no conf correto isso que vc me passou eu ja havia feito, mas mesmo assim agradeço muito.

    Se mais alguem puder me ajudar pois eu ja tentei umas 10 vezes este negocio de reverso e nada de conseguir.

    Desde ja agradeço



  5. #5

    Padrão

    Na Embratel, quando você não tem uma classe C cheia, ou seja, /29, como é o seu caso é necessário pedir a Embratel que seja habilitado o DNS Reverso. Não seria o seu caso?

    Marcelo Vitor

  6. #6

    Padrão

    Marcelo eu já pedi a habilitação do DNS Reverso para a monopolizadora BRT (agora OI) e já foi feita por eles na semana passada por isso que agora estou me matando para configurar pois antes ainda nao estava configurado (demorou mais de um mes para liberarem).

    valew



  7. #7

    Padrão

    A principio ficaria assim:

    named.conf:

    zone "24-29.9.11.189.in.addr.arpa" IN {
    type master;
    file "/etc/bind/db.cambira.pr.gov.br.rev";
    allow-transfer { 189.11.9.26; };
    };



    zone vai ficar assim:

    TTL 86400
    $ORIGIN 24-31.9.11.189.in-addr.arpa.
    @ IN SOA pmc01.cambira.pr.gov.br. hostmaster.cambira.pr.gov.br. (
    2009050801 ; serial
    3H ; refresh
    15M ; retry
    1W ; expiry
    2D ) ; minimum

    IN NS pmc01.cambira.pr.gov.br.
    IN NS pmc02.cambira.pr.gov.br.

    28 IN PTR cambira.pr.gov.br.
    26 IN PTR pmc02.cambira.pr.gov.br.

    Abraços,
    Marcelo


  8. #8

    Padrão

    putz!!! mais de um mês???? na Embratel fazem de imediato, desde que seu servidor esteja ok, pois eles testam logo a transferência de zona reversa.

    Vou postar meus arquivos, inclusive o named.conf.options, que não vi você mencionar.

    OBS: O IP 200.255.125.214 é do servidor da Embratel.

    *** named.conf

    // This is the primary configuration file for the BIND DNS server named.
    //
    // Please read /usr/share/doc/bind9/README.Debian.gz for information on the
    // structure of BIND configuration files in Debian, *BEFORE* you customize
    // this configuration file.
    //
    // If you are just adding zones, please do that in /etc/bind/named.conf.local

    include "/etc/bind/named.conf.options";

    // prime the server with knowledge of the root servers
    zone "." {
    type hint;
    file "/etc/bind/db.root";
    };

    // be authoritative for the localhost forward and reverse zones, and for
    // broadcast zones as per RFC 1912

    zone "localhost" {
    type master;
    file "/etc/bind/db.local";
    };

    zone "127.in-addr.arpa" {
    type master;
    file "/etc/bind/db.127";
    };

    zone "0.in-addr.arpa" {
    type master;
    file "/etc/bind/db.0";
    };

    zone "255.in-addr.arpa" {
    type master;
    file "/etc/bind/db.255";
    };

    zone "dominio.com.br" {
    type master;
    file "/etc/bind/dominio.zone";
    allow-transfer { 127.0.0.1; 200.255.125.214; };
    };

    zone "200-207.200.200.200.in-addr.arpa" {
    type master;
    file "/etc/bind/dominio.rev";
    allow-transfer { 127.0.0.1; 200.255.125.214; };
    };

    // zone "com" { type delegation-only; };
    // zone "net" { type delegation-only; };

    // From the release notes:
    // Because many of our users are uncomfortable receiving undelegated answers
    // from root or top level domains, other than a few for whom that behaviour
    // has been trusted and expected for quite some length of time, we have now
    // introduced the "root-delegations-only" feature which applies delegation-only
    // logic to all top level domains, and to the root domain. An exception list
    // should be specified, including "MUSEUM" and "DE", and any other top level
    // domains from whom undelegated responses are expected and trusted.
    // root-delegation-only exclude { "DE"; "MUSEUM"; };

    include "/etc/bind/named.conf.local";




    *** named.conf.options
    options {
    directory "/var/cache/bind";
    version "secured";
    query-source address * port 53;
    auth-nxdomain no;
    also-notify { 200.255.125.214; };
    allow-transfer { 200.255.125.214; };

    // If there is a firewall between you and nameservers you want
    // to talk to, you might need to uncomment the query-source
    // directive below. Previous versions of BIND always asked
    // questions using port 53, but BIND 8.1 and later use an unprivileged
    // port by default.

    // query-source address * port 53;

    // If your ISP provided one or more IP addresses for stable
    // nameservers, you probably want to use them as forwarders.
    // Uncomment the following block, and insert the addresses replacing
    // the all-0's placeholder.

    // forwarders {
    // 0.0.0.0;
    // };

    // auth-nxdomain no; # conform to RFC1035
    // listen-on-v6 { any; };
    };


    *** dominio.zone
    $TTL 86400
    @ IN SOA server.dominio.com.br. marcelo.dominio.com.br. (
    2009050801 ; serial
    1H ; refresh
    15M ; retry
    14D ; expire
    12H ; default_ttl
    )

    @ IN MX 5 mail.dominio.com.br.

    @ IN NS ns1.dominio.com.br.
    @ IN NS ns2.dominio.com.br.
    @ IN NS ns.embratel.net.br.

    @ IN TXT "v=spf1 ip4:200.200.200.2 -all"

    @ IN A 200.200.200.2

    server IN A 200.200.200.2
    ns1 IN A 200.200.200.2
    ns2 IN A 200.200.200.3
    mail IN A 200.200.200.2
    router IN A 200.200.200.1
    www IN A 200.200.200.4



    *** dominio.rev
    $TTL 86400
    @ IN SOA server.dominio.com.br. marcelo.dominio.com.br. (
    2009050801 ; serial
    1H ; refresh
    15M ; retry
    14D ; expire
    12H ; default_ttl
    )
    @ IN NS ns1.dominio.com.br.
    @ IN NS ns2.dominio.com.br.
    @ IN NS ns.embratel.net.br.
    2 IN PTR mail.dominio.com.br.


    Faço o reverso somente para o servidor de email.

    Depois do bind pronto, a porta 53, protocolos TCP e UDP devem estar liberadas no firewall para que haja a transferência de zona.

    Espero que ajude.

    Marcelo Vitor



  9. #9

    Padrão

    Caras fiz exatamente com vcs passaram para mim mas infelizmente nao deu certo mas uma coisa eu notei que na minhas configurações não se usa "@" e na que vcs passaram é utilizado será que isto pode ser um fator agravante..

    o comando host 189.11.9.28 continua retornando SERVFAIL

  10. #10

    Padrão

    Faz igual ao que te mandei, trocando IP e nome do que for Embratel para o teu ISP.



  11. #11

    Padrão

    MACVITOR agoara sim copiei suas confs e colei aqui no meu server alterando as opçoes que precisava mas mesmo assim está dando erro não teve jeito mesmo, eu estou começando a duvidar que a BRT liberou o meu reverso pois nao está funcionando com as confs que vcs me passaram nem com outras que eu já havia tentado mas o duro tb é que da a mensagem SERVFAIL e não outro erro como retornar o endereço da BRT com eu já vi por ai.

  12. #12

    Padrão

    Estranho, cara! Pois era pra funcionar.

    Qual a versão do seu bind? Eu uso bind9 do Debian Etch.



  13. #13

    Padrão

    Eu uso Bind 9 no Debian 5 acredito que seja a mesma conf só a unica coisa que tirei foi o seguinte

    @ IN TXT "v=spf1 ip4:200.200.200.2 -all"
    por que nao sei oque é isso mas acredito que nao faca muita diferenca

  14. #14

    Padrão

    não faz diferença mesmo.

    notei uma coisa: cambira.pr.gov.br é subdomínio de pr.gov.br. Quem administra pr.gov.br é você também?



  15. #15

    Padrão

    nao é o CELEPAR mas eles disseram que lá está tudo OK com os reversos

  16. #16

    Padrão

    Posta o log do erro, quem sabe assim fica mais facil te ajudar.

    Outra coisa importante, é que normalmente a BRT lhe manda como eles denominaram o bloco.

    Pois se tiver diferente não ira funcionar mesmo.

    Experimente as seguintes denominações: 24-31.9.11.189.in.addr.arpa ou 31-24.9.11.189.in.addr.arpa

    Não me lembro mais como era, mas um destes esta correto.

    Se você não recebeu o informativo, solicite ao seu gerente comercial, que eles lhe encaminham como foi efetuada a denominação.