+ Responder ao Tópico



  1. #1

    Padrão load por grupos +hotspot, tem como? RESOLVIDO

    Ola, to aqui na bancada com uma rb450g e testei o load por grupo, muito show, adorei, fix como um amigo fex aki no forum , apontar cliente por cliente, so que tem uma coisa, nao consigo fazer ele funcionar com hotspot, alguem tem uma solucao??

    meu route

    0.0.0.0/0 r 192.168.30.1 grupo1
    0.0.0.0/0 r 201.67.25x.xx grupo2
    10.5.50.0/24 10.5.50.1 rede interna
    192.168.30.0/24 192.168.30.10
    201.67.25x.xx/29 201.67.25x.xx


    COMO FOI RESOLVIDO:
    Que tava ocorrendo que o balanceamento por grupo funcionava bem até ativar hotspot, ativando, todo trafego de porta 80 saia por link do grupo A- .

    Com a ajuda de Thyago TGCNET-Provedor TRLINK- ele me solucionou o problema, viu minhas configuracoes, e fizemos muitos testes, mais como estava com muita pressa, ele deixou o balanceamento por grupo a e grupo b, e controle por QUEUE- e colocou muitas regras de firewall iradas, mais umas marcaçao de pacotes para que alguns sites mais acesso passasse pela queue mangle(tipo um cache) irado!!! Deixou minha RB 450G Tinindo.

    Quem precisar de mais detalhes mande sua pergunta que responderei com prazer!!

    Obrigado Thyago, fosse o unico a se prontificar a ajudar!!!!
    Última edição por diox; 14-05-2009 às 09:16. Razão: Foi resolvido

  2. #2

    Padrão

    Olá, Diox!

    Amigo, eu estou com o mesmo problema que você tinha aí... Será que poderá me ajudar ?

    Quando eu desligo o hotspot o trafego separa direitinho. Se eu fizer downloads, ele vai pelo link que realmente deveria ir.

    Agora se ligar o hotspot, a saída enlouquece. Sites que informam o ip me mostram sempre o IP da rota padrão (link1). Se eu fizer um telnet ou um ftp o servidor identifica o IP do link2 (q é por onde deveria sair mesmo), sendo que dá um erro ainda, como se trocasse o IP de origem.

    O que você puder passar de informação sobre como contornar isto eu agradeço!

    Abraços.



  3. #3

    Padrão

    Amigo, ainda nao tive resposta, meu problems é o mesmo eu creio, ativo hotspot, dah como se sai pelo link 1 apenas, mais dou um tracert iG - O mundo é de quem faz – Notícias, blogs, famosos e esporte , aparece como link 2, bem loko!

    mais resolvendo te dou um toque!!

  4. #4

    Padrão

    Bem pessoal eu tb estou com o mesmo problema, mais eu tenho uma observação p fazer eu estava usando a versão 2.9.51 e tudo funcionava muito bem:
    2 links sendo que uma ranger usava o link 1 e outro range o link 2 e tada tudo funcionando blz, mais ai fez a mudança p versão 3.25 e ta nessa situação que vcs sitaram, com a msm regra o tracert da p um link A e quando to em outro IP dp tracert e vai p o link B, mais quando começo um download só vai p um link, muito estranho isso.
    dse alguem axar a solução . ..

    vo passar as regras:

    / ip firewall mangle
    add chain=prerouting action=mark-routing new-routing-mark=LINK1 \
    passthrough=yes src-address=10.1.1.49-10.1.1.100 comment="" disabled=no

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.2.1 routing-mark=LINK1 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.1.1 scope=30 target-scope=10

    /ip route
    add chain=srcnat action=masquerade out-interface=LINK1 comment="" disabled=no
    add chain=srcnat action=masquerade out-interface=LINK2 comment="" disabled=no

    até onde lembro só com isso ja rodava, abraço



  5. #5

    Padrão

    Gente logo em seguida de postar essas regras eu consegui o problema gente :

    Vo passar o que fiz isso para acabar o problema:

    O mikrotik que estou usando é a versão 3.25

    Bem de acordo com todas as regras que passei o problema estava na regra NAT, o problema é que depois de alguns testes descobri que a regra estava com problema, segue a regra correta.

    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no src-address=\
    10.1.1.0/24
    add action=masquerade chain=srcnat comment="" disabled=no src-address=\
    10.1.2.0/24

    remova as regras do mascaramento do hotspot e substitua por estas regras substituindo por seus ranges da rede.

    espero ter ajudado

  6. #6

    Padrão

    Eu já tinha desistido dessa configuração. Vou fazer os testes e depois eu posto aqui.

    Abraços.



  7. #7
    Mikrotiando..
    Ingresso
    Sep 2007
    Localização
    São Paulo
    Posts
    329
    Posts de Blog
    2

    Padrão

    Eu fiquei quase um mês fazendo tudo que é teste (do meu conhecimento), e a conclusão é que pra trabalhar com hotspot a melhor forma foi por rota, é a forma que tem apresentado o melhor aqui.
    Deixo um modem em bridge, com o mk discando normal, e em ip-->router, coloco tudo que quero que saia pelo outro link.
    Agora por grupo, não fui muito feliz não.. problema direto.

  8. #8

    Cool Como faço para load balançe com hotspot+cachefull+2 links dsl bridge

    ola pessoal ,to com um robleminha aqui ,tenho que fazer o balançe aqui entre 2 links para conecoes p2p so que nao tenho a minima ideia como faco isso,e tenho uma regra para pagina de aviso,por causa do cache full alguém poderia me ajudar


    vo postar as minhas regras de firewall


    add chain=prerouting p2p=all-p2p action=mark-connection \
    new-connection-mark=p2p passthrough=yes comment="P2P" disabled=no
    add chain=prerouting connection-mark=p2p action=mark-packet \
    new-packet-mark="p2p 2" passthrough=yes comment="" disabled=no
    add chain=output protocol=tcp src-port=3128 content="X-Cache: HIT" \
    action=mark-connection new-connection-mark="PROXY CONNECTION" \
    passthrough=yes comment="PRXY FULL" disabled=no
    add chain=output connection-mark="PROXY CONNECTION" action=mark-packet \
    new-packet-mark="PROXY PACKET" passthrough=yes comment="" disabled=no
    / ip firewall nat
    add chain=srcnat src-address=10.0.0.0/24 action=masquerade comment="masquerade \
    hotspot network" disabled=no
    add chain=pre-hotspot dst-address=200.221.0.0/16 action=accept comment="RADIO \
    UOL" disabled=no
    add chain=pre-hotspot dst-address=201.7.0.0/16 action=accept \
    comment="GLOBO.COM" disabled=no
    add chain=pre-hotspot dst-address=10.0.0.1 protocol=tcp dst-port=80 \
    hotspot=auth action=redirect to-ports=64873 comment="Paginas de status do \
    hotspot\"" disabled=no
    add chain=pre-hotspot in-interface=bridge1 protocol=tcp dst-port=80 \
    hotspot=auth action=redirect to-ports=3128 comment="REDIRECIONAMENTO DE \
    PROXY HOTSPOT" disabled=no
    / ip firewall connection tracking
    set enabled=yes tcp-syn-sent-timeout=5s tcp-syn-received-timeout=5s \
    tcp-established-timeout=1d tcp-fin-wait-timeout=10s \
    tcp-close-wait-timeout=10s tcp-last-ack-timeout=10s \
    tcp-time-wait-timeout=10s tcp-close-timeout=10s udp-timeout=10s \
    udp-stream-timeout=3m icmp-timeout=10s generic-timeout=10m \
    tcp-syncookie=no
    / ip firewall filter
    add chain=forward dst-address=10.0.0.0 protocol=tcp action=drop \
    comment="limitar conex es por clientes" disabled=no
    add chain=input in-interface="modem 4 Mega" protocol=tcp dst-port=3128 \
    action=drop comment="bloqueio de proxy externo" disabled=no
    add chain=input protocol=tcp psd=21,3s,3,1 action=drop comment="Bloquear \
    scanport" disabled=no
    add chain=input connection-state=established action=accept comment="Accept \
    established connections" disabled=no
    add chain=input connection-state=related action=accept comment="Accept related \
    connections" disabled=no
    add chain=input protocol=udp action=accept comment="UDP" disabled=no
    add chain=input protocol=icmp limit=50/5s,2 action=accept comment="Allow \
    limited pings" disabled=no
    add chain=input protocol=tcp dst-port=22 action=accept comment="SSH for secure \
    shell" disabled=no
    add chain=input protocol=tcp dst-port=8291 action=accept comment="winbox" \
    disabled=no
    add chain=input protocol=icmp icmp-options=8:0 limit=1,5 action=accept \
    comment="DOS ATTACK" disabled=no
    add chain=icmp protocol=icmp icmp-options=0:0 action=accept comment="drop \
    invalid connections" disabled=no
    add chain=icmp protocol=icmp icmp-options=3:0 action=accept comment="allow \
    established connections" disabled=no
    / ip firewall service-port
    set ftp ports=21 disabled=yes
    set tftp ports=69 disabled=yes
    set irc ports=6667 disabled=yes
    set h323 disabled=yes
    set quake3 disabled=yes
    set gre disabled=yes
    set pptp disabled=yes

    interface

    add name="pppoe-out 4 Mega" max-mtu=1480 max-mru=1480 interface="modem 4 Mega" \
    user="[email protected]" password="re...b" profile=default \
    service-name="" ac-name="" add-default-route=yes dial-on-demand=no \
    use-peer-dns=yes allow=pap,chap,mschap1,mschap2 disabled=no
    add name="pppoe-out 2 Mega" max-mtu=1480 max-mru=1480 interface="Modem 2 Mega" \
    user="[email protected]" password="re...b" profile=default \
    service-name="" ac-name="" add-default-route=yes dial-on-demand=no \
    use-peer-dns=yes allow=pap,chap,mschap1,mschap2 disabled=no

    adress list


    # ADDRESS NETWORK BROADCAST INTERFACE
    0 ;;; hotspot network
    10.0.0.1/24 10.0.0.0 10.0.0.255 bridge1
    1 D 201....2...14/32 200.204.......4 0.0.0.0 pppoe-out 2 Mega
    2 D 189....80..../32 201.92........7 0.0.0.0 pppoe-out 4 Mega


    como que faço