Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão

    Amigos, é possivel sim, load balance com o hospot, o que deve estar acontecendo com voces, pode estar relacionado a versao do mikrotik, na versao 3.23 esta funcionndo tranquilo, fiz 3 desses ontem ainda, com 5 links, com 2 links, com 3 adsl e 2 dedicado

    nao tem segredo mesmo, as regras que o hotspot faz nao tem nada de errado.

  2. #22

    Padrão

    Pior que não... Os ADSL's são de 2 operadoras diferentes. 1 deles é Oi e o outro Embratel...

    Com relação aos 2 gw da mesma operadora, eu tenho instalado em outro local uma rb com o lb do mesmo jeito desse, 2 adsl da mesma operadora e está funcionando normalmente. Só que lá eu NÃO uso hotspot. Em ip>routes eu estou escolhendo o GW Interface, sem informar o IP, talvez seja por isso que funciona...

    E nesse daqui, se eu desligar o HS funciona normalmente... Estou muito intrigado com isso...

    Abraços.



  3. #23

    Padrão

    Citação Postado originalmente por jhonnyp Ver Post
    Amigos, é possivel sim, load balance com o hospot, o que deve estar acontecendo com voces, pode estar relacionado a versao do mikrotik, na versao 3.23 esta funcionndo tranquilo, fiz 3 desses ontem ainda, com 5 links, com 2 links, com 3 adsl e 2 dedicado

    nao tem segredo mesmo, as regras que o hotspot faz nao tem nada de errado.
    Jhonnyp, vou atualizar a versão, embora tenha tido sérios problemas com a versão 3.23 + user-manager (escrevi sobre isto em outro tópico).

    Pelo que você viu nos outros posts, estaria tudo de acordo ou alguma crítica ?

    Obrigado e abraços.

  4. #24

    Padrão exemplo hotspot

    segue em anexo um exemplo de balanceamento, com hospot funcionando na versao 3.23
    fiz agora, usei lista adress list fixa, nao dinamica, só pra exemplo

    os dois link estao saindo por uma interface eth, indo pra um swith. e dai pros modems roteados.
    Arquivos Anexos Arquivos Anexos



  5. #25

    Padrão

    Citação Postado originalmente por jhonnyp Ver Post
    segue em anexo um exemplo de balanceamento, com hospot funcionando na versao 3.23
    fiz agora, usei lista adress list fixa, nao dinamica, só pra exemplo

    os dois link estao saindo por uma interface eth, indo pra um swith. e dai pros modems roteados.
    Obrigado pela configuração disponibilizada.

    A configuração está semelhante à que eu implementei, com a diferença que estou utilizando o MK para autenticar o pppoe, pra evitar sobrecarga e travamentos nos modems. Será que o problema é por conta disto (da autenticação ser feita pelo mk) ?

    Vou criar coragem pra rotear os modems e fazer uma outra programação para testar.

    Abraços.

  6. #26

    Padrão

    Citação Postado originalmente por jhonnyp Ver Post
    segue em anexo um exemplo de balanceamento, com hospot funcionando na versao 3.23
    fiz agora, usei lista adress list fixa, nao dinamica, só pra exemplo

    os dois link estao saindo por uma interface eth, indo pra um swith. e dai pros modems roteados.
    Amigo, o que seria esses IP´s?

    /ip firewall address-list
    add address=192.168.3.253 comment="" disabled=no list=link2
    add address=192.168.3.252 comment="" disabled=no list=link2



  7. #27

    Padrão

    estra é uma lista, onde cadastro manualmente os ips que quero que saiam por um link, ou por outro link

    como disse nao usei o nth nesse exemplo, pq o obejtivo era usar estaticamente mesmo,
    ip firewall address-list
    add address=192.168.3.253 comment="" disabled=no list=link2
    add address=192.168.3.252 comment="" disabled=no list=link1
    add address=192.168.3.244 comment="" disabled=no list=link2
    add address=192.168.3.252 comment="" disabled=no list=link2
    add address=192.168.3.233 comment="" disabled=no list=link1
    add address=192.168.3.252 comment="" disabled=no list=link2

    nesse caso é poucas maquinas, e link baixo. 1 de 128k e 1 de 64k ((hehe))

  8. #28
    Mikrotiando..
    Ingresso
    Sep 2007
    Localização
    São Paulo
    Posts
    329
    Posts de Blog
    2

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    rssssssssss

    Posso te garantir que funciona perfeitamente (uso em mais de 50 servidores aqui na empresa). Sobre o netwatch, infelismente tem muita coisa que não rola aqui e na maioria dos forum. Tenho dezenas de soluções que são particulares ou mesmo são exclusivas para atendimentos dos meus clientes. Muitas delas, eu tive que me dedicar muito mesmo para desenvolver (não aprendi em forum, até porque não tem nada a respeito). Consegui desenvolver um sisteminha simples que consegue monitorar a adsl do modem ou mesmo a condição do enlace de um link, caso o mesmo caia ele toma uma ação (não é o campo "distance" das rotas). Sabemos que a maioria dos problemas no load é que quando cai o link, a rota do modem (quando está roteado) continua ativa, fazendo com que o load dê pau. Isso já tenho solução a muito tempo. Outra coisa foi que consegui fazer o load + proxy sair pelos 2 links, pois também sabemos que quando se ativa o proxy, tudo que passa por ele sai pela rota default. Entre essas e outras tenho dezenas de soluções baseadas em scripts e outras ferramentas do próprio Mikrotik. Muitos aqui acham que eu fico perdendo meu tempo copiando isso ou aquilo pelos cantos, só rindo mesmo para não chorar!! Eu sei o quanto estudo e me dedico. Agora mesmo to estudando inglês na Wizard, pois pretendo ir ao MUM de Dallas no final do ano, em breve vamos ter novidades, pode anotar!! rsssssssssssss
    E ai David,
    Realmente funciona com hotspot e trabalha certinho com o "netwatch", os testes que eu estava fazendo era pegando 2 links wireless e jogando no MK e fazendo o balanciamento, desse modo não consegui usando o hotspot, mas pegando os 2 adsl vindo direto do modem, funcionou perfeito!!

    abraços,