Página 3 de 11 PrimeiroPrimeiro 12345678 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. Citação Postado originalmente por alamdias Ver Post
    Eu novamente.

    Nessa dica, vai um SCRIPT que pode ser alterado de várias formas, a fim de atender suas necessidades. Aqui acho muito útil pois, depois da meia noite, rodo todo mundo para 450k

    É uma ferramenta boa para testes de banda etc.. e gerenciamento dos clientes.

    Primeiro SCRIPT
    Função. Muda Incodicionalmente TODAS as queues, com base em uma busca onde TODAS as queues que tiverem o atributo PRIORITY=8 No meu caso, todas são 8, então a busca vai retornar 100%, ou seja TODAS

    /system script

    add name="GERAL PARA 256K" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"


    Esse script diz de uma forma leiga:

    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"
    ^^^^^MUDE ^^^^QUEM FOR PRIORITY=8 ^^PARA 100k UP / 256k down

    Daí você pode ter script de 100, 200 300 600k, da forma que quiser.

    Mas e se eu quiser mudar somente as queues dos meus clientes que tem 128k/128k, para 256/256?
    Basta mudarmos a busca.

    add name="128k/128k PARA 256k/256k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=128000/128000] max-limit=256000/256000"


    Nesse caso acima, o SET vai mudar todas que tiverem up/down = 128000 e vai mudar para 256/256.

    Não esqueça de fazer um script ao contrário, para retornar ao normal, logo ficaria assim:

    add name="256k/256k PARA 128k/128k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=256000/256000] max-limit=128000/128000"


    Observação: Cuidado com K (maiusculo) e k (minusculo).

    Basicamente, é tudo baseado no FIND. Sabendo fazer a busca certa, dá pra fazer de tudo.

    Daí é só fazer um agendamento para seu script rodar em determinados horários, ou utilizar o TRAFFIC MONITOR, para ver se o link estiver folgado, liberar mais banda para os clientes.

    Qualquer dúvida, estamos aí !

    Abraços

    Bem explicado, ficou muito boa sua DICA, poderia fazer mais algumas delas para tornar nosso fórum mais completo ?

    Esta de parabéns Alam, fico feliz em ver que além de você, esta semana ganhamos novos colaboradores, tenho lido o post de todos e notado que quem normalmente antes só agradecia agora também esta criando soluções e compartilhando com os demais, acho que este é o verdadeiro espirito do fórum.

    Grande abraço e espero que continue com este trabalho.

  2. Opa.

    A idéia e função do fórum deve ser sempre esta.

    Nem sempre podemos gastar 30 minutinhos, ajudando o conteúdo, adoro contribuir ! Mas nem sempre dá.

    Ás vezes fico pensando em no que criar um tópico de dicas.. mas o tempo é curto.

    Se nós não nos ajudarmos, o que será ?

    Abraços



  3. VALEW ALAM MUITO OBRIGADO PELO LINK DO YUTUB QUE VC COLOCOU AI DA REGRA DO ORKUT FICO MUITO AGRADECIDO POR ISSO VALEW MESMO....

  4. Citação Postado originalmente por VictorOliveira Ver Post
    como fazer este script rodar na versão 4.0Beta2? pelo que vi a maneira de usar find nas versões 4 foi modificada, ou pelo menos é um bug, porque o find na versão 4 retorna todos os valores existentes e não apenas o que procuramos, no caso acima de tivesse alguns clientes com prioridade = 5 ou 6 estariam dentro da nova velocidade, poderia esclarecer?
    Bom pessoal, quem estiver com este problema podem atualizar para a versão 4.0beta3 que o bug foi corrigido e funciona perfeitamente o script do colega, além disso foi incorporado o "LUA" shell para potencializar as possibilidades de tarefas agendadas com o mikrotik.



  5. Parabéns pelo, post

    posso postar estas regras no meu blog...


    falows...


    Citação Postado originalmente por alamdias Ver Post
    Eu novamente.

    Nessa dica, vai um SCRIPT que pode ser alterado de várias formas, a fim de atender suas necessidades. Aqui acho muito útil pois, depois da meia noite, rodo todo mundo para 450k

    É uma ferramenta boa para testes de banda etc.. e gerenciamento dos clientes.

    Primeiro SCRIPT
    Função. Muda Incodicionalmente TODAS as queues, com base em uma busca onde TODAS as queues que tiverem o atributo PRIORITY=8 No meu caso, todas são 8, então a busca vai retornar 100%, ou seja TODAS

    /system script

    add name="GERAL PARA 256K" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"

    Esse script diz de uma forma leiga:

    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"
    ^^^^^MUDE ^^^^QUEM FOR PRIORITY=8 ^^PARA 100k UP / 256k down

    Daí você pode ter script de 100, 200 300 600k, da forma que quiser.

    Mas e se eu quiser mudar somente as queues dos meus clientes que tem 128k/128k, para 256/256?
    Basta mudarmos a busca.

    add name="128k/128k PARA 256k/256k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=128000/128000] max-limit=256000/256000"

    Nesse caso acima, o SET vai mudar todas que tiverem up/down = 128000 e vai mudar para 256/256.

    Não esqueça de fazer um script ao contrário, para retornar ao normal, logo ficaria assim:

    add name="256k/256k PARA 128k/128k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=256000/256000] max-limit=128000/128000"

    Observação: Cuidado com K (maiusculo) e k (minusculo).

    Basicamente, é tudo baseado no FIND. Sabendo fazer a busca certa, dá pra fazer de tudo.

    Daí é só fazer um agendamento para seu script rodar em determinados horários, ou utilizar o TRAFFIC MONITOR, para ver se o link estiver folgado, liberar mais banda para os clientes.

    Qualquer dúvida, estamos aí !

    Abraços






Tópicos Similares

  1. Respostas: 7
    Último Post: 27-03-2015, 06:46
  2. Script para mudar regra no firewall, Filtro.
    Por ellandson no fórum Redes
    Respostas: 3
    Último Post: 21-02-2013, 23:12
  3. Dica - Script para DNS Dinamico (DynDNS)
    Por gsiena no fórum Redes
    Respostas: 0
    Último Post: 14-09-2009, 19:34
  4. Respostas: 5
    Último Post: 08-06-2009, 10:25
  5. Script para mudar atributos de arquivos
    Por nataniel no fórum Linguagens de Programação
    Respostas: 3
    Último Post: 11-04-2008, 13:46

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L