Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #21

    Padrão

    Pessoal, estou montando meu QOS aqui e estou com uma dúvida cruél, criei duas arvores de qos no queue tree, uma para upload (in-clientes > out-link) e outra para download (in-link > out-clientes), e respectivamente as duas tem o parent assim, QOS-Down - seu parent é global-in e na QOS-Up seu parent é global-out, a minha dúvida é a seguinte, isto está correto, pois estive pensando, tudo que é in no link ele prioriza, ok, e depois tudo que vai para o cliente é out, então há a necessidade de duas regras ? Na mesma conexão ele passa pela regra do global-in e out ? No mangle, utiliza-se para esta finalidade qual chain (prerouting, postrouting ou as duas para cada regra, ex. tudo que for porta 80, uma com prerouting e ela denovo com postrouting).

    Se alguém puder me ajudar, desejo elaborar um passo-a-passo de como montar um qos bem funcional e prático.

    Obrigado !!

  2. #22

    Padrão

    Faço isto usando prerouting para marcar a in e o postrouting marcando o dscp do prerouting anterior, assim fica melhor, pois não irie ter dois tipos de tráfego.



  3. #23

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Faço isto usando prerouting para marcar a in e o postrouting marcando o dscp do prerouting anterior, assim fica melhor, pois não irie ter dois tipos de tráfego.
    Raniel, gostei muito da sua explicação, você poderia exemplificar para ficar um pouco mais claro, a parte do postrouting eu não entendi muito bem, você altera o tos em prerouting e ignora ele no postrouting, assim somente terás o up originados pelos clientes ?


    Obrigado

  4. #24

    Padrão Consulta da Argentina

    Caro amigo

    Eu preciso saber se esta configuração é a implementação de QoS em um mikrotik funciona também como web proxy.

    E além de pedir
    Como faço para ajustar essas configurações para um mikrotik ThunderCache que está conectado?

    Espero a vossa ajuda, thanks

    * Tradução em Português com o Google Translator



  5. #25
    Não Registrado
    Visitante

    Padrão

    Citação Postado originalmente por insanet Ver Post
    Caro amigo

    Eu preciso saber se esta configuração é a implementação de QoS em um mikrotik funciona também como web proxy.

    E além de pedir
    Como faço para ajustar essas configurações para um mikrotik ThunderCache que está conectado?

    Espero a vossa ajuda, thanks

    * Tradução em Português com o Google Translator
    Sim, essa configuração está rodando em um mikrotik com o webproxy ativado.
    Creio que para colocar em funcionamento com um webproxy em paralelo, basta você editar a regra NAT que faz o redirecionamento para o proxy. E desativar o webproxy interno, é claro.

  6. #26

    Padrão

    Na configuração de você mostrar-se neste fórum, os pacotes de marca MSN para dar mais prioridade?
    Se isso não for contemplado, poderia me ajudar a configurar meu servidor?

    obrigado



  7. #27

    Padrão

    Amigo, primeiramente parabens pelo tutorial completíssimo... só preciso tirar uma dúvida, o que realmente significa e qual a finalidade das regras http... com tamanhos diferentes de arquivo e no final e principalmente http-Infinite.

    Obrigado!
    Última edição por EdilsonLSouza; 07-11-2009 às 23:47.

  8. #28

    Padrão

    isso só funciona com hotpot?

    uso dhcp com contrle de ip-mac

    como ficaria as minhas simple-queue?

    controlo a banda do cliente pela simple-queue

    fico no aguaro e agradeco desde ja

    ah...muito bom o artigo, parabens



  9. #29

    Padrão Já que estás a ajudar solicito uma informação!!!

    [QUOTE=renangomes;404699] Mikrotik 3.23
    renangomes,
    Muito bom mesmo este material, nós que já estamos por aqui a algum tempo sabemos que já esta tão difícil alguém postar materiais deste porte que caimos em cima de forma a parecer "urubu na carniça" (no sentido figurado e no bom sentido rsrsrs), mas eu quero aproveitar aqui para perguntar se já passou por isso, vejo que usa MK 3.23 você teve alguma dificuldade ao migrar das versões que no meu caso foi da 2.9.27 para 2.9.51(legal...) e agora quero apenas migrar para 3.13 e não consigo em meus testes que clientes naveguem, somente pegam IP e pronto não se faz mas nada o hotspot não da nem sinal de vida, se puder ajudar por favor sou todo ouvidos para que possa me ajudar, irei abrir um topico logo mais se não conseguir.
    desde já obrigado.

  10. #30

    Padrão

    Caro Renan:

    Antes de mais nada parabéns pela inciativa. Estive olhando a documentação que vc enviou e fiquei com algumas dúvidas. No parte do mangle, onde vc criou um bloco para HTTP, reparei que vc incluiu uma regra de marcação de conexões originadas na porta 80. Logo depois vc criou várias marcações de pacotes, a primeira delas atrelada às conexões da porta 80, onde vc define os tamanhos de downloads dos arquivos. O problema é que essas regras de marcação de pacotes não estão atreladas à marcação das conexões da porta 80 e sendo assim, a regra fica práticamente sem função.A marcação de pacotes não está apontada para qualquer regra de marcação de conexões na porta 80. Não sei se eu fiz algo errado aqui, mas a passagem de pacotes é praticamente nenhuma, nas opções de 1Mbyte pra cima.
    Você poderia trocar uma ideia sobre o assunto ?

    Abraço.



  11. #31

    Padrão

    Citação Postado originalmente por macewindu Ver Post
    Caro Renan:

    Antes de mais nada parabéns pela inciativa. Estive olhando a documentação que vc enviou e fiquei com algumas dúvidas. No parte do mangle, onde vc criou um bloco para HTTP, reparei que vc incluiu uma regra de marcação de conexões originadas na porta 80. Logo depois vc criou várias marcações de pacotes, a primeira delas atrelada às conexões da porta 80, onde vc define os tamanhos de downloads dos arquivos. O problema é que essas regras de marcação de pacotes não estão atreladas à marcação das conexões da porta 80 e sendo assim, a regra fica práticamente sem função.A marcação de pacotes não está apontada para qualquer regra de marcação de conexões na porta 80. Não sei se eu fiz algo errado aqui, mas a passagem de pacotes é praticamente nenhuma, nas opções de 1Mbyte pra cima.
    Você poderia trocar uma ideia sobre o assunto ?

    Abraço.
    Olá Renan !
    Conseguiu verificar o que apontei na resposta acima ?

  12. #32

    Padrão

    Citação Postado originalmente por renangomes Ver Post
    Bem, eu já tentei várias formas de melhorar a navegação de meus clientes. Recentemente eu sai "catanto" todas as dicas do UnderLinux e na Wiki do Mikrotik e cheguei ao meu Sistema de QoS proprio....
    ...

    Caso alguem encontre algum erro, por favor, poste aqui para que eu saiba do mesmo e corrija em meu servidor.
    Renan, a marcação de pacotes esta fazendo o trabalho dela certinho, porém as queues tree não estao fazendo quase nada, ou pelo menos, não estão fazendo seu papel principal (priorizar trafego e reservar banda). Para que isso ocorra você tem que primeiramente informar para seu sistema o quanto de banda disponivel voce tem. Definindo isso através de uma arvore pai, apos isso voce vai dividir e alocar essa banda para servicos especificos, atraves de arvores filhas, que devem estar obrigatoriamente dentro da hierarquia de arvores.
    Entao é necessario termos em mente bem definido o conceito de QoS, e o que esperamos conseguir atraves da implementacao de tais politicas.
    No entanto parabens pela iniciativa.



  13. #33

    Padrão

    Citação Postado originalmente por anjunior Ver Post
    Renan, a marcação de pacotes esta fazendo o trabalho dela certinho, porém as queues tree não estao fazendo quase nada, ou pelo menos, não estão fazendo seu papel principal (priorizar trafego e reservar banda). Para que isso ocorra você tem que primeiramente informar para seu sistema o quanto de banda disponivel voce tem. Definindo isso através de uma arvore pai, apos isso voce vai dividir e alocar essa banda para servicos especificos, atraves de arvores filhas, que devem estar obrigatoriamente dentro da hierarquia de arvores.
    Entao é necessario termos em mente bem definido o conceito de QoS, e o que esperamos conseguir atraves da implementacao de tais politicas.
    No entanto parabens pela iniciativa.

    Então se deixar sem limitação de banda na queue tree, irá apenas marcar os pacotes mas não vai priorizar trafego e reservar banda?

  14. #34

    Padrão

    Citação Postado originalmente por renangomes Ver Post
    # Adicionando as Filas
    # Meu link eh de 1M, e algumas filas estao liberadas. (ex. A navegacao)
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=10M name=Cache-Full packet-mark=proxyfull parent=\
    global-total priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=1M name=ServicosDaRede packet-mark=servicosdarede parent=\
    global-total priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Ssl packet-mark=ssl parent=global-total priority=2 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=200k name=P2P packet-mark=p2p parent=global-total priority=\
    8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=1M name=BatePapo packet-mark=batepapo parent=global-total \
    priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Udp packet-mark="" parent=global-total priority=3 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Udp-100 packet-mark=udp-100 parent=Udp priority=1 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Udp-500 packet-mark=upd-500 parent=Udp priority=2 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Udp-Other packet-mark=upd-other parent=Udp priority=\
    3 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Email packet-mark="" parent=global-total priority=4 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Pop3 packet-mark=pop3 parent=Email priority=1 queue=\
    default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Imap packet-mark=imap parent=Email priority=3 queue=\
    default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Http packet-mark="" parent=global-total priority=2 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=1M name=Http-Navegacao packet-mark=http-navegacao parent=\
    global-total priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Http-1Mbyte packet-mark=http-1Mbyte parent=Http \
    priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Http-3Mbyte packet-mark=http-3Mbyte parent=Http \
    priority=3 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Http-6Mbyte packet-mark=http-6Mbyte parent=Http \
    priority=4 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Http-30Mbyte packet-mark=http-30Mbyte parent=Http \
    priority=5 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Http-60Mbytes packet-mark=http-60Mbytes parent=Http \
    priority=6 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=600k name=Http-Infinite packet-mark=http-Infinite parent=\
    Http priority=7 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Youtube packet-mark=Youtube parent=Http priority=4 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Outros packet-mark="" parent=global-total priority=7 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Outros-0bytes packet-mark=0bytes parent=Outros \
    priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Outros-1Mbyte packet-mark=1Mbyte parent=Outros \
    priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Outros-3Mbyte packet-mark=3Mbyte parent=Outros \
    priority=3 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Outros-6Mbyte packet-mark=6Mbyte parent=Outros \
    priority=4 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Outros-30Mbyte packet-mark=30Mbyte parent=Outros \
    priority=5 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Outros-60Mbytes packet-mark=60Mbytes parent=Outros \
    priority=6 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Outros-Infinite packet-mark=Infinite parent=Outros \
    priority=7 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Outros-Desconhecidos packet-mark=Outros parent=\
    Outros priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=AcessoRemoto packet-mark=acessoremoto parent=\
    global-total priority=3 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Voip packet-mark=voip parent=global-total priority=6 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=5M name=Hotspot packet-mark=hotspot parent=global-total \
    priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=Smtp packet-mark=smtp parent=Email priority=2 queue=\
    default



    ---
    Ixi maria! Muito maior do que eu imaginei.. Pensei que ia caber tudo em um post só...



    Teria como me ajudar no meu firewall
    estou precisando melhorar



  15. #35

    Padrão

    galera...aos mais entendidos, uma dúvida que sempre tive.

    imaginem uma rede, com uns 10 mkt e tudo em bridge. imagine que é uma fila indiana eles ok?

    imagine que o mkt 1 é onde vem o link e o mkt 10 é onde estou conectao, o QoS para funcionar, deveria ser feito igualmente em todos os 10mkt ou só no 10 e no 1?

    Obrigado

  16. #36

    Padrão

    Sem dúvida para otimizar o tráfego interno é interessante configurar o mesmo qos em todas as 10 rbs.
    Além de fazer o mesmo no Servidor.



  17. #37
    rogernofx
    Visitante

    Padrão

    Boa noite !!! Alguem sabe me dar uma informaçao se o QoS funciona no MK em modo Bridge ?????
    Fico no aguardo Obrigado!!!!

  18. #38



  19. #39

    Padrão

    amigos, minha topologia de rede é semelhante ao do nosso amigo renan, criador do topico, e seguindo as regras dele, e usando um outro manual que tinha eu ativei o meu webproxy, fiz as regras de nat, mangle, queue simple, aí depois "fiz" as regras do Qos Completo, acontece que cada usuario que conecta ao hotspot a regra do cache full vai descendo, então gostaria de saber se teria que colocar algum script para ela sempre ficar no topo da simple queue ?, outra coisa fiz o teste do cache full, e baixei o winrar no baixaki, limpei o cache do navegador e baixei novamente o winrar, vi que funcionou o cache, pois o segundo download foi bem rapido, aí fui fazer o mesmo teste com o java, no java.com, fiz o primeiro donwload e no 2º e 3º download ele continuou baixando direto do site, sem pegar o arquivo que ja estava no cache, isso tem a ver com o tamanho do arquivo será ?

    agradeço a todos que puder me ajudar com essas duvidas ..

    Att
    Helder

  20. #40

    Padrão

    olha se lá no hotspot, user profiles olha se o transparent proxy está marcado?, se estiver desmarque! acho que isso pode ajudar, o seu webproxy é paralelo ou o do mkt mesmo?


    Citação Postado originalmente por exclusivenet Ver Post
    amigos, minha topologia de rede é semelhante ao do nosso amigo renan, criador do topico, e seguindo as regras dele, e usando um outro manual que tinha eu ativei o meu webproxy, fiz as regras de nat, mangle, queue simple, aí depois "fiz" as regras do Qos Completo, acontece que cada usuario que conecta ao hotspot a regra do cache full vai descendo, então gostaria de saber se teria que colocar algum script para ela sempre ficar no topo da simple queue ?, outra coisa fiz o teste do cache full, e baixei o winrar no baixaki, limpei o cache do navegador e baixei novamente o winrar, vi que funcionou o cache, pois o segundo download foi bem rapido, aí fui fazer o mesmo teste com o java, no java.com, fiz o primeiro donwload e no 2º e 3º download ele continuou baixando direto do site, sem pegar o arquivo que ja estava no cache, isso tem a ver com o tamanho do arquivo será ?

    agradeço a todos que puder me ajudar com essas duvidas ..

    Att
    Helder