+ Responder ao Tópico



  1. #1

    Padrão Apenas um usuário no sarg...

    PessoALL,

    Eu não consigo configurar o SARG ou MK para gerar relatório de cada usuário... apenas o usuário IP da máquina do SQUID. O que estou fazendo de errado? é a regra de redirecionamento? ou configuração no squid.conf?

    Veja na imagem!

    Obrigado!
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         sarg.JPG
Visualizações:	232
Tamanho: 	44,0 KB
ID:      	4586  

  2. #2

    Padrão

    tb passo pelo mesma situação

    ja dei uma lida aki no fórum + naum obtive sucesso



  3. #3

    Padrão

    Bom, então vamos aguardar um amigo nos dar uma luz!

  4. #4

    Padrão galera ajuda ai

    Citação Postado originalmente por EdilsonLSouza Ver Post
    Bom, então vamos aguardar um amigo nos dar uma luz!

    cara naum estou muito certo + parece q tem q enviar as requisições do mk pro sarg

    agora eu naum sei como se faz isso

    pelo q andei lendo são regras aplicadas no firewall do mk desviando e recebendo devolta os pacotes

    os pacotes tem q pasar pelo sarg



  5. #5

    Padrão parent proxy

    não pode ser usado parent proxy no mikrotik, tem que ser criado um NAT para o squid no mikrotik....

  6. #6

    Padrão

    isso ae, parent rola n, bom e com dstnat,,,
    enquanto a o proxy receber o ip apenas do mk 'gw', segui uma regra do alexandre correa, e ate agora, tudo em ordem,,

    ja postado no forum!
    basicamente, marca rota http, cria uma rota no mk para o gw de todos ser o proxy.. e aponta a marcação de rota,,
    no proxy.. linux, ative o roteamento, crie um masquerade, e redirecione todo o trafego da 80 para a porta de seu proxy..
    detalhe, desativar o 'nat' dos clientes no mk e o 'redirect' pra o proxy..
    repito.. ja postado no forum!



  7. #7

    Padrão

    Citação Postado originalmente por alanvictorjp Ver Post
    isso ae, parent rola n, bom e com dstnat,,,
    enquanto a o proxy receber o ip apenas do mk 'gw', segui uma regra do alexandre correa, e ate agora, tudo em ordem,,

    ja postado no forum!
    basicamente, marca rota http, cria uma rota no mk para o gw de todos ser o proxy.. e aponta a marcação de rota,,
    no proxy.. linux, ative o roteamento, crie um masquerade, e redirecione todo o trafego da 80 para a porta de seu proxy..
    detalhe, desativar o 'nat' dos clientes no mk e o 'redirect' pra o proxy..
    repito.. ja postado no forum!
    Eu procurei e não encontrei... o que consegui não era o que eu esperava... se pesquisar por "usuário" "sarg" "um" não encontra... se você souber o link eu ficaria grato! não é preguiça de procurar não, eu não localizei mesmo! valeu!

  8. #8

    Padrão

    Solução para voces:

    Mikrotik + Squid 3.0-Stable8 Paralelo(rota estática) + Thunder Cache + Sarg

    Utilizem as regras de IPTABLES desse tópicos que continuarão controlando a banda no MK porém as requisições chegaram ao SQUID por cada IP dos clientes.



  9. #9

    Padrão

    PessoALL,

    Eu segui todos os procedimento das informações postadas, mas mesmo assim hoje o relatório foi gerado com apenas um cliente.

  10. #10

    Padrão tenta assim

    Citação Postado originalmente por EdilsonLSouza Ver Post
    PessoALL,

    Eu segui todos os procedimento das informações postadas, mas mesmo assim hoje o relatório foi gerado com apenas um cliente.
    tenta desta forma :

    / ip firewall nat
    add chain=srcnat action=masquerade comment="MASCAREDE PARA A REDE" \
    disabled=yes

    add chain=dstnat src-address=10.1.1.0 dst-address=10.1.1.0 protocol=tcp \
    dst-port=80 action=dst-nat to-addresses=192.168.10.250 to-ports=3128 \
    comment="********desvia o trafego pra o prove***********" disabled=no


    add chain=srcnat src-address=10.1.1.0/24 dst-address=!192.168.10.250 \
    action=masquerade comment="masquerade hotspot network" disabled=no
    add chain=srcnat src-address=192.168.10.250 action=masquerade \
    comment="masquerade hotspot network" disabled=no
    add chain=pre-hotspot src-address=10.1.1.0/24 protocol=tcp dst-port=80 \
    hotspot=auth action=dst-nat to-addresses=192.168.10.250 to-ports=3128 \
    comment=">>PROXY DEBIAN<<" disabled=no


    *10.1.1.0/24 rede clientes( substitua pela sua rede)
    *192.168.10.250 ip do servidor onde esta o squid/sarg (se ligue tb na porta q esta sendo usada pelo squid.conf (aki uso a 3128))
    *depois q colocar as regas lembre-se de desabilitar o mascarede para a rede
    / ip firewall nat
    add chain=srcnat action=masquerade comment="MASCAREDE PARA A REDE" \
    disabled=yes


    *se ligue tb nessas regras pra o squid:
    acl redelocal src 10.1.1.0/24
    http_access allow localhost
    http_access allow redelocal
    liberam acesso a sua rede

    aki como uso o hotspot ja mandei com todas as regras para o mesmo ser utilizado

    espero ter ajudado qualquer duvida e so me add (tentaremos resolver)