+ Responder ao Tópico



  1. #1

    Padrão Queue Tree/QoS - mais de uma interface publica... como fazer??

    Bom dia amigos, to com uma dúvida aki. Tenho um Mikrotik com 5 interfaces publicas (conectadas diretamente à Internet) e uma local, fazendo load balance, tudo certinho.
    Porem eu gostaria de fazer um Qos, priorizar certos trafegos... com uma interface publica e uma local ja fiz .. porem como fazer com mais de uma interface publica?
    Desde ja grato.

    Att.
    Gabriel Siena

  2. #2
    Avatar de felixhmakowski
    Ingresso
    Feb 2009
    Localização
    Pitanga, Parana, Brazil, Brazil
    Posts
    171

    Padrão

    tenho 2 links fibra to usando qos e nao tem problema, pelo contrario funciona melhor que o load
    cara faz assim

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="CONTROLE NAVEGACAO" \
    disabled=no dst-port=443 new-connection-mark=Navegacao-Conexao \
    passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    3528 new-connection-mark=Navegacao-Conexao passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    80 new-connection-mark=Navegacao-Conexao passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    53 new-connection-mark=Navegacao-Conexao passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    53 new-connection-mark=Navegacao-Conexao passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    21 new-connection-mark=Navegacao-Conexao passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    Navegacao-Conexao disabled=no new-packet-mark=Navegacao-Pacotes \
    passthrough=no
    add action=mark-connection chain=prerouting comment="CONTROLE E-MAIL" \
    disabled=no dst-port=110 new-connection-mark=E-mail-Conexao passthrough=\
    yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    25 new-connection-mark=E-mail-Conexao passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    25 new-connection-mark=E-mail-Conexao passthrough=yes protocol=udp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    E-mail-Conexao disabled=no new-packet-mark=E-mail-Pacotes passthrough=no
    add action=mark-connection chain=prerouting comment="CONTROLE MESSENGER" \
    disabled=no dst-port=1863 new-connection-mark=Messenger-Conexao \
    passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    1863 new-connection-mark=Messenger-Conexao passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    6891-6901 new-connection-mark=Messenger-Conexao passthrough=yes protocol=\
    tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    6891-6901 new-connection-mark=Messenger-Conexao passthrough=yes protocol=\
    udp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    5190 new-connection-mark=Messenger-Conexao passthrough=yes protocol=udp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    Messenger-Conexao disabled=no new-packet-mark=Messenger-Pacotes \
    passthrough=no
    add action=mark-connection chain=prerouting comment="CONTROLE P2P" disabled=\
    no new-connection-mark=P2P-Conexao-Limite p2p=all-p2p passthrough=yes \
    protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    P2P-Conexao-Limite disabled=no new-packet-mark=P2P-Pacotes passthrough=no
    add action=mark-connection chain=prerouting comment="CONTROLE ICMP" disabled=\
    no new-connection-mark=ICMP-Conexao passthrough=yes protocol=icmp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    ICMP-Conexao disabled=no new-packet-mark=ICMP-Pacotes passthrough=no
    add action=mark-connection chain=prerouting comment="CONTROLE ACESSO REMOTO" \
    disabled=no dst-port=22 new-connection-mark=Acesso-Remoto-Conexao \
    passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    23 new-connection-mark=Acesso-Remoto-Conexao passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Terminal Server" \
    disabled=no dst-port=3389 new-connection-mark=Acesso-Remoto-Conexao \
    passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment=VNC disabled=no dst-port=\
    5800 new-connection-mark=Acesso-Remoto-Conexao passthrough=yes protocol=\
    tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    5900 new-connection-mark=Acesso-Remoto-Conexao passthrough=yes protocol=\
    tcp
    add action=mark-connection chain=prerouting comment=Winbox disabled=no \
    dst-port=8291 new-connection-mark=Acesso-Remoto-Conexao passthrough=yes \
    protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    Acesso-Remoto-Conexao disabled=no new-packet-mark=Acesso-Remoto-Pacotes \
    passthrough=no
    add action=mark-connection chain=prerouting comment=\
    "CONTROLE BANCO DE DADOS - SQL" disabled=no dst-port=3306 \
    new-connection-mark=Banco-Dados-Conexao passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment=Oracle disabled=no \
    dst-port=1521 new-connection-mark=Banco-Dados-Conexao passthrough=yes \
    protocol=tcp
    add action=mark-connection chain=prerouting comment="Microsoft SQL Server" \
    disabled=no dst-port=1433-1434 new-connection-mark=Banco-Dados-Conexao \
    passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    Banco-Dados-Conexao disabled=no new-packet-mark=Banco-Dados-Pacotes \
    passthrough=no
    add action=mark-connection chain=prerouting comment="CONTROLE JOGOS" \
    disabled=no dst-port=7171 new-connection-mark=Jogos-Conexao passthrough=\
    yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    27015 new-connection-mark=Jogos-Conexao passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="Mu Online" disabled=no \
    dst-port=55905 new-connection-mark=Jogos-Conexao passthrough=yes \
    protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    55905 new-connection-mark=Jogos-Conexao passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="Line Age" disabled=no \
    dst-port=4376 new-connection-mark=Jogos-Conexao passthrough=yes protocol=\
    tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    4376 new-connection-mark=Jogos-Conexao passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment=WarCraft disabled=no \
    dst-port=6112 new-connection-mark=Jogos-Conexao passthrough=yes protocol=\
    tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    6112 new-connection-mark=Jogos-Conexao passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    4500 new-connection-mark=Jogos-Conexao passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    4500 new-connection-mark=Jogos-Conexao passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    6900 new-connection-mark=Jogos-Conexao passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    6900 new-connection-mark=Jogos-Conexao passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    5000 new-connection-mark=Jogos-Conexao passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    5000 new-connection-mark=Jogos-Conexao passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="Counter Strike" \
    disabled=no dst-port=27018 new-connection-mark=Jogos-Conexao passthrough=\
    yes protocol=tcp



  3. #3
    Avatar de felixhmakowski
    Ingresso
    Feb 2009
    Localização
    Pitanga, Parana, Brazil, Brazil
    Posts
    171

    Padrão

    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    27018 new-connection-mark=Jogos-Conexao passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    27015 new-connection-mark=Jogos-Conexao passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    27015 new-connection-mark=Jogos-Conexao passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    27016 new-connection-mark=Jogos-Conexao passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    27016 new-connection-mark=Jogos-Conexao passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    27020 new-connection-mark=Jogos-Conexao passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    27020 new-connection-mark=Jogos-Conexao passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    27019 new-connection-mark=Jogos-Conexao passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    27019 new-connection-mark=Jogos-Conexao passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    27013 new-connection-mark=Jogos-Conexao passthrough=yes protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    27013 new-connection-mark=Jogos-Conexao passthrough=yes protocol=udp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    Jogos-Conexao disabled=no new-packet-mark=Jogos-Pacotes passthrough=no
    add action=mark-connection chain=prerouting comment="CONTROLE UDP" disabled=\
    no new-connection-mark=UDP-Conexao passthrough=yes protocol=udp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    UDP-Conexao disabled=no new-packet-mark=UDP-Pacotes passthrough=no
    add action=mark-connection chain=prerouting comment=\
    "CONTROLE SERVICOS NAO IDENTIFICADOS" disabled=no new-connection-mark=\
    Outros-Conexao passthrough=yes
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    Outros-Conexao disabled=no new-packet-mark=Outros-Pacotes passthrough=no
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=100M name=QOS packet-mark="" parent=global-total priority=8 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=100M \
    max-limit=100M name="1 - Navegacao" packet-mark=Navegacao-Pacotes parent=\
    QOS priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=512k \
    max-limit=1M name="2 - Messenger" packet-mark=Messenger-Pacotes parent=\
    QOS priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=512k \
    max-limit=1M name="2 - E-mail" packet-mark=E-mail-Pacotes parent=QOS \
    priority=3 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=512k name="8 - P2P" packet-mark=P2P-Pacotes parent=QOS \
    priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=256k \
    max-limit=1M name="4 - Acesso-Remoto" packet-mark=Acesso-Remoto-Pacotes \
    parent=QOS priority=2 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=256k \
    max-limit=512k name="5 - ICMP" packet-mark=ICMP-Pacotes parent=QOS \
    priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=2M \
    max-limit=4M name="6 - UDP" packet-mark=UDP-Pacotes parent=QOS priority=3 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=10M name="7 - Outros" packet-mark=Outros-Pacotes parent=QOS \
    priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=256k \
    max-limit=512k name="3 - Banco-Dados" packet-mark=Banco-Dados-Pacotes \
    parent=QOS priority=3 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=512k \
    max-limit=1M name="3 - Jogos" packet-mark=Jogos-Pacotes parent=QOS \
    priority=3 queue=default
    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    GATEWAY 1 ,GATEWAY 1 ,GATEWAY 2,GATEWAY 2 ,GATEWAY 2,GATEWAY 3 \
    scope=255 target-scope=10
    NO EXEMPLO DE 3 LINKS
    LINK 1 = 2 MB GATEWAY 192.192.192.192
    LINK 2= 3MB GATEWAY 192.192.192.193
    LINK 3= 1 MB GATEWAY 172.168.29.1
    NO CASSO FICARIA ASSIM
    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.192.192.192 ,192.192.192.192 ,192.192.192.193,192.192.192.193 ,192.192.192.193,172.168.29.1 \
    scope=255 target-scope=10
    OU SEJA PRA CADA 1 MB DE LINK ADICIONA 1 GATEWAY E TODOS OS GATEWAYS EM UMA MSM ROUTE OU SEJA ESSE É O LOAD PRA QOS
    QUALQUER COISA POSTA AKI

  4. #4

    Padrão Testando

    Ok amigo, muito obrigado pelas regras, vou fazer testes e posto os resultados.



  5. #5
    Avatar de felixhmakowski
    Ingresso
    Feb 2009
    Localização
    Pitanga, Parana, Brazil, Brazil
    Posts
    171

    Padrão

    SO PRA LEMBRAR ESSAS REGRA SO FUNCINAM NA VERSAO 3.X

  6. #6

    Padrão

    Ola amigo Felix.. achei bem interessante suas regras,,, mas uma pergunta!

    Como vc controle o que eh up e o que eh down???

    Ta tudo no mesmo?

    achei estranho isso,... principalmente pelo P2P...

    abraço Tiago


    Edit..: Outra dúvida... ao implantar a regra.. fica 90% do trafego no OUTROS.. vc sabe porque?
    Última edição por tmelooliveira; 03-07-2009 às 21:09. Razão: alteração pergunta



  7. #7
    Avatar de felixhmakowski
    Ingresso
    Feb 2009
    Localização
    Pitanga, Parana, Brazil, Brazil
    Posts
    171

    Padrão

    controle de up e don ta tudo no msm...
    questao de outros..desabilita as outras regras que vc tem ai ... se tiver proxy é so adiciona a porta no controle navegacao...eu uso aki na versao 3.24... se for outra versao diferente pode dar problema... principalmente se for 2.x.x ou 3.12, 3.13, 3.14, 3.15, 3.16, 3.17 essas tao com bug e o qos nao fica legal...

  8. #8

    Padrão

    Tem como fazer up e down separados???

    é so marcar in e out?

    Meu link é assimétrico.. e ter tudo no mesmo é complicado!



  9. #9
    Avatar de felixhmakowski
    Ingresso
    Feb 2009
    Localização
    Pitanga, Parana, Brazil, Brazil
    Posts
    171

    Padrão

    sim tem como, so que da trabalho..vai duplica a quantidade de regras..
    duplica as regras e especifica o in e out, la em queues tree

  10. #10

    Padrão

    Valeu amigo....

    Suas dicas me ajudaram muito.. assim que eu configurar meu Qos com o up e down separado eu posto aqui...

    Agora to com outra dúvida! (pra variar)

    Mesmo eu adicionando a minha porta do webproxy (3128) na marcação dos pacotes continua passando um monte de coisa pela porta 80 sem ser marcada.. vc pode dar uma olhada no print?

    To fritando aqui e as vezes uma pessoa de fora resolve rapido!

    Grato Tiago (foto em anexo)
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         duvida qos.JPG
Visualizações:	269
Tamanho: 	260,5 KB
ID:      	4825  



  11. #11
    Avatar de felixhmakowski
    Ingresso
    Feb 2009
    Localização
    Pitanga, Parana, Brazil, Brazil
    Posts
    171

    Padrão

    cara eu fiz aki so o controle do que vai pros clientes....donloads
    o upload e feito no controle de banda do cliente...
    ta filé...
    esse problema do web-proxy nunca vi...
    que versao do mk vc ta usando?...

  12. #12

    Padrão

    no mangle poderia colocar otimizado a parte de jogos tcp-ports 27010-27018 e mesmo pro udp, mas o balance ae por ecmp roda sim, mas estou mudando pra testes o pcc

    mas valeu o post



  13. #13

    Padrão

    Amigo felixhmakowski adorei sua marcacao, muito boa mesmo. Estava procurando estudar sobre o assunto vai me ajudar.
    Estou usando a versao 3.30 do MK será que da certinho ? meu link é de 5 megas, essa marcacao da certo pra 5 megas ?
    Depois se tiver como me enviar o filter tbm pra eu estudar aqui: [email protected]
    Essa marcacao que vc fez deve ter dado um trabalho danado né ? fazer igual ao Maia da MD Brasil, vc deve ter desenhado antes, rsrsrs

  14. #14
    Avatar de felixhmakowski
    Ingresso
    Feb 2009
    Localização
    Pitanga, Parana, Brazil, Brazil
    Posts
    171

    Padrão

    Citação Postado originalmente por superxandaoce Ver Post
    Amigo felixhmakowski adorei sua marcacao, muito boa mesmo. Estava procurando estudar sobre o assunto vai me ajudar.
    Estou usando a versao 3.30 do MK será que da certinho ? meu link é de 5 megas, essa marcacao da certo pra 5 megas ?
    Depois se tiver como me enviar o filter tbm pra eu estudar aqui: [email protected]
    Essa marcacao que vc fez deve ter dado um trabalho danado né ? fazer igual ao Maia da MD Brasil, vc deve ter desenhado antes, rsrsrs
    velho tenho aki um servidor com 6MB divididos em 2 link e ta funcionando muito bem,
    em relaçao a versao que vc ta usando recomendo a 3.28 que ta mais robusta a 3.30 ta com bug no pppoe
    as regras do filter estao ai https://under-linux.org/f132201-filt...eto#post438554
    gente boa o MAIA fiz um curso com ele em florianopolis pense que fodesao hsuasuasasuh
    qualquer coisa posta ai...
    abrass



  15. #15

    Padrão

    amigo, eu to fazendo cache em paralelo com o squid 2.7, como ficaria a marcação do cache full ? neste seu exemplo ? onde e como eu add a marcação ?