+ Responder ao Tópico



  1. #1

    Padrão web-proxy apenas para log

    Bom dia galera.

    Alguem já usou o web-proxy do mkt apenas para salvar logs das páginas acessadas dos clientes?

    Eu tentei usar em RB das versões 3.xx, e o processamento vai a 100% sempre. E não faço cache nem nada, só salvar os logs mesmo via syslog.Uso RB de 300mhz e 600mhz.
    Alguem tem alguma dica pra pasasr sobre isso?


    Valeu

  2. #2

    Padrão

    Olá meu caro,
    Se quer apenas saber os passos andados pelos usuários de sua rede pode usar um servidor mikrotik separado com o servidor calea configurado.



  3. #3
    vmh0909
    Visitante

    Padrão

    Ola.

    eu utilizei uma RB450G e fiz conforme abaixo, e fiz um programa para ler estes logs e gerar relatorios em banco de dados mysql.

    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=2048KiB \
    max-client-connections=600 max-fresh-time=3d max-server-connections=600 \
    parent-proxy=0.0.0.0 parent-proxy-port=0 port=8080 serialize-connections=\
    no src-address=0.0.0.0
    /ip firewall nat
    add action=redirect chain=dstnat comment="redirecionar trafego Web proxy para gerar log" disabled=no dst-port=80 \
    in-interface=ether2 protocol=tcp to-ports=8080
    /ip firewall filter
    add action=drop chain=input comment="" disabled=no dst-port=8080 \
    in-interface=ether1 protocol=tcp
    /system logging action
    add disk-file-count=5 disk-file-name=acessos disk-lines-per-file=10000 \
    disk-stop-on-full=no name=acesso target=disk
    add disk-file-count=5 disk-file-name=usuarios disk-lines-per-file=100 \
    disk-stop-on-full=no name=usuario target=disk
    /system logging
    add action=acesso disabled=no prefix=<<<acesso>>> topics=web-proxy,!debug
    add action=usuario disabled=no prefix=<<<usuario>>> topics=hotspot

    Funcionou legal.
    espero ter ajudado, pois não sou muito bom neste tal de MK.

  4. #4

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Olá meu caro,
    Se quer apenas saber os passos andados pelos usuários de sua rede pode usar um servidor mikrotik separado com o servidor calea configurado.

    Raniel este sistema trabalha da mesma forma que o Proxylizer ??

    obrigado



  5. #5

    Padrão

    Citação Postado originalmente por gustavinho69 Ver Post
    Raniel este sistema trabalha da mesma forma que o Proxylizer ??

    obrigado
    Este sistema faz a mesma coisa que um sniffer, ele filtra tudo que é acessado e gera um relatório. Podemos dizer, parcialmente, que trabalha.

  6. #6

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Este sistema faz a mesma coisa que um sniffer, ele filtra tudo que é acessado e gera um relatório. Podemos dizer, parcialmente, que trabalha.
    Hum entendi, mais sera que é mais eficiente que o Proxylizer????

    Pois pelo que vi no proxylizer ele ja captura os logs de acordo com os users do hotspot e ainda da opções de envio do relatorio por email.



  7. #7

    Padrão

    Olha meu caro, eu nunca usei o este sistema, fiquei de fazer alguns testes mais até agora tô enrolando. Mas pelo que eu lhe, ele é obrigatório nos EUA.

  8. #8

    Padrão

    Eh eu também só cheguei a instalar ele mais nao coloquei em uso....mais agora que vc citou este vou ver se faço o teste.

    vlw



  9. #9

    Padrão

    tentei utilizr o proxylizer, mas nao consegui, usei a imagem de vm que tem la no wiki mas ele nao funcionou aqui, preciso ver o porque ainda.

    mas o calea, ainda não testei. preciso estudar ele ainda pra ver como eles faz. mas pelo que entendi, ele realmente sniffa e envia pra outro mkt que armazena esses logs, correto?

    alguem tem mais sujestões ou mais informações sobre esses sistemas?

    obrigado.

  10. #10

    Padrão

    pelo que eu entendi dele ele sniffa e guarda as informações em um arquivo no proprio MK.

    Mais é preciso criar regras para cada rede do MK, pelo menos foi o que entendi.

    Até entao acho que o proxylizer ja é muito mais eficiente.



  11. #11

    Padrão

    o proxylizer, nao consegui rodar..rsrs..depois mexo mais nele..mas ainda com ele necessito do web-proxy. minha solução que estava usando (Dude recebendo os logs de todos mkt e salvando), reativei, mas em uns 3 a 4 mkt só pra testar.
    Coloquei uma regra que criei para que se o processamento for mais que 90%, ele desativa o web-proxy com as regras dele...assim, nao corro o risco de ficar ruim as conexões.