+ Responder ao Tópico



  1. #1

    Exclamation Ajuda com putty

    Estou tentando acessar meu servidor linux fora da rede interna e não estou conseguindo.

    estou em um terminal windows com putty instalado, e quero acessar o servidor que está com slackware instalado e com ip dinamico eu sei qual é o ip, mas não estou conseguindo acessar sempre aparece a mensagem de erro: "Network erro: connection timed out"

    já que na rede interna eu acesso normalmente.
    qual comando devo usar para conseguir o acesso na rede externa?

  2. #2
    Sempre na luta Avatar de jacksonezidio
    Ingresso
    Jun 2008
    Localização
    São Paulo - SP
    Posts
    208
    Posts de Blog
    1

    Post

    Citação Postado originalmente por NetLagos Ver Post
    Estou tentando acessar meu servidor linux fora da rede interna e não estou conseguindo.

    estou em um terminal windows com putty instalado, e quero acessar o servidor que está com slackware instalado e com ip dinamico eu sei qual é o ip, mas não estou conseguindo acessar sempre aparece a mensagem de erro: "Network erro: connection timed out"

    já que na rede interna eu acesso normalmente.
    qual comando devo usar para conseguir o acesso na rede externa?

    Esta tentando logar como root ou usuario?
    O slackware esta direto na internet com ip dinamico eh isso?
    ja verificou seu arquivo de configuração do servidor ssh?



  3. #3

    Padrão

    Citação Postado originalmente por jacksonezidio Ver Post
    Esta tentando logar como root ou usuario?
    O slackware esta direto na internet com ip dinamico eh isso?
    ja verificou seu arquivo de configuração do servidor ssh?
    O SLACKWARE ESTÁ DIRETO NA INTERNET COM IP DINAMICO(VELOX)
    ESTOU TENTANDO LOGAR COMO ROOT, ESTÁ ERRADO?
    Última edição por NetLagos; 28-06-2009 às 20:52.

  4. #4
    Não Registrado
    Visitante

    Padrão Logando com putty de rede externa

    Citação Postado originalmente por NetLagos Ver Post
    Estou tentando acessar meu servidor linux fora da rede interna e não estou conseguindo.

    estou em um terminal windows com putty instalado, e quero acessar o servidor que está com slackware instalado e com ip dinamico eu sei qual é o ip, mas não estou conseguindo acessar sempre aparece a mensagem de erro: "Network erro: connection timed out"

    já que na rede interna eu acesso normalmente.
    qual comando devo usar para conseguir o acesso na rede externa?
    Olá. Como está tentando acessar? A princípio, se estiver utilizando IP e porta corretos, tem grande chance de ser o FW.



  5. #5
    Sempre na luta Avatar de jacksonezidio
    Ingresso
    Jun 2008
    Localização
    São Paulo - SP
    Posts
    208
    Posts de Blog
    1

    Post

    Citação Postado originalmente por NetLagos Ver Post
    O SLACKWARE ESTÁ DIRETO NA INTERNET COM IP DINAMICO(VELOX)
    ESTOU TENTANDO LOGAR COMO ROOT, ESTÁ ERRADO?
    vc consegue logar direto como root pela rede local???
    da uma conferida se o login de root esta habilitado no sshd_config
    se ele estiver desabilitado ou vc habilita ou vc pode logar como usuario normal, depois subir pra root.

  6. #6

    Padrão

    Citação Postado originalmente por jacksonezidio Ver Post
    vc consegue logar direto como root pela rede local???
    da uma conferida se o login de root esta habilitado no sshd_config
    se ele estiver desabilitado ou vc habilita ou vc pode logar como usuario normal, depois subir pra root.
    na rede local eu logo normalmente como root, só não estou conseguindo fora da rede.
    qual comando você usa pra logar pela rede externa?



  7. #7
    jose.bezerra
    Visitante

    Padrão Ajuda com putty

    Citação Postado originalmente por NetLagos Ver Post
    na rede local eu logo normalmente como root, só não estou conseguindo fora da rede.
    qual comando você usa pra logar pela rede externa?
    Caro colega. Primeiramente, ping o ip, se estriver obtendo resposta, confirme a porta onte está habilitado o ssh e rode o putty novamente. Não é problema de login primário como "root" a princípio; pois, pelo que entendi, você nem consegue chegar à tela de login.

  8. #8
    Sempre na luta Avatar de jacksonezidio
    Ingresso
    Jun 2008
    Localização
    São Paulo - SP
    Posts
    208
    Posts de Blog
    1

    Post

    Citação Postado originalmente por NetLagos Ver Post
    na rede local eu logo normalmente como root, só não estou conseguindo fora da rede.
    qual comando você usa pra logar pela rede externa?

    Pelo putty nenhum comando, apenas configuro o ip e a porta..
    da uma conferida no firewal desse seu slackware, ve se tem alguma regra bloqueando o acesso externo ao servidor ssh.



  9. #9

    Padrão

    Citação Postado originalmente por jacksonezidio Ver Post
    Pelo putty nenhum comando, apenas configuro o ip e a porta..
    da uma conferida no firewal desse seu slackware, ve se tem alguma regra bloqueando o acesso externo ao servidor ssh.
    IP e Porta é o que eu coloco, más não está indo
    pelo que eu ví, não achei nada de errado no firewal, vou continuar tentando

  10. #10
    Sempre na luta Avatar de jacksonezidio
    Ingresso
    Jun 2008
    Localização
    São Paulo - SP
    Posts
    208
    Posts de Blog
    1

    Post

    Da uma explicada ai certinho como q esta sua rede... as configurações tmb



  11. #11
    jose.bezerra
    Visitante

    Padrão Ajuda com putty

    Citação Postado originalmente por NetLagos Ver Post
    IP e Porta é o que eu coloco, más não está indo
    pelo que eu ví, não achei nada de errado no firewal, vou continuar tentando
    Por favor, confira com carinho teu FW. A resposta que está recebendo geralmente é de FW. Verifique se não existe uma regra para bloquear conexões de fora. Crie uma regra, se for o caso, para aceitar conexões de fora da rede interna, pode aproveitar e mudar a porta padrão também!

  12. #12

    Padrão

    Citação Postado originalmente por jose.bezerra Ver Post
    Caro colega. Primeiramente, ping o ip, se estriver obtendo resposta, confirme a porta onte está habilitado o ssh e rode o putty novamente. Não é problema de login primário como "root" a princípio; pois, pelo que entendi, você nem consegue chegar à tela de login.
    realmente não aparece a tela de login.
    vou checar as configurações e tentar novamente.
    vlw



  13. #13

    Padrão

    Citação Postado originalmente por jose.bezerra Ver Post
    Por favor, confira com carinho teu FW. A resposta que está recebendo geralmente é de FW. Verifique se não existe uma regra para bloquear conexões de fora. Crie uma regra, se for o caso, para aceitar conexões de fora da rede interna, pode aproveitar e mudar a porta padrão também!
    desculpa a ignorancia, más como faço para chegar as config. do ssh no slackware?
    qual comentario preciso add?

  14. #14
    Sempre na luta Avatar de jacksonezidio
    Ingresso
    Jun 2008
    Localização
    São Paulo - SP
    Posts
    208
    Posts de Blog
    1

    Post

    Citação Postado originalmente por NetLagos Ver Post
    desculpa a ignorancia, más como faço para chegar as config. do ssh no slackware?
    qual comentario preciso add?

    procure a pasta de config dele, no ubuntu fica em /etc/ssh/sshd_config
    qualquer coisa use o find:
    find / -iname ssh



  15. #15

    Padrão

    Citação Postado originalmente por jacksonezidio Ver Post
    procure a pasta de config dele, no ubuntu fica em /etc/ssh/sshd_config
    qualquer coisa use o find:
    find / -iname ssh
    achei o arquivo vou postar tem como verificar se tem alguma coisa de errado?

    # $OpenBSD: sshd_config,v 1.77 2008/02/08 23:24:07 djm Exp $

    # This is the sshd server system-wide configuration file. See
    # sshd_config(5) for more information.

    # This sshd was compiled with PATH=/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin

    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented. Uncommented options change a
    # default value.

    #Port 22
    #AddressFamily any
    #ListenAddress 0.0.0.0
    #ListenAddress ::

    # Disable legacy (protocol version 1) support in the server for new
    # installations. In future the default will change to require explicit
    # activation of protocol 1
    Protocol 2

    # HostKey for protocol version 1
    #HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    #HostKey /etc/ssh/ssh_host_rsa_key
    #HostKey /etc/ssh/ssh_host_dsa_key

    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 1h
    #ServerKeyBits 768

    # Logging
    # obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    #LogLevel INFO

    # Authentication:

    #LoginGraceTime 2m
    #PermitRootLogin yes
    #StrictModes yes
    #MaxAuthTries 6

    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile .ssh/authorized_keys

    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes

    # To disable tunneled clear text passwords, change to no here!
    #PasswordAuthentication yes
    #PermitEmptyPasswords no

    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes

    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes
    #KerberosGetAFSToken no

    # GSSAPI options
    #GSSAPIAuthentication no
    #GSSAPICleanupCredentials yes

    # Set this to 'yes' to enable PAM authentication, account processing,
    # and session processing. If this is enabled, PAM authentication will
    # be allowed through the ChallengeResponseAuthentication and
    # PasswordAuthentication. Depending on your PAM configuration,
    # PAM authentication via ChallengeResponseAuthentication may bypass
    # the setting of "PermitRootLogin without-password".
    # If you just want the PAM account and session checks to run without
    # PAM authentication, then enable this but set PasswordAuthentication
    # and ChallengeResponseAuthentication to 'no'.
    #UsePAM no

    #AllowTcpForwarding yes
    #GatewayPorts no
    #X11Forwarding no
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #TCPKeepAlive yes
    #UseLogin no
    #UsePrivilegeSeparation yes
    #PermitUserEnvironment no
    #Compression delayed
    #ClientAliveInterval 0
    #ClientAliveCountMax 3
    #UseDNS yes
    #PidFile /var/run/sshd.pid
    #MaxStartups 10
    #PermitTunnel no
    #ChrootDirectory none

    # no default banner path
    #Banner none

    # override default of no subsystems
    Subsystem sftp /usr/libexec/sftp-server

    # Example of overriding settings on a per-user basis
    #Match User anoncvs
    # X11Forwarding no
    # AllowTcpForwarding no
    # ForceCommand cvs server

  16. #16
    Sempre na luta Avatar de jacksonezidio
    Ingresso
    Jun 2008
    Localização
    São Paulo - SP
    Posts
    208
    Posts de Blog
    1

    Post

    Citação Postado originalmente por NetLagos Ver Post
    achei o arquivo vou postar tem como verificar se tem alguma coisa de errado?

    # $OpenBSD: sshd_config,v 1.77 2008/02/08 23:24:07 djm Exp $

    # This is the sshd server system-wide configuration file. See
    # sshd_config(5) for more information.

    # This sshd was compiled with PATH=/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin

    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented. Uncommented options change a
    # default value.

    #Port 22
    #AddressFamily any
    #ListenAddress 0.0.0.0
    #ListenAddress ::

    # Disable legacy (protocol version 1) support in the server for new
    # installations. In future the default will change to require explicit
    # activation of protocol 1
    Protocol 2

    # HostKey for protocol version 1
    #HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    #HostKey /etc/ssh/ssh_host_rsa_key
    #HostKey /etc/ssh/ssh_host_dsa_key

    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 1h
    #ServerKeyBits 768

    # Logging
    # obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    #LogLevel INFO

    # Authentication:

    #LoginGraceTime 2m
    #PermitRootLogin yes
    #StrictModes yes
    #MaxAuthTries 6

    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile .ssh/authorized_keys

    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes

    # To disable tunneled clear text passwords, change to no here!
    #PasswordAuthentication yes
    #PermitEmptyPasswords no

    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes

    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes
    #KerberosGetAFSToken no

    # GSSAPI options
    #GSSAPIAuthentication no
    #GSSAPICleanupCredentials yes

    # Set this to 'yes' to enable PAM authentication, account processing,
    # and session processing. If this is enabled, PAM authentication will
    # be allowed through the ChallengeResponseAuthentication and
    # PasswordAuthentication. Depending on your PAM configuration,
    # PAM authentication via ChallengeResponseAuthentication may bypass
    # the setting of "PermitRootLogin without-password".
    # If you just want the PAM account and session checks to run without
    # PAM authentication, then enable this but set PasswordAuthentication
    # and ChallengeResponseAuthentication to 'no'.
    #UsePAM no

    #AllowTcpForwarding yes
    #GatewayPorts no
    #X11Forwarding no
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #TCPKeepAlive yes
    #UseLogin no
    #UsePrivilegeSeparation yes
    #PermitUserEnvironment no
    #Compression delayed
    #ClientAliveInterval 0
    #ClientAliveCountMax 3
    #UseDNS yes
    #PidFile /var/run/sshd.pid
    #MaxStartups 10
    #PermitTunnel no
    #ChrootDirectory none

    # no default banner path
    #Banner none

    # override default of no subsystems
    Subsystem sftp /usr/libexec/sftp-server

    # Example of overriding settings on a per-user basis
    #Match User anoncvs
    # X11Forwarding no
    # AllowTcpForwarding no
    # ForceCommand cvs server

    Me add no msn fica mais facil pra te ajudar ok!



  17. #17