+ Responder ao Tópico

PCC



  1. #201

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Acredito q não DSS, pq todos os clientes que já fiz esse load PCC tiveram problemas com bradesco e videos do tv terra e globo.com. E são de lugares diferentes e links totalmente diferentes.

    Interessante, mas aqui nao acontece.

  2. #202

    Padrão

    Citação Postado originalmente por exclusivenet Ver Post
    Amigo DSSS,
    fiz as alterações aqui, pode verificar se é dessa forma que você falou ?
    tá as regras abaixo:

    Código :
    /ip firewall mangle
    add action=mark-connection chain=input comment="" disabled=no in-interface=\
        Oi_UP_512 new-connection-mark=Oi_UP_512_conn passthrough=yes
    add action=mark-connection chain=input comment="" disabled=no in-interface=\
        Oi_UP_256 new-connection-mark=Oi_UP_256_conn passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=\
        Oi_UP_512_conn disabled=no new-routing-mark=to_Oi_UP_512 passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=\
        Oi_UP_256_conn disabled=no new-routing-mark=to_Oi_UP_256 passthrough=yes
    [B]add action=accept chain=prerouting comment="" disabled=no dst-address=\[/B]
    [B]    189.80.219.80/29 in-interface=Rede_Local[/B]
    [B]add action=accept chain=prerouting comment="" disabled=no dst-address=\[/B]
    [B]    189.80.16.80/29 in-interface=Rede_Local[/B]
    add action=mark-connection chain=prerouting comment="" disabled=no \
        dst-address-type=!local in-interface=Rede_Local new-connection-mark=\
        Oi_UP_256_conn passthrough=yes per-connection-classifier=\
        both-addresses:3/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
        dst-address-type=!local in-interface=Rede_Local new-connection-mark=\
        Oi_UP_512_conn passthrough=yes per-connection-classifier=\
        both-addresses:3/1
    add action=mark-connection chain=prerouting comment="" disabled=no \
        dst-address-type=!local in-interface=Rede_Local new-connection-mark=\
        Oi_UP_512_conn passthrough=yes per-connection-classifier=\
        both-addresses:3/2
    add action=mark-routing chain=prerouting comment="" connection-mark=\
        Oi_UP_512_conn disabled=no in-interface=Rede_Local new-routing-mark=\
        to_Oi_UP_512 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=\
        Oi_UP_256_conn disabled=no in-interface=Rede_Local new-routing-mark=\
        to_Oi_UP_256 passthrough=yes

    lColoquei 1 para o link de 256 e 2 para o de 512, outra coisa, tenho aqui esse servidor aí fazendo só o balance PCC, a saida do link desse aí, é a entrada do outro servidor, hotspot, to tendo problemas de pagina não pode ser exibida direto, tipo se a conexão estive-se caindo, você acredita que tem a ver com essas marcações aí ? o meu hotspot não uso brigde, você acha que pode tá interferindo também ?

    Há, aqui uso 2 links dedicados da Oi, não é adsl não ..

    Agradeço desde já
    A divisao esta ok. Agora tente fazer sua marcacao no preroutin por interface! Mas aparentemente esta tudo ok.



  3. #203

    Padrão

    Citação Postado originalmente por DSSS Ver Post
    Agora tente fazer sua marcacao no preroutin por interface!
    amigo, não entendi essa parte do comentario ..
    Seria essas duas da ação ( accept ) ???
    Última edição por exclusivenet; 05-10-2009 às 16:31.

  4. #204

    Padrão

    Citação Postado originalmente por exclusivenet Ver Post
    amigo, não entendi essa parte do comentario ..
    Seria essas duas da ação ( accept ) ???

    Olhe o texto em negrito, vc esta marcando por IP e não por interface. Meu PCC roda tranquilo marcando a interface, o se método é como o how to que esta no WIki da Mikrotik. Esta correto! mas como seu conexão esta caindo tente usar o método de marcação por interface. Tem outro post aqui ensinando a fazer dessa maneira.

    abraços



  5. #205
    Avatar de renatocostas
    Ingresso
    Dec 2007
    Localização
    Av. Santos Dumont 119, centro -Montes Claros MG
    Posts
    288

    Padrão

    só acompanhando...

  6. #206

    Padrão

    amigos ..,
    seguinte, verifiquei aqui hoje toda a minha rede, parte de estrutura, cabos, swithcs, conectores ..
    e tá ok .., mas esse problema persiste, vou postar a imagem abaixo, para vocês ver se já passaram por algo parecido.
    O balanceamento ao meu ver tá funcionando beleza ..
    aí abaixo tem as figuras dos 2 servidores, o do balance, pinga no site do uol por exemplo, beleza, sem perdas, funcionando tranquilo, já o do hotspot que fica depois do balance (recebe o link do balance), as vezes fica dando problema de pagina não pode ser exibida, então abrir o teminal e fui testar pelo ping e deu a msg de erro, pensei que poderia ser problema de dns, mas os dns dos 2 são os mesmos, e o do balance funciona beleza ..,..

    figura no anexo abaixo ..

    Antes de tentar colocar o balance, eu tinha 1 servidor para cada link e dividia os clientes por servidores, só que ficava muito ruim de administrar, achar cliente num servidor, olhar se ta no outro, então depois de fazer um curso pela MD Brasil, vi esse negocio do balance PCC e me interessei bastante, mas confesso que to ficando doido e esse negocio não funciona

    Agradeço a todos que estão me ajudando na resolução desse problema ..
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         imagem.JPG
Visualizações:	179
Tamanho: 	232,9 KB
ID:      	5747  



  7. #207

    Padrão

    Citação Postado originalmente por exclusivenet Ver Post
    amigos ..,
    seguinte, verifiquei aqui hoje toda a minha rede, parte de estrutura, cabos, swithcs, conectores ..
    e tá ok .., mas esse problema persiste, vou postar a imagem abaixo, para vocês ver se já passaram por algo parecido.
    O balanceamento ao meu ver tá funcionando beleza ..
    aí abaixo tem as figuras dos 2 servidores, o do balance, pinga no site do uol por exemplo, beleza, sem perdas, funcionando tranquilo, já o do hotspot que fica depois do balance (recebe o link do balance), as vezes fica dando problema de pagina não pode ser exibida, então abrir o teminal e fui testar pelo ping e deu a msg de erro, pensei que poderia ser problema de dns, mas os dns dos 2 são os mesmos, e o do balance funciona beleza ..,..

    figura no anexo abaixo ..

    Antes de tentar colocar o balance, eu tinha 1 servidor para cada link e dividia os clientes por servidores, só que ficava muito ruim de administrar, achar cliente num servidor, olhar se ta no outro, então depois de fazer um curso pela MD Brasil, vi esse negocio do balance PCC e me interessei bastante, mas confesso que to ficando doido e esse negocio não funciona

    Agradeço a todos que estão me ajudando na resolução desse problema ..
    opa amigo. seguinte:

    1 - seu balanceamento PCC tem regras de firewall alem das do mangle ? se tiver desative e teste.
    2 - no servidor mikrotik que gerencia os clientes, mude o DNS para ver se é isso.
    3 - no seu balanceamento vc tem dois links um de 512k e 256k o problema de expiração de paginas pode ser dois, um é estar usando a opção both-address and ports, mas n é o seu caso, o outro é seu links estar no gargalo, no caso sendo todo usado, e com isso te da problemas de expiração de pagina sim, como tmb voltar mensagens msn, etc.
    4 - teste o ping entre o servidor "loadbalaced" e servidor "mikrotik clientes"

    Responda para gente o q perguntei acima para podermos analisar

  8. #208

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    opa amigo. seguinte:

    1 - seu balanceamento PCC tem regras de firewall alem das do mangle ? se tiver desative e teste.
    No balance não tem regras de firewall não, somente as regras do balance ..
    2 - no servidor mikrotik que gerencia os clientes, mude o DNS para ver se é isso.
    Fiz esse teste, usei tanto os dns da Oi (operadora) quanto do OpenDNS ..e o problema persisti
    3 - no seu balanceamento vc tem dois links um de 512k e 256k o problema de expiração de paginas pode ser dois, um é estar usando a opção both-address and ports, mas n é o seu caso, o outro é seu links estar no gargalo, no caso sendo todo usado, e com isso te da problemas de expiração de pagina sim, como tmb voltar mensagens msn, etc.
    Acho que o problema pode ser esse gargalo no link então, só que eu resolvi fazer o balance, pelo seguinte motivo, antes do balance, eu usava esses 2 links em servidores separados, sendo que o de 512, ficava na faixa de 25 a 30 usuarios simultaneos, sendo que nossos clientes estão setados a 70k de download e 40k de upload, e o de 256, tinha a faixa de 20 a 25 online, setados com essas mesmas velocidades 70 down e 40up., só que esse link de 256 ficava parte da tarde e noite ociosos, então resolvi fazer o balance para aproveitar essa ociosidade dele e desafogar um pouco o de 512, mas hoje com os 2 links balanceados tive observando que com 30 usuarios simultaneos, já começa a dar esse problema .., depois que fiz essa imagem do anexo do topico anterior, desliguei toda a rede , e fui liberando por parte, até chegar nesse numero de usuarios que voltou a apresentar o problema. Diante dessa situação, poderiamos dizer que se fizer um servidor de cache, resolveria a minha situação ???

    Obs: nossos usuarios usam a internet apenas pra navegar (pesquisas, orkut ..) e msn ...

    4 - teste o ping entre o servidor "loadbalaced" e servidor "mikrotik clientes"
    o ping entre o Balance PCC e o Servidor-Hotspot é de 1ms sem falhas
    Responda para gente o q perguntei acima para podermos analisar
    Agradeço a você thiago , ao DSSS e a todos que estão me ajudando nessa luta ..
    Última edição por exclusivenet; 06-10-2009 às 19:05.



  9. #209

    Padrão

    Citação Postado originalmente por exclusivenet Ver Post
    Agradeço a você thiago , ao DSSS e a todos que estão me ajudando nessa luta ..
    Certo, acredito q chegamos a uma conclusão, o PCC funcionando perfeito e o seu problema é falta de link.
    O servidor squid/proxy vai te ajudar sim, as com o tempo, pq logo de cara ele vai estar zerado, mas com uns 15 dias vc vai sentir uma melhoria.

    abraços

  10. #210

    Padrão

    Chego então ao fim desse tópico, com as conclusões que graças a ajuda dos amigos, consegui fazer o balance funcionar, e realmente o meu problema deve ser esse que você citou, falta de link, no meu entender com o balance eu iria melhorar, mas acredito que seu eu manter os servidores separados, e tentar colocar por exemplo o proxy no que tiver mais "gargalo", terei uma melhora na minha rede, até que a Oi resolva liberar upgrade dos meus links, pois estou tentando a tempos e não consigo, viver no interior e mexer com tecnologia é complicado ..
    temos hoje esses 2 links um de 256 e outro de 512 e pagamos a bagatela de 4.600,00 e o pior de tudo e que não conseguimos ampliar o link, e a cidade está se desenvolvendo, cada dia + clientes compram computadores e querem internet , o concorrente que eu tinha , tinha um link de 128k da Oi, e não conseguiu sobreviver, pois o que arrecada com os seus clientes nao pagavam o link.
    então tenho uma lista grande de clientes em espera e eu procurando soluções para poder agregar esses clientes, novamente achei que com o balance iria ser a solução.

    No mais, volto a agradecer a todos por me ajudar nessa jornada, hoje faz 12 dias que estou com dedicação total a esse trabalho "balance" (12 dias topado, dia e noite), com poucas horas de descanço e chego a conclusão que realmente aprendi com os amigos do forum, mas infelizmente fiquei preso as limitações da Operadora a minha cidade.

    Att
    Helder Cavalcante
    Última edição por exclusivenet; 06-10-2009 às 19:44.



  11. #211

    Padrão

    Citação Postado originalmente por exclusivenet Ver Post
    Chego então ao fim desse tópico, com as conclusões que graças a ajuda dos amigos, consegui fazer o balance funcionar, e realmente o meu problema deve ser esse que você citou, falta de link, no meu entender com o balance eu iria melhorar, mas acredito que seu eu manter os servidores separados, e tentar colocar por exemplo o proxy no que tiver mais "gargalo", terei uma melhora na minha rede, até que a Oi resolva liberar upgrade dos meus links, pois estou tentando a tempos e não consigo, viver no interior e mexer com tecnologia é complicado ..
    temos hoje esses 2 links um de 256 e outro de 512 e pagamos a bagatela de 4.600,00 e o pior de tudo e que não conseguimos ampliar o link, e a cidade está se desenvolvendo, cada dia + clientes compram computadores e querem internet , o concorrente que eu tinha , tinha um link de 128k da Oi, e não conseguiu sobreviver, pois o que arrecada com os seus clientes nao pagavam o link.
    então tenho uma lista grande de clientes em espera e eu procurando soluções para poder agregar esses clientes, novamente achei que com o balance iria ser a solução.

    No mais, volto a agradecer a todos por me ajudar nessa jornada, hoje faz 12 dias que estou com dedicação total a esse trabalho "balance" (12 dias topado, dia e noite), com poucas horas de descanço e chego a conclusão que realmente aprendi com os amigos do forum, mas infelizmente fiquei preso as limitações da Operadora a minha cidade.

    Att
    Helder Cavalcante
    Será que nao eh um problema de limitação no numero de conexões simultaneas?

  12. #212

    Padrão

    Citação Postado originalmente por froyer Ver Post
    Será que nao eh um problema de limitação no numero de conexões simultaneas?
    como assim ??



  13. #213

    Padrão

    Citação Postado originalmente por exclusivenet Ver Post
    Chego então ao fim desse tópico, com as conclusões que graças a ajuda dos amigos, consegui fazer o balance funcionar, e realmente o meu problema deve ser esse que você citou, falta de link, no meu entender com o balance eu iria melhorar, mas acredito que seu eu manter os servidores separados, e tentar colocar por exemplo o proxy no que tiver mais "gargalo", terei uma melhora na minha rede, até que a Oi resolva liberar upgrade dos meus links, pois estou tentando a tempos e não consigo, viver no interior e mexer com tecnologia é complicado ..
    temos hoje esses 2 links um de 256 e outro de 512 e pagamos a bagatela de 4.600,00 e o pior de tudo e que não conseguimos ampliar o link, e a cidade está se desenvolvendo, cada dia + clientes compram computadores e querem internet , o concorrente que eu tinha , tinha um link de 128k da Oi, e não conseguiu sobreviver, pois o que arrecada com os seus clientes nao pagavam o link.
    então tenho uma lista grande de clientes em espera e eu procurando soluções para poder agregar esses clientes, novamente achei que com o balance iria ser a solução.

    No mais, volto a agradecer a todos por me ajudar nessa jornada, hoje faz 12 dias que estou com dedicação total a esse trabalho "balance" (12 dias topado, dia e noite), com poucas horas de descanço e chego a conclusão que realmente aprendi com os amigos do forum, mas infelizmente fiquei preso as limitações da Operadora a minha cidade.

    Att
    Helder Cavalcante
    É amigo, é complicado....
    infelizmente ainda existe inumeras cidades nesse nosso grande Pais que ainda esta engatinhado quando se fala em tecnologia e telecomunicações, e infelizmente ficamos nas mãos das grandes teles.
    O q vc pode tentar ai sera primeiro montar mesmo um servidor de squid bem montado, quem sabe rodar o videocache ou thundercache e alguém do forum poder te enviar em DVD ou HD mesmo o q tiver de videos e atualizações de windows-update etc para vc não precisar baixar eles tudo de novo. Por exemplo tenho de videos do youtube, redtube, etc 1T lotado de video. Para mim aqui ajuda bastante q tenho 32MB de link PPP agora imagina vc q tem essses meros 512 e 256k. outra coisa q vc pode fazer se eu fosse vc extinguir-se o uso de P2P na sua rede, limitaria o numero de conexões dos seus clientes para no máxmo 15 conexões, etc. E volto a dizer investiria em uma maquina boa somente para cache com 4 ou 8G de memoria, 1 HD para sistema, 1 HD para cache de arquivos normais do squid, e 1 HD de 1T para os videos que te falei. Ai sim vc veria q melhoraria em muito sua net.

    Mas infelizmente ainda n seria a solução, mas pelo menos poderia respirar por mais um tempo.

    abraços e boa noite

  14. #214

    Padrão

    Bom Dia pessoal, estou com um problema relatado em outro post, com o Proxy squid em conjunto com o PCC, segue o link do post


    https://under-linux.org/f131343-pcc-...-14#post439216


    Agradeço des de Ja!!!



  15. #215

    Padrão

    Tava lendo o topico e vi que é possivel deixar os modens em bridge e que em /ip firewall mangle tem que fazer algumas mudaça, minha duvida e em /ip route como deve ficar???.
    Aqui tenho 3adsl de 2.5m queria deixar os 3 em bridge.
    Se alguem puder ajudar.

  16. #216

    Padrão

    Citação Postado originalmente por ricardomarquess Ver Post
    Tava lendo o topico e vi que é possivel deixar os modens em bridge e que em /ip firewall mangle tem que fazer algumas mudaça, minha duvida e em /ip route como deve ficar???.
    Aqui tenho 3adsl de 2.5m queria deixar os 3 em bridge.
    Se alguem puder ajudar.
    coloc como GW a interface do PPPoE



  17. #217

    Padrão

    Thiago,
    Atualmente ta configurado conforme ao arquivo em anexo, mas tou com alguns problema com os modens roteado, como falei anterior vi que e possivel usar os modens em bridge se vc puder me falar o que preciso mudar para que o load funcione com os 3 modem em bridge.

    Obrigado.
    Arquivos Anexos Arquivos Anexos
    • Tipo de Arquivo: txt load.txt (3,3 KB, 151 visualizações)

  18. #218

    Padrão

    Citação Postado originalmente por ricardomarquess Ver Post
    Thiago,
    Atualmente ta configurado conforme ao arquivo em anexo, mas tou com alguns problema com os modens roteado, como falei anterior vi que e possivel usar os modens em bridge se vc puder me falar o que preciso mudar para que o load funcione com os 3 modem em bridge.

    Obrigado.
    Amigo, simples, basta configurar os modem em modo bridge, e criar discadores PPPoE para discar cada modem, logo as suas mudanças é apenas mudar em /ip firewall mangle e /ip route o nome das interfaces n é mais as interfaces ethernet e sim as PPPoE.

    Se n me engano tem um topico do CATV que explica como fazer os modem em bridge e colocar o mikrotik para discar o adsl



  19. #219

    Padrão

    Amigos aqui vai minha solução para forçar a saida de determinadas portas por apenas UM LINK

    /ip firewall mangle

    add action=mark-routing chain=prerouting comment="FORCAR SAIDA LINK1" disabled=no new-routing-mark=Forcar_Saida_Link1 passthrough=no protocol=tcp \
    src-address=10.1.1.0/29
    add action=mark-routing chain=prerouting comment="FORCAR SAIDA LINK2" disabled=no dst-port=443 new-routing-mark=Forcar_Saida_Link2 passthrough=no protocol=\
    tcp src-address=10.1.1.0/29
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=3389 new-routing-mark=Forcar_Saida_Link2 passthrough=no protocol=tcp src-address=\
    10.1.1.0/29
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=80 new-routing-mark=Forcar_Saida_Link2 passthrough=no protocol=tcp src-address=\
    10.1.1.0/29
    /ip route
    add comment="FORCAR SAIDA LINK2" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=xxx.xxx.xxx.xxx routing-mark=Forcar_Saida_Link2 scope=30 target-scope=10
    add comment="FORCAR SAIDA LINK1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=yyy.yyy.yyy.yyy routing-mark=Forcar_Saida_Link1 scope=30 target-scope=\
    10


    Aonde xxx.xxx.xxx.xxx é o Gateway do seu LINK1 e yyy.yyy.yyy.yyy é o LINK2

    Abraços

  20. #220

    Padrão PCC 3 Links e 3 Redes

    Caros colegas sou usuário do forum ha algum tempo mas na maioria das vezes para consultas apenas, mas chegou a minha hora de pedir HELP também.

    Minha necessidade é a seguinte

    Link 1 -----\ ______________/ ---- Rede 1 (192.168.0.0/24)
    Link 2 ------> MKT Controler< ----- Rede 2 (192.168.1.0/24)
    Link 3 -----/ ______________\ ---- Rede 3 (192.168.2.0/24)

    Sendo que cada link mencionado já se encontram roteado na mesma rede correspondente como ex:

    Link 1 (192.168.0.1 ) na Rede 1 (192.168.0.0/24)

    Em linhas gerais é o seguinte gostaria de usar a "facinante" solução PCC nos meus links mas disponibilizar todos para as 3 redes, seguindo os wiki e tutoriais situados aqui no forum e no da Mikrotik não alcancei de fazer as configurações necessarias para a minha necessidade.

    Conto com a compreensão de todos e apoio

    *** Obs: Estou usando Router OS 4.1 Level 5

    Alessandro Dias
    Última edição por impar; 22-10-2009 às 20:07. Razão: Layout