+ Responder ao Tópico

PCC



  1. #241

    Padrão

    Citação Postado originalmente por vie190 Ver Post
    amigo,por favor ,,,,,gostaria de sua ajuda,,pois vc diz que ta funcionando perfeito
    ,pois ja reli este topico 4 x desde o inicio,,3 x o foro internacional e vi muintos colegas com meu problema tambem,e nenhum posto como foi resolvido,ja refiz a configuração pcc 4 vezes e sempre ta o mesmo problema ,os link trabalha por igual por algum tempo e vai diminuindo a carga ficando sempre o link 1 sobrecarregado,,quando retira o cabo do link 1 o 2 assume ,colocando novamente o cabo do link eles trabalha por 10 minutos por igual e vai baxando carga do 2 até zera,,,ja sobrecarreguei pra ver se ta saindo pelos demail e não ta fica faltando link;.;.

    minha red ta assim,,

    link 4mb adsl-------------
    link 4mb ip fixo----------- pc p4 3.0 com pcc 4.2 fazendo controle de clientes por arp e queue--link 2mb dedicado--------

    somente 1 computador fazendo balance, queue,arp com programa 4.2;;

    por favor passa pra mim onde estou errando
    Amigo o seu problema, é que tem de ter uma maquina exclusiva para PCC, como vc disse vc ta fazendo o controle na mesma maquina, ai num vai fucionar mesmo, coloque uma maquina so pra fazer o PCC e outra pra controlar os clientes.

    Ps. Aqui eu uso o MK 4.3 e ta perfeito!

  2. #242

    Padrão

    Citação Postado originalmente por Briza Ver Post
    Rapaz vc usa a versao 4.0 do mk se sim nao use esta versao e sim a 2.38 a unica que funciona bem com pcc a versao 4.0 é voltada para as redes N.... nem na versao 3.30 o pcc funciona direito.
    =====================tentei ate mesmo mudar de versao para ver se resolvia,,mais o problema era com arp e queue que apos ser retirado e ser feito em outra macna ficou 10



  3. #243

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Amigo o seu problema, é que tem de ter uma maquina exclusiva para PCC, como vc disse vc ta fazendo o controle na mesma maquina, ai num vai fucionar mesmo, coloque uma maquina so pra fazer o PCC e outra pra controlar os clientes.

    Ps. Aqui eu uso o MK 4.3 e ta perfeito!
    --------rogerio te agradeço pela dica pois apos tirar queue e arp e passar em outro pc o pcc ficou nota 10

  4. #244

    Padrão

    ja usei em versoes 4.2 e 4.3 e roda normal, o pcc tb roda junto com pppoe e hotspot so é mais complicado fazer, eu prefiro sempre deixar esse serviço de balanceamento num hardware separado.



  5. #245
    Não Registrado
    Visitante

    Padrão

    tenho um link dedicado e um reforço (ADSL) como tria que fazer para aparecer apenas o ip do link dedicado no loadbalance pcc.

  6. #246

    Padrão

    Citação Postado originalmente por Mirandapb Ver Post
    Não entendi do sistema parar caso os modens estejam roteados, pois nesse outro post: https://under-linux.org/f131343-pcc-...links-por-m4d3, é inciado, mostrando exemplos com 3 modens roteados sem nenhuma restrição referente a ADSL.
    É que os modens (principalmente os caseiros) não tem poder de processamento suficiente para tanto tráfego. Assim, o mais indicado é utilizá-los apenas como BRIDGE e deixar a parte pesada para o PC.

    Abraço.



  7. #247

    Padrão

    Citação Postado originalmente por fasseabra Ver Post
    Coloquei os modens em Bridge, só tive q lembrar de desmarcar o Default route, o resto foi só adaptar as interfaces no mangle. Vlw Tiago.

    Não estava conseguindo acessar o meu MK principal pois qdo digitava o IP do link caia no meu MK com PCC. Consegui resolver e vou postar pois posso ajudar alguém com essa mesma dificuldade.
    A estrutura esta assim:
    02 ADSL 4Mb => MK com PCC => MK principal => Clientes.

    1º - Mudei a porta do meu Winbox do MK com PCC.
    IP -> Sevices
    Alterei a porta default do winbox para a 8290.
    Agora para acessar o winbox do MK com PCC tenho q colocar 189.74.xx.xxx:8290

    2º - Criei uma regra redirecionando a porta default do winbox (8291) para o IP do MK principal. O IP 192.168.50.2 é a interface Link do MK principal.
    IP -> Firewall -> NAT
    add action=dst-nat chain=dstnat comment="" disabled=no dst-port=8291 in-interface=wan1-pppoe protocol=tcp to-addresses=192.168.50.2 to-ports=8291

    3º - Para acessar o MK principal o IP de onde eu estiver tem q estar fora do Balance. Seguindo o Script do Tiago tem no Mangle a regra "FORA DO LOADBALACED".
    Eu adicionei o IP de onde estou lá em IP -> Firewall - Address List.
    add address=189.72.239.109 comment="COLOCAR O IP PARA FICAR FORA DO BALANCE - BART" disabled=no list=loopback

    Depois é só alterar o IP qdo for preciso.

    Espero ter ajudado. Vlw galera.
    olha a regra que eu coloquei aqui para não presisar colocar o ip no address list:

    add action=add-src-to-address-list address-list=loopback address-list-timeout=1h chain=input comment=\
    "tentando passar link" disabled=no dst-address=187.xxx.xxx.xxx dst-port=8200-8300 protocol=tcp

    com ela eu conecto pelo endereço valodo e ele já poe no address list sempre tenho que conectar no load primeiro eu mantenho por 1 hora mas é opcional

  8. #248

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Boa tarde cristianoduarte,
    esse balanceamento esta muito melhor doque os demais que a mikrotik tem hoje, mas com alguns problemas que devem ser corrigidos breve pela mikrotik, e um deles é os videos que as vezes tem q se precisar F5/Refresh para poder carregar o video principalmente do youtube.

    o melhor lugar para poder acompanhar o andamento desse balanceamento veja no forum da mikrotik no seguinte endereço:
    >>>>> MikroTik RouterOS • View topic - New firewall matcher PCC

    mas vou postar os script q postei lá balanceando 7 link

    Código :
    My interfaces
    Interfaces WANs:
    ether1, ether2, ether3, ether4, ether5, ether6 and ether7
    LAN Interface: ether9-Clientes
    Tentei fazer item a item deste seu export, so alterando minhas interfaces
    Tenho 2 modens da virtua NET de 12Mb cada, todos usam dhcp cliente do MK.
    Tenho um interface wlan1 onde distribuo para todos de casa, nao uso comercial, mas gostaria de aproveitar mais estes 2 links.
    Segue minha configuracao que tive que desabilitar pois nao consigo navegar, mas consigo dar ping diretamento do terminal do mk.
    Estranho que no mangle a linha out load DST nao estava contanto 0/0 porem como sou iniciante reparei depois de algum tempo que deveria colocar no address list a linha rede-interna com minha rede 192.168.0.0/25 so depois disto que comecou a contar, mas memso assim nao navegava no pc, porem a linha to_ether1 e to_ether2 nao sai do zero.
    Nao sei mais o que fazer pois como falei estou estudando bastante sobre o mk, fui ao mum2009 em copa onde aprendi bastante, mas falta muitas milhas para alcancar voces.
    Segue meu export

    Código :
    # dec/28/2009 21:20:53 by RouterOS 4.4
     
    #
    /ip firewall mangle
    add action=accept chain=prerouting comment="out load DST" disabled=yes \
        dst-address-list=rede-interna in-interface=wlan1
    add action=mark-connection chain=input comment=ether1_conn connection-state=\
        new disabled=yes in-interface=ether1 new-connection-mark=ether1_conn \
        passthrough=yes
    add action=mark-connection chain=input comment=ether2_conn connection-state=\
        new disabled=yes in-interface=ether2 new-connection-mark=ether2_conn \
        passthrough=yes
    add action=mark-routing chain=output comment=to_ether1 connection-mark=\
        ether1_conn connection-state=new disabled=yes new-routing-mark=to_ether1 \
        passthrough=no
    add action=mark-routing chain=output comment=to_ether2 connection-mark=\
        ether2_conn connection-state=new disabled=yes new-routing-mark=to_ether2 \
        passthrough=no
    add action=mark-connection chain=prerouting comment=ether1_conn disabled=yes \
        dst-address-type=!local in-interface=wlan1 new-connection-mark=\
        ether1_conn passthrough=yes per-connection-classifier=\
        both-addresses-and-ports:2/0
    add action=mark-connection chain=prerouting comment=ether2_conn disabled=yes \
        dst-address-type=!local in-interface=wlan1 new-connection-mark=\
        ether2_conn passthrough=yes per-connection-classifier=\
        both-addresses-and-ports:2/1
    add action=mark-routing chain=prerouting comment=to_ether1 connection-mark=\
        ether1_conn disabled=yes in-interface=wlan1 new-routing-mark=to_ether1 \
        passthrough=no
    add action=mark-routing chain=prerouting comment=to_ether2 connection-mark=\
        ether2_conn disabled=yes in-interface=wlan1 new-routing-mark=to_ether2 \
        passthrough=no
     
    ________________________________________________________________________________
     
    /ip firewall address-list
    add address=192.168.0.0/25 comment="" disabled=yes list=rede-interna
     
    _________________________________________________________________________________
     
     
    /ip firewall filter
    add action=tarpit chain=input comment="" disabled=no dst-port=21-23 protocol=\
        tcp
    add action=accept chain=forward comment="Rede interna" disabled=no \
        src-address=192.168.0.0/25
    add action=accept chain=forward comment="" disabled=no dst-address=\
        192.168.0.0/25
    add action=drop chain=forward comment=Exclusao disabled=no
     
     
    _________________________________________________________________________
     
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=yes out-interface=\
        ether1
    add action=masquerade chain=srcnat comment="" disabled=yes out-interface=\
        ether2
    add action=masquerade chain=srcnat comment="" disabled=no
     
    ________________________________________________________________________________
     
    /ip route
    add comment=link1 disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=\
        ether1 routing-mark=to_ether1 scope=30 target-scope=10
    add comment=link2 disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=\
        ether2 routing-mark=to_ether2 scope=30 target-scope=10

    Desculpa pelo texto longo.
    Abracao a todos



  9. #249

    Padrão

    Caros amigos, estou tentando fazer um pcc com dois links iguais de 1m/500k, uso um modem 500g e 500t ambos roteados que jogam para uma rb 450 3.30 so para esse balance, porem a carga esta saindo apenas por um link , o outro so funciona quando desativo o primeiro, pelo que sei o pcc balanceia de forma por igual , porem ja fiz as regras pelo pcc do wiki e nada, agora estou tentando pelo do m4d3 e ainda nao consigui resolver esse problema, peço ajuda do colegas pois ja revisei todas as regras varias vezes e nada de dar certo, abaixo posto minhas regras. obrigado.


    ether 3 - cliente
    ether 4 - modem 1
    ether 5 - modem 2

    /ip address

    add address=172.2.10.2/24 broadcast=172.2.10.255 comment="MODEM 1" disabled=\
    no interface=ether4 network=172.2.10.0

    add address=172.3.10.2/24 broadcast=172.3.10.255 comment="MODEM 2" disabled=\
    no interface=ether5 network=172.3.10.0

    add address=172.1.10.1/24 broadcast=172.1.10.255 comment="CLIENTE" \
    disabled=no interface=ether3 network=172.1.10.0

    --------------------------------------------------------------------------------

    /ip firewall mangle

    add action=accept chain=prerouting comment="Sem Balance" disabled=no \
    dst-address-list=Sem_Balance in-interface=ether3

    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=ether4 new-connection-mark=modem1_conn \
    passthrough=yes

    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=ether5 new-connection-mark=modem2_conn \
    passthrough=yes

    add action=mark-routing chain=output comment="" connection-mark=modem1_conn \
    disabled=no new-routing-mark=to_modem1 passthrough=no

    add action=mark-routing chain=output comment="" connection-mark=modem2_conn \
    disabled=no new-routing-mark=to_modem2 passthrough=no

    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=local in-interface=ether3 new-connection-mark=\
    modem1_conn1 passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/0

    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=local in-interface=ether3 new-connection-mark=\
    modem2_conn2 passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:2/1

    add action=mark-routing chain=prerouting comment="" connection-mark=\
    modem1_conn1 disabled=no in-interface=ether3 new-routing-mark=to1_modem1 \
    passthrough=no

    add action=mark-routing chain=prerouting comment="" connection-mark=\
    modem2_conn2 disabled=no in-interface=ether3 new-routing-mark=to2_modem2 \
    passthrough=no

    -----------------------------------------------------------------------------------

    /ip route

    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    172.3.10.1 routing-mark=to_modem2 scope=30 target-scope=10

    add check-gateway=ping comment="" disabled=no distance=2 dst-address=\
    0.0.0.0/0 gateway=172.2.10.1 scope=30 target-scope=10

    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    172.2.10.1 routing-mark=to_modem1 scope=30 target-scope=10

    add check-gateway=ping comment="" disabled=no distance=3 dst-address=\
    0.0.0.0/0 gateway=172.3.10.1 scope=30 target-scope=10

    -----------------------------------------------------------------------------------

    /ip firewall nat

    add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
    ether4

    add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
    ether5


    Clique na imagem para uma versão maior

Nome:	         interfaces.JPG
Visualizações:	97
Tamanho: 	40,6 KB
ID:      	8579

  10. #250

    Padrão

    eu estava com mesmo problema ,,,
    e apos rever todas as regras com muito cuidado e atenção ( e tinha erros de configuração ) no meu caso resolveu assim ,
    ,na quarta regra no ip,firewal,mangle,no extra adress tip local ticar a opção invert,,,apos ta perfeito com 3 link de 4 mb..
    pode rever e persistir que da certo,,



  11. #251

    Padrão

    apos inumeras revisoes e testes com as regras do m4d3 e do wiki pcc ainda nao consegui, mas vou conseguir, mas ate la se alguem puder me dar essa luz agradeço.

  12. #252

    Padrão

    opa galera... estou usando as regras do M4D3, e tenho notado que o uso do pppoe-out1 ta maior que do pppoe-out2... e sempre que abro o Meu ip - Qual é o Meu IP? 74.86.20.154, ele amostra o ip do pppoe-out2... engraçado neh? poiseh...

    Address-list:
    /ip firewall address-list
    add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=sem_balance
    add address=201.7.178.0/24 comment=\\\"Videos Globo.com\\\" disabled=no list=sem_balance
    add address=201.7.180.0/24 comment=\\\"\\\" disabled=no list=sem_balance
    add address=201.7.176.0/24 comment=\\\"\\\" disabled=no list=sem_balance
    add address=200.154.56.0/24 comment=\\\"Videos Terra\\\" disabled=no list=sem_balance
    add address=208.84.247.0/24 comment=\\\"\\\" disabled=no list=sem_balance
    Mangle:
    /ip firewall mangle
    add action=change-mss chain=forward comment=\\\"\\\" disabled=no new-mss=1360 out-interface=pppoe-out1 protocol=tcp tcp-flags=syn tcp-mss=1453-65535
    add action=change-mss chain=forward comment=\\\"\\\" disabled=no in-interface=pppoe-out1 new-mss=1360 protocol=tcp tcp-flags=syn tcp-mss=1441-65535
    add action=change-mss chain=forward comment=\\\"\\\" disabled=no new-mss=1360 out-interface=pppoe-out2 protocol=tcp tcp-flags=syn tcp-mss=1453-65535
    add action=change-mss chain=forward comment=\\\"\\\" disabled=no in-interface=pppoe-out2 new-mss=1360 protocol=tcp tcp-flags=syn tcp-mss=1441-65535
    add action=mark-routing chain=prerouting comment=\\\"\\\" connection-mark=Rota1 disabled=yes in-interface=EthClientes new-routing-mark=Rota1 passthrough=no
    add action=mark-routing chain=prerouting comment=\\\"\\\" connection-mark=Rota2 disabled=yes in-interface=EthClientes new-routing-mark=Rota2 passthrough=no
    add action=accept chain=prerouting comment=\\\"SEM BALANCE\\\" disabled=no dst-address-list=sem_balance in-interface=EthClientes
    add action=mark-connection chain=input comment=\\\"\\\" connection-state=new disabled=no in-interface=EthLinkA new-connection-mark=conn_na passthrough=yes
    add action=mark-connection chain=input comment=\\\"\\\" connection-state=new disabled=no in-interface=EthLinkB new-connection-mark=conn_nb passthrough=yes
    add action=mark-routing chain=output comment=\\\"\\\" connection-mark=conn_na disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment=\\\"\\\" connection-mark=conn_nb disabled=no new-routing-mark=to_rb passthrough=no
    add action=mark-connection chain=prerouting comment=\\\"\\\" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_ma0 \
    passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment=\\\"\\\" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
    passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment=\\\"\\\" connection-mark=conn_ma0 disabled=no in-interface=EthClientes new-routing-mark=to_nra passthrough=no
    add action=mark-routing chain=prerouting comment=\\\"\\\" connection-mark=conn_mb1 disabled=no in-interface=EthClientes new-routing-mark=to_nrb passthrough=no
    NAT:
    /ip firewall nat
    add action=masquerade chain=srcnat comment=\\"MASCARAMENTO PCC\\" disabled=no out-interface=pppoe-out1
    add action=masquerade chain=srcnat comment=\\"\\" disabled=no out-interface=pppoe-out2
    Routes
    /ip firewall nat
    add action=masquerade chain=srcnat comment=\\"\\" disabled=no dst-address=192.168.254.254 out-interface=EthLinkA
    add action=masquerade chain=srcnat comment=\\"\\" disabled=no dst-address=192.168.1.1 out-interface=EthLinkB
    add action=masquerade chain=srcnat comment=\\"MASCARAMENTO PCC\\" disabled=no out-interface=pppoe-out1
    add action=masquerade chain=srcnat comment=\\"\\" disabled=no out-interface=pppoe-out2
    Lembrando que sao 2 links de 1MB
    Imagem em anexo
    Anexo 8888



  13. #253

    Padrão

    Bom dia,
    otimo post...
    fiz o bal. pcc e funcionou perfeito, no notebook. quando coloca ele no servidor ele nao pinga na rb750....

    link 1 - 192.168.254.254
    link 2 - 192.168.1.1

    ip pcc rb 750 - 192.168.100.1

    coloco no notebook
    192.168.100.2
    255.255.255.0
    192.168.100.1
    192.168.100.1

    funciona o perfeito, pingo nos dois modens.
    quanbdo coloco no servidor, nao vai por nada
    ja fiz ip fixo, dhcp

    uso o dns da google

    se alguem puder ajudar

    agradeço denovo pelo Post

  14. #254

    Padrão

    Aproveitando o topico quero fazer uma pergunta pra voce Tiago.

    Estou instalando 7 Links Dedicado de 2MB de uma operadora só (Telemar-Oi), ja tenho os roteadores cada um de 2 MB, são 7 roteadores saindo 2MB cada um, te pergunto se tem como fazer um Load em um PC ou RB entrando os 7Links e saindo uma interface ou seja um ip tipo 192.168.1.1/30 com 14MB?

    Se tem e se não for pedir de mais gostaria que voce postasse as regras pra eu fazer aki.

    Desde já Agradeço.



  15. #255

    Padrão

    Citação Postado originalmente por willianrcn Ver Post
    Aproveitando o topico quero fazer uma pergunta pra voce Tiago.

    Estou instalando 7 Links Dedicado de 2MB de uma operadora só (Telemar-Oi), ja tenho os roteadores cada um de 2 MB, são 7 roteadores saindo 2MB cada um, te pergunto se tem como fazer um Load em um PC ou RB entrando os 7Links e saindo uma interface ou seja um ip tipo 192.168.1.1/30 com 14MB?

    Se tem e se não for pedir de mais gostaria que voce postasse as regras pra eu fazer aki.

    Desde já Agradeço.
    Seguinte amigo,

    o PCC ele não soma os links. No caso ele não pega 2MB+2MB e vai dar 4MB, e sim balancea a carga entre os links, fazendo com que o consumo seja dividido entre todos eles. Mas se caso um cliente seu fazer um download e pegar do link A por exemplo, o máximo que vai chegar a taxa de transferencia dele é em cima de um circuito de 2MB.
    Existe uma forma de configurar para que some os links, mas mesmo assim vc terá q usar no cliente um gerenciador de download para dar a soma dos link, com por exemplo o orbit, download celerator "nem sei mais se existe esse" etc, mas fiz testes aqui e não gostei.

    E para vc fazer o pcc com 7 links acredito q olhando bem as regras que tem aqui vc consegue.

    abraços

  16. #256

    Question Pcc + failover

    amigos quero utilizar o pcc para usar dois link dedicados antes do servidor quero usar uma rb750g com failover será que pega ? porque vai ficar tipo uma redundacia caso um link caia .

    se alguem usa diga como funciona

    obrigado



  17. #257

    Padrão

    amigos me ajudem... naum consigo fazer o balancemento funcionar de nenhuma forma naum sei o que é

  18. #258

    Padrão

    minhas configurações são essas:

    /ip firewall mangle add action=accept chain=prerouting comment="SEM BALANCE" disabled=no dst-address-list=sem_balance in-interface=Local
    /ip address add address=192.168.0.1/24 interface=Local
    /ip address add address=189.7.254.125/255.255.248.0 interface=wlan1
    /ip address add address=189.35.164.207/255.255.248.0 interface=wlan2
    /ip firewall mangle add chain=input in-interface=wlan1 action=mark-connection new-connection-mark=wlan1_conn
    /ip firewall mangle add chain=input in-interface=wlan2 action=mark-connection new-connection-mark=wlan2_conn
    /ip firewall mangle add chain=output connection-mark=wlan1_conn action=mark-routing new-routing-mark=to_wlan1
    /ip firewall mangle add chain=output connection-mark=wlan2_conn action=mark-routing new-routing-mark=to_wlan2
    /ip firewall mangle add chain=prerouting dst-address=189.7.248.0/255.255.248.0 action=accept in-interface=Local
    /ip firewall mangle add chain=prerouting dst-address=189.35.160.0/255.255.248.0 action=accept in-interface=Local
    /ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:2/0 action=mark-connection new-connection-mark=wlan1_conn passthrough=yes
    /ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:2/1 action=mark-connection new-connection-mark=wlan2_conn passthrough=yes
    /ip firewall mangle add chain=prerouting connection-mark=wlan1_conn in-interface=Local action=mark-routing new-routing-mark=to_wlan1
    /ip firewall mangle add chain=prerouting connection-mark=wlan2_conn in-interface=Local action=mark-routing new-routing-mark=to_wlan2
    /ip route add dst-address=0.0.0.0/0 gateway=189.7.248.1 routing-mark=to_wlan1 check-gateway=ping
    /ip route add dst-address=0.0.0.0/0 gateway=189.35.160.1 routing-mark=to_wlan2 check-gateway=ping
    /ip route add dst-address=0.0.0.0/0 gateway=189.7.248.1 distance=1 check-gateway=ping
    /ip route add dst-address=0.0.0.0/0 gateway=189.35.160.1 distance=2 check-gateway=ping
    /ip firewall nat add action=masquerade chain=srcnat src-address=192.168.0.0/24 comment="MASCARAMENTO PCC" disabled=no
    /ip firewall nat add chain=srcnat out-interface=wlan1 action=masquerade
    /ip firewall nat add chain=srcnat out-interface=wlan2 action=masquerade



  19. #259

    Padrão

    tenho dois links da net virtua cada um com um ip fixo dhcp. Me ajudem por favor....desde ja obrigado

  20. #260

    Padrão

    na minha outra rb com 03 links é assim mais de todo jeito so sai por um link...


    /ip firewall mangle add action=accept chain=prerouting comment="SEM BALANCE" disabled=no dst-address-list=sem_balance in-interface=Local
    /ip address add address=192.168.0.1/24 interface=Local
    /ip address add address=189.7.248.22/255.255.248.0 interface=wlan1
    /ip address add address=189.7.248.203/255.255.248.0 interface=wlan2
    /ip address add address=189.7.248.227/255.255.248.0 interface=wlan3
    /ip firewall mangle add chain=input in-interface=wlan1 action=mark-connection new-connection-mark=wlan1_conn
    /ip firewall mangle add chain=input in-interface=wlan2 action=mark-connection new-connection-mark=wlan2_conn
    /ip firewall mangle add chain=input in-interface=wlan3 action=mark-connection new-connection-mark=wlan3_conn
    /ip firewall mangle add chain=output connection-mark=wlan1_conn action=mark-routing new-routing-mark=to_wlan1
    /ip firewall mangle add chain=output connection-mark=wlan2_conn action=mark-routing new-routing-mark=to_wlan2
    /ip firewall mangle add chain=output connection-mark=wlan3_conn action=mark-routing new-routing-mark=to_wlan3
    /ip firewall mangle add chain=prerouting dst-address=189.7.248.0/255.255.248.0 action=accept in-interface=Local
    /ip firewall mangle add chain=prerouting dst-address=189.7.248.0/255.255.248.0 action=accept in-interface=Local
    /ip firewall mangle add chain=prerouting dst-address=189.7.248.0/255.255.248.0 action=accept in-interface=Local
    /ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:6/0 action=mark-connection new-connection-mark=wlan1_conn passthrough=yes
    /ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:6/1 action=mark-connection new-connection-mark=wlan1_conn passthrough=yes
    /ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:6/2 action=mark-connection new-connection-mark=wlan1_conn passthrough=yes
    /ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:6/3 action=mark-connection new-connection-mark=wlan1_conn passthrough=yes
    /ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:6/4 action=mark-connection new-connection-mark=wlan2_conn passthrough=yes
    /ip firewall mangle add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses:6/5 action=mark-connection new-connection-mark=wlan3_conn passthrough=yes
    /ip firewall mangle add chain=prerouting connection-mark=wlan1_conn in-interface=Local action=mark-routing new-routing-mark=to_wlan1
    /ip firewall mangle add chain=prerouting connection-mark=wlan2_conn in-interface=Local action=mark-routing new-routing-mark=to_wlan2
    /ip firewall mangle add chain=prerouting connection-mark=wlan3_conn in-interface=Local action=mark-routing new-routing-mark=to_wlan3
    /ip route add dst-address=0.0.0.0/0 gateway=189.7.248.1 routing-mark=to_wlan1 check-gateway=ping
    /ip route add dst-address=0.0.0.0/0 gateway=189.7.248.1 routing-mark=to_wlan2 check-gateway=ping
    /ip route add dst-address=0.0.0.0/0 gateway=189.7.248.1 routing-mark=to_wlan3 check-gateway=ping
    /ip route add dst-address=0.0.0.0/0 gateway=189.7.248.1 distance=1 check-gateway=ping
    /ip route add dst-address=0.0.0.0/0 gateway=189.7.248.1 distance=2 check-gateway=ping
    /ip route add dst-address=0.0.0.0/0 gateway=189.7.248.1 distance=3 check-gateway=ping
    /ip firewall nat add action=masquerade chain=srcnat src-address=192.168.0.0/24 comment="MASCARAMENTO PCC" disabled=no
    /ip firewall nat add chain=srcnat out-interface=wlan1 action=masquerade
    /ip firewall nat add chain=srcnat out-interface=wlan2 action=masquerade
    /ip firewall nat add chain=srcnat out-interface=wlan3 action=masquerade