+ Responder ao Tópico

PCC



  1. Citação Postado originalmente por tskstar Ver Post
    Certo,segue entao as configuracoes atuais....

    Esta daqui eh de acordo com a mikrotikWiki que esta funcionando OK agora...

    Mas conforme nosso colega disse acima que o do colega do forum funciona melhor.Gostaria de saber qual seria a melhora,somente de curiosidade? E confirmar se esta tudo ok...
    Aparentemente, estão corretas sim;
    tanto a que esta seguindo no wiki da mikrotik.com quanto a que eu postei aqui neste tópico tem o mesmo sentido, lógico que a aque eu postei é para 7 link, mas que pode ser ajustado para a quantidade necessarias. E as regras postadas aqui foram feita em cima do wiki da mikrotik.com tanto que nenhuma é melhor que a outra, pq elas fazem a mesma coisa com o mesmo sentido.

    Esclarecido, acredito que neste topico mesmo existe um outro poste com varios links interessantes que vale a pena o senhor ler.

    abraços
    Última edição por tiagomatias; 13-08-2009 às 16:08.

  2. Citação Postado originalmente por tiagomatias Ver Post
    Aparentemente, estão corretas sim;
    tanto a que esta seguindo no wiki da mikrotik.com quanto a que eu postei aqui neste tópico tem o mesmo sentido, lógico que a aque eu postei é para 7 link, mas que pode ser ajustado para a quantidade necessarias. E as regras postadas aqui foram feita em cima do wiki da mikrotik.com tanto que nenhuma é melhor que a outra, pq elas fazem a mesma coisa com o mesmo sentido.

    Esclarecido, acredito que neste topico mesmo existe um outro poste com varios links interessantes que vale a pena o senhor ler.

    abraços
    Bem obrigado por verificar as regras...Eh que e interessantes nos sabermos as melhorias quais foram que voce fez tiago,afinal nada melhor alguem que saiba como melhorar e compartilhe uma versao mais aprimorada com a sua...

    E com relacao ao fato de eu utilizar 2 links por exemplo e tirar o cabo de um deles,eh normal com 2 Links Ativos cair a navegacao ou tipo abre metade da pagina ou senao demora demaisss demaisss...isso eh normal quando se utilizar somente 2 links ?

    Caso positivo e adquira um terceiro link,isso iria continuar a ocorrer?

    Muito obrigado a todos!



  3. Citação Postado originalmente por tskstar Ver Post
    Bem obrigado por verificar as regras...Eh que e interessantes nos sabermos as melhorias quais foram que voce fez tiago,afinal nada melhor alguem que saiba como melhorar e compartilhe uma versao mais aprimorada com a sua...

    E com relacao ao fato de eu utilizar 2 links por exemplo e tirar o cabo de um deles,eh normal com 2 Links Ativos cair a navegacao ou tipo abre metade da pagina ou senao demora demaisss demaisss...isso eh normal quando se utilizar somente 2 links ?

    Caso positivo e adquira um terceiro link,isso iria continuar a ocorrer?

    Muito obrigado a todos!
    Caro tskstar, de fato o problema de um link não assumir o outro é normal! isso pq ?
    seguinte: a mikrotik acredito eu para n fugir do assunto que ela estaa ensinando/explicando em determinado momento ela utiliza para checagem se um link caiu ou não o check-gateway=ping, e a logica desta checagem é pingando o seu gateway, certo ? correto, mas tem um detalhe aqui, se o link do seu link1 cair e esse link1 for um roteador ou modem em modo routeado, você vai parar de pingar seu gateway ? não! desta forma ele pensa q seu link não caiu, e não o chamado FailOver que devria fazer. Para isso se deve utilizar uma outra ferramenta que a propria mikrotik tem para fazer o FailOver "se um link cair o outro assumir" e a ferramenta que te auxiliará em fazer isso é o NETWATH acho que escrevi o nome corretamente . O netwath faz uma checagem pingando um determinado host que você irá escolher, caso esse host up ou down ele irá ativar um script que você irá defenir para ativar sua rota ou não. De uma procura aqui no forum sobre netwath que acredito que vai encontrar bastante material sobre o mesmo que te ajudará em fazer esse FailOver.

    Emfim, o problema de um link não assumir o outro é este! Espero ter ajudado você em como solucionar o mesmo.

    abraços
    Última edição por tiagomatias; 13-08-2009 às 17:18.

  4. Citação Postado originalmente por tiagomatias Ver Post
    Caro tskstar, de fato o problema de um link não assumir o outro é normal! isso pq ?
    seguinte: a mikrotik acredito eu para n fugir do assunto que ela estaa ensinando/explicando em determinado momento ela utiliza para checagem se um link caiu ou não o check-gateway=ping, e a logica desta checagem é pingando o seu gateway, certo ? correto, mas tem um detalhe aqui, se o link do seu link1 cair e esse link1 for um roteador ou modem em modo routeado, você vai parar de pingar seu gateway ? não! desta forma ele pensa q seu link não caiu, e não o chamado FailOver que devria fazer. Para isso se deve utilizar uma outra ferramenta que a propria mikrotik tem para fazer o FailOver "se um link cair o outro assumir" e a ferramenta que te auxiliará em fazer isso é o NETWATH acho que escrevi o nome corretamente . O netwath faz uma checagem pingando um determinado host que você irá escolher, caso esse host up ou down ele irá ativar um script que você irá defenir para ativar sua rota ou não. De uma procura aqui no forum sobre netwath que acredito que vai encontrar bastante material sobre o mesmo que te ajudará em fazer esse FailOver.

    Emfim, o problema de um link não assumir o outro é este! Espero ter ajudado você em como solucionar o mesmo.

    abraços

    Certo,mais assim eu fiz o teste com o cabo desligado ai no caso ele ainda nao navega bem qnd eu tiro o cabo do outro..

    Oque seria o ideal para fazer neste caso ?

    Att



  5. Citação Postado originalmente por tskstar Ver Post
    Certo,mais assim eu fiz o teste com o cabo desligado ai no caso ele ainda nao navega bem qnd eu tiro o cabo do outro..

    Oque seria o ideal para fazer neste caso ?

    Att
    Repare que em aonde você mais precisava usar o check-gateway=ping que era nas rotas padrão você não utilizou.

    /ip route
    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=Local
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.111.0.1 \
    routing-mark=to_wan1 scope=30 target-scope=10
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.112.0.1 \
    routing-mark=to_wan2 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.111.0.1 scope=30 target-scope=10

    Se não tiver o check-gateway nestas rotas não irá funcionar o failover quando você tirar o cabo de rede. Acrecente nelas.

    Mas como já disse anteriormente a melhor forma é usando netwath






Tópicos Similares

  1. PCC Balance de 3 a 16 links - Por: M4D3
    Por m4d3 no fórum Redes
    Respostas: 509
    Último Post: 30-05-2016, 12:59
  2. Ajuda PCC Mikrotik
    Por marsilba no fórum Redes
    Respostas: 5
    Último Post: 19-09-2009, 20:32
  3. Problemas depois de implementar PCC
    Por antonoel no fórum Redes
    Respostas: 2
    Último Post: 14-08-2009, 09:57
  4. Lentidão depois do PCC
    Por Evilazio no fórum Redes
    Respostas: 17
    Último Post: 04-08-2009, 22:56
  5. Respostas: 2
    Último Post: 24-07-2009, 19:11

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L