Página 3 de 15 PrimeiroPrimeiro 12345678 ... ÚltimoÚltimo
+ Responder ao Tópico

PCC



  1. #41

    Padrão

    Estou gostando muito desta balancemaneto, esta me dando um desempenho muito bom nos links,
    aqui tenho 7 circuitos da BrasilTelecom e 6 da Embratel, comprei diuas Rb493HA e em cada uma fiz o balanceamento dos links separado por operadora, e interliguei as duas, se uma operadora cair a outra assume, no caso o balancemaneto assume, vou postar algumas fotos, e o grafico de uma das routerbaord com balanceamento entre 7 links.

    2 RB493AH balanceando link com algoritimo PCC
    http://www.linuxap.com.br/images/loa...oadbalaced.jpg

    http://www.linuxap.com.br/images/loa...dbalacedII.jpg

    http://www.linuxap.com.br/images/loa...balacedIII.jpg

  2. #42

    Padrão

    estou tendo problemas com alguns sites ex o cartola da globo.com o site rapids
    hare e bancos sera que é somente eu estava usando both addresses dae mudei pra ver se melhora com o both ports tambem mais ainda persiste



  3. #43

    Padrão Problemas

    Citação Postado originalmente por powernetscm Ver Post
    estou tendo problemas com alguns sites ex o cartola da globo.com o site rapids
    hare e bancos sera que é somente eu estava usando both addresses dae mudei pra ver se melhora com o both ports tambem mais ainda persiste
    Estou testando este balanceamento, realmente esta muito bom. Estou fazendo com 6 links e a distribuiçâo de carga entre eles esta bem uniforme. Porem tambem estou tendo algums problemas, alguns que foram relatados: problemas com sites de banco, problemas para criar contas de hotmail e orkut e problemas com downloads no rapidshare, easyshare, megaupload.
    Pra sites de bancos até dei uma "Soluçao" , dizendo pra redes ip dos bancos sairem por uma rota especifica, mas os outros problemas ta dificil...

  4. #44

    Padrão

    é estou no mesmo barco, mas tenho certeza que vamos juntos resolver uma ferramenta nova dessas, é normal que daria esses contra tempos

    Sds a todos



  5. #45

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Estou gostando muito desta balancemaneto, esta me dando um desempenho muito bom nos links,
    aqui tenho 7 circuitos da BrasilTelecom e 6 da Embratel, comprei diuas Rb493HA e em cada uma fiz o balanceamento dos links separado por operadora, e interliguei as duas, se uma operadora cair a outra assume, no caso o balancemaneto assume, vou postar algumas fotos, e o grafico de uma das routerbaord com balanceamento entre 7 links.

    2 RB493AH balanceando link com algoritimo PCC
    http://www.linuxap.com.br/images/loa...oadbalaced.jpg

    http://www.linuxap.com.br/images/loa...dbalacedII.jpg

    http://www.linuxap.com.br/images/loa...balacedIII.jpg

    onde consequiu comprar as cases dessa rb

  6. #46

    Padrão

    to achando que vou ter que voltar para o balance por rotas novamente



  7. #47

    Padrão

    Ola amigos, a respeito do site de banco só tive problemas com um banco que foi o Bradesco, mas o mesmo já sabem como resolver, hoje temos mais de 2 mil clientes diretamente e n estou tento problema algum referente referente aos que o senhores estao relatando, como viram tenho duas RB493AH uma balanceio apenas link da Brasiltelecom e a outra da Embratel e ao mesmo tempo uma ta de backup da outra. O Link da Brasiltelecom são 7 circuitos e da embratel 3 com multilink de 4MB.

    Detalhe, n sei se é o caso dos senhores, mas se usam proxy externo com squid, vc tem q fazer com q o squid use o balanceamento do mikrotik, se não o squid sempre sairá para internet pelo GW dele neste caso apenas um IP, desta forma vc vai ter problemas com rapishare etc, existe varias formas de se arrumar isso, e cada caso é um caso, no meu utilizo iproute2 no squid, assim o cliente sai para internet pelo balanceamento.

    Atualizem tmb caso já n esteja a routerboard para a ultima versão, que no caso ate o momento é a 3.27

    n estou dizendo q o problema de vcs é esse estou apenas levatando as possibilidades dos problemas

    Ps. como disse temos muitos clientes e uma boa parte são empresas que usam banco o tempo inteiro, e outros viciados em internet que caso acontecesse esse problema de interromper download eles ligariam com certeza.

    abraços

  8. #48

    Padrão Problemas resolvidos

    O problema de criar contas do Hotmail ja descobri o que é, trata-se de que o hotmail colocou alguma espécie de limite de criaçao de contas diárias em 5 por IP, como temos centenas de clientes atras de NAT e poucos IPs validos, então as vezes acontece de estourar esse limite de criaçao de 5 contas por dia.
    O problema com rapidshare e similares nao está mais acontecendo depois da migraçao para versao 3.27 e classificador=both-address
    Problema com banco: foi unicamente o Bradesco, setei uma regra pra todos os pacotes com destino a rede do Bradesco (200.155.80.0/20) sairem por um unico link.
    Problemas com redirecionamentos: Defino ips Ips de origem da rede interna que rodam serviços com acesso externo (redirecionamentos) tambem para sairem somente por um link.

    Considero os problemas resolvidos, obrigado pela colaboraçao
    Att.

    Gabriel Siena



  9. #49

    Padrão

    aqui fiz dessa forma, resolveu todos os sites que tive problemas espero ajudar aqueles me ajudam sem cobrar 800,00

    /ip firewall address-list
    add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    add address=208.69.32.0/24 comment="" disabled=no list=loopback
    add address=208.67.217.0/24 comment="" disabled=no list=loopback
    add address=201.7.178.0/24 comment="" disabled=no list=loopback
    add address=201.7.176.0/24 comment="" disabled=no list=loopback
    add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback


    /ip firewall mangle
    add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=Clientes

    com isso esses destinos cadastrados no adress list saem por fora do balance, que podem ser observados pelo torc, se tiver alguma coisa errada ou ajuste me avise pois fiz essa solução baseado no curso da md e forum gringo e alguns amigos

    Obrigatorio clicar em Agradecer pra liberar o copiar e colar rsrs

    Sds

  10. #50

    Padrão

    Citação Postado originalmente por powernetscm Ver Post
    aqui fiz dessa forma, resolveu todos os sites que tive problemas espero ajudar aqueles me ajudam sem cobrar 800,00

    /ip firewall address-list
    add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    add address=208.69.32.0/24 comment="" disabled=no list=loopback
    add address=208.67.217.0/24 comment="" disabled=no list=loopback
    add address=201.7.178.0/24 comment="" disabled=no list=loopback
    add address=201.7.176.0/24 comment="" disabled=no list=loopback
    add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback


    /ip firewall mangle
    add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=Clientes

    com isso esses destinos cadastrados no adress list saem por fora do balance, que podem ser observados pelo torc, se tiver alguma coisa errada ou ajuste me avise pois fiz essa solução baseado no curso da md e forum gringo e alguns amigos

    Obrigatorio clicar em Agradecer pra liberar o copiar e colar rsrs

    Sds
    Coloque essa regra do mangle abaixo dos input e output e acima dos prerouting

    outro detalhe, na lista loopback tem q estar todas as faixas de IPs dos seus links.

    se for isso acredito q resolve



  11. #51

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Coloque essa regra do mangle abaixo dos input e output e acima dos prerouting

    outro detalhe, na lista loopback tem q estar todas as faixas de IPs dos seus links.

    se for isso acredito q resolve
    Não importa a ordem dos pacotes nesse caso. O pacote só é processado por 1 canal de cada vez, então não fará diferênça a ordem a qual está sendo mostrados entre os canais. O que é importante neste caso é no canal específico (input ou prerouting ou output, etc), as regras estejam na ordem correta. No mais, na vizualização "all" não fará diferença as ordens...

    Para melhro fazer isso que você sugeriu, é necessário selecionar cada cadeia individualmente e ae sim, colocar as regras da cadeia específica na ordem desejada.

  12. #52

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Não importa a ordem dos pacotes nesse caso. O pacote só é processado por 1 canal de cada vez, então não fará diferênça a ordem a qual está sendo mostrados entre os canais. O que é importante neste caso é no canal específico (input ou prerouting ou output, etc), as regras estejam na ordem correta. No mais, na vizualização "all" não fará diferença as ordens...

    Para melhro fazer isso que você sugeriu, é necessário selecionar cada cadeia individualmente e ae sim, colocar as regras da cadeia específica na ordem desejada.

    estou tendo problemas com o itau, mesmo colocando os ips la ele abre a pagina inicial e quando é colocado agencia e conta nao carrega a pagina até expirar ela.



  13. #53

    Padrão

    Citação Postado originalmente por gsiena Ver Post
    O problema de criar contas do Hotmail ja descobri o que é, trata-se de que o hotmail colocou alguma espécie de limite de criaçao de contas diárias em 5 por IP, como temos centenas de clientes atras de NAT e poucos IPs validos, então as vezes acontece de estourar esse limite de criaçao de 5 contas por dia.
    O problema com rapidshare e similares nao está mais acontecendo depois da migraçao para versao 3.27 e classificador=both-address
    Problema com banco: foi unicamente o Bradesco, setei uma regra pra todos os pacotes com destino a rede do Bradesco (200.155.80.0/20) sairem por um unico link.
    Problemas com redirecionamentos: Defino ips Ips de origem da rede interna que rodam serviços com acesso externo (redirecionamentos) tambem para sairem somente por um link.

    Considero os problemas resolvidos, obrigado pela colaboraçao
    Att.

    Gabriel Siena
    Amigo,

    Como vc criou esta regra do Bradesco ?

  14. #54

    Padrão registro.br

    Citação Postado originalmente por cristianoduarte Ver Post
    Amigo,

    Como vc criou esta regra do Bradesco ?
    primeiramente dei um ping no www.bradesco.com.br , peguei o IP e consultei no registro.br , dai o registro.br me mostra o ASN do bradesco, novamente no registro.br fiz a pesquisa pelo ASN , essa pesquisa mostra todas as sub-redes alocadas para uma determinada entidade. No caso do Bradesco mostrou só a 200.155.80.0/20



  15. #55

    Padrão

    Amigos, funcionaria desse jeito:


    ----Link1-------
    ----Link2------- Mikrotik PCC------Linux/Squid/HTB------Clientes
    ----Link3-------

    Para usar o CacheFull isso daria certo? Ou seria melhor um esquema com Proxy parent ou paralelo?

  16. #56

    Padrão

    Citação Postado originalmente por Josue Guedes Ver Post
    Amigos, funcionaria desse jeito:


    ----Link1-------
    ----Link2------- Mikrotik PCC------Linux/Squid/HTB------Clientes
    ----Link3-------

    Para usar o CacheFull isso daria certo? Ou seria melhor um esquema com Proxy parent ou paralelo?
    Josue, funcionaria sim sem problemas algum.

    Existe "N" formas de se fazer loadbalaced com PCC e usar proxy externo e cache full, essa que vc mesmo esta mostrando acima é uma delas, mas acredito que n é a melhor na minha opinião, hoje usar os recursos do mikrotik para controle de banda, firewall etc é bem melhor doque linux/squid/htb, n desmerecendo o linux, mas em termos de facilidade de manuseio entre outros.

    abraços



  17. #57

    Padrão

    Sim Tiago, realmente o manuseio em Mikrotik é muito mais prático, na realidade, já me acustumei muito ao HTB e CentOS, confio muito no htb, por isso uso assim, mais vamos iniciar alguns testes usando MK na saída para clientes. Todos os problemas com PCC foram sanados? Bancos, jogos, Msn, SSL? Grato.

  18. #58

    Padrão

    Citação Postado originalmente por Josue Guedes Ver Post
    Sim Tiago, realmente o manuseio em Mikrotik é muito mais prático, na realidade, já me acustumei muito ao HTB e CentOS, confio muito no htb, por isso uso assim, mais vamos iniciar alguns testes usando MK na saída para clientes. Todos os problemas com PCC foram sanados? Bancos, jogos, Msn, SSL? Grato.
    banco n é problema e sim q alguns sites q ao se navegar por dentro delle muda-se as faixas de IP do banco ele detecta q vc entrou com outro IP, e o único q esta tendo esse problema é o Bradesco.
    MSN nunca teve problema com PCC, jogos so pode ocorrer o mesmo problema se o IP do servidor mudar tmb, caso contrario n vai dar problema pq o PCC ele segura a conexão ate o termino dela.

    O problema q estava ocorrendo era com videos mas já esta ok.



  19. #59

    Padrão

    opa, estou com um problema, usei as regras que o tiago passou, mais quando adiciona os gateways, o primeiro gateway fica Ativo e Estático, mais os outros 2 os gateways ficam marcados em azul, achei que podia ser algo que eu fiz errado, apaguei tudo, e fiz novamente, agora pela explicação da wiki da mikrotik, e tá o mesmo problema, alguem testou o PCC na v3.27?

    Código :
    # Inicio do script
    # IP address
    /ip address
    add address=192.168.3.100/24 interface=clientes
    add address=192.168.4.100/24 interface=clientes
    add address=192.168.5.100/24 interface=clientes
    add address=189.11.xxx.xxx/29 interface=link1
    add address=192.168.101.10/24 interface=link2
    add address=192.168.102.10/24 interface=link3
    add address=192.168.103.10/24 interface=link4
    add address=192.168.104.10/24 interface=link5
     
    # Address-list
    /ip firewall address-list add list=rede-interna address=192.168.3.0/24
    /ip firewall address-list add list=rede-interna address=192.168.4.0/24
    /ip firewall address-list add list=rede-interna address=192.168.5.0/24
     
    # Mangle Input
    /ip firewall mangle
    add action=accept chain=prerouting comment="Fora do load balance" disabled=no dst-address-list=rede-interna in-interface=clientes
    add action=mark-connection chain=input comment="Connections to the router itself" connection-state=new disabled=no in-interface=link1 new-connection-mark=link1_conn passthrough=yes
    add action=mark-connection chain=input connection-state=new disabled=no in-interface=link2 new-connection-mark=link2_conn passthrough=yes
    add action=mark-connection chain=input connection-state=new disabled=no in-interface=link3 new-connection-mark=link3_conn passthrough=yes
    add action=mark-connection chain=input connection-state=new disabled=no in-interface=link4 new-connection-mark=link4_conn passthrough=yes
    add action=mark-connection chain=input connection-state=new disabled=no in-interface=link5 new-connection-mark=link5_conn passthrough=yes
    add action=mark-routing chain=output comment="Routes to the router itself" connection-mark=link1_conn disabled=no new-routing-mark=to_link1 passthrough=no
    add action=mark-routing chain=output connection-mark=link2_conn disabled=no new-routing-mark=to_link2 passthrough=no
    add action=mark-routing chain=output connection-mark=link3_conn disabled=no new-routing-mark=to_link3 passthrough=no
    add action=mark-routing chain=output connection-mark=link4_conn disabled=no new-routing-mark=to_link4 passthrough=no
    add action=mark-routing chain=output connection-mark=link5_conn disabled=no new-routing-mark=to_link5 passthrough=no
     
    # Mangle Prerouting
    /ip firewall mangle
    add action=mark-routing chain=prerouting disabled=no dst-port=443 in-interface=clientes new-routing-mark=to_link1 passthrough=no protocol=tcp
    add action=mark-connection chain=prerouting comment="Per-Connection Classifier" disabled=no dst-address-type=!local in-interface=clientes new-connection-mark=link1_conn passthrough=yes per-connection-classifier=both-addresses:5/0
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=clientes new-connection-mark=link2_conn passthrough=yes per-connection-classifier=both-addresses:5/1
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=clientes new-connection-mark=link3_conn passthrough=yes per-connection-classifier=both-addresses:5/2
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=clientes new-connection-mark=link4_conn passthrough=yes per-connection-classifier=both-addresses:5/3
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=clientes new-connection-mark=link5_conn passthrough=yes per-connection-classifier=both-addresses:5/4
    add action=mark-routing chain=prerouting connection-mark=link1_conn disabled=no in-interface=clientes new-routing-mark=to_link1 passthrough=no
    add action=mark-routing chain=prerouting connection-mark=link2_conn disabled=no in-interface=clientes new-routing-mark=to_link2 passthrough=no
    add action=mark-routing chain=prerouting connection-mark=link3_conn disabled=no in-interface=clientes new-routing-mark=to_link3 passthrough=no
    add action=mark-routing chain=prerouting connection-mark=link4_conn disabled=no in-interface=clientes new-routing-mark=to_link4 passthrough=no
    add action=mark-routing chain=prerouting connection-mark=link5_conn disabled=no in-interface=clientes new-routing-mark=to_link5 passthrough=no
     
    # NAT
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=link1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=link2
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=link3
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=link4
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=link5
     
    # Route
    /ip route
    add comment="Rotas padrao com failover" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=189.11.xxx.xxx scope=30 target-scope=10
    add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.101.1 scope=30 target-scope=10
    add disabled=no distance=3 dst-address=0.0.0.0/0 gateway=192.168.102.1 scope=30 target-scope=10
    add disabled=no distance=4 dst-address=0.0.0.0/0 gateway=192.168.103.1 scope=30 target-scope=10
    add disabled=no distance=5 dst-address=0.0.0.0/0 gateway=192.168.104.1 scope=30 target-scope=10
    add comment="Policy Routing" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=189.11.xxx.xxx routing-mark=to_link1 scope=30 target-scope=10
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.101.1 routing-mark=to_link2 scope=30 target-scope=10
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.102.1 routing-mark=to_link3 scope=30 target-scope=10
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.103.1 routing-makr=to_link4 scope=30 target-scope=10
    add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.104.1 routing-mark=to_link5 scope=30 target-scope=10
    Esse script o gsiena passou pra mim, e o problema persiste!!
    Última edição por xandemartini; 02-11-2009 às 11:31.

  20. #60

    Padrão

    Amigo vc pode me ajudar? eu estou com dois links adsl do net virtua que me dão ip validos dhcp e precisava de um tuto ou regaras para fazer um load no 3,27 rb1000u com hot e pppoe vc tem ou sabe onde tem pra me ajudar? Tenho 99 clientes e estou tendo problemas por favor me ajude....
    obrigado