+ Responder ao Tópico

PCC



  1. #81

    Padrão

    sim, vai ter de usar o masquerade no mk do meio tbm!!
    a questão do link aqui, fiz um com 5 links, se um deles cai, funciona normal, agora não sei te dizer com certeza, se com 2 links acontece a mesma coisa!

  2. #82

    Padrão

    Citação Postado originalmente por kilder Ver Post
    sim, vai ter de usar o masquerade no mk do meio tbm!!
    a questão do link aqui, fiz um com 5 links, se um deles cai, funciona normal, agora não sei te dizer com certeza, se com 2 links acontece a mesma coisa!

    Voce seguiu qual esquema para fazer o pcc? O do nosso amigo aqui do topico que fez com 7 links ou seguiu algum wiki ? Se voce puder dar uma ajudinha seria de muita ajuda pois nao sei se oq eu fiz esta correto...

    Muito obrigado



  3. #83

    Padrão

    tskstar, eu testei os dois e os dois funcionaram, mais esse do tiagomatias é mais completo, aqui uso o dele, e tá funcionando mto bem!! oq vc precisa, manda ae se eu não souber com ctza tem gente aqui que sabe!!

  4. #84

    Padrão pcc

    todos rodao bem se tiver duvidas poste aki pra ajudalo...



  5. #85

    Padrão

    Certo,segue entao as configuracoes atuais....

    Esta daqui eh de acordo com a mikrotikWiki que esta funcionando OK agora...

    Mas conforme nosso colega disse acima que o do colega do forum funciona melhor.Gostaria de saber qual seria a melhora,somente de curiosidade? E confirmar se esta tudo ok...

    Bem constatei que com um Link ativo somente ou seja se eu tiro o outro cabo de rede ele simplesmente para de carregar pela metade a pagina...Nao sei se isso soh acontece quando voce deixa com 1 Link,afinal se voce tiver 4 por exemplo e tirar 1 por exemplo iria sobrar 3 links para ainda efetuar a divisao agora somente com 1link...bem nem sei se eh isso se alguem puder me esclarecer...ficaria grato..

    Código :
    /ip firewall mangle
    add action=mark-connection chain=input comment="Make the packet leaves via same interface" disabled=no \
        in-interface=wan1 new-connection-mark=wan1_conn passthrough=yes
    add action=mark-connection chain=input comment="" disabled=no in-interface=wan2 new-connection-mark=\
        wan2_conn passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=wan1_conn disabled=no new-routing-mark=\
        to_wan1 passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=wan2_conn disabled=no new-routing-mark=\
        to_wan2 passthrough=yes
    add action=accept chain=prerouting comment="Assigning the propper routing-mark" disabled=no dst-address=\
        10.111.0.0/24 in-interface=Local
    add action=accept chain=prerouting comment="" disabled=no dst-address=10.112.0.0/24 in-interface=Local
    add action=mark-connection chain=prerouting comment="Avoind loop" disabled=no dst-address-type=!local \
        in-interface=Local new-connection-mark=wan1_conn passthrough=yes per-connection-classifier=\
        both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=\
        Local new-connection-mark=wan2_conn passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="Marking all the packets" connection-mark=wan1_conn \
        disabled=no in-interface=Local new-routing-mark=to_wan1 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=wan2_conn disabled=no in-interface=\
        Local new-routing-mark=to_wan2 passthrough=yes
    Código :
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan2
    Código :
    /ip route
    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=Local
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.111.0.1 \
        routing-mark=to_wan1 scope=30 target-scope=10
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.112.0.1 \
        routing-mark=to_wan2 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.111.0.1 scope=30 target-scope=10
    Última edição por tskstar; 13-08-2009 às 17:18.

  6. #86

    Padrão

    Citação Postado originalmente por tskstar Ver Post
    Certo,segue entao as configuracoes atuais....

    Esta daqui eh de acordo com a mikrotikWiki que esta funcionando OK agora...

    Mas conforme nosso colega disse acima que o do colega do forum funciona melhor.Gostaria de saber qual seria a melhora,somente de curiosidade? E confirmar se esta tudo ok...
    Aparentemente, estão corretas sim;
    tanto a que esta seguindo no wiki da mikrotik.com quanto a que eu postei aqui neste tópico tem o mesmo sentido, lógico que a aque eu postei é para 7 link, mas que pode ser ajustado para a quantidade necessarias. E as regras postadas aqui foram feita em cima do wiki da mikrotik.com tanto que nenhuma é melhor que a outra, pq elas fazem a mesma coisa com o mesmo sentido.

    Esclarecido, acredito que neste topico mesmo existe um outro poste com varios links interessantes que vale a pena o senhor ler.

    abraços
    Última edição por tiagomatias; 13-08-2009 às 17:08.



  7. #87

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Aparentemente, estão corretas sim;
    tanto a que esta seguindo no wiki da mikrotik.com quanto a que eu postei aqui neste tópico tem o mesmo sentido, lógico que a aque eu postei é para 7 link, mas que pode ser ajustado para a quantidade necessarias. E as regras postadas aqui foram feita em cima do wiki da mikrotik.com tanto que nenhuma é melhor que a outra, pq elas fazem a mesma coisa com o mesmo sentido.

    Esclarecido, acredito que neste topico mesmo existe um outro poste com varios links interessantes que vale a pena o senhor ler.

    abraços
    Bem obrigado por verificar as regras...Eh que e interessantes nos sabermos as melhorias quais foram que voce fez tiago,afinal nada melhor alguem que saiba como melhorar e compartilhe uma versao mais aprimorada com a sua...

    E com relacao ao fato de eu utilizar 2 links por exemplo e tirar o cabo de um deles,eh normal com 2 Links Ativos cair a navegacao ou tipo abre metade da pagina ou senao demora demaisss demaisss...isso eh normal quando se utilizar somente 2 links ?

    Caso positivo e adquira um terceiro link,isso iria continuar a ocorrer?

    Muito obrigado a todos!

  8. #88

    Padrão

    Citação Postado originalmente por tskstar Ver Post
    Bem obrigado por verificar as regras...Eh que e interessantes nos sabermos as melhorias quais foram que voce fez tiago,afinal nada melhor alguem que saiba como melhorar e compartilhe uma versao mais aprimorada com a sua...

    E com relacao ao fato de eu utilizar 2 links por exemplo e tirar o cabo de um deles,eh normal com 2 Links Ativos cair a navegacao ou tipo abre metade da pagina ou senao demora demaisss demaisss...isso eh normal quando se utilizar somente 2 links ?

    Caso positivo e adquira um terceiro link,isso iria continuar a ocorrer?

    Muito obrigado a todos!
    Caro tskstar, de fato o problema de um link não assumir o outro é normal! isso pq ?
    seguinte: a mikrotik acredito eu para n fugir do assunto que ela estaa ensinando/explicando em determinado momento ela utiliza para checagem se um link caiu ou não o check-gateway=ping, e a logica desta checagem é pingando o seu gateway, certo ? correto, mas tem um detalhe aqui, se o link do seu link1 cair e esse link1 for um roteador ou modem em modo routeado, você vai parar de pingar seu gateway ? não! desta forma ele pensa q seu link não caiu, e não o chamado FailOver que devria fazer. Para isso se deve utilizar uma outra ferramenta que a propria mikrotik tem para fazer o FailOver "se um link cair o outro assumir" e a ferramenta que te auxiliará em fazer isso é o NETWATH acho que escrevi o nome corretamente . O netwath faz uma checagem pingando um determinado host que você irá escolher, caso esse host up ou down ele irá ativar um script que você irá defenir para ativar sua rota ou não. De uma procura aqui no forum sobre netwath que acredito que vai encontrar bastante material sobre o mesmo que te ajudará em fazer esse FailOver.

    Emfim, o problema de um link não assumir o outro é este! Espero ter ajudado você em como solucionar o mesmo.

    abraços
    Última edição por tiagomatias; 13-08-2009 às 18:18.



  9. #89

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Caro tskstar, de fato o problema de um link não assumir o outro é normal! isso pq ?
    seguinte: a mikrotik acredito eu para n fugir do assunto que ela estaa ensinando/explicando em determinado momento ela utiliza para checagem se um link caiu ou não o check-gateway=ping, e a logica desta checagem é pingando o seu gateway, certo ? correto, mas tem um detalhe aqui, se o link do seu link1 cair e esse link1 for um roteador ou modem em modo routeado, você vai parar de pingar seu gateway ? não! desta forma ele pensa q seu link não caiu, e não o chamado FailOver que devria fazer. Para isso se deve utilizar uma outra ferramenta que a propria mikrotik tem para fazer o FailOver "se um link cair o outro assumir" e a ferramenta que te auxiliará em fazer isso é o NETWATH acho que escrevi o nome corretamente . O netwath faz uma checagem pingando um determinado host que você irá escolher, caso esse host up ou down ele irá ativar um script que você irá defenir para ativar sua rota ou não. De uma procura aqui no forum sobre netwath que acredito que vai encontrar bastante material sobre o mesmo que te ajudará em fazer esse FailOver.

    Emfim, o problema de um link não assumir o outro é este! Espero ter ajudado você em como solucionar o mesmo.

    abraços

    Certo,mais assim eu fiz o teste com o cabo desligado ai no caso ele ainda nao navega bem qnd eu tiro o cabo do outro..

    Oque seria o ideal para fazer neste caso ?

    Att

  10. #90

    Padrão

    Citação Postado originalmente por tskstar Ver Post
    Certo,mais assim eu fiz o teste com o cabo desligado ai no caso ele ainda nao navega bem qnd eu tiro o cabo do outro..

    Oque seria o ideal para fazer neste caso ?

    Att
    Repare que em aonde você mais precisava usar o check-gateway=ping que era nas rotas padrão você não utilizou.

    /ip route
    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=Local
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.111.0.1 \
    routing-mark=to_wan1 scope=30 target-scope=10
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.112.0.1 \
    routing-mark=to_wan2 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.111.0.1 scope=30 target-scope=10

    Se não tiver o check-gateway nestas rotas não irá funcionar o failover quando você tirar o cabo de rede. Acrecente nelas.

    Mas como já disse anteriormente a melhor forma é usando netwath



  11. #91

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Repare que em aonde você mais precisava usar o check-gateway=ping que era nas rotas padrão você não utilizou.

    /ip route
    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=Local
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.111.0.1 \
    routing-mark=to_wan1 scope=30 target-scope=10
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.112.0.1 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.112.0.1 \
    routing-mark=to_wan2 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.111.0.1 scope=30 target-scope=10

    Se não tiver o check-gateway nestas rotas não irá funcionar o failover quando você tirar o cabo de rede. Acrecente nelas.

    Mas como já disse anteriormente a melhor forma é usando netwath
    Opa,obrigado pela correcao...tem razao ja efetuei a mesma...uma coisa que gostaria de conferir a mais se nao for explorar demais....

    Depois que eu entao passar a conexao do balanceador que estavamos configurando ate agora....no Router principal (x86) eu simplesmente coloco uma regra de Masquerade para a interface que vem do Balanceador...para os clientes acessarem?tipo esta abaixo ou preciso de alguma coisa a mais ?


    No Servidor principal que recebe o link ja balanceado...

    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=LINK1



    Estaria certo ou precisaria de alguma coisa a mais para liberar o acesso para os clientes ?

  12. #92

    Padrão

    Bom dia a todos. Estou usando aqui o PCC e não tive nehum problema, a não ser com o bendito Bradesco. Já tentei algumas soluções sugeridas pelos amigos e não tive sucesso. Alguém pode postar a regra de marcação do Bradesco? Grato.



  13. #93

    Padrão

    Citação Postado originalmente por Josue Guedes Ver Post
    Bom dia a todos. Estou usando aqui o PCC e não tive nehum problema, a não ser com o bendito Bradesco. Já tentei algumas soluções sugeridas pelos amigos e não tive sucesso. Alguém pode postar a regra de marcação do Bradesco? Grato.

    Bem a solucao aqui foi a seguinte,se utiliza a opcao connection-state=new nos inputs e outputs ele nao ira funcionar a nao ser que voce direcione https somente para uma rota marcando a rota...caso voce utilize o padrao do Wiki-Mikrotik voce nao ira conseguir "somar" os download porem ira funcionar 100%...de uma testadinha e qualquer duvida estamos a disposicao..

  14. #94

    Padrão

    Citação Postado originalmente por Josue Guedes Ver Post
    Bom dia a todos. Estou usando aqui o PCC e não tive nehum problema, a não ser com o bendito Bradesco. Já tentei algumas soluções sugeridas pelos amigos e não tive sucesso. Alguém pode postar a regra de marcação do Bradesco? Grato.
    Josué de uma olhada neste topico desde o começo que acredito q eu ou outro posto ja a faixa de ips do brasdesco e aonde ela tem q ser colocada no mangle para que essa faixa de ip n passe pelo balanceamento. N me lembro em qual pagina está, mas vc vai achar. Ela resolve seu problema.

    abraços



  15. #95

    Padrão

    Citação Postado originalmente por tskstar Ver Post
    Opa,obrigado pela correcao...tem razao ja efetuei a mesma...uma coisa que gostaria de conferir a mais se nao for explorar demais....

    Depois que eu entao passar a conexao do balanceador que estavamos configurando ate agora....no Router principal (x86) eu simplesmente coloco uma regra de Masquerade para a interface que vem do Balanceador...para os clientes acessarem?tipo esta abaixo ou preciso de alguma coisa a mais ?


    No Servidor principal que recebe o link ja balanceado...

    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=LINK1


    Estaria certo ou precisaria de alguma coisa a mais para liberar o acesso para os clientes ?
    A principio esta certo sim.

  16. #96

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    A principio esta certo sim.
    Certo,agora ficou 100%,refiz tudo direitinho...ficou realmente muito bom esse sistema de balanceamento bem melhor q nth,nao tendo problemas com rotas nem nada,nem bancos e as conexoes wan sempre uma quase igual a outra o consumo..

    Futuramente irei adicionar mais delas...

    Muito obrigado a todos pela colaboracao!Mais uma vez...



  17. #97

    Smile

    Prezados estou querendo implantar aqui um load com PCC, usava o NTH mas como comentado aqui pelo pessoal o PCC eh bem melhor, mas ainda nao encontrei a solucao pra minha duvida simples%

    Tenho tres links:

    2 adsl de 8 megas
    1 Embratel ful de 2 megasl

    Gostaria de um script que dividisse a banda por igual, pois eu fiz aqui, e o link da embratel fica sempre no talo e os outros dois rodando folgado.


    Agardeco as que contribuirem


    abracos

  18. #98

    Padrão pcc

    amigo existe varios exemplos de se fazer isso tem ja um script do proprio tiago explicando como fazer divisao dos links, poste sua regras para vermos onde esta errando pois o intuito e de voce aprender e nao pegar um scritp todo pronto e copiar e colar.



  19. #99

  20. #100

    Padrão

    Citação Postado originalmente por aprinou Ver Post
    amigo existe varios exemplos de se fazer isso tem ja um script do proprio tiago explicando como fazer divisao dos links, poste sua regras para vermos onde esta errando pois o intuito e de voce aprender e nao pegar um scritp todo pronto e copiar e colar.
    reforçando o que aprinou disse. Vamos pensar como vc quer fazer.

    se vc tem:
    2 links de 8MB e
    1 de 2 MB
    vc tem q dividir o trafego por igual em pesos iguais de acordo com seu link de menor tamanho. Exemplo:
    se seu link menor é de 2MB vc pega os links maiores e dividir em partes iguais para ficarem com o mesmo tamanho do menor.
    8MB / 2MB = 4 links de 2MB
    faça assim com os dois links de 8MB
    as regras de INPUT, OUTPUT e PREROUTING com marcação de MARK ROUTING não mudam, não se acrecenta nada, o q vai acrecentar são as regras de PREROUTING com marcação de MARK CONNECTION, nelas que vc vai dividir o trafego por igual, no caso a divisão seria:
    4 marcação para 1 link de 8MB
    4 marcação para 1 link de 8MB
    1 marcação para 1 link de 2MB

    acredito q assim vc tera o trafego dividido de forma correta.