Página 8 de 15 PrimeiroPrimeiro ... 345678910111213 ... ÚltimoÚltimo
+ Responder ao Tópico

PCC



  1. #141

    Padrão

    Aqui está a imagem das minhas interfaces e das minhas rotas:

    O link da NET (Virtua) é através de cable modem conectado direto a RB, e pega endereço via DHCP.

    Os 2 outros links (GVT) estão roteados no modem.

    http://www.awgnet.com.br/Images/pcc2.jpg

  2. #142

    Padrão

    Citação Postado originalmente por awgnet Ver Post
    Aqui está a imagem das minhas interfaces e das minhas rotas:

    O link da NET (Virtua) é através de cable modem conectado direto a RB, e pega endereço via DHCP.

    Os 2 outros links (GVT) estão roteados no modem.

    http://www.awgnet.com.br/Images/pcc2.jpg
    Poste todos os scripts de
    /ip firewall mangle export
    /ip route export



  3. #143

    Padrão

    Seguem os scripts solicitados:

    ##########################################################
    /ip firewall mangle
    add action=mark-connection chain=input comment="" disabled=no in-interface=\
    wan_gvt1 new-connection-mark=wan_gvt1_conn passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=wan_net1 new-connection-mark=wan_net1_conn \
    passthrough=yes
    add action=mark-connection chain=input comment="" disabled=no in-interface=\
    wan_gvt2 new-connection-mark=wan_gvt2_conn passthrough=yes
    add action=mark-connection chain=output comment="" connection-mark=\
    wan_gvt1_conn disabled=no new-connection-mark=to_wan_gvt1 passthrough=yes
    add action=mark-connection chain=output comment="" connection-mark=\
    wan_net1_conn connection-state=new disabled=no new-connection-mark=\
    to_wan_net1 passthrough=yes
    add action=mark-connection chain=output comment="" connection-mark=\
    wan_gvt2_conn disabled=no new-connection-mark=to_wan_gvt2 passthrough=yes
    add action=accept chain=prerouting comment="" disabled=no dst-address=\
    10.1.1.0/29 in-interface=lan
    add action=accept chain=prerouting comment="" disabled=no dst-address=\
    10.1.1.8/29 in-interface=lan
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_gvt1_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_gvt2_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/1
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_net1_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/2
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_gvt1_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/3
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_gvt2_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/4
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_net1_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/5
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_gvt1_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/6
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_gvt2_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/7
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_net1_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/8
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_gvt1_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/9
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_gvt2_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/10
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_net1_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/11
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_gvt1_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/12
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_gvt2_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/13
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_net1_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/14
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=lan new-connection-mark=\
    wan_gvt2_conn passthrough=yes per-connection-classifier=\
    both-addresses:16/15
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    wan_gvt1_conn disabled=no in-interface=lan new-routing-mark=to_wan_gvt1 \
    passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    wan_net1_conn connection-state=established disabled=no in-interface=lan \
    new-routing-mark=to_wan_net1 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    wan_gvt2_conn disabled=no in-interface=lan new-routing-mark=to_wan_gvt2 \
    passthrough=yes

    ##########################################################
    /ip route
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=10.1.1.9 routing-mark=to_wan_gvt2 scope=30 \
    target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=189.103.80.1 routing-mark=to_wan_net1 scope=30 \
    target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=10.1.1.1 routing-mark=to_wan_gvt1 scope=30 \
    target-scope=10
    add check-gateway=ping comment="" disabled=no distance=2 dst-address=\
    0.0.0.0/0 gateway=10.1.1.9 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=10.1.1.1 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=3 dst-address=\
    0.0.0.0/0 gateway=189.103.80.1 scope=30 target-scope=10

    Agradeço antecipadamente a ajuda.

  4. #144
    Não Registrado
    Visitante

    Padrão agora ferrou de vez a cabeca

    Citação Postado originalmente por aprinou Ver Post
    sim ficao em azul pois elas ficam em standy by pois elas podem ser monitoradas via chek ping ou netwatch verificando a atividade dos links caso um saia fora vai pro outro link por isso tem as distancias neles, caso use modem em modo roteado use o netwatch pra monitorar seus links e rodar regras de desativar etc...esssa regras que postem e apenas um exemplo que vc deve claro adptar pro nos de suas interfaces...
    Nao entendi nadaagora amigo aprimor, se as azuis ficam em aul pq ficam de backup, entao o balance não usa as duas entradas?? ou seja, se to em ponte e tenho 2 dsl de 2 com o balance vou ter sempre 2m e os outros 2 mg vao ficar em azul apenas pra qd o link principal cair?? confesso que to zuadao agora....deculpe, fo o que entendi



  5. #145

    Padrão Problema nos vídeos da globo.com

    Seguindo o modelo de regras que o tiago postou,caso alguém encontre problemas para visualizar vídeos da globo.com , segue a regra pra tirar ele fora do lb

    add address=201.7.176.0/20 comment="Globo" disabled=no list=loopback

    Vlws...

  6. #146

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    Seguindo o modelo de regras que o tiago postou,caso alguém encontre problemas para visualizar vídeos da globo.com , segue a regra pra tirar ele fora do lb

    add address=201.7.176.0/20 comment="Globo" disabled=no list=loopback

    Vlws...
    no meu site do terratv esta aparecendo video_not_found seria o load do pcc igual da globo, alguem tem o ip do terratv?



  7. #147

    Padrão

    Citação Postado originalmente por antonoel Ver Post
    no meu site do terratv esta aparecendo video_not_found seria o load do pcc igual da globo, alguem tem o ip do terratv?
    teste terra
    208.84.247.0/24
    200.154.56.0/24

  8. #148

    Padrão Pcc fica lento

    ola pessoal estou fazendo implantação do pcc, so que faço a configuração seguindo esta wiki PCC - MikroTik Wiki, no meu servido proxy (mikrotik) fica mais lenta navegação.
    estou colocando um link 4mb mais adsl de 4mb.

    oque tenho que fazer para isso funcionar e melhorar o desenpenho?
    Obrigado



  9. #149

    Padrão

    Citação Postado originalmente por evertonfritz Ver Post
    ola pessoal estou fazendo implantação do pcc, so que faço a configuração seguindo esta wiki PCC - MikroTik Wiki, no meu servido proxy (mikrotik) fica mais lenta navegação.
    estou colocando um link 4mb mais adsl de 4mb.

    oque tenho que fazer para isso funcionar e melhorar o desenpenho?
    Obrigado

    Basta deixar o pcc em outra maquina depois seu web proxy pcc---webproxy ja foi dito aki ...


    Parabens tiago ficou 1001 uma delicia usar o pcc

  10. #150

    Padrão

    Pessoal, fiz uma balanceamento através da explicação do PCRam, só que estou com uma dúvida cruel que é a seguinte. Tenho dois velox de 01MB ligados na RB450 só que estou querendo que o mesmo manda a quantidade necessária de link para as demais portas que aqui ficaram com o padrão ether3, 4, 5. Só que fui baixar um arquivo e percebi que só estava usando um link "Velox-2" só que na verdade estou querendo que seja usado os dois simultaneamente assim terei ainda mais velocidade na navegação. Estou usando esse sistema em minha casa e quero ver como realmente funciona e o pessoal puder me ajudar eu agradeço bastante.



  11. #151

    Padrão

    Citação Postado originalmente por rafajohn Ver Post
    Pessoal, fiz uma balanceamento através da explicação do PCRam, só que estou com uma dúvida cruel que é a seguinte. Tenho dois velox de 01MB ligados na RB450 só que estou querendo que o mesmo manda a quantidade necessária de link para as demais portas que aqui ficaram com o padrão ether3, 4, 5. Só que fui baixar um arquivo e percebi que só estava usando um link "Velox-2" só que na verdade estou querendo que seja usado os dois simultaneamente assim terei ainda mais velocidade na navegação. Estou usando esse sistema em minha casa e quero ver como realmente funciona e o pessoal puder me ajudar eu agradeço bastante.

    pelo pouco conhecimento que tenho este balanceamento não soma os links e sim divide a carga entre eles no caso de downloads ele só vai somar caso utilize algum programa de gerenciamento de downloads, um exemplo é no meu caso usando o utorrent consigo baixar a mais de 700kb/s aonde tenho virtua 1mb e 2 speedys de 2 e 4mb, caso esteja falando alguma besteira alguém me corrija.

  12. #152

    Padrão

    Citação Postado originalmente por antonoel Ver Post
    pelo pouco conhecimento que tenho este balanceamento não soma os links e sim divide a carga entre eles no caso de downloads ele só vai somar caso utilize algum programa de gerenciamento de downloads, um exemplo é no meu caso usando o utorrent consigo baixar a mais de 700kb/s aonde tenho virtua 1mb e 2 speedys de 2 e 4mb, caso esteja falando alguma besteira alguém me corrija.
    Esta correto, alem disso precisa mudar o algorito de both-address para both-address and ports.
    mas n tive muito sucesso com ele, devido a ficar dando algunas requisições expiradas.



  13. #153

    Padrão

    estou acompanhando esse post e o outro que tambem fala do pcc, e estudando os 2 estou tentando implentar aqui na minha rede,, tenho aqui 2 links, um de 256 e outo de 512.
    só que quando eu coloquei o pcc pra rodar o hotspot parou, não abre mais nem a pagina de autenticação, estive olhando os conceitos do outro topico, mas não consegui achar o erro das minhas configurações, vou postar elas abaixo, para que os amigos possam me dar uma luz..

    Att
    Helder

    Código :
    /ip address
    add address=172.16.0.254/24 broadcast=172.16.0.255 comment="Rede Local - Clientes Prefeitura" disabled=no interface="Rede Local" network=172.16.0.0
    add address=189.80.16.82/29 broadcast=189.80.16.87 comment="Ip Link 256" disabled=no interface="Oi UP 256" network=189.80.16.80
    add address=189.80.219.82/29 broadcast=189.80.219.87 comment="Ip Link 512" disabled=no interface="Oi UP 512" network=189.80.219.80
    add address=10.10.10.1/24 broadcast=10.10.10.255 comment="Rede Local - Clientes Rua" disabled=no interface="Rede Local" network=10.10.10.0
     
    / ip firewall mangle
    add chain=input in-interface="Oi UP 512" action=mark-connection new-connection-mark=Oi_UP_512_conn
    add chain=input in-interface="Oi UP 256" action=mark-connection new-connection-mark=Oi_UP_256_conn
    add chain=output connection-mark=Oi_UP_512_conn action=mark-routing new-routing-mark=to_Oi_UP_512
     
    add chain=output connection-mark=Oi_UP_256_conn action=mark-routing new-routing-mark=to_Oi_UP_256
    add chain=prerouting dst-address=189.80.219.80/29  action=accept in-interface=Rede Local
     
    add chain=prerouting dst-address=189.80.16.82/29  action=accept in-interface=Rede Local
    add chain=prerouting dst-address-type=!local in-interface="Rede Local" per-connection-classifier=both-addresses:2/0 \
        action=mark-connection new-connection-mark=Oi_UP_512_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface="Rede Local" per-connection-classifier=both-addresses:2/1 \
        action=mark-connection new-connection-mark=Oi_UP_256_conn passthrough=yes
    add chain=prerouting connection-mark=Oi_UP_512_conn in-interface="Rede Local" action=mark-routing new-routing-mark=to_Oi_UP_512
    add chain=prerouting connection-mark=Oi_UP_256_conn in-interface="Rede Local" action=mark-routing new-routing-mark=to_Oi_UP_256
     
    / ip route
    add dst-address=0.0.0.0/0 gateway=189.80.219.81 routing-mark=to_Oi_UP_512 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=189.80.16.81  routing-mark=to_Oi_UP_256 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=189.80.219.81 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=189.80.16.81  distance=2 check-gateway=ping
     
    / ip firewall nat 
    add chain=srcnat out-interface="Oi UP 512" action=masquerade
    add chain=srcnat out-interface="Oi UP 256" action=masquerade

  14. #154

    Padrão

    Citação Postado originalmente por exclusivenet Ver Post
    estou acompanhando esse post e o outro que tambem fala do pcc, e estudando os 2 estou tentando implentar aqui na minha rede,, tenho aqui 2 links, um de 256 e outo de 512.
    só que quando eu coloquei o pcc pra rodar o hotspot parou, não abre mais nem a pagina de autenticação, estive olhando os conceitos do outro topico, mas não consegui achar o erro das minhas configurações, vou postar elas abaixo, para que os amigos possam me dar uma luz..

    Att
    Helder

    Código :
    /ip address
    add address=172.16.0.254/24 broadcast=172.16.0.255 comment="Rede Local - Clientes Prefeitura" disabled=no interface="Rede Local" network=172.16.0.0
    add address=189.80.16.82/29 broadcast=189.80.16.87 comment="Ip Link 256" disabled=no interface="Oi UP 256" network=189.80.16.80
    add address=189.80.219.82/29 broadcast=189.80.219.87 comment="Ip Link 512" disabled=no interface="Oi UP 512" network=189.80.219.80
    add address=10.10.10.1/24 broadcast=10.10.10.255 comment="Rede Local - Clientes Rua" disabled=no interface="Rede Local" network=10.10.10.0
     
    / ip firewall mangle
    add chain=input in-interface="Oi UP 512" action=mark-connection new-connection-mark=Oi_UP_512_conn
    add chain=input in-interface="Oi UP 256" action=mark-connection new-connection-mark=Oi_UP_256_conn
    add chain=output connection-mark=Oi_UP_512_conn action=mark-routing new-routing-mark=to_Oi_UP_512
     
    add chain=output connection-mark=Oi_UP_256_conn action=mark-routing new-routing-mark=to_Oi_UP_256
    add chain=prerouting dst-address=189.80.219.80/29  action=accept in-interface=Rede Local
     
    add chain=prerouting dst-address=189.80.16.82/29  action=accept in-interface=Rede Local
    add chain=prerouting dst-address-type=!local in-interface="Rede Local" per-connection-classifier=both-addresses:2/0 \
        action=mark-connection new-connection-mark=Oi_UP_512_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface="Rede Local" per-connection-classifier=both-addresses:2/1 \
        action=mark-connection new-connection-mark=Oi_UP_256_conn passthrough=yes
    add chain=prerouting connection-mark=Oi_UP_512_conn in-interface="Rede Local" action=mark-routing new-routing-mark=to_Oi_UP_512
    add chain=prerouting connection-mark=Oi_UP_256_conn in-interface="Rede Local" action=mark-routing new-routing-mark=to_Oi_UP_256
     
    / ip route
    add dst-address=0.0.0.0/0 gateway=189.80.219.81 routing-mark=to_Oi_UP_512 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=189.80.16.81  routing-mark=to_Oi_UP_256 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=189.80.219.81 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=189.80.16.81  distance=2 check-gateway=ping
     
    / ip firewall nat 
    add chain=srcnat out-interface="Oi UP 512" action=masquerade
    add chain=srcnat out-interface="Oi UP 256" action=masquerade

    Não sei se reparou se n me engano aquele outro usa-se nas regras uma opção a mais chamado connection-state=new com essa opção ativa vc pode usar o hotspot na mesma maquina do loadbalaced, mas o ideal é colocar o loadbalaced em uma maquina diferente do hotspot, mas caso n possa, utilize da forma q te disse, nas outras regras do Luciano m4d3 está para funcionar junto.

    abraços



  15. #155

    Padrão Vídeos Terra...

    No site do terra.com.br os vídeos_terra,parecem estar ok,entretanto o tv_terra da a mensagem de vídeo não encontrado.Antes eu usava o thundercache2.x e tinha que desabilitar o plugin do terra,só assim os vídeos carregavam numa boa,mesmo usando o LB por PCC.

    Tiago! Experimentei usar as ranges de ip para o terra,não obtive sucesso.Mas como eu citei,parece ser o plugin do terra(Caso use o TC)....

    Atualmente estou usando o TC3,vou desabilitar o plugin do terra,depois posto aqui o resultado...

    t+

  16. #156

    Padrão

    Citação Postado originalmente por evertonfritz Ver Post
    ola pessoal estou fazendo implantação do pcc, so que faço a configuração seguindo esta wiki PCC - MikroTik Wiki, no meu servido proxy (mikrotik) fica mais lenta navegação.
    estou colocando um link 4mb mais adsl de 4mb.

    oque tenho que fazer para isso funcionar e melhorar o desenpenho?
    Obrigado
    A navegação ficou lenta após implantar o LB por PCC?

    Reparou se a carga entre ambos estão bem divididas?

    Aqui tenho uma mescla de Dedicado + DSL.Deixo os modens todos em modo bridge,assim ganho desempenho no processamento de pacotes.

    Poste mais informações...

    t+



  17. #157

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Não sei se reparou se n me engano aquele outro usa-se nas regras uma opção a mais chamado connection-state=new com essa opção ativa vc pode usar o hotspot na mesma maquina do loadbalaced, mas o ideal é colocar o loadbalaced em uma maquina diferente do hotspot, mas caso n possa, utilize da forma q te disse, nas outras regras do Luciano m4d3 está para funcionar junto.

    abraços
    valeu, vou testar dessa forma e posto aqui os resultados ..

  18. #158

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    No site do terra.com.br os vídeos_terra,parecem estar ok,entretanto o tv_terra da a mensagem de vídeo não encontrado.Antes eu usava o thundercache2.x e tinha que desabilitar o plugin do terra,só assim os vídeos carregavam numa boa,mesmo usando o LB por PCC.

    Tiago! Experimentei usar as ranges de ip para o terra,não obtive sucesso.Mas como eu citei,parece ser o plugin do terra(Caso use o TC)....

    Atualmente estou usando o TC3,vou desabilitar o plugin do terra,depois posto aqui o resultado...

    t+
    Os videos e tv do terra n pode passar pelo loadbalaced, tire eles, tem em outro topico n lembro o nome postei eu e outro cara os ips dos servidores deles para tirar do balanceador para ser assistido os videos



  19. #159

    Padrão

    Amigos por que sera que quando deixo both-address para both-address and ports ele "soma os links" mas tem gente dizendo que ele ta dando problema com paginas...

    Se eu voltar both-address ele nao "soma" PQ?

  20. #160

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    Amigos por que sera que quando deixo both-address para both-address and ports ele "soma os links" mas tem gente dizendo que ele ta dando problema com paginas...

    Se eu voltar both-address ele nao "soma" PQ?
    amigo, com a opçào both-address and ports ele soma o link como vc viu, mas somente quando o cliente usa um gerenciador de download. Até a versão 3.27 tinha testado com ele e o mesmo dava algumas paginas expiradas "conexões espiradas" elas se perdiam... etc

    por isso parei de usar.

    Ps. so soma os links se vc usar algum gerenciador de download