Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #7

    Padrão

    Citação Postado originalmente por lipeiori Ver Post
    Aqui eu deixo o Keepalive Timeout em 2 minutos, depois disso o cliente é desconectado e a queue dinâmica some, se ele voltar a navegar ai sim a queue volta e ele é conectado novamente mas sem pedir login e senha já que o cookie deixei pra expirar depois de 3 dias.
    Tchê, eu ainda não consegui entender bem o funcionamento desse trem.
    Fiz mais alguns testes agora que estou sozinho na rede e não funcionou. Fiquei monitorando e eu devia ter sido removido da queue.
    Mas observando o tráfego, notei que fica mostrando atividade entre 3 e 7 kbps. Acho que assim, não vai sair da queue, pois o servidor vai entender que tem atividade?
    Para cair deveria zerar a atividade.
    E isso acontece com todos que estão conectados mas sem atividade. Sem mostra algum resquicio de atividade.
    No log, tenho observado que o assinante foi deslogado by keepalive timeout, mas isso depois de muito tempo.
    O keepalive timeout funciona em harmonia com mais algum parâmetro, para obedecer este dois minutos, ou bastaria só determinar o tempo?

  2. #8

    Padrão

    Eu notei que para o Keepalive começar a contagem para desconectar o cliente, ele precisar estar com 0bps de tráfego, ai sim começa a contar os 2 minutos para ser excluido da lista dos clientes ativos.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         hotspot.JPG
Visualizações:	277
Tamanho: 	48,9 KB
ID:      	5093  



  3. #9

    Padrão

    Citação Postado originalmente por lipeiori Ver Post
    Eu notei que para o Keepalive começar a contagem para desconectar o cliente, ele precisar estar com 0bps de tráfego, ai sim começa a contar os 2 minutos para ser excluido da lista dos clientes ativos.
    Eu estava fazendo uma barberagem ao monitorar. Pois estava monitorando pelo winbox da mesma máquina que estava conectado. Assim, não zera nunca, pois o winbox fica enviando.

    Daí conectei com outra máquina e não fiz atividade nenhuma e fui noutra máquina e fiquei monitorando, tráfego zero por 15 minutos e não desconectou. Deve ter outra config que talvez impeça a queda. O idle timeout está como none. Será isso?

    E olhando no log achei outra coisa que não conhecia.
    Só tem um usuário que de hora em hora, exata, ele é desconectato com a mensagem que aparece no log: "host removed: overrided bu static entry" ou seja anulado por entrada estática. Todos os perfis são os mesmos, mas isso só acontece com este usuário. Quando completa um período de 1 hora ele é desconectado. E isso se repete a cada período de uma hora. Sabe porque acontece isso?
    Última edição por 1929; 09-08-2009 às 22:43.

  4. #10

    Padrão

    Coloca o Keepalive no profile do cliente no Hotspot.

    A segunda imagem mostra o log dele saindo.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         hotspot2.JPG
Visualizações:	334
Tamanho: 	35,1 KB
ID:      	5094   Clique na imagem para uma versão maior

Nome:	         hotspot3.JPG
Visualizações:	256
Tamanho: 	91,0 KB
ID:      	5095  




  5. #11

    Padrão

    Citação Postado originalmente por lipeiori Ver Post
    Coloca o Keepalive no profile do cliente no Hotspot.

    A segunda imagem mostra o log dele saindo.
    O meu profile já está com o tempo 00:02:00. A única diferença entre o meu e o teu é que no meu não tem aquela caixa na frente do tempo para habilitar. Mas isso deve ser por diferença de versão. Estou com a 3.10
    No log aparece frequentemente usuários sendo desconectado por keepalive timeout. Mas na realidade não sei quanto tempo leva para desconectar.
    Por isso fiz o teste comigo mesmo para ter a certeza e com 2 minutos de configuração não desconectou nem em 15 minutos. Daí desisti de continuar monitorando.

  6. #12

    Padrão

    Citação Postado originalmente por 1929 Ver Post
    O meu profile já está com o tempo 00:02:00. A única diferença entre o meu e o teu é que no meu não tem aquela caixa na frente do tempo para habilitar. Mas isso deve ser por diferença de versão. Estou com a 3.10
    No log aparece frequentemente usuários sendo desconectado por keepalive timeout. Mas na realidade não sei quanto tempo leva para desconectar.
    Por isso fiz o teste comigo mesmo para ter a certeza e com 2 minutos de configuração não desconectou nem em 15 minutos. Daí desisti de continuar monitorando.
    Faz o seguinte, desmarca as opções do profile e seta direto no Hotspot > Servers, o idle e keepalive timeout.