Página 3 de 12 PrimeiroPrimeiro 12345678 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #41

    Padrão

    Bill Gates, veja só

    Testei aqui colocando o GTW do pppoe e tirei a marcação da porta 80 do LINK2.
    Também coloquei o DNS da OpenDNS.
    resultado: Não obtive navegação.

    Cara só falta fazer o LINK1 funcionar.

    Veja como ficou:
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         pppoe-lb2.GIF
Visualizações:	225
Tamanho: 	106,2 KB
ID:      	4864  

  2. #42

    Padrão

    Citação Postado originalmente por gustavinho69 Ver Post
    Bill Gates, veja só

    Testei aqui colocando o GTW do pppoe e tirei a marcação da porta 80 do LINK2.
    Também coloquei o DNS da OpenDNS.
    resultado: Não obtive navegação.

    Cara só falta fazer o LINK1 funcionar.

    Veja como ficou:
    huahauha,ae vc me quebra as pernas!!!

    Olha no seu NAT...notou algo errado???

    Out interface, é o basicao cara, pppoe-out1(nome da sua conexão pppoe client)

    Testa ai !!!



  3. #43

    Padrão

    NOoooooossaa que brexaaa meu brother!!!!!! ahuhauhauahu tava fuçando em tanta coisa pra ver se pegava que saiu essa mancada...maravilhaaa bill gates...funcionando caraa.......hehehe poww vlww mesmo por toda força...agora só aprimorar o server...

  4. #44

    Padrão

    alguem ai poderia fazer um tuto para o fedora
    estou a dias tentando instalar ele no fedora, e ate agora nao consegui...
    ja tentei de tudo, outros tuto... e ate algumas dicas postadas por companheiros, e nada ate agora
    segue o link: Instalacao Thunder Cache



  5. #45

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    Deixa eu ver se ententi...

    Antes seu cache full funcionava perfeitamente mas o thundercache não...
    Agora que você colocou as regras do tutorial,ele vem a full a primeira vez,mas é usado todo o seu link de internet?

    Ja na segunda vez,vem a full usando apenas o link da rede!

    No thunder.config, onde esta marcado a velocidade dos downloads que sera feita pelo thunder, em quanto vc setou?

    No queue tree, vc notou na segunda vez que vc faz o down do msm arquivo,qual a velocidade que esta baixando?

    Desabilite o redirecionamento do thunder e teste baixar um novo arquivo que não esteja cacheado!

    Não uso/conheço o sistema do pedro,então caso seja flexivel, tente desabilita-lo e fazer autenticação dos seus clientes pelo próprio MK. O modo testado com exito no tutorial foi por PPPoE,então caso vc possa migrar a forma de autenticação(Somente para teste),faça isso e teste novamente fazer um Down de um arquivo que não esteja cacheado.

    Depois poste os resultados se possivel...
    Meu problema foi resolvido com ajuda do KrysecK


    minhas regras do mangle

    /ip firewall mangle
    Cara muito Obrigado por ter me ajudado é de gente como você que o forum precisa agora esta indo a full tudo que esta no THUNDER CACHE segue minhas regras do mangle conforme dica do nosso amigo KrysecK
    mais uma vez muito obrigado.
    add chain=prerouting protocol=tcp content="THUNDER: THUNDER" \
    action=mark-connection new-connection-mark=thunder-connection \
    passthrough=yes comment="THUNDER CACHE FULL" disabled=no
    add chain=prerouting protocol=tcp connection-mark=thunder-connection \
    action=mark-packet new-packet-mark=thunder-packs passthrough=no comment="" \
    disabled=no

    Mas ainda estou com um problema os videos do youtube alguns deles são gravados no thunder com tamanho 0 (zero) se alguem já passou por isso o que fazer meu thunder V2.1 desde já obrigado.

  6. #46

    Padrão

    Qual sua versão do MK?

    Pq para 2.x deve-se marcar por tag, assim como esta na sua regra...

    Sobre alguns vídeos cachear com tamanho "0",isso esta acontecendo msm, no forum do thunder,

    www.thundercache.org , tem mais colegas com esse problema... mas da pra ir contornando isso,indo ate o proxy e apagando os arquivos menos que 100kytes

    Não testei a nova revisão ,pq vi muitos comentarios que tem alguns problemas com ela,então estou esperando a proxima revisão,pq essa que estou usando esta me servindo perfeitamante..

    Obs.:

    Post sua versão akee se possivel junto com suas regras de mangle para a marcação do cache full,
    acredito que sejam 6 regras de mangle,mas ao inves de marcar no ip vc esteja marcando pelo tag mesmo,e como mencionado as versões 2.x use-se o tag THUNDER...




  7. #47

    Padrão

    Citação Postado originalmente por mascaraapj Ver Post
    alguem ai poderia fazer um tuto para o fedora
    estou a dias tentando instalar ele no fedora, e ate agora nao consegui...
    ja tentei de tudo, outros tuto... e ate algumas dicas postadas por companheiros, e nada ate agora
    segue o link: Instalacao Thunder Cache
    Essa eu passo,por 2 motivos:
    - Não sei como seria o desempenho no fedora,pois usei somente no ubuntu e debian.
    - Estou meio sem tempo...

    Mas imagino que vc possa seguir ma mesma linha desse tutorial,alguém fez em distro diferente?poderia comentar?


  8. #48

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    Essa eu passo,por 2 motivos:
    - Não sei como seria o desempenho no fedora,pois usei somente no ubuntu e debian.
    - Estou meio sem tempo...

    Mas imagino que vc possa seguir ma mesma linha desse tutorial,alguém fez em distro diferente?poderia comentar?

    problema resolvido...
    vou montar um tuto passo a passo... bem explicadinho...
    e postar aqui no forum, para ajudar outros = a min.. uehsues

    Instalacao Thunder Cache - Página 4



  9. #49

    Padrão

    Citação Postado originalmente por mascaraapj Ver Post
    problema resolvido...
    vou montar um tuto passo a passo... bem explicadinho...
    e postar aqui no forum, para ajudar outros = a min.. uehsues

    Instalacao Thunder Cache - Página 4
    Parabéns colega,faça mesmo pois todo conteúdo é bem vindo!

  10. #50

    Padrão Tutorial load balance (paralelo) + Debian + ThunderCache + servidor MK 3.13-3.22

    Falando em conteúdo,ta meio corrido akee nesses ultimos dias.
    Estou devendo a regra de redirecionamento de downloads,então amanhã vou postar akee...




  11. #51

    Padrão

    a unica coisa que muda da versão 3 .XX para a 2.xx é o mangle que temn que ser diferente? Pois tenho o seguinte cenario aqui.....
    Tenho um link apenas então a parte do load será para mais pra frente.....to com o thunder rodando na minha rede ja....e gostaria de implantar o cache full pois ainda não coloquei? To sem saber quais regras usar pois estou com medo de colocar as regras do 3.xx e não funcionar.

  12. #52

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    Olha só como é a vida...

    Tenho um amigo que usa versão 2.9.51,e esta funcionando perfeitamente com as regras de mangle que postei aqui no topico.
    Porém,ajudei esses dias um colega que usava 2.9.27(cracked) e não obtivemos resultados satisfatorios com as regras do topico.

    Então estive dando uma olhada do forum do thundercache.org e vi um colega que postou uma regra para a versão 2.9.27 que funcionou segundo ele perfeitamente...

    Vou procurar o link e ja ja post aki...

    Segue abaixo o topico do forum do thundercache.org
    Observe que existem alterações no squid.config , thunder.config e apache...
    Porem apenas use as regras de mangle e faça os testes !

    -> Forum Proxy Masters • Entrar

    Última edição por BillGates; 13-07-2009 às 10:29.



  13. #53

    Padrão

    Citação Postado originalmente por gustavinho69 Ver Post
    em relação ao load balance, aqui na 2.9.27 funcionou tranquilo as regras.
    Opa,que bom saber disso colega...

    Só pra galera não ficar na duvida,vamos esclarecer então:

    Você usa a versão 2.9.x?
    Você fez o load balance(paralelo) seguindo este topico?
    Você usou as regras para marcação de pacotes e cache full deste topico?
    Voce fez sua configuração de proxy + loadbalance seguindo este topico?

    Pois se a resposta for sim para as 4 perguntas,então deduzimos que se mais alguem estiver passando por problemas,sera alguma regra extra que esta dando conflito na implantação do cache full....
    flw garoto!
    Última edição por sergio; 19-07-2009 às 10:58.

  14. #54

    Padrão Tutorial load balance (paralelo) + Debian + ThunderCache + servidor MK 3.13-3.22

    14º Parte:

    Redirecionando Downloads para outro Link.

    Primeiramente vamos esclarecer o seguinte!

    Como realmente funciona o redirecionamento de downloads do tipo .exe , .rar etc?

    Bom,como marcamos pelo Content então tudo o que for relacionado ao nome exe ,rar,iso,etc(desde que seja marcado no firewall) sera redirecionado ao link em que escolhemos.
    Então fica facíl perceber que o link para qual estamos redirecionando o "download",ele não sabe que é um download,apenas ele assume a obrigação de enviar os pacotes.

    Concluindo,se abrirmos um site com o nome de www.exemplar.com ficou evidente que o nosso link que assumira os "downs",ira assumir também à abertura do site citado no exemplo.

    Resumindo,a navagação limpa passara também por ele. (Em raros casos,mas passara)

    Bom esse é meu ponto de vista,mas se analisarmos com calma,iremos perceber que são apenas alguns sites que entraram pelo nosso link destinado a "Downloads".

    Faz uns 4 dias que estou fazendo testes aqui,e realmente os downs que marquei (.exe , .rar , .zip e .iso) estão sendo todos tranferidos pelo link correto(link usado apenas para os downs),deixando assim o link para a navegação "limpa" e descongestionado,passando apenas os downs que não marquei.Mas também fica difícil querer redirecionar tudo,uma vez que como mencionado em outro post,alguns "downs" do tipo mp3 que se encontram em sites www.4shared.com tem como link o nome totalmente desrelacionado à extensão do arquivo.

    Veja o exemplo abaixo de um arquivo em mp3 hospedado em um site:

    Link para download do arquivo mp3:
    4shared.com - online file sharing and storage - download Bruno e Marrone - Não Tente me Impedir.mp3

    http://img41.imageshack.us/img41/1884/tutorial18.jpg

    Então se marcarmos para redirecionar arquivos de mp3,mp4 etc eu não veria necessidade,ja que mp3,mp4 etc são baixados frequentemente por nos mesmos e usuários da rede em programas do tipo P2P.
    E os tais p2p ja passam por um link destinado a navegação "suja",caso estejam seguindo nosso loadbalance deste tópico.


    Continua...
    Última edição por BillGates; 13-07-2009 às 11:54.



  15. #55

    Padrão Tutorial load balance (paralelo) + Debian + ThunderCache + servidor MK 3.13-3.22

    15º Parte:

    Regras para o Redirecionamento de "Downloads"

    Para quem seguiu o tópico desde o início,não tera problemas nesta etapa.

    Configuração feita no MK Balance:

    /ip firewall filter

    add action=add-dst-to-address-list address-list=Download address-list-timeout=3d11h chain=forward comment=\
    "FASE DE TESTES - REDIRECIONAMENTO DE DOWNLOADS COM EXTENSAO .EXE - LINK3" content=.exe disabled=no
    add action=add-dst-to-address-list address-list=Download address-list-timeout=3d11h chain=forward comment=\
    "FASE DE TESTES - REDIRECIONAMENTO DE DOWNLOADS COM EXTENSAO .ISO - LINK3" content=.iso disabled=no
    add action=add-dst-to-address-list address-list=Download address-list-timeout=3d11h chain=forward comment=\
    "FASE DE TESTES - REDIRECIONAMENTO DE DOWNLOADS COM EXTENSAO .RAR - LINK3" content=.rar disabled=no
    add action=add-dst-to-address-list address-list=Download address-list-timeout=3d11h chain=forward comment=\
    "FASE DE TESTES - REDIRECIONAMENTO DE DOWNLOADS COM EXTENSAO .ZIP - LINK3" content=.zip disabled=no
    add action=mark-routing chain=prerouting comment="Videos - YouTube" disabled=no dst-address=189.73.192.208 new-routing-mark=Link-3 \
    passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.209 new-routing-mark=Link-3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.210 new-routing-mark=Link-3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.211 new-routing-mark=Link-3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.212 new-routing-mark=Link-3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.213 new-routing-mark=Link-3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.214 new-routing-mark=Link-3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.215 new-routing-mark=Link-3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.216 new-routing-mark=Link-3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.217 new-routing-mark=Link-3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.218 new-routing-mark=Link-3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.219 new-routing-mark=Link-3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.220 new-routing-mark=Link-3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.221 new-routing-mark=Link-3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.222 new-routing-mark=Link-3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.223 new-routing-mark=Link-3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=189.73.192.224 new-routing-mark=Link-3 passthrough=yes

    /ip firewall nat

    add action=src-nat chain=srcnat comment="NAT - Redirecionamento de Downloads com extensoes .exe .rar .iso .zip" connection-mark=Down disabled=no protocol=tcp \
    to-addresses=192.168.3.2 to-ports=0-65535


    /ip firewall mangle

    add action=mark-connection chain=prerouting comment="FASE DE TESTES - REDIRECIONAMENTO DE DOWNLOADS COM EXTENSOES .EXE .ISO .RAR .ZIP" connection-state=new \
    disabled=no dst-address-list=Download in-interface=Link-Gerenciado new-connection-mark=Down passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=Down disabled=no in-interface=Link-Gerenciado new-routing-mark=Link-3 passthrough=no

    Obs.:
    A regra de NAT devera ficar acima de todas as outras NAT!
    Última edição por BillGates; 25-07-2009 às 10:05.

  16. #56

    Padrão Tutorial load balance (paralelo) + Debian + ThunderCache + servidor MK 3.13-3.22

    16º Parte:

    Passo a Passo de como colocar sua Publicidade no MSN e ORKUT!


    Em breve...




  17. #57

    Padrão em relação ao load balance se um link para

    caso um dos links pare, autenticação do adsl (ip fixo speedy), problemas no link, etc, com estas regras como fica a coisa, os serviços daquelas portas jogadas pra ele vão parar também?

  18. #58

    Padrão

    Citação Postado originalmente por antonoel Ver Post
    caso um dos links pare, autenticação do adsl (ip fixo speedy), problemas no link, etc, com estas regras como fica a coisa, os serviços daquelas portas jogadas pra ele vão parar também?
    Sim!

    Não tenho um script por enquanto que possa fazer apenas um link assumir tudo...Na verdade não tenho problemas quanto a quedas de links por akee.
    Mas vou dar uma olhada por ae,caso eu encontre postarei...




  19. #59
    Neto Mikrotik
    Visitante

    Padrão Parabéns

    Excelente Tutorial..... Saiba que seu trabalho esta sendo muito elogiado por aqui..

  20. #60

    Exclamation

    Billgates e amigos,

    só tenho uma dúvida !

    eu tenho acesso remoto ao balance funcionando tranqüilamente configurado pelo Enhanced Dynamic DNS Solutions, tenho também acesso da rede interna ao balanceamento.

    Eis a dúvida !!!

    como terei acesso remoto ao segundo mikrotik?

    exemplo:

    winbox -> cliente -> MK Controle -> MK Balanceamento = ok
    winbox -> MK Balanceamento -> MK Controle = ok

    winbox -> Internet -> MK Balanceamento -> MK Controle = ?


    Regras já funcionando:

    Servidor Balanceamento

    ip do serv balance = 172.16.10.1
    ip do serv controle = 172.16.10.2

    / ip firewall nat
    add chain=dstnat dst-address=172.16.10.1 protocol=tcp dst-port=4040 action=dst-nat to-addresses=172.16.10.2 \
    to-ports=23 comment="Acesso remoto ao firewall mk" disabled=no
    add chain=dstnat dst-address=172.16.10.1 protocol=udp dst-port=4040 action=dst-nat to-addresses=172.16.10.2 \
    to-ports=23 comment="" disabled=no

    Servidor Controle

    ip do serv balance rede clientes= 192.168.254.254
    ip do serv controle = 172.16.10.1

    / ip firewall nat
    add chain=dstnat dst-address=192.168.254.254 protocol=tcp dst-port=4040 action=dst-nat to-addresses=172.16.10.1 \
    to-ports=23 comment="Acessar remotamento o outro mk" disabled=no
    add chain=dstnat dst-address=192.168.254.254 protocol=udp dst-port=4040 action=dst-nat to-addresses=172.16.10.1 \
    to-ports=23 comment="" disabled=no