Página 7 de 12 PrimeiroPrimeiro ... 234567891011 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #121

    Padrão

    Citação Postado originalmente por gustavinho69 Ver Post
    Seu MK Balance não vai precisar ter 5 eths para se comunicar com seu mk controle.....apenas recebera 5 links e 1 eth interligando no mk controle.

    Assim todos sairam por esta eth para os outros links.
    Exato! Em resumo nosso MK Balance ira ser um "SuperModem"

    Então pensem, do MK Balance sairia um unico cabo de rede que seria ligado ao MK Controle,este por sua vez somente usa um Nat de internet.Ou seja o MK Controle reconhece o MK Balance com um simples modem,entretanto no MK Balance esta todos os serviçoes afinados.

    Quando o cliente abrir o msn o MK Controle chama o modem(MK Balance) e o mesmo entrega os pacotes pelo link que esta marcado a porta 1863 e assim por diante...

  2. #122

    Padrão

    Bill Gates, Parabens cara show sua iniciativa do tutorial, estava precisando e gostei demais, se o mundo fosse feito somente de pessoas assim o nivel de conhecimento seria muito maior, porque um passado informações para os outros, sempre aprendemos coisas novas...

    Valeu



  3. #123

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    Opa, to em serviço agora... mas posso lhe adiantar algo..

    * Akee deixo o msn em link especifico e nao tive problemas..
    (Tente deixar o msn na rota default msm,ou seja não o redirecione)

    * Cuidado com algumas regras em seu firewall,sugiro a deixar somente o controle de conexões simultâneas

    Cuidado com o Controle(Bloquei) de udp,uma vez que i msn usa esse protocolo..

    Posto seu cenário e informações sobre suas regras,principalmente de firewall..

    Mais a noite dou uma passada por akee,,..


    Sucesso ai!!!

    Amigo criei o server do zero com a unica finalidade de servir como balanceador nada a mais, pretendo fazer mais uns testes hoje a noite para ver se resolvo.

  4. #124

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    Amigo,se vc tem um LB por NTH tambem fiquei curioso,fiz uns poucos testes akee e não obtive exito,se puder e quiser colocar algo para nós aqui do forum,seriamos muito grato!!!

    Penso em fazer pelo nth ,mas marcando as rotas especificas para os serviços que necessitam de rota fixa...
    Fala Bill...
    Seguinte.. eu tinha um link full de 2mb e + 2 adsl... usava um pc a parte com mkt para fazer o balanceamento por nth... serviços como banco (443) eu marcava para sair apenas pelo link dedicado...
    Agora ativei mais 2mb full passando de 2 para 4mb... por enquanto desativei o balance... to deixando soh no link full pra testar bem ele...
    Mas agora to querendo montar o mesmo cenário q tu tem ai.. mkt soh para balanceamento, navegação pelo link full, restante nos 2 adsl... o que acha? compensa usar thundercache? compensa usar squid numa maquina linux a parte? Vlw...



  5. #125

    Padrão

    Oi Bill
    Configurando a ensinar neste tutorial completo Thundercache, só funciona com Mikrotik PPPOE ou você pode utilizar o IP FIXO NO SIMPLES QUEUE?

    Osvaldo
    Argentina

  6. #126

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    Exato! Em resumo nosso MK Balance ira ser um "SuperModem"

    Então pensem, do MK Balance sairia um unico cabo de rede que seria ligado ao MK Controle,este por sua vez somente usa um Nat de internet.Ou seja o MK Controle reconhece o MK Balance com um simples modem,entretanto no MK Balance esta todos os serviçoes afinados.

    Quando o cliente abrir o msn o MK Controle chama o modem(MK Balance) e o mesmo entrega os pacotes pelo link que esta marcado a porta 1863 e assim por diante...



    amigo sou iniciante em mk, e estou com uma duvida. Onde é feito a nat para os clientes no mk balance ou no mk controle?
    quem vai ser o gw dos clientes o mk controle ou mk balance?
    tenho que fazer a nat no balence também?/
    como disse sou iniciante desculpe-me...



  7. #127

    Padrão

    Citação Postado originalmente por bola25a2008 Ver Post
    amigo sou iniciante em mk, e estou com uma duvida. Onde é feito a nat para os clientes no mk balance ou no mk controle?
    quem vai ser o gw dos clientes o mk controle ou mk balance?
    tenho que fazer a nat no balence também?/
    como disse sou iniciante desculpe-me...
    No Balance,é feito nat sim...leia todo o tutorial que ira ver... feito o trabalho em cima do balance vc apenas cria um nat para o mk balance, no mk controle...

    O gateway continua sendo o mk controle!

    No mk balance vc faz todo o procedimento e na interface de saida que ira conectar ao mk controle,vc cria um ip adress ex: 192.168.100.1/24... e no mk controle vc cria uma ip address 192.168.100.2/24...

    Use cabo crossover para a conexão,assim vc ve o trafego gerado pelo mk balance(modem)

  8. #128

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    No Balance,é feito nat sim...leia todo o tutorial que ira ver... feito o trabalho em cima do balance vc apenas cria um nat para o mk balance, no mk controle...

    O gateway continua sendo o mk controle!

    No mk balance vc faz todo o procedimento e na interface de saida que ira conectar ao mk controle,vc cria um ip adress ex: 192.168.100.1/24... e no mk controle vc cria uma ip address 192.168.100.2/24...

    Use cabo crossover para a conexão,assim vc ve o trafego gerado pelo mk balance(modem)


    cara parabéns, sou iniciante e estou aprendendo muito com seu tuto, poucos aqui tem a paciência que vc tem.
    obrigado pela resposta.
    so mais uma pergunta,

    Do tutorial inteiro que eu tenho que mudar para que dê certo na versão do meu mk que é 2.9.50?
    Última edição por bola25a2008; 01-08-2009 às 01:26.



  9. #129

    Padrão

    Citação Postado originalmente por bola25a2008 Ver Post
    cara parabéns, sou iniciante e estou aprendendo muito com seu tuto, poucos aqui tem a paciência que vc tem.
    obrigado pela resposta.
    so mais uma pergunta,

    Do tutorial inteiro que eu tenho que mudar para que dê certo na versão do meu mk que é 2.9.50?
    Se eu não estiver enganado,seria somente as regras de mangle... um colega colocou as regras que ele usa no mk 2.9.27 dele,a dica esta no forum do www.thundercache.org .

    Caso eu passe por la,posto o link akee pra ti... mas vai la da uma olha que vc acha...

    t+

  10. #130

    Thumbs up Tutorial load balance (paralelo) + Debian + ThunderCache + servidor MK 3.13-3.22

    17º Parte:

    Publicidade MSN e ORKUT!!!

    Bora lá!!!

    Vou mostrar como colocar publicidade no MSN e ORKUT através do nosso Proxy.
    - Distro Testada: Debian5.1,Ubuntu9.04

    Seguindo o nosso cenário inicial,iremos hospedar as imagens da publicidade em nosso próprio proxy.

    1º Passo:

    Dentro da pasta /var/www coloque uma imagem GIF de tamanho 234x60.
    Esta imagem você cria com a sua publicidade e sera a imagem que aparece no MSN.
    Atenção!Nomeie esta imagem como ban_msn
    Veja onde ficara:

    http://img37.imageshack.us/img37/5787/imagem1vln.jpg

    Pronto...

    Agora você cria uma imagem com sua publicidade e também coloca dentro da pasta /var/www .
    Esta imagem sera sua publicidade no Orkut,a imagem deve ser no formato JPG e ter o tamanho 250x239 .
    Atenção!Nomeie esta imagem como banner_orkut
    Veja onde ficará:

    http://img253.imageshack.us/img253/2772/imagem2vab.jpg

    Pronto...

    Imagens criadas e colocadas no devido diretorio,vamos a proxima etapa...

    2º Passo:

    Agora va até /etc/squid e abra o seu squid.conf e acresente essas linhas dentro do mesmo:

    acl ADSAdClient url_regex ADSAdClient31.dll
    http_access deny ADSAdClient
    deny_info http://ip_do_seu_proxy/ban_msn.gif ADSAdClient

    * Estas serão responsável pela publicidade no MSN!

    Ainda no squid.conf acresente mais estas linhas:

    acl ork.users url_regex ork.users
    http_access deny ork.users
    deny_info http://ip_do_seu_proxy/banner_orkut.jpg ork.users

    * Estas serão responsável pela publicidade no Orkut!

    Obs.:
    - Para evitar possiveis problemas,deixe estas linhas logo acima da opção:
    Nega Cache Youtube
    - Talves um simples comando squid -R reconfigure não seja suficiente para colocar em funcionamento as publicidades,sendo necessário um reboot ou shutdown -r now em seu proxy.
    - Caso queira deixar um pouco mais organizada sua pasta www ,crie o diretório Publicidade,e coloque as imagens da publicidade dentro,não esquecendo de redirecionar o caminho em squid.conf.

    * Se este post não gerar pelo menos uns 10 agradecimentos,então vou imaginar que não serviu de proveito para ninguém,logo não foi util e tão pouco necessário ter cido postado!
    Então na proxima vez,não perderei meu tempo criando um post detalhado com a finalidade de ajudar,uma vez que não é necessária tal ajuda!

    Reparem o horário do post e também o horário da ultima edição,ou seja,foi dedicado uma hora para criar esse post entre edição,reedição e hospedagem de imagens...

    Amanhã postarei sobre como colocar a publicidade no youtube...

    t+
    Última edição por BillGates; 02-08-2009 às 00:50.



  11. #131

    Padrão

    Citação Postado originalmente por mascaraapj Ver Post
    problema resolvido...
    vou montar um tuto passo a passo... bem explicadinho...
    e postar aqui no forum, para ajudar outros = a min.. uehsues

    Instalacao Thunder Cache - Página 4
    amigo, kd o tuto??
    to agurdando...

  12. #132

    Padrão

    Citação Postado originalmente por Arlin Ver Post
    Opa verdade os arquivos 2 e 3 estavam com problemas mais tão ai ok blz

    A sim se alquem precisar tenho a apostila do curço mikrotik brasil 2007 não anexei pois tem 45 mb e não pode por link aki né mais se alquem quiser é so pedir que mando o link por e-mail pra baixar ok

    opa, se puder mandar pra mim eu [email protected]



  13. #133

    Padrão

    eu tbm quero

    [email protected]

    se der para me enviar, eu agradeco

    PS: ia fazer o curso aqui na cidade, Cuiaba
    mas perdi... qdo fui fazer a inscricao ja nao tinha mais vaga!

  14. #134

    Padrão Foco!!!

    Pessoal,cuidado para não perdermos o foco do tuto...

    Dakee a pouco o sergio vem e da um closed



  15. #135

    Padrão

    Opa pessoal boa tarde prazer em participar do fórum com vocês sou novo aqui , estava acompanhando o tutorial ( estou montando este sever segundo o tutorial ) , tem uma forma eu não sei como, que quando vc vai no navegador e digita o endereço do Linux ( 192.168.2.250 aparece uma pagina de internet mostrando as estatísticas do uso do link o quanto economizou etc , eu achei o youtube com o nome ConLinux ThunderCache Interface no link [ame=http://www.youtube.com/watch?v=xr7ZWU8_v8g&NR=1]YouTube - ConLinux ThunderCache Interface[/ame]
    alguém sabe algo sobre isso ?
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         thunder.jpg
Visualizações:	123
Tamanho: 	114,4 KB
ID:      	5085  

  16. #136

    Padrão

    e tenho ele instalado conlinux (pcram ) mas esse player aqui não funciona, nem aparece.



  17. #137

    Padrão

    olá amigos não tenho conhecimento em linux e então estou montando um servidor aki seguindo passo a passo o tuto e surgiam duas coisinhas aki.

    ao final do segundo video foi digitado o comando: nmap localhost quando eu digito aki aparece: -bash: nmap: command not found

    baixei o WinSCP e quando tento logar aparece: Network error: Connection refused. pior que eu consigo pingar no endereço 192.168.10.250 e tambem pingo o server mk a partir do debian.
    ja liberei a porta 22 no firewal e tb não funcionou. o que será que está errado?

    ajuda ae galera.

    obrigado

  18. #138

    Talking

    Citação Postado originalmente por Evilazio Ver Post
    olá amigos não tenho conhecimento em linux e então estou montando um servidor aki seguindo passo a passo o tuto e surgiam duas coisinhas aki.

    ao final do segundo video foi digitado o comando: nmap localhost quando eu digito aki aparece: -bash: nmap: command not found

    baixei o WinSCP e quando tento logar aparece: Network error: Connection refused. pior que eu consigo pingar no endereço 192.168.10.250 e tambem pingo o server mk a partir do debian.
    ja liberei a porta 22 no firewal e tb não funcionou. o que será que está errado?

    ajuda ae galera.

    obrigado
    como vc esta insatalando pelo script e ele é automatico então apena digite no terminal mais digite tudo junto ok e não linha por linha ok

    wget http://www.pcram.com.br/conlinux/conlinuxZ4.sh
    chmod +x conlinuxZ4.sh
    ./conlinuxZ4.sh

    e aguarde o termino que vai da certo
    ai depois copie e cole hehehe
    shutdown -r now
    conlinux:¯# nmap localhost
    Última edição por Arlin; 07-08-2009 às 12:19.



  19. #139

    Padrão Tutorial load balance (paralelo) + Debian + ThunderCache + servidor MK 3.13-3.22

    18º Parte:

    Conversando com um colega do forum,ele me passou a seguinte dica:

    Para fazermos a marcação dos pacotes do thunder e squid no mangle...

    As regras postadas aqui neste topico anteriormente são estas:

    /ip firewall mangle
    add action=mark-connection chain=forward comment="Cache Full" content="X-Cache: HIT" disabled=no new-connection-mark=forward-hits \
    passthrough=yes protocol=tcp
    add action=mark-packet chain=forward comment="" connection-mark=forward-hits disabled=no new-packet-mark=cache-hits passthrough=yes
    add action=mark-connection chain=postrouting comment="" disabled=no dscp=12 new-connection-mark=proxy-hits passthrough=yes
    add action=mark-packet chain=postrouting comment="" connection-mark=proxy-hits disabled=no new-packet-mark=proxy-squid passthrough=yes
    add action=mark-connection chain=forward comment="Thunder - Cache Full" disabled=no dst-address=192.168.10.250 dst-port=80 \
    new-connection-mark=thunder-connection passthrough=yes protocol=tcp
    add action=mark-packet chain=forward comment="" connection-mark=thunder-connection disabled=no new-packet-mark=thunder-packs \
    passthrough=yes protocol=tcp



    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=2000000 max-limit=3000000 name=Cache-Hits packet-mark=\
    proxy-squid parent=global-out priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=2000000 max-limit=3000000 name=Cache-Old packet-mark=cache-hits \
    parent=global-out priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=2000000 max-limit=3000000 name=ThunderCache packet-mark=\
    thunder-packs parent=global-out priority=8 queue=default


    As novas regras sugeridas são estas:

    /ip firewall mangle

    add action=mark-connection chain=prerouting comment="Squid - Cache Full" disabled=no dscp=12 new-connection-mark=proxy-hits passthrough=yes
    add action=mark-packet chain=prerouting comment="" connection-mark=proxy-hits disabled=no new-packet-mark=proxy-squid passthrough=no
    add action=mark-connection chain=prerouting comment="Thunder - Cache Full" disabled=no dst-address=192.168.10.250 dst-port=80 new-connection-mark=\
    thunder-connection passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=thunder-connection disabled=no new-packet-mark=thunder-packs passthrough=no protocol=tcp


    /queue tree

    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=2000000 max-limit=3000000 name=SquidCache-Down packet-mark=proxy-squid parent=\
    global-out priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=2000000 max-limit=3000000 name=SquidCache-Up packet-mark=proxy-squid parent=global-in \
    priority=8 queue=default

    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=2000000 max-limit=3000000 name=ThunderCache-Down packet-mark=thunder-packs parent=global-out \
    priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=2000000 max-limit=3000000 name=ThunderCache-Up packet-mark=thunder-packs parent=global-in \
    priority=8 queue=default

    - As duas formas funcionam,mas a segunda da uma refinida a mais!!!
    - Pessoalmente deixo a regra do thunder full desabilitada,sendo assim o cliente puxa do proxy mas na velocidade contratada.
    - Ja o squid full esse sim,pode deixar que fica muito boa a velocidade da navegação.Cuidado com o tamanho dos arquivos armazenados em cache pelo squid,pois arquivos grandes vao gerar latência na sua rede.


    "Como sempre costumo dizer,não é uma regra e sim uma dica!"
    Última edição por BillGates; 07-08-2009 às 15:24.

  20. #140

    Padrão Tutorial load balance (paralelo) + Debian + ThunderCache + servidor MK 3.13-3.22

    19º Parte:

    Sobre o uso da NAT exclusiva para o "Debian-Proxy"

    Através de ajustes e testes,não vejo a necessidade do uso dessa regra de nat para o proxy.
    Aqui retirei essa regra e não houve diferença alguma,a mesma quase não marcava pacotes,devido a isto a retirei.Fazem duas semanas que não utilizo mais esta regra,e até então não esta fazendo falta alguma!

    Fica ai a sugestão para quem quiser desabilitar a tal regra!