+ Responder ao Tópico



  1. #161

    Padrão

    Uma sugestão a todos que estão tendo problemas com o thundercache...

    Não fique tentando fazer emendas,pegue em bancada e instale em uma maquina uma distro (debian/ubuntu) seguindo o passo a passo ja postado aqui em um outro tópico....

    No Mk basta colocar umas simples regras para fazer a marcação de pacotes vindo do proxy e pronto,tudo funcionando normalmente...também ja postado aqui...

    Caso use loadbalance,sugiro a fazer o mesmo em um mk paralelo,também ja postado aqui (a não ser que saiba exatamente o que esta fazendo).

    Sobre qual versão usar do MK ou distro linux:

    - No MK as versões que ja testei e estão funcionando sem problemas são 3.13 até 3.28
    - No Linux as versões que testei e estão funcionando sem problemas são Debian/Ubuntu

    Mais uma vez resaltando,é recomendado que faça testes em bancada com o MK o mais básico possivel,pois algumas regras em seu firewall pode gerar problemas no desempenho do thunder,então faça a instalação e integração do proxy/thunder ao mk e teste...vera que vai fluir numa boa... após isso comece a personalizar seu firewall....

    Detalhe,algumas pessoas tem me procurado no msn relatando problemas e em muitas fiz um acesso remoto e vi regras de firewall bloqueando a porta de conexão ente o proxy e MK rs... ai fica dificil msm qualquer proxy se comunicar com o mk neh ... outra coisa é a famosa versão 2.9.27 Crk,como muitos sabem ,essa versão msm original possui bugs que foram corrigidos nas vesões posteriores a ela...então abra a mão e faça um pequeno mas valioso investimento em uma licença..
    Para nos pequenos provedores que usamos nosso link dedicado aliado a outros links adsl,esta ai o PCC (Alguns chamam de Primeiro Comando da Capital ,mas acho que deveria ser PCCC Primeiro Controle Confiável de Conexões) que esta se mostrando ser uma otima opção de balance... Opção essa que esta disponivel apenas em versões 3.24 acima...

    Por enquanto são apenas estas as sugestões,mas que farão o minimo e básico ou seja,farão que seu proxy/thunder funcione rs ...

    t+
    Última edição por BillGates; 13-08-2009 às 12:15.

  2. #162

    Padrão

    Citação Postado originalmente por JeffersonParre Ver Post
    bom dia a todos, acordei hj as 4 da matina pra colocar meu novo server no ar, funcionou tudo blz, ou melhor, quase tudo, a parte de redirecionamento de downloads nao está funcionando, onde eu marco os pacotes pra redirecionar pro link q deixei pra fazer downloads (em mangle) percebi q se eu colocar o address list em src-address-list ele redireciona certinho, porem nao consigo fazer nenhuma navegacao....alguem pode me ajudar?
    BillGates, por favor, me ajude com esse meu problema, ta comendo todo o meu link e o adsl de 8MB ta saindo somente uma merreca...desde ja agradeco....

    Configuracoes:

    2 Link, sendo 1 de 2MB FULL e outro de 8MB ADSL (speedy)

    fiz tudo conforme o tutorial: deixei o de 2MB FULL como o default e quero colocar os downloads para sair somente no ADSL de 8MB...

    caso vc quiser eu passo meu ip pra vc conectar e ver o problema, meu msn: [email protected]

    grato



  3. #163

    Padrão

    Citação Postado originalmente por JeffersonParre Ver Post
    BillGates, por favor, me ajude com esse meu problema, ta comendo todo o meu link e o adsl de 8MB ta saindo somente uma merreca...desde ja agradeco....

    Configuracoes:

    2 Link, sendo 1 de 2MB FULL e outro de 8MB ADSL (speedy)

    fiz tudo conforme o tutorial: deixei o de 2MB FULL como o default e quero colocar os downloads para sair somente no ADSL de 8MB...

    caso vc quiser eu passo meu ip pra vc conectar e ver o problema, meu msn: [email protected]

    grato
    Depois que passei os modens todos para modo bridge,não estou mais conseguindo redirecionar as extensoes .exe .rar etc para um link em especifico...

    Logo que tiver a solução ,posto akee!

    "Detalhe,ja comentei isso de nao estar funcionando muito bem o redir para "downs"

  4. #164

    Padrão

    Boa tarde a todos,

    Visando em deixa o link1 somente para navegação eu pesquisei sobre o Outlook Express, Mozilla Thunderbird e outro gerenciador de email.

    Bom as portas padrao pop3 e smtp são as 110 e 1080 respectivamente.

    Mais tambem tem as portas pop3 SSL e smtp SSL que são as 995 e 587 respectivamente.

    A regra fikaria a seguinte

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="Pop3 SSL" \
    disabled=no dst-port=995 new-routing-mark=Link-3 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment="SMTP SSL" disabled=no dst-port=587 \
    new-routing-mark=Link-3 passthrough=yes protocol=tcp

    floww



  5. #165

    Padrão

    BillGates, to com um probleminha aki no meu thundercache, vou tentar explicar pra vc o que ta acontecendo...
    quando entro em um video q nao está cacheado, ele comeca o filme e derrepente ele para como se ja tivesse passado todo o filme, eu vou entrando nele toda hora até ele ficar em cache, depois nao da mais problemas, o q poderá estar ocorrendo com meu cache? fiz tudo certinho e depois conferi varias vezes....vc pode me ajudar nisso?

    obrigado

  6. #166

    Padrão

    Citação Postado originalmente por JeffersonParre Ver Post
    BillGates, to com um probleminha aki no meu thundercache, vou tentar explicar pra vc o que ta acontecendo...
    quando entro em um video q nao está cacheado, ele comeca o filme e derrepente ele para como se ja tivesse passado todo o filme, eu vou entrando nele toda hora até ele ficar em cache, depois nao da mais problemas, o q poderá estar ocorrendo com meu cache? fiz tudo certinho e depois conferi varias vezes....vc pode me ajudar nisso?

    obrigado
    Videos de onde???
    Youtube?
    Globo?
    Todos??

    Que versão do thunder esta usando? Instalado passo a passo ou por script automatico??

    Post algumas informações a mais...



  7. #167

    Padrão

    Como faço para ter contato com vc BillGates

    Preciso de serviços em meu provedor

    Citação Postado originalmente por BillGates Ver Post
    11º Parte:

    Regras para o LoadBalance:

    É isso ai pessoal,tamuh ae em pé acordado e deitado sem dormir!!!

    Vamos continuar com o tuto...

    Bom,nesse momento ja temos nosso servidor MK LB ou BL como preferir,então vamos às regras:

    /ip firewall filter
    add action=drop chain=forward comment="Bloqueio de acesso ao modem DSL2 pela rede." \
    disabled=no src-address=192.168.2.1
    add action=drop chain=forward comment="Bloqueio de acesso ao modem DSL3 pela rede." \
    disabled=no src-address=192.168.3.1
    add action=accept chain=forward comment=\
    "Total do Trafego gerado entre todos os Links" disabled=no out-interface=\
    Link-Gerenciado

    Regras 1 e 2: São para impedir o acesso ao modem pela rede.
    (Nosso amigo Demo Bill,sugeriu logo acima um tipo de regra um pouco mais complexa para o bloqueio de acesso aos modens.Estas citadas por mim estão correspondendo perfeitamente.).

    Regra 3: É para mostrar apenas o trafego total gerado pelos links.(Opcional)

    Vejam que não adicionei o modem DSL1 para a regra de bloqueio,uma vez que não consegui acessa-lo via browser nem pinga-lo.Deve ser pelo fato dele estar em modo bridge ou até mesmo porque não foi adicionado ao /ip address(Por estar sendo discado pelo MK,não é necessário adicionar ao /ip address).Irei fazer mais alguns testes e caso necessário teremos que adicionar ele às regras de bloqueio.
    Obs.:
    REGRAS ABERTAS A COMENTÁRIOS

    /ip firewall nat
    add action=masquerade chain=srcnat comment="NAT - Modem DSL-1" disabled=no \
    out-interface=Internet
    add action=masquerade chain=srcnat comment="NAT - Modem DSL-2" disabled=no \
    out-interface=Modem-DSL2
    add action=masquerade chain=srcnat comment="NAT - Modem DSL-3" disabled=no \
    out-interface=Modem-DSL3

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="Navegacao em FTP-Downloads" \
    disabled=no dst-port=21 new-routing-mark=Link-2 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=22 \
    new-routing-mark=Link-2 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=23 \
    new-routing-mark=Link-2 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=25 \
    new-routing-mark=Link-2 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment=\
    "Protocolo responsavel por resolucao de DNS" disabled=yes dst-port=53 \
    new-routing-mark=Link-2 passthrough=yes protocol=udp
    add action=mark-routing chain=prerouting comment=\
    "Navegacao em sites http e downloads" disabled=no dst-port=80 new-routing-mark=\
    Link-2 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=110 \
    new-routing-mark=Link-2 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=1080 \
    new-routing-mark=Link-2 passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="Pacotes marcados para o Link-2" \
    disabled=no new-packet-mark=Link-2 passthrough=yes routing-mark=Link-2
    add action=mark-routing chain=prerouting comment=\
    "Navegacao em sites https-encriptados" disabled=no dst-port=443 new-routing-mark=\
    Link-3 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment=\
    "Navegacao em messenger - Windows Lime Messenger" disabled=no dst-port=1863 \
    new-routing-mark=Link-3 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment=\
    "Navegacao em WebCam - Windows Live Messenger" disabled=no dst-port=6891 \
    new-routing-mark=Link-3 passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="Pacotes marcados para o Link-3" \
    disabled=no new-packet-mark=Link-3 passthrough=yes routing-mark=Link-3

    Repare que a marcação para a regra da porta 53 esta desativada,em testes que estou realizando aqui,achei por bem deixar esta porta saindo pelo link default mesmo.REGRA EM TESTES

    Veja abaixo como ficara nossa tabela filter rules:
    http://img132.imageshack.us/img132/2785/tutorial14.jpg
    e...

    Veja abaixo como ficara nossa tabela Nat:
    http://img7.imageshack.us/img7/5981/tutorial13hrc.jpg
    e...

    Veja abaixo como ficara nossa tabela mangle:
    http://img406.imageshack.us/img406/6260/tutorial12.jpg

    Foi adicionando alguns comentários em algumas portas,então os colegas podem sugerir comentários para as que estão sem e até mesmo alguma correção para algum comentário feito.

    "Sugiro desabilitar o redirecionamento da porta 21(FTP),em testes aqui,percebi que alguns downs não estavam sendo iniciados devido a este redirecionamento,então caso alguém encontre problemas com FTP,deixe esta porta saindo pelo link default mesmo,ou seja,não faça nenhum redirecionamento desta porta"

    Continua...

  8. #168

    Padrão

    billGates, os os videos voltaram ao normal...só que o thunder para de fazer o cache, onde eu marco ele na mangle nao vejo passar nenhum pacote e nem na queues tree nao tem trafego nenhum...a versao do thunder é a mesma do tutorial e rodei o script mesmo, estou montando um outro cache mas esse é pra outro servidor aki da empresa mesmo, mas nesse vou montar manual, ou seja, sem o script.
    percebi tb q a net ficou um poko lenta, será q é o cache?



  9. #169

    Padrão

    billgates, acabei de reiniciar o servidor do thunder e ele voltou a fazer cache, to usando um maquina com 2 de memoria ram e um hd de 750gb, o q será q pode ser?
    precisa de alguma informacao a amais?

  10. #170

    Padrão

    Citação Postado originalmente por JeffersonParre Ver Post
    billgates, acabei de reiniciar o servidor do thunder e ele voltou a fazer cache, to usando um maquina com 2 de memoria ram e um hd de 750gb, o q será q pode ser?
    precisa de alguma informacao a amais?
    O que posso lhe adiantar é o seguinte,faça o seu proxy desde o inicio,assim vc sabera tudo o que foi feito e instalado e ao mesmo tempo aprendera...

    https://under-linux.org/f130724-thundercache-desde-instalacao-ate-configuracao-final-por-billgates

    Olha só,assim como comentado neste e em outros tópicos,o minimo de Hardware seria:

    P4 3.0Ghz .. 4GB de RAM .. HDSataII (500GB) .. Sugiro colocar o thunder em um HD para cachear separado do Squid.

    Uso aqui uma estrutura semelhante:
    Proxy em Ubuntu 9.04
    C2D 2.0GHZ .. 4GB de RAM .. HDSataII 750GB para o ThunderCache e HDSataII 320GB para o Squid.

    Seguindo este cenário tenho 290 clientes,sendo que 140 simultâneos em média...
    Última edição por BillGates; 19-08-2009 às 15:42.



  11. #171

    Padrão Alguns esclarecimentos por favor...

    Gostaria de turbinar a porta 80 com dois links de 2 mega pois percebi que o trafego da porta 80 e em geral o dobro de uso do outros 2 links...0 link 3 nao fica carregado de trafego acho que nao esta capitando todo trafego do msn e orkut...alguma dica?


    Parabens pelo seu topico acho um dos melhores do site.

  12. #172

    Padrão

    Citação Postado originalmente por daviradio Ver Post
    Gostaria de turbinar a porta 80 com dois links de 2 mega pois percebi que o trafego da porta 80 e em geral o dobro de uso do outros 2 links...0 link 3 nao fica carregado de trafego acho que nao esta capitando todo trafego do msn e orkut...alguma dica?


    Parabens pelo seu topico acho um dos melhores do site.
    E é mesmo colega, a porta 80 é a mais requisitada em tudo,bom aqui em minha rede percebo que não são downloads o que mais gera trafego na porta 80 e sim os sites que contenham vídeos.Te aconselho a marcar os sites de vídeos (youtube,globo principalmente) para o link 3,ai sim vc vera trafego nele.
    Estou fazendo testes em um balance em modo pcc, de forma que uns 3 links ficariam para a porta 80 e outros links para videos e p2p...



  13. #173

    Padrão

    Olá eu uso MK 2.9 com Hotspot + DHCP + STATICO , como seria a configuração sendo que ja instalei tudo da forma desse tuto ? meu ip de cliente e faixa 192.168.10.0/ sendo meu ip do mk 192.168.10.1 e queria saber como fica minha configuração do servidor thunder pra integrar ao mk , sendo que meu servidor ubuntu está com ip 192.168.10.2 ? , outra coisa eu ligo ele direto no swicht ou cabo cross integrando outra placa de rede no Mk ? a Nat de redirecionar qual seria pra essa config do meu prover ? sei que tenho que desativar o cache full do mk . abraços a todos que possam me dar uma luz , só to esperando uma ajuda pra colocar o sever proxy externo pra funfar aqui junto ao mk .

  14. #174

    Padrão

    Citação Postado originalmente por Barone10 Ver Post
    Olá eu uso MK 2.9 com Hotspot + DHCP + STATICO , como seria a configuração sendo que ja instalei tudo da forma desse tuto ? meu ip de cliente e faixa 192.168.10.0/ sendo meu ip do mk 192.168.10.1 e queria saber como fica minha configuração do servidor thunder pra integrar ao mk , sendo que meu servidor ubuntu está com ip 192.168.10.2 ? , outra coisa eu ligo ele direto no swicht ou cabo cross integrando outra placa de rede no Mk ? a Nat de redirecionar qual seria pra essa config do meu prover ? sei que tenho que desativar o cache full do mk . abraços a todos que possam me dar uma luz , só to esperando uma ajuda pra colocar o sever proxy externo pra funfar aqui junto ao mk .
    isso vou fik devendo,pois estou trabalhando em outro cenário,fica no aguardo ae que logo um colega aparece com a dica...

    t+



  15. #175

    Padrão

    Citação Postado originalmente por Barone10 Ver Post
    Olá eu uso MK 2.9 com Hotspot + DHCP + STATICO , como seria a configuração sendo que ja instalei tudo da forma desse tuto ? meu ip de cliente e faixa 192.168.10.0/ sendo meu ip do mk 192.168.10.1 e queria saber como fica minha configuração do servidor thunder pra integrar ao mk , sendo que meu servidor ubuntu está com ip 192.168.10.2 ? , outra coisa eu ligo ele direto no swicht ou cabo cross integrando outra placa de rede no Mk ? a Nat de redirecionar qual seria pra essa config do meu prover ? sei que tenho que desativar o cache full do mk . abraços a todos que possam me dar uma luz , só to esperando uma ajuda pra colocar o sever proxy externo pra funfar aqui junto ao mk .

    add chain=srcnat src-address=192.168.10.0/24 action=masquerade \
    comment="Nat-Ubuntu" disabled=no
    add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=3128 \
    comment="PROXY REDIRECTION" disabled=yes
    add chain=dstnat src-address=192.168.10.0/24 dst-address=!192.168.10.2 \
    protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.10.2 \
    to-ports=3128 comment="Redirecionamento para o Proxy" disabled=yes

    Estas regras serve de redirecionamento para comunicação do mk com thunder,e de preferencia ligue com cabo direto cossover.

  16. #176

    Lightbulb

    Obrigado amigo por me responder ,mais outra duvida , como seria pra aparecer minha pagina hotspot , que vai fazer esse papel e o Mk mesmo ou agora ou o Porxy externo ? . Porquer precisa dessa tela de logim e senha do hotspot para ter acesso a net .



  17. #177
    Analista de Suporte em Ti Avatar de rpclanhouse
    Ingresso
    Sep 2008
    Localização
    Suzano SP
    Posts
    410
    Posts de Blog
    10

    Padrão

    O grande Bill. aqui ta dando o seguinte problema: Depois de instalar o debian, baixar os pacotes e instalar o thunder, quando rodo o winscp, ele retorna o seguinte erro : Conection refused. Tentei entrar por ftp, mas nao consigo logar como root por ftp no windows, nem pelo MK, porém antes de pensar que digitei senha errada, quando logo no debian como root e coloco minha senha ele entra. o que poderia estar acontecendo ? por favor !
    Última edição por rpclanhouse; 31-08-2009 às 20:55.

  18. #178

    Talking

    Citação Postado originalmente por rpclanhouse Ver Post
    O grande Bill. aqui ta dando o seguinte problema: Depois de instalar o debian, baixar os pacotes e instalar o thunder, quando rodo o winscp, ele retorna o seguinte erro : Conection refused. Tentei entrar por ftp, mas nao consigo logar como root por ftp no windows, nem pelo MK, porém antes de pensar que digitei senha errada, quando logo no debian como root e coloco minha senha ele entra. o que poderia estar acontecendo ? por favor !
    Por acauso vc instalou o SSH no debian/ubuntu né ?
    se não so instalar apt-get update depois apt-get install ssh

    falow



  19. #179
    Analista de Suporte em Ti Avatar de rpclanhouse
    Ingresso
    Sep 2008
    Localização
    Suzano SP
    Posts
    410
    Posts de Blog
    10

    Padrão

    Citação Postado originalmente por Arlin Ver Post
    Por acauso vc instalou o SSH no debian/ubuntu né ?
    se não so instalar apt-get update depois apt-get install ssh

    falow
    Continua dando o mesmo erro ! tem ideia do q pose ser ? estou instalando pelo debian, mas testei pelo unbuntu e conseguia acesso ao Servidor thunder ( porém não conseguir fazer funcionar o cache ) , só que pelo debian, nem acessar os arquivos *.conf pelo Win scp estou conseguindo, reparei na lista de Hosts de meu hotspot, que ele está lá, cadastrei ele em Bidings e ele está tudo certo, (aparentemente), consigo pingar o servidor, mas nada de acessá-lo ! alguém pode ajudar ?

  20. #180
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Citação Postado originalmente por rpclanhouse Ver Post
    Continua dando o mesmo erro ! tem ideia do q pose ser ? estou instalando pelo debian, mas testei pelo unbuntu e conseguia acesso ao Servidor thunder ( porém não conseguir fazer funcionar o cache ) , só que pelo debian, nem acessar os arquivos *.conf pelo Win scp estou conseguindo, reparei na lista de Hosts de meu hotspot, que ele está lá, cadastrei ele em Bidings e ele está tudo certo, (aparentemente), consigo pingar o servidor, mas nada de acessá-lo ! alguém pode ajudar ?
    Comente tudo no /etc/hosts.deny, aqui só funcionou assim.