+ Responder ao Tópico



  1. #1

    Padrão Putty fecha qdo digito senha

    Uso o fedora
    sempre funcionou o putty normalmente... nunca deu problema

    recentemente passei para o fedora 11
    fiz as mesmas instalacoes de sempre... funcionou normal... porem...
    desde ontem, nao consigo acessar o servidor atraves do putty.

    eu digito o ip do servidor, a porta
    e entro... ok
    ele pede o nome do usuario... ok
    pede a senha...

    porem, ao digitar a senha... o putty simplesmente fecha...
    o q poderia ser isso?
    alguem poderia me dar uma luz?

  2. #2

    Padrão

    tentei acessar o servidor de outro terminal linux...

    e recebi a seguinte resposta:
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    @ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
    Someone could be eavesdropping on you right now (man-in-the-middle attack)!
    It is also possible that the RSA host key has just been changed.
    The fingerprint for the RSA key sent by the remote host is
    42:98:ea:23:67:60:0b:41:ab:65:10:52:e0:1b:70:4c.
    Please contact your system administrator.
    Add correct host key in /root/.ssh/known_hosts to get rid of this message.
    Offending key in /root/.ssh/known_hosts:2
    RSA host key for [172.168.0.1]:2210 has changed and you have requested strict checking.
    Host key verification failed.
    o q isso significa?



  3. #3

    Padrão

    primeiro apague esse arquivo /root/.ssh/known_hosts para ele poder registrar o seu pc na lista de maquinas conhecidas outro detalhe de uma olhada no seu /etc/passwd olhe seu nome e veja se ele tem na frente dele o /bin/bash

    ex..

    eder:x:642:643::/home/eder:/bin/bash

    se estiver assim

    compras:x:635:636::/home/compras:/sbin/nologin

    vc nao tem um bash entao ele vai logar e fechar a janela

    abraços

  4. #4

    Padrão

    Acesse o servidor e apague somente a 2ª linha de /root/.ssh/known_hosts
    Ele notou a mudança da impressão digital quando vc instalou outro sistema e manteve o ip.



  5. #5

    Padrão servidor nao acessa

    e por conta da mudança no servidor basta zerar o configuraçäo antiga pra autenticar novamente a conexäo: ssh-keygen -R xxx.xxx.xxx.xxx onde xxx é o endereço do servidor deve funcionar com isso

  6. #6

    Padrão

    hoje levei um monitor, teclado e mouse...
    la aonde esta o server...

    liguei eles la... reiniciei o server
    e fui ver os logs de:
    /var/log/messages
    /var/spool/mail/root

    em um deles.. vi o selinux..
    ai resolvi desabilitar ele:
    #vim /etc/selinux/config
    SELINUX=disabled
    reiniciei o servidor, e voltou a funcionar...