+ Responder ao Tópico



  1. #1

    Padrão Script netlogon.bat

    Oi pessoal,

    estou tentando configurar um script netlogon personalizado por grupo ou usuário.
    No meu arquivo smb.conf já coloquei de várias formas (uma de cada vez):

    logon script = %u.bat %g
    logon script = netlogon.bat %u

    Porém os parametros %u e %g são ignorados, eles não chegam no script. E o mais intrigante é que ele sempre chama o script netlogon.bat, mesmo que o smb.conf aponte para outro. Se eu removo esse script de la, não é executado nada.

    Só informando que na pasta indicada estão os scripts netlogon.bat, usuario1.bat...

    Alguém já passou por isso?

  2. #2

    Padrão Netlogon..

    Cara não entendi muito bem oq tento explicar..
    Já testou rodar só os scripts para ver se os mesmo estão ok?!
    As permissões do scripts estão p/ execução.. "chmod +x ()"
    Se postar o seu smb.conf, ficará mais fácil o para compreensão de todos.
    Grato!



  3. #3

    Padrão

    Meu smb.conf

    Código :
    logon script = %u.bat
     
    [netlogon]
       comment = Servico de Logon em Rede
       path = /dados/netlogon
       browseable = yes
       writeable = yes
       read only = yes
       guest ok = yes 
       valid users = %U

    Na pasta /dados/netlogon tem os scripts netlogon.bat e usuario1.bat. Porém qualquer valor que eu coloco em logon script, ele sempre executa netlogon.bat.

    Obrigado

  4. #4

    Padrão

    Amigo, tenho mapeamento pro grupo.

    E no meu caso esta assim.

    logon script = %G.bat
    logon path =
    logon home = \\%N\%U
    E depois coloco o path do Netlogon.
    [netlogon]
    comment = Network Logon Service
    path = /home/netlogon

    Tente alterar o "u" por "U", não é para o samba ser case sensitive por padrão era para ele conhecer os 2 "[u-U]"
    Verificar permissões da pasta netlogon, isto é muito importante.

    Grato!



  5. #5

    Padrão

    Citação Postado originalmente por mauricioliz Ver Post

    Tente alterar o "u" por "U", não é para o samba ser case sensitive por padrão era para ele conhecer os 2 "[u-U]"
    Verificar permissões da pasta netlogon, isto é muito importante.

    Grato!
    Já tentei "u-U" e "g-G" e sempre executa o arquivo netlogon.bat. Permissão não deve ser pois os arquivos tem a mesma permissão e estão na mesma pasta e somente o netlogon é executado.
    Já tentei assim:

    Código :
    netlogon.bat %G
    porém o parametro %G chega vazio no script.
    As outras variáveis que vc citou estão assim:

    Código :
    logon path =
    logon home =

  6. #6

    Padrão Samba ok!

    [global]
    workgroup = "Dominio"
    netbios name = "arqfile"
    character set = ISO8859-15
    logon script = %U.bat
    logon path =
    logon drive = Z:
    domain logons = Yes
    encrypt passwords = Yes
    map to guest = Bad User
    socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    os level = 128
    preferred master = Yes
    domain master = Yes
    dns proxy = No
    wins support = Yes
    printing = lprng
    veto files = /*.mp3/*.wmv/*.wma/*.ogg/*.eml/*.nws/riched20.dll/*.{*}/
    preserve case = Yes
    admin users = root
    add machine script = /usr/sbin/useradd -g maquinas -c "Samba Micro" -d /tmp/micros -s /bin/false %u


    [netlogon]
    comment = Network Logon Service
    path = /home/netlogon
    browseable = No

    Cara ficando deste jeito não tem como dar errado, porém deve ser ajeitado p/ suas conf.
    Grato!



  7. #7

    Padrão

    vamos lah se vc quer colocar por usuario e so deixar essa linha

    logon script = %U.bat

    se for por grupo

    logon script = %G.bat

    lembre que vc tem q converter o arquivo para o formato DOS se nao ele nao vai conseguir ler no red hat centos fedora basta vc usar o comando unix2dos arquivo.bat

  8. #8

    Padrão

    Cara, achei a resposta !!!

    O problema é que o usuário tinha um atributo setado
    Código :
     
    Código :
    [URL="http://192.168.1.85/phpldapadmin/cmd.php?cmd=schema&server_id=0&view=attributes&viewvalue=sambaLogonScript"]sambaLogonScript[/URL] = netlogon.bat
    e esse atributo sobrepoem o configurado no smb.conf.
    Setei esse atributo para "" e funcionou!

    Valeu pela força!