+ Responder ao Tópico



  1. #1

    Padrão Novato apanhando no Ubuntu

    Bom, eu sou novo no linux e to usando o Ubuntu. Instalei ele no sabado. Eu to tentando instalar uns programas e plugins, mas to apanhando aqui... hahaha

    Uso o firefox pra navegar na internet. No windows eu uso o internet explorer com o flash player, mas o firefox no Ubuntu nao ta com o flash player instalado... E eu tbm nao to conseguindo instalar... Eu entro no site do adobe, e ele me mostra as versões do flash que eu poso baixar, mas as mirrors que o flash disponibiliza é para o yum, ubuntu 8.04 e outras la... e a minha versão do ubuntu é a 9.04. Quando eu baixo o arquivo e vou descompacta-lo e instalar, da erro... Alguem sabe onde eu posso baixar e como eu posso instalar o flash player ou algum software baseado em flash pra eu instalar no firefox usando o ubuntu 9.04?

    Eu entrei nesse site http://www.aircrack-ng.org/doku.php?id=Main pra tentar baixar o software aircrack-ng para usar no Ubuntu, e nao sei se eu fiz tudo correto... bom, pra começar, minha placa wireless é intel (R) wifi 5100 AGN. Essa placa é compatível? Nesse site qual o software que eu devo baixar? Eu devo baixar algum driver especifico para usar minha placa wireless no ubuntu? Acho que ela ja esta fucionando, pois eu consigo ver algumas redes sem fio e o nivel de sinal correspondente de cada uma. O que eu fiz foi o seguinte:

    Download


    Current version

    Latest version: 1.0-rc4

    Primeiro eu cliquei nesse link Kinux do site http://www.aircrack-ng.org/doku.php?id=Main . Depois que eu cliequei, ele abriu um download. Eu mandei baixar o arquivo, e ele baixou na area de trabalho. Ele baixou em um formato .gz (acho que esse formato seria o correspondente ao formato .zip ou .rar no windows). Eu dei uma lida no site, abri o terminal e digitei o comando: sudo apt-get install build-essential conforme fala no site na parte Installing the aircrack-ng suite. Depois que eu digitei esse comando, ele pediu minha senha, eu digite a mesma, apertei enter e ele fez uma porrada de coisa la que eu nao sei o que é... Eu cliquei com o botão direito em cima do arquivo que eu baixei do site e cliquei em "extrair aqui". Ai ele descompactou o arquivo em uma pasta (pelo menos eu acho que foi isso que ele fez). Quando eu entro nessa pasta, nao tem nenhum arquivo .exe para que eu possa instalar o programa, mas tem um arquivo la chamado INSTALL. Quando eu abro esse arquivo, ele é um arquivo de texto. Esse arquivo de texto tem umas instruções e codigos la, os quais eu nao sei se fiz correto... Tem uma parte la nesse arquivo INSTALL que ele fala de um tal de SQlite (que eu nem sei o que que isso...). Pelo que eu deduzi essa instrução fala de de instalar o SQlite eu acho... Nessa instrução tem alguns comandos de texto. Um dos comandos era "wget" e na frente um link de um site (eu acho que esse comando baixa algum arquivo do tal site). Depois eu digitei um comando, que eu aacho que é pra descompactar esse mesmo arquivo, e depois um comando para instalar esse arquivo (nao me lembro direito). Depois ele da um outro wget e um outro link. Depois que digitei esse wget e esse novo link, manda dar um outro comando...

    Depois disso, vai para a parte do make. Aí apresenta o comando make Sqlite e mais umas coisas no comando que eu nao me lembro... Ate aí, parece que vai fucionando direitinho, e parece que eu to fazendo as coisas certas, pois a cada comando digitado, o terminal realiza alguma tarefa ou processamento. Porem depois dessa parte do make, tem o comando do install. Eu tento executar o comando conforme descrito no arquivo de texto, porem quando eu aperto enter, aparece a mensagem falando que nao tem permissão para instalar o arqivo ou diretorio, parece...

    Se alguem puder me ajudar... Eu estou fazendo certo? tem alguma coisa que eu fiz errado? o que eu tenho de fazer?!?!?!

    ah, e como eu faço pra saber qual a placa de rede que eu estou usando no ubuntu 9.04? Pra eu dsecobrir, eu tive de sair do linux e logar no windows para descobrir. No linux eu fui na opção sistemas->drivers e hardwares mas nao aparece nenhum driver o hardware listado la...

    Desde ja eu eu agradeço

  2. #2



  3. #3

    Padrão

    hehe cara aqui e o caiocc12 lá do outro tópico que vc postou...

    vc tá fazendo tudo do jeito mais difícil, hehehe
    vc tá aplicando a filosofia Windows de instalar software no Linux (ir na net, baixar um .exe e executar...) , e no Ubuntu não é assim que funciona!! heuheuheuh

    Primeiro, pra instalar o flash é simplíssimo:
    1) Entre em qualquer site que use o flash...
    2) O firefox mostra um aviso falando que é necessária a instalação de plugins.. clique nele.
    3) abre uma janela oferecendo três opções de plugin do flash, escolha a "Adobe Flash Player"
    4) Ele instala sozinho pra você...

    para instalar o aircrack-ng
    AVISO: eu não sei se a placa é compatível, mas provavelmente NÃO É, porque é da INTEL. Seu laptop é CENTRINO? Se for, esquece o aircrack.. rrsrsrs

    Recomendo você passar no camelô mais próximo e comprar aqueles wireless USB da china (sao os melhores pra isso), eu recomendo um tal de Encore ENUWI-G2, o chipset é da Realtek, muito bom, e custou só R$ 50. Qdo for comprar, recomendo levar o laptop, pedir pra testar o treco, espetar na USB e dar o comando "lsusb" no console, que te informa direitinho o chipset do aparelho. Foi assim que comprei o meu.

    1) Vá em sistema -> administração -> Gerenciador de Pacotes Synaptic
    2) na caixa de busca, procure por aircrack
    3) clique com o botao direito no item desejado, depois em "Marcar para instalação"
    4) clique em Aplicar .. ele baixa e instala sozinho pra você..

    Talvez você precise ativar os repositórios de software "proprietário", é simples, é so ir em Aplicações -> Adicionar/Remover .. e em "Exibir" escolher a opção "Todos os aplicativos disponíveis", seguir as orientações e sair .. só isso.
    Última edição por caiocc12; 04-08-2009 às 14:12.

  4. #4

    Padrão

    Primeiro, pra instalar o flash é simplíssimo:
    1) Entre em qualquer site que use o flash...
    2) O firefox mostra um aviso falando que é necessária a instalação de plugins.. clique nele.
    3) abre uma janela oferecendo três opções de plugin do flash, escolha a "Adobe Flash Player"
    4) Ele instala sozinho pra você...


    Eu ja tentei isso... nao ta dando certo... por exemplo, quando eu abro o site do underlinux, aparece a janela pedindo pra instalar o plugin. quando eu clico na janela, aparecem 3 opções perguntando quais dessas 3 eu desejo instalar. Ja tentei selecionar todas que aparecem e instalar, mas nenhuma da certo. Da erro durante a instalacao...

    Com relação a minha placa de rede, ela realmente é da intel: intel wifi 5100 agn e meu note é centrino... Sendo assim, a unica solução é comprando esse adaptador usb?!?! nao tem um outro programa similar que fucionaria?!?!

    Eu andei dando uma pesquisida em alguns foruns, e tem algumas coisas relacionadas a placa da intel e o aircrack... nao sei se é falando que fuciona ou falando que nao fuciona... hahaha
    Obrigado!!!
    Última edição por liecht; 04-08-2009 às 16:49.



  5. #5

    Padrão

    sobre o flash:
    nesse caso, tente abrir o Synaptic (está la nas instrucoes para instalar o aircrack)
    só que na caixa de busca procure por flash...
    acho que o nome do treco é "flashplugin-nonfree" ou algo assim, já instala automático.

    se ainda assim nao conseguir faça no braço: baixe o plugin lá do site oficial da Adobe, mas em vez de usar o instalador deles, pegue o arquivo "libflashplayer.so" e coloque na pasta ~/.mozilla/firefox/plugins

    lembrando que o flash nao tem pra 64 bits. até que tem, mas é beta, e eu nem lembro mais onde baixei o meu. kkkkkkkkkkk

    sobre o aircrack, com centrino, depende do modelo, as centrino sao meio problematicas, so um modelo especifico lá (5xxx) que funciona, e ainda tem que correr atrás de driver, compilar, ai da erro de compilacao e tem que editar o codigo fonte pra arrumar.. (essa ultima foi brincadeira hehe)
    aqui tem uma tabela de compatibilidade
    http://www.aircrack-ng.org/doku.php?...bility_drivers
    eu recomendo altamente os chipsets da Realtek que permitem uma maior flexibilidade nesse aspecto já que eles não abstraíram demais o hardware como a Intel então pelo software dá pra brincar bastante com a funcionalidade da placa..
    Última edição por caiocc12; 04-08-2009 às 17:20.

  6. #6



  7. #7

    Padrão

    jajaja
    é mesmo.. quando eu comecei a usar Linux há uns 2 anos atrás, levei três meses até conseguir botar esses drivers e aircrack e o capeta pra funcionar.
    Depois desceu redondo que nem skol, rsrsrs

  8. #8

    Padrão

    consegui resolver meu problema do firefox... O problema era que antes de baixar e instalar o plugin do flash, eu tinha de baixar umas atualizações do firefox que estavam disponiveis... Depois que eu baixei essas atualizações e instalei, consegui baixar o flash e instalar... mas agora surgiu um outro problema... hahaha

    vou criar um novo topico com todos os problemas que estao ocorrendo agora, pra ficar mais oranizado...

    valeu!!!



  9. #9

    Padrão

    ah sim cara, esquecemos de te avisar...
    aliás isso você já devia saber huhuheuhue
    a primeira coisa que você faz ao instalar um sistema é ATUALIZAR!
    seja ele Linux, Mac, Windows, etc..
    Claro que a galera do Windows não tá muito acostumada com isso, a primeira coisa que faz é desativar as atualizações pq é pirata né? kkkkkkkk

  10. #10

    Padrão Atualizações Rwindows

    Realmente, eu mesmo quando termino a Instalação do RWindows, primeira coisa que faço é desabilitar Atualizações, inclusive desabilito até no Gerenciador de Serviços .... agora no Ubuntu, é uma maravilha ... !!!



  11. #11

    Padrão

    é pq no windows da um trabalho baixar atualizações, pq vem tudo com erro, bugado, bichado, com virus, e ainda corre o risco de vir a msg que seu windows nao é original... dessa forma, nem tinha mandado baixar as atualizações no linux...