+ Responder ao Tópico



  1. #181

    Padrão

    Citação Postado originalmente por ceusbar Ver Post
    tu já fez pra ficar aparecendo mais de uma imagem no msn?
    será q imagem em flash funciona ou só em gif?

    a do msn faz uma gif animada que rola legal a minha ta assim gif animada ainda não tentei com flash

  2. #182
    Analista de Suporte em Ti Avatar de rpclanhouse
    Ingresso
    Sep 2008
    Localização
    Suzano SP
    Posts
    410
    Posts de Blog
    10

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    Ainda não estou trabalhando em cima de relatórios,mas veja o relatório do squid em seu proxy, e perceba o ip que ele esta mostrando... geralmente ele mostra sempre o mesmo ip,ou seja ,ele parece estar identificando apenas o mk como um unico cliente a solicitar dados ao proxy... Essa semana vou começar a trabalhar em cima do sarg...

    Atenção! Para que seja gerado relatório vc deve descomentar uma linha no squid.conf ...

    Caso esteja assim:

    hierarchy_stoplist cgi-bin ?
    #access_log /var/log/squid/access.log

    ... deixe assim:

    hierarchy_stoplist cgi-bin ?
    access_log /var/log/squid/access.log


    Arlin, se você puder me dar uma mão na instalação do sarg,estou no msn agora...

    Assim eu crio um mini tuto de como configurar o sarg pra galera ai, vi muitos tendo problemas com isso...

    t+
    Bill para instalar o sarg, eu segui o topico do Arlin onde diz apr-get install sarg Leia-se apt-get install sarg ( claro que vc sabe isso né rsrsrsr ). seguindo o passo a passo do Arlin rodou .

    Aqui :

    apt-get install sarg

    abra o sarg.conf que se encontra em /etc/squid/sarg.conf

    e confirure desta forma

    # sarg.conf
    #
    # TAG: language
    # Available languages:
    # Bulgarian_windows1251
    # Catalan
    # Czech
    # Dutch
    # English
    # French
    # German
    # Greek
    # Hungarian
    # Indonesian
    # Italian
    # Japanese
    # Latvian
    # Polish
    # Portuguese
    # Romanian
    # Russian_koi8
    # Russian_UFT-8
    # Russian_windows1251
    # Serbian
    # Slovak
    # Spanish
    # Turkish
    #por padrão vem em ingles altere pra portuguese
    language Portuguese
    # TAG: access_log file
    # Where is the access.log file
    # sarg -l file
    #
    access_log /var/log/squid/access.log
    # TAG: graphs yes|no
    # Use graphics where is possible.
    # graph_days_bytes_bar_color blue|green|yellow|orange|brown|red
    #
    #graphs yes
    #graph_days_bytes_bar_color orange
    # TAG: title
    # Especifique aqui o titulo da pagina que vc querira que apareça.
    #
    title "Nome do seu relatório "
    # TAG: font_face
    # Especify the font for html page.
    #
    font_face Tahoma,Verdana,Arial
    # TAG: header_color
    # Especify the header color
    #
    header_color darkblue
    # TAG: header_bgcolor
    # Especify the header bgcolor
    #
    header_bgcolor blanchedalmond
    # TAG: font_size
    # Especify the text font size
    #
    font_size 9px
    # TAG: header_font_size
    # Especify the header font size
    #
    #header_font_size 9px
    # TAG: title_font_size
    # Especify the title font size
    #
    #title_font_size 11px
    # TAG: background_color
    # TAG: background_color
    # Html page background color
    #
    background_color white
    # TAG: text_color
    # Html page text color
    #
    text_color #000000
    # TAG: text_bgcolor
    # Html page text background color
    #
    text_bgcolor lavender
    # TAG: title_color
    # Html page title color
    #
    title_color green
    # TAG: logo_image
    # Html page logo.
    #
    #logo_image none
    # TAG: logo_text
    # Html page logo text.
    #
    #logo_text ""
    # TAG: logo_text_color
    # Html page logo texti color.
    #
    #logo_text_color #000000
    # TAG: logo_image_size
    # Html page logo image size.
    # width height
    #
    #image_size 80 45
    # TAG: background_image
    # Html page background image
    #
    #background_image none
    # TAG: password
    # User password file used by authentication
    # If used here, reports will be generated only for that users.
    #
    #password none
    # TAG: temporary_dir
    # Temporary directory name for work files
    # sarg -w dir
    #
    temporary_dir /tmp
    # TAG: output_dir
    # The reports will be saved in that directory
    # sarg -o dir
    #
    #output_dir /var/www/html/squid-reports
    output_dir /var/www/squid-reports
    # TAG: output_email
    # Email address to send the reports. If you use this tag, no html reports will be generated.
    # sarg -e email
    #
    #output_email none
    # TAG: resolve_ip yes/no
    # Convert ip address to dns name
    # sarg -n
    resolve_ip
    # TAG: user_ip yes/no
    # Use Ip Address instead userid in reports.
    # sarg -p
    user_ip no
    # TAG: topuser_sort_field field normal/reverse
    # Sort field for the Topuser Report.
    # Allowed fields: USER CONNECT BYTES TIME
    #
    topuser_sort_field BYTES reverse
    # TAG: user_sort_field field normal/reverse
    # Sort field for the User Report.
    # Allowed fields: SITE CONNECT BYTES TIME
    #
    user_sort_field BYTES reverse
    # TAG: exclude_users file
    # users within the file will be excluded from reports.
    # you can use indexonly to have only index.html file.
    #
    exclude_users /etc/squid/sarg.users
    # TAG: exclude_hosts file
    # Hosts, domains or subnets will be excluded from reports.
    #
    # Eg.: 192.168.10.10 - exclude ip address only
    # 192.168.10.0 - exclude full C class
    # s1.acme.foo - exclude hostname only
    # acme.foo - exclude full domain name
    #
    exclude_hosts /etc/squid/sarg.hosts
    # TAG: useragent_log file
    # useragent.log file patch to generate useragent report.
    #
    #useragent_log none
    # TAG: date_format
    # Date format in reports: e (European=dd/mm/yy), u (American=mm/dd/yy), w (Weekly=yy.ww)
    #
    date_format u
    # TAG: per_user_limit file MB
    # Saves userid on file if download exceed n MB.
    # This option allow you to disable user access if user exceed a download limit.
    #
    #per_user_limit none
    # TAG: lastlog n
    # How many reports files must be keept in reports directory.
    # The oldest report file will be automatically removed.
    # 0 - no limit.
    #
    lastlog 0
    # TAG: remove_temp_files yes
    # Remove temporary files: geral, usuarios, top, periodo from root report directory.
    #
    remove_temp_files yes
    # TAG: index yes|no|only
    # Generate the main index.html.
    # only - generate only the main index.html
    #
    index yes
    # TAG: index_tree date|file
    # How to generate the index.
    #
    index_tree file
    # TAG: overwrite_report yes|no
    # yes - if report date already exist then will be overwrited.
    # no - if report date already exist then will be renamed to filename.n, filename.n+1
    #
    overwrite_report yes
    # TAG: records_without_userid ignore|ip|everybody
    # What can I do with records without user id (no authentication) in access.log file ?
    #
    # ignore - This record will be ignored.
    # ip - Use ip address instead. (default)
    # everybody - Use "everybody" instead.
    #
    records_without_userid ip
    # TAG: use_comma no|yes
    # Use comma instead point in reports.
    # Eg.: use_comma yes => 23,450,110
    # use_comma no => 23.450.110
    #
    use_comma yes
    # TAG: mail_utility mail|mailx
    # Mail command to use to send reports via SMTP
    #
    mail_utility mailx
    # TAG: topsites_num n
    # How many sites in topsites report.
    #
    topsites_num 100
    # TAG: topsites_sort_order CONNECT|BYTES A|D
    # Sort for topsites report, where A=Ascendent, D=Descendent
    #
    topsites_sort_order CONNECT D
    # TAG: index_sort_order A/D
    # Sort for index.html, where A=Ascendent, D=Descendent
    #
    index_sort_order D
    # TAG: exclude_codes file
    # Ignore records with these codes. Eg.: NONE/400
    #
    exclude_codes /etc/squid/sarg.exclude_codes
    # TAG: replace_index string
    # Replace "index.html" in the main index file with this string
    # If null "index.html" is used
    #
    #replace_index <?php echo str_replace(".", "_", $REMOTE_ADDR); echo ".html"; ?>
    # TAG: max_elapsed milliseconds
    # If elapsed time is recorded in log is greater than max_elapsed use 0 for elapsed time.
    # Use 0 for no checking
    #
    #max_elapsed 0
    # 8 Hours
    max_elapsed 28800000
    # TAG: report_type type
    # What kind of reports to generate.
    # topusers - users, sites, times, bytes, connects, links to accessed sites, etc
    # topsites - site, connect and bytes report
    # sites_users - users and sites report
    # users_sites - accessed sites by the user report
    # date_time - bytes used per day and hour report
    # denied - denied sites with full URL report
    # auth_failures - autentication failures report
    # site_user_time_date - sites, dates, times and bytes report
    # downloads - downloads per user report
    #
    # Eg.: report_type topsites denied
    #
    #report_type topusers topsites sites_users users_sites date_time denied auth_failures site_user_time_date downloads
    report_type topusers topsites sites_users users_sites date_time denied auth_failures site_user_time_date downloads
    # TAG: usertab filename
    # You can change the "userid" or the "ip address" to be a real user name on the reports.
    # Table syntax:
    # userid name or ip address name
    # Eg:
    # SirIsaac Isaac Newton
    # vinci Leonardo da Vinci
    # 192.168.10.1 Karol Wojtyla
    #
    # Each line must be terminated with '\n'
    #
    usertab /etc/squid/sarg.usertab
    # TAG: long_url yes|no
    # If yes, the full url is showed in report.
    # If no, only the site will be showed
    #
    # YES option generate very big sort files and reports.
    #
    long_url no
    # TAG: date_time_by bytes|elap
    # Date/Time reports will use bytes or elapsed time?
    #
    date_time_by bytes
    # TAG: charset name
    # ISO 8859 is a full series of 10 standardized multilingual single-byte coded (8bit)
    # graphic character sets for writing in alphabetic languages
    # You can use the following charsets:
    # Latin1 - West European
    # Latin2 - East European
    # Latin3 - South European
    # Latin4 - North European
    # Cyrillic
    # Arabic
    # Greek
    # Hebrew
    # Latin5 - Turkish
    # Latin6
    # Windows-1251
    # Koi8-r
    #
    charset Latin1

    Depois disso, localize essas duas linhas #access_log /var/log/squid/access.log
    #access_log /var/log/squid/error.log no squid.conf e descomente.

    Testei usando o comando squid -k reconfigure e não rolou, tive que reiniciar o Proxy, mas qdo voltou, é só acessar seu debian pelo terminal ou mesmo por ssh do seu Mk e digitar "sarg" vai gerar o relatório e depois vc digita no seu navegador IPdoseuproxy/squid-reports que vai gerar a tela. como abaixo :

    Viu Arlin, aprendi rsrsrsr valeu amigos vcs estão me ajudando muito nessa minha caminhada ! as vezes leio meu primeiro tópico, e fico até com vergonha das baboseiras que eu perguntava rsrsrsrsr

    Fiquem com Deus !

    Ricardo Sobrinho .



  3. #183

    Padrão

    Viu Arlin, aprendi rsrsrsr valeu amigos vcs estão me ajudando muito nessa minha caminhada ! as vezes leio meu primeiro tópico, e fico até com vergonha das baboseiras que eu perguntava rsrsrsrsr

    Fiquem com Deus !

    Ricardo Sobrinho .[/QUOTE]

    valeu brother... agora vou correr atras para deixar o relatorio rodando certinho,mastrando os ips do clientes...

    valeu Arlin, valeu Ricardo...

  4. #184

    Padrão

    Citação Postado originalmente por Arlin Ver Post
    a do msn faz uma gif animada que rola legal a minha ta assim gif animada ainda não tentei com flash

    blz....vou fazer um banner em flash e testar pra ver se funfa legal....
    caso não, faço uma gif animada...posto se deu certo
    vlw



  5. #185

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    Viu Arlin, aprendi rsrsrsr valeu amigos vcs estão me ajudando muito nessa minha caminhada ! as vezes leio meu primeiro tópico, e fico até com vergonha das baboseiras que eu perguntava rsrsrsrsr

    Fiquem com Deus !

    Ricardo Sobrinho .
    valeu brother... agora vou correr atras para deixar o relatorio rodando certinho,mastrando os ips do clientes...

    valeu Arlin, valeu Ricardo...[/QUOTE]



    Bill, no seu tuto vc vai mostrar apenas a instalação/config do SARG ou vai aproveitar e integrar o WEBMIN por exemplo?
    Ficaria mais bacana o tuto.

  6. #186
    Analista de Suporte em Ti Avatar de rpclanhouse
    Ingresso
    Sep 2008
    Localização
    Suzano SP
    Posts
    410
    Posts de Blog
    10

    Padrão

    Citação Postado originalmente por ceusbar Ver Post
    blz....vou fazer um banner em flash e testar pra ver se funfa legal....
    caso não, faço uma gif animada...posto se deu certo
    vlw
    Então ceusbar, Já fiz um banner do orkut em flash e ta rolando de boa, pro msn nao testei ainda, vas testo agora, já o do orkut fica show, da pra colocar até anuncios de comércios da região entrando aleatoriamente ...



  7. #187

    Talking

    Citação Postado originalmente por rpclanhouse Ver Post
    Então ceusbar, Já fiz um banner do orkut em flash e ta rolando de boa, pro msn nao testei ainda, vas testo agora, já o do orkut fica show, da pra colocar até anuncios de comércios da região entrando aleatoriamente ...

    essa é a idéia ou melhor serviços agregados.
    Pessoal após a colocação do thunder,venho tendo problemas de acesso a FTP.
    Algum de vcs teve esse problema? como resolveu?

    grato

  8. #188
    Analista de Suporte em Ti Avatar de rpclanhouse
    Ingresso
    Sep 2008
    Localização
    Suzano SP
    Posts
    410
    Posts de Blog
    10

    Padrão

    Citação Postado originalmente por ceusbar Ver Post
    essa é a idéia ou melhor serviços agregados.
    Pessoal após a colocação do thunder,venho tendo problemas de acesso a FTP.
    Algum de vcs teve esse problema? como resolveu?

    grato

    Acabei de testar, basta apenas fazer um banner com 234x60 (Pixels), em flash, e salva-lo com o nome de /var/www/ban_msn.swf rolou de boa, agora é só soltar a criatividade.

    Aqui nao percebi o problema do ftp mas vou ver .

    Bom dia e fiquem com Deus !

    Ricardo Sobrinho.



  9. #189

    Padrão Hardware?

    salve galera! Paz seja com todos
    Primeiramente obrigado a todos pela contribuição na construção do tuto, está 100%

    até agora estava usando o thunder só pra teste com alguns clientes, más vou colocar ele pra rodar pra geral, más estou com duas duvidas:

    1º tem como eu copiar todos os arquivos ja cacheados, salvo no HD pro novo que vou instalar? (lembrando que uso o thunder com debian)

    2º o servidor que estou montando aguenta uns 100 clientes simultaneos?
    Placa Mãe GA EP43-DS3L
    Processador Core 2 Quad Q9550-BOX
    8 GB DDR2 800
    HD IDE 80 Pro debian
    HD SATA2 320 Pro thunder.

    lembrando que todas as sugestões são bem vindas e vão ser avaliadas para possiveis alterações pois o numero de clientes vai aumentar pra cerca de 200 simultaneos.

    desde já agradeço as respostas e aos demais.

  10. #190

    Padrão

    Citação Postado originalmente por rpclanhouse Ver Post
    Acabei de testar, basta apenas fazer um banner com 234x60 (Pixels), em flash, e salva-lo com o nome de /var/www/ban_msn.swf rolou de boa, agora é só soltar a criatividade.

    Aqui nao percebi o problema do ftp mas vou ver .

    Bom dia e fiquem com Deus !

    Ricardo Sobrinho.

    testei tb e já ia postar assim q vc colocou....
    funcionou blz.....ficou legal...
    agora só esse probleminha de FTP e o direcionamento para página de bloqueio não consegui realizar, mas se digito o endereço direto no browser vai sem problemas.
    usei essas regras:

    /ip firewall filter

    add action=accept chain=forward comment="Bloqueio de usuarios por falta de pagamento.Suspensao" disabled=no dst-port=81 protocol=tcp src-address-list=\
    Bloqueio-Debito-Suspensao
    add action=accept chain=forward comment="" disabled=no dst-port=53 protocol=udp src-address-list=Bloqueio-Debito-Suspensao
    add action=drop chain=forward comment="" disabled=no src-address-list=Bloqueio-Debito-Suspensao

    /ip firewall nat

    add action=masquerade chain=srcnat comment="Redirecionamento para pagina de aviso" disabled=no src-address=192.160.1.0/24
    add action=same chain=dstnat comment="Controle de clientes por falta de pagamento.Debito 15 dias de atraso" disabled=no dst-port=80 protocol=tcp \
    same-not-by-dst=no src-address-list=Bloqueio-Debito to-addresses=192.168.100.2 to-ports=81

    - Onde esta em verde:
    Faixa de ip da sua rede

    - Onde esta em vermelho:
    Ip da maquina onde esta hospedada a página (Nesse caso,em nosso proxy)




  11. #191

    Padrão

    Citação Postado originalmente por Arlin Ver Post
    instala o SARG que ele gera os relatorios do Squid
    as regras do cache full pra versão 2xxxx uso essas

    / ip firewall mangle
    add chain=output protocol=tcp src-port=3128 content="X-Cache: HIT" action=mark-connection \
    new-connection-mark=conn_squid-up passthrough=yes comment="CACHE FULL" disabled=no
    add chain=output connection-mark=conn_squid-up action=mark-packet new-packet-mark=pacotes_squid-up \
    passthrough=yes comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=3128 action=mark-connection new-connection-mark=conn_squid-down \
    passthrough=yes comment="" disabled=no
    add chain=prerouting connection-mark=conn_squid-down action=mark-packet new-packet-mark=pacotes_squid-down \
    passthrough=yes comment="" disabled=no


    /ip firewall filter
    add chain=input protocol=tcp dst-port=3128 action=accept comment="ACEITAR CONEXOES PROXY" disabled=no

    /queue tree
    add name="\[CACHE-FULL\] - Download" parent=global-in packet-mark=pacotes_squid-down limit-at=0 queue=default \
    priority=1 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
    add name="\[CACHE-FULL\] - Upload" parent=global-out packet-mark=pacotes_squid-up limit-at=0 queue=default \
    priority=1 max-limit=7000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no

    Arlin, fiz conforme acima para que o mk ficasse com o cache full apenas do squid. Mas parece que não ta rolando. Fiz testes com velocidade de 120 k e parece que mesmo o site estanco em cache vai para o cliente na velocidade de 128k. Até todos os contadores mesmo do queue tree e do firewall Mangle estão zerados. Será que esqueci de algo ou tem algo errado neste script?

    Lembrando que não fiz nenhuma alteração. Tinha que ter feito alguma?

  12. #192

    Talking

    Citação Postado originalmente por ceusbar Ver Post
    /ip firewall filter
    add action=accept chain=forward comment="Bloqueio de usuarios por falta de pagamento.Suspensao" disabled=no dst-port=81 protocol=tcp src-address-list=\
    Bloqueio-Debito-Suspensao
    add action=accept chain=forward comment="" disabled=no dst-port=53 protocol=udp src-address-list=Bloqueio-Debito-Suspensao
    add action=drop chain=forward comment="" disabled=no src-address-list=Bloqueio-Debito-Suspensao
    /ip firewall nat
    add action=masquerade chain=srcnat comment="Redirecionamento para pagina de aviso" disabled=no src-address=192.160.1.0/24
    add action=same chain=dstnat comment="Controle de clientes por falta de pagamento.Debito 15 dias de atraso" disabled=no dst-port=80 protocol=tcp \
    same-not-by-dst=no src-address-list=Bloqueio-Debito to-addresses=192.168.100.2 to-ports=81
    - Onde esta em verde:
    Faixa de ip da sua rede
    - Onde esta em vermelho:
    Ip da maquina onde esta hospedada a página (Nesse caso,em nosso proxy)
    as regras do filter rules vc adicona elas e podem ficar na ultima linha mesmo mais as duas regras do nat tem que ficar logo abaixo da nat dos clientes ou seja em primeiro lugar a nat dos clientes ai em segundo a redirecionamento pra pagina de aviso e a terceira a controle de falta de pagamento debito 15 dias e depois as demais regras por ultimo redirecionamento pro proxy ai depois em address list coloque em NOME bloqueio-debito e o ip do camarada a ser bloqueado e em coment o nome do danado e pronto vai funcionar de certeza ok.



  13. #193

    Padrão

    Citação Postado originalmente por FernandodeDeus Ver Post
    Arlin, fiz conforme acima para que o mk ficasse com o cache full apenas do squid. Mas parece que não ta rolando. Fiz testes com velocidade de 120 k e parece que mesmo o site estanco em cache vai para o cliente na velocidade de 128k. Até todos os contadores mesmo do queue tree e do firewall Mangle estão zerados. Será que esqueci de algo ou tem algo errado neste script?

    Lembrando que não fiz nenhuma alteração. Tinha que ter feito alguma?
    amigo as regras estão corretas e deve aver trafego de dados no queue tree sim se não ta tendo deve ter algo errado vc usando a versão 2 XX deve ter o web proxy configurado as regras de redirecionamento pro proxy interno tudo funcionando pro cache full funcionar.

    configurando web proxy
    Primeiro vamos em ip -> web-proxy e clique no botão Settings.
    Em PORT Escolha a porta do seu web-proxy, no meu caso escolhi a porta padrão do proxy 3128;

    Marque a opção TRANSPARENT PROXY. Lembre de deixar desmarcada esta opção "Transparent Proxy" nos perfil do hotsport (ip -> hotspot -> user - > Botão Profiles);

    Em CACHE ADMINISTRATOR, deixe padrão: "webmaster";

    Em MAXIMUM OBJECT SIZE, deixei "65536 kiB" que é 64M para o tamanho máximo para arquivos que devem ser armazenados, acima disso não gravo.

    Em CACHE DRIVE, deixe "system", dessa forma o HD será o mesmo HD que o Mikrotik estar instalado. No caso da imgem, tenho um HD de 40Gb extra como escravo onde utilizo a opção "secondary-master" que é meu segundo HD.

    Em MAXIMUM CACHE SIZE, defini o tamanho máximo do meu HD de 40GB para "33712000 KiB", no seu caso pode ser diferente de acordo com seu HD, sempre informe o tamanho em KiloBytes.

    Em MAXIMUM RAM, defini o tamanho máximo da minha mémória RAM em "458752 KiB" porque tenho 512Mb de ram, mas deixei apenas 448MB para cache, porque deixei 64M para o Mikrotik.

    O web-proxy estar configurado, agora clique no botão “ENABLE” para dar início ao web-proxy.

    Agora vamos definir o que não pode ser gravado no web-proxy:

    /ip web-proxy cache
    add url=":cgi-bin \\\?" action=deny comment="sem cache" disabled=no
    add url="https:/
    /" action=deny comment="sem cache" disabled=no

    As duas regras são páginas dinâmicas e páginas de autenticação como as que os bancos usam, estas não devem ser gravadas no web-proxy e para isso estaremos definidos elas como deny (negadas).

    Vamos definir quem tem o acesso ao web-proxy:

    / ip web-proxy access
    add src-address=192.168.20.0/
    24 action=allow comment="" disabled=no
    add action=deny comment="" disabled=no

    Na regra acima, a primeira definir que minha rede de clientes 192.168.20.0/24 terá acesso ao web-proxy, e na segunda falo ao mikrotik que fora estas nenhuma mais.

    Agora vamos configurar o mikrotik para conversar antes com o proxy, vamos criar a regra para redirecionar as requisições primeiro para o proxy, para isso:

    A regra baixo criará um redirecionamento da porta 80 para a porta do web-proxy 3128 em ip -> firewall -> nat:

    / ip firewall nat
    add chain=dstnat in-interface=CLIENTES src-address=192.168.20.0/
    24 protocol=tcp dst-port=80 action=redirect \
    to-ports=3128 comment="REDIRECIONAR PROXY" disabled=no

    Em IN-INTERFACE, definimos a interface dos clientes, no caso a minha tem o nome CLIENTES, onde pode ser o nome da sua INTERFACE onde fica os seus clientes.

    Em SRC-ADDRESS, definir a rede dos CLIENTES, altere de acordo com sua rede.

    Obs.: Se tiver mais de uma interface, crie uma regra para cada.


    Uma regra importante é o bloqueio do proxy externo:

    / ip firewall filter
    add chain=input in-interface=LINK1 protocol=tcp dst-port=3128 action=drop comment="BLOQUEIO DO PROXY EXTERNO"\

    Em IN-INTERFACE, defina sua interface com a internet, ou seja, seu link de internet.


    faça assim depois como falei no outro post o CACHE FULL OK que vai da certo se vc ta usando o proxy externo em web proxy em parent proxy coloque o IP do seu proxy externo e em Parent proxy Port a porta que seu proxy trabalha ex. 3128



  14. #194

    Padrão

    Citação Postado originalmente por Arlin Ver Post
    as regras do filter rules vc adicona elas e podem ficar na ultima linha mesmo mais as duas regras do nat tem que ficar logo abaixo da nat dos clientes ou seja em primeiro lugar a nat dos clientes ai em segundo a redirecionamento pra pagina de aviso e a terceira a controle de falta de pagamento debito 15 dias e depois as demais regras por ultimo redirecionamento pro proxy ai depois em address list coloque em NOME bloqueio-debito e o ip do camarada a ser bloqueado e em coment o nome do danado e pronto vai funcionar de certeza ok.

    ahhh tá....agora realmente funfou blz.....
    mas nobre Arli, essa regra não bloqueia msn e p2p, apenas os browsers não é?



  15. #195

    Padrão

    Citação Postado originalmente por ceusbar Ver Post
    ahhh tá....agora realmente funfou blz.....
    mas nobre Arli, essa regra não bloqueia msn e p2p, apenas os browsers não é?
    sim mais se ele sair e tentar entrar novamnete no msn tambem não vai entrar mais o mesmo vale pro p2p se ele desconectar não reconecta mais

  16. #196

    Padrão

    Citação Postado originalmente por Arlin Ver Post
    as regras do filter rules vc adicona elas e podem ficar na ultima linha mesmo mais as duas regras do nat tem que ficar logo abaixo da nat dos clientes ou seja em primeiro lugar a nat dos clientes ai em segundo a redirecionamento pra pagina de aviso e a terceira a controle de falta de pagamento debito 15 dias e depois as demais regras por ultimo redirecionamento pro proxy ai depois em address list coloque em NOME bloqueio-debito e o ip do camarada a ser bloqueado e em coment o nome do danado e pronto vai funcionar de certeza ok.
    Ta certinho....

    Só um detalhe,cheguei usar o proxy externo e versão 2.9.27... O meu webproxy ficava disabled... Não tinha mas nenhuma função...

    Sobre o p2p e msn, eles caem depois de alguns segundos ao bloqueio... Cuidado! Certifique que selecionou a opção correta do address-lists,assim ele bloqueia geral o cliente...

    Usando estas regras vc pode criar varias formas de bloqueio...
    Ex:

    vc cria para bloqueio,para aviso,para manutenção...

    É só repetir a regra no filter rules e na nat, seguindo as portas do proxy...



  17. #197

    Padrão LoadBalance - Modo PCC - Modem Bridge

    E ai Arlin... Coloquei o PCC trabalhando com os modens em modo bridge... Por hora coloquei apenas 3 modens pra testar,mas parece que rodou 100% ,assim como no modo router.Pode ter cido até coincidencia,mas olha como esta dividido o trafego... Usei em modo Router durante 4 dias,e não ficou tão dividido assim rs....

    http://img170.imageshack.us/img170/8977/imagemxv.jpg

    Ja to trabalhando pra usar PCC + Rotas estaticas... Logo logo coloco alguma coisa aqui.. vlws

  18. #198

    Padrão

    Arlin, esse cache full só funfa quando se faz cache na mesma maquina do mk? Pois uso o seguinte cenario como o amigo bill disse o meu web proxy não tem mais serventia não trabalho em Parent , trabalho com proxy em Paralelo. Trabalho com Hotspot , com web prox desativado e desviando o trafego para uma maquina com Debian + Thunder diretamente do hotspot setando o ip do debian no hotspot > server > profile.

    Será que tem alguma forma para esse cenario com o cache em maquina separada no 2.9.27 fazendo cache full dos arquivos do squid?



  19. #199

    Padrão

    Citação Postado originalmente por FernandodeDeus Ver Post
    Arlin, esse cache full só funfa quando se faz cache na mesma maquina do mk? Pois uso o seguinte cenario como o amigo bill disse o meu web proxy não tem mais serventia não trabalho em Parent , trabalho com proxy em Paralelo. Trabalho com Hotspot , com web prox desativado e desviando o trafego para uma maquina com Debian + Thunder diretamente do hotspot setando o ip do debian no hotspot > server > profile.

    Será que tem alguma forma para esse cenario com o cache em maquina separada no 2.9.27 fazendo cache full dos arquivos do squid?
    Amigo, vc quer squid fazendo cache em uma maquina e o thunder cacheando em outra?

  20. #200

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    Amigo, vc quer squid fazendo cache em uma maquina e o thunder cacheando em outra?
    Não, gostaria de fazer cache full apenas para o cache do squid e não do thunder, assim como vc faz só que uso a versão 2.XX e gostaria de uma ajuda.