Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. sim seria otimo mas uso modem roteado entao nao achei um script que funcione
    e meu modem nao tem a função de atualizar o ip
    vc teria alguma ideia e ja conseguiu atualizar com modem roteado ?

  2. Citação Postado originalmente por deson00 Ver Post
    sim seria otimo mas uso modem roteado entao nao achei um script que funcione
    e meu modem nao tem a função de atualizar o ip
    vc teria alguma ideia e ja conseguiu atualizar com modem roteado ?
    Realmente com Modem Roteado acho que não tem como, a não ser que seu Modem tenha a função DDNS, assim você consegueria atualizar seu endereço através de outros serviços parecidos com o ChangeIP, como DynDNS e outros.

    A solução para são duas :

    1- Você põe seu modem no Modo Bridge, põe o MKT para fazer a discagem e com o IP válido no MKT você conseguirá rodar o Script sem problemas.

    ou

    2- Você deixa uma máquina dentro da rede com o DynDNS rodando 24hs e faz um DMZ do modem direcionando para o servidor.

    Para as duas soluções você encontra todo o material no Fórum.

    Espero ter ajudado.

    Abçs.



  3. voce deve tem uma conta no changeip.com para utilizar este script
    va em system, scritp
    clique no botao +
    name: ddns
    em source: coloque isto:

    :log info "DDNS: Begin"
    :global ddns-user "seu login"
    :global ddns-pass "sua senha"
    :global ddns-host "seu_host_name"
    :global ddns-interface "nome da interface que esta ligado o modem"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"


    agora em system, scheduler:

    name: ddns
    start date: jan/08/2009
    start time: 00:00:00
    interval: 01:00:00
    on event: / system script run ddns



    espero ter ajudado
    caso isto nao de certo procure sobre DMZ e DDNS em seu modem

  4. Amigo procura ai um script chamado DDNS que tem pronto..
    "Eu mesmo ja peguei,,.."
    Ai vc cadastra o seu servidor e acessa via winbox pelo endereço que será fornecido pra vc..."GRATIS".. o server autentica toda vez que faz a discagem do pppoeclient;
    Abraços...






Tópicos Similares

  1. Respostas: 3
    Último Post: 13-08-2012, 15:32
  2. Respostas: 2
    Último Post: 14-09-2009, 18:27
  3. Rotina para enviar IP do servidor por e-mail
    Por finhanho no fórum Servidores de Rede
    Respostas: 2
    Último Post: 23-12-2004, 01:37
  4. Script para Pegar IP, Enviar e-mail e escrever no pptp.conf
    Por Skill no fórum Linguagens de Programação
    Respostas: 21
    Último Post: 26-06-2003, 11:34
  5. Script para Pegar IP da ETH ou PPP0, e enviar por email
    Por Skill no fórum Servidores de Rede
    Respostas: 0
    Último Post: 28-03-2003, 15:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L