+ Responder ao Tópico



  1. #1

    Padrão NTH problemas - Algém pode ajudar

    Olá pessoal vocês pode me ajudar nessa questão

    Tenho dois links aqui um de 8 Megas e um de 2 megas tentei fazer o balanceamento por NTH e está apresentando alguns problemas:

    1 - No addres list o nth sempre direciona mais clientes para o link marcado como rota default, ou seja, se eu modificar o ip da rota default sempre o NTH manda para o link onde esta essa rota, independetemente se é ou não o maior

    2 - Alguns clientes não estão acessando alguns sites, por exemplo o hotmail não entra, apesar do messenger entrar


    Segue minhas regas



    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.248 routing-mark=even scope=255 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.248 scope=255 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=200.249.152.129 routing-mark=odd scope=255 target-scope=10


    /ip address
    add address=200.249.152.140/29 broadcast=200.249.152.135 comment=Server disabled=no interface=link01 network=200.249.152.128
    add address=199.198.111.1/24 broadcast=199.198.111.255 comment=hotspot disabled=no interface=clientes network=199.198.111.0
    add address=192.168.1.240/24 broadcast=192.168.1.255 comment="" disabled=no interface=link02 network=192.168.1.0
    add address=200.249.152.133/29 broadcast=200.249.152.135 comment=Embratel disabled=no interface=link01 network=200.249.152.128
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="Load Balance" disabled=no in-interface=clientes new-connection-mark=odd passthrough=yes \
    src-address-list=odd
    add action=mark-routing chain=prerouting comment="" disabled=no in-interface=clientes new-routing-mark=odd passthrough=no src-address-list=odd
    add action=mark-connection chain=prerouting comment="" disabled=no in-interface=clientes new-connection-mark=even passthrough=yes src-address-list=even
    add action=mark-routing chain=prerouting comment="" disabled=no in-interface=clientes new-routing-mark=even passthrough=no src-address-list=even
    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=clientes new-connection-mark=odd nth=2,0 passthrough=yes
    add action=add-src-to-address-list address-list=odd address-list-timeout=2d chain=prerouting comment="" disabled=no in-interface=clientes
    add action=mark-routing chain=prerouting comment="" connection-mark=odd disabled=no in-interface=clientes new-routing-mark=odd passthrough=no
    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=clientes new-connection-mark=even nth=2,1 passthrough=\
    yes
    add action=add-src-to-address-list address-list=even address-list-timeout=2d chain=prerouting comment="" connection-mark=even disabled=no in-interface=\
    clientes
    add action=mark-routing chain=prerouting comment="" connection-mark=even disabled=no in-interface=clientes new-routing-mark=even passthrough=no
    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no in-interface=clientes new-connection-mark=even nth=2,2 passthrough=\
    yes src-address-list=odd


    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes
    add action=masquerade chain=srcnat comment="masquerade hotspot network" disabled=no src-address=10.0.0.0/24
    add action=masquerade chain=srcnat comment="masquerade hotspot network" disabled=no src-address=199.198.111.0/24
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=link01
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=link02

    Se alguem poder ajudar

  2. #2

    Padrão

    tente usar o balanceamento por PCC. é melhor..



  3. #3

    Padrão

    Eu descobri a bronca aqui. O problema em si não é no NTH e sim Upload do outro link que só tem 512k. Tenha alguma regra para que eu possa enviar o tráfico de upload para o link full?

  4. #4

    Thumbs up

    Citação Postado originalmente por DSSS Ver Post
    Eu descobri a bronca aqui. O problema em si não é no NTH e sim Upload do outro link que só tem 512k. Tenha alguma regra para que eu possa enviar o tráfico de upload para o link full?
    Duplique suas regras de NTH e NAT e Route até chegar na equivalência de 512 exemplo 4 mega e 512k vão ser 8 regras para o link de 4 mega e uma para o link de 512 !



  5. #5

    Padrão

    Cara venho tentando fazer esse balancemanto(NTH) a um certo tempo e não consigo alguem conseguiu e poder postar ai um passo a passo. so que eu uso:

    HotSpot + WebProxy +
    - Link 01 - 2mb - Modem ADSL (Modo Bridge discando pelo Mikrotik)
    - Link 02 - 1mb - Modem ADSL (Modo Bridge discando pelo Mikrotik)
    - Link 03 - 512k - IP FIXO Embratel

    Ajuda ae pessoal ja to quase desistindo

  6. #6

    Padrão

    Citação Postado originalmente por DSSS Ver Post
    Olá pessoal vocês pode me ajudar nessa questão

    Tenho dois links aqui um de 8 Megas e um de 2 megas tentei fazer o balanceamento por NTH e está apresentando alguns problemas:

    1 - No addres list o nth sempre direciona mais clientes para o link marcado como rota default, ou seja, se eu modificar o ip da rota default sempre o NTH manda para o link onde esta essa rota, independetemente se é ou não o maior

    2 - Alguns clientes não estão acessando alguns sites, por exemplo o hotmail não entra, apesar do messenger entrar


    Segue minhas regas





    /ip route



    /ip address


    /ip firewall mangle




    /ip firewall nat


    Se alguem poder ajudar
    Caso não tenhas um otimo motivo para usar o NTH, recomendo que leia a respeito do > PCC Balance <, neste link pode ter uma idéia real de como se configura, e posso garantir que são grandes as vantagens em relação NTH.

    Obs: recomendado Mikrotik 3.28 ou superior.

    Abraço



  7. #7

    Padrão

    Citação Postado originalmente por m4d3 Ver Post
    Caso não tenhas um otimo motivo para usar o NTH, recomendo que leia a respeito do > PCC Balance <, neste link pode ter uma idéia real de como se configura, e posso garantir que são grandes as vantagens em relação NTH.

    Obs: recomendado Mikrotik 3.28 ou superior.

    Abraço
    Confirmo, o que m4d3 disse.

  8. #8

    Padrão olha rapaz

    2 link de 8 mb com 512 k de up ( velox ) e um de 2 mb full ( embratel ) , pensei que vc usava um link full de 32 mb recebendo por fibra otica, eita eita a gente ver cada uma kkkkkkkkkkkkkk