+ Responder ao Tópico



  1. #201

    Padrão Balance

    Amigos estou com um problema serissimo, acontece q tenho dois links adsl da mesma operadora so q quando conecta ela atrapalha tudo em rotas ai fica uma bagunça isso tudo por que o gateway é o mesmo pros dois links, o q devo fazer ja q estou fazendo a discagem no mk ? E sobreo o pcc ta funcionando muito bem mais os videos da globo.com nao abrem alguem tem a solução ?
    Última edição por Binhos5; 03-12-2009 às 13:02.

  2. #202

    Padrão

    Citação Postado originalmente por Binhos5 Ver Post
    Amigos estou com um problema serissimo, acontece q tenho dois links adsl da mesma operadora so q quando conecta ela atrapalha tudo em rotas ai fica uma bagunça isso tudo por que o gateway é o mesmo pros dois links, o q devo fazer ja q estou fazendo a discagem no mk ? E sobreo o pcc ta funcionando muito bem mais os videos da globo.com nao abrem alguem tem a solução ?

    Amigo presta bem a atenção na 1ª regra do luciano que ele cria a uma regra para a Address-List, na address-list adicione os Dois ips que a globo tem que são 201.7.0.0/16 e 201.30.0.0/16 e não esquece de em name selecionar o nome que você escolheu, caso tenha copiado totalmente o passo a passo do Luciano seleciona a opção "sem_balance".

    Espero ter ajudado... um abraço



  3. #203

    Padrão zeroshell

    Amigo, cara a solução de todos os meus problemas não foi o balance do mk, se sim a super facilidade do ZEROSHELL ele salvou meu provedor sinceramente, esse programa deveria ser mais estudado aqui nesse forum, eu falei para várias pessoas no MUM e ninguem me deu muita credibilidade, mais hoje uso ele segurando 280 clientes on, com 4 link's adsl

  4. #204

    Padrão

    Citação Postado originalmente por limajlp Ver Post
    Amigo, cara a solução de todos os meus problemas não foi o balance do mk, se sim a super facilidade do ZEROSHELL ele salvou meu provedor sinceramente, esse programa deveria ser mais estudado aqui nesse forum, eu falei para várias pessoas no MUM e ninguem me deu muita credibilidade, mais hoje uso ele segurando 280 clientes on, com 4 link's adsl
    Acredito que não existe programa perfeito, e sim o q vc se familiariza melhor com ele, no seu caso se familiarizou com o ZEROSHELL, no meu caso uso mikrotik desde 2004 tudo que preciso consigo fazer nele, tenho 2500 cliente a traz de dois balanceador PCC, eai qual é melhor ? como te disse o q vc mais se familiariza, eu o PCC vc o ZEROSHELL.

    abraços



  5. #205

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Acredito que não existe programa perfeito, e sim o q vc se familiariza melhor com ele, no seu caso se familiarizou com o ZEROSHELL, no meu caso uso mikrotik desde 2004 tudo que preciso consigo fazer nele, tenho 2500 cliente a traz de dois balanceador PCC, eai qual é melhor ? como te disse o q vc mais se familiariza, eu o PCC vc o ZEROSHELL.

    abraços

    Assino embaixo tiagomatias, aqui na minha empresa foi tudo migrado para mikrotik desde 2005, foi quando eu entrei, deu trabalho no começo devido a falta de experiência, mas conforme o tempo passou você percebe que é uma ferramenta com infinitas opções, até mesmo coisas que achei que fossem impossiveis que só um servidor com linux para resolver eis uma pesquisa e via que aquilo estava disponivel, só que faltava conhecimento, hoje migrei até mesmo servidores de empresas para mikrotik e particulamente é 100% melhor.

  6. #206

    Padrão

    Vou tentar montar um aqui para teste de bancada, alguem poderia me dizer, como faço a divisão pois meus links deram 111 a divisão, são eles.
    Link dedicado 1M (medida 1M) ##### Adsl 10M (medida 11M) ##### Adsl 100M (medida 125M)

    1+10+100=111

    Como ficaria??

    Editado...

    Montei o load seguindo o tuto, só mudei os ips para se adequar a minha rede, Mais ficou muito lento.
    no speedtest
    A latência normal do meu adsl 10 megas é 12 a 15 ms
    do adsl de 100megas é 2 a 3 ms
    do link dedicado é 10 a 13 ms

    tá dando 1033ms

    e tem site que não abre nem com reza.

    Obrigado.
    Última edição por RobertoLima; 11-12-2009 às 16:42.



  7. #207

    Padrão

    Amigos pra na desperdiçar o tempo da galera, venho avisar que resolvi o problema da lentidão, não se se fiz certo mais está funfando. não sei se fiz certo. mais criei uma marca pra cada mega, kkkkkk

    link 1 mega = 111/0

    link 10 megas = 111/1 até 111/10

    link 100 megas = 111/11 até 111/110

    só que notei que só o link 10 megas está recebendo bastante trafego, o link 1 mega fica quase o tempo todo em 0kbps e o de 100megas raramente passa de 1500kbps,

    Abraço a todos, e parabens pelo tuto. nunca tinha chegado tão longe, agora é só detalhes. he he he
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         pcc.JPG
Visualizações:	189
Tamanho: 	171,9 KB
ID:      	6296  

  8. #208

    Padrão PCC Balance de 3 a 16 links - Por: M4D3

    Muito bom !! porém estou com um problema.. fiz a configuração prevendo tres modems adsls em bridge, sendo que as conexoes ppp conectam sendo que somente 1º que conecta ficar com atividade tx e rx na interface ppoe-cliente vou passar minha configuração.. ve se mata a charada !!

    Caso desative uma a outra entra... sendo que preciso o fazer o loadbalance !!

    MANGLE
    add action=accept chain=prerouting comment="SEM BALANCEAMENTO" disabled=no \
    dst-address-list=sem_balance

    add action=mark-connection chain=input comment="Marca\E7\E3o das conex\F5es" \
    connection-state=new disabled=no in-interface=EthLinkA \
    new-connection-mark=conn_na passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=EthLinkB new-connection-mark=conn_nb \
    passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=yes in-interface=EthLinkC new-connection-mark=conn_nc \
    passthrough=yes

    add action=mark-routing chain=output comment="Marca\E7\E3o das Rotas" \
    connection-mark=conn_na disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb \
    disabled=no new-routing-mark=to_rb passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nc \
    disabled=yes new-routing-mark=to_rc passthrough=no

    add action=mark-connection chain=prerouting comment="Balancemento dos links" \
    disabled=no dst-address-type=!local in-interface=EthCliente \
    new-connection-mark=conn_ma0 passthrough=no per-connection-classifier=\
    both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=EthCliente new-connection-mark=\
    conn_mb1 passthrough=no per-connection-classifier=both-addresses:2/1
    add action=mark-connection chain=prerouting comment="" disabled=yes \
    dst-address-type=!local in-interface=EthCliente new-connection-mark=\
    conn_mc2 passthrough=no per-connection-classifier=both-addresses:3/2

    NAT
    add action=masquerade chain=srcnat comment="MASCARAMENTO PCC" disabled=no src-address=192.168.0.0/24

    ROTA

    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=EthLinkA scope=30 target-scope=10
    add comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=EthLinkB scope=30 target-scope=10
    add comment="" disabled=no distance=4 dst-address=0.0.0.0/0 gateway=EthLinkC scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkA routing-mark=to_nra
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkB routing-mark=to_nrb
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=EthLinkC routing-mark=to_nrc


    Antecipadamente agradeço,

    Carlos Gonzaga



  9. #209

    Padrão

    Também estou com problema para discar os modens e funcionar!
    Hoje utilizo balanceamento por rotas.. mas estou afim de deixar um mirkotik so para balanceamento..

    o pcc seria a melhor opção no momento??

    Eu quero que saia somente um gateway para meu server mikrotik original.. o que vcs recomendam? pcc??

    Se alguém conseguiu aplicar o pcc com modens em bridge poderia nos dar uma dica?

    Abraços

  10. #210

    Padrão

    Citação Postado originalmente por tmelooliveira Ver Post
    Também estou com problema para discar os modens e funcionar!
    Hoje utilizo balanceamento por rotas.. mas estou afim de deixar um mirkotik so para balanceamento..

    o pcc seria a melhor opção no momento??

    Eu quero que saia somente um gateway para meu server mikrotik original.. o que vcs recomendam? pcc??

    Se alguém conseguiu aplicar o pcc com modens em bridge poderia nos dar uma dica?

    Abraços
    Olá Mestre Tiago.
    Ainda bem que acalmaram as tempestades pelo litoral. Algum prejuízo?

    Participo em outra lista onde uma pessoa ofereceu RB 450 ou 490 (ou 493) não me lembro agora, já configuradas exclusivamente para balanceamento. A 493 tem 9 portas, ideal para as adsl, que não é o meu caso.
    Segundo ele, balanceamento perfeito em todos os aspectos. Estou aguardando para ver os comentários de quem está usando. Pretendo pegar uma rb450.



  11. #211

    Padrão

    Fala grande 1929.. prejuizo sempre se tem.. quando não é equipamentos é de tempo perdido (chuva não se instala)..

    Mas entre os mortos e feridos até que ficamos bem!

    Eu estou montando um micro so para fazer balanceamento dos adsl...

    E entrar no gateway (mikrotik) como sendo um ip unico.. assim separo as coisas.. so estou com problemas na hora da configuração.. mas vou testar mais agora a noite..

    Ahh.. estou fazendo isso por causa do proxy squid e do thunder que vou colocar também.. quero ver se melhoro mais ainda a qualidade da rede..

    abraços,

  12. #212

    Padrão PCC Balance de 3 a 16 links - Por: M4D3

    Olá.. consegui resolver o meu problema vou te passar como esta a minha configuração :

    Lembrando que esto com dois links adsl velox 1 4mb e 1 2mb... Boa sorte !!


    /interface ethernet
    set 0 arp=enabled auto-negotiation=yes cable-settings=default comment=\
    "####### INTERFACE LINK4MB ####" disable-running-check=yes disabled=no \
    full-duplex=yes mac-address=00:E0:4C:63:F6:A9 mtu=1500 name=EthLinkA \
    speed=100Mbps
    set 1 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
    disable-running-check=yes disabled=no full-duplex=yes mac-address=\
    00:E0:4C:77:18:A3 mtu=1500 name=EthLinkB speed=100Mbps
    set 2 arp=enabled auto-negotiation=yes cable-settings=default comment=\
    "####### INTERFACE CLIENTES ####" disable-running-check=yes disabled=no \
    full-duplex=yes mac-address=00:E0:4C:63:F7:2E mtu=1500 name=EthClientes \
    speed=100Mbps
    set 3 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
    disable-running-check=yes disabled=no full-duplex=yes l2mtu=1600 \
    mac-address=00:16:17:69:34:2C mtu=1500 name=ether4 speed=100Mbps

    /interface pppoe-client
    add ac-name="" add-default-route=yes allow=pap,chap,mschap1,mschap2 comment=\
    "" dial-on-demand=no disabled=no interface=EthLinkA max-mru=1480 max-mtu=\
    1480 mrru=disabled name=DISCADOR_4MB password=2122539500 profile=default \
    service-name="" use-peer-dns=yes [email protected]
    add ac-name="" add-default-route=yes allow=pap,chap,mschap1,mschap2 comment=\
    "" dial-on-demand=no disabled=no interface=EthLinkB max-mru=1480 max-mtu=\
    1480 mrru=disabled name=DISCADOR_2MB password=2122539500 profile=default \
    service-name="" use-peer-dns=yes [email protected]

    /ip address
    add address=10.1.10.130/27 broadcast=10.1.10.159 comment=\
    "###### INTERFACE LINK 4MB ###" disabled=no interface=EthLinkA network=\
    10.1.10.128
    add address=192.168.1.1/30 broadcast=192.168.1.3 comment=\
    "###### INTERFACE CLIENTE ###" disabled=no interface=EthClientes network=\
    192.168.1.0
    add address=10.1.10.162/27 broadcast=10.1.10.191 comment=\
    "###### INTERFACE LINK 2MB ###" disabled=no interface=EthLinkB network=\
    10.1.10.160

    /ip firewall mangle
    add action=accept chain=prerouting comment="Fora do LoadBalanced" disabled=no \
    dst-address-list=loopback in-interface=EthClientes
    add action=mark-connection chain=input comment=\
    "Marcar conexao ether1_conn ether2_conn " connection-state=new disabled=\
    no in-interface=EthLinkA new-connection-mark=ether1_conn passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=EthLinkB new-connection-mark=ether2_conn \
    passthrough=yes
    add action=mark-routing chain=output comment=\
    "Marca\E7\E3o to_ether1 to_ether2" connection-mark=ether1_conn \
    connection-state=new disabled=no new-routing-mark=to_ether1 passthrough=\
    no
    add action=mark-routing chain=output comment="" connection-mark=ether2_conn \
    connection-state=new disabled=no new-routing-mark=to_ether2 passthrough=\
    no
    add action=mark-connection chain=prerouting comment=LoadBalance disabled=no \
    dst-address-type=!local in-interface=EthClientes new-connection-mark=\
    ether1_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:6/0
    add action=mark-connection chain=prerouting comment=ether2_conn disabled=no \
    dst-address-type=!local in-interface=EthClientes new-connection-mark=\
    ether1_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:6/1
    add action=mark-connection chain=prerouting comment=ether4_conn disabled=no \
    dst-address-type=!local in-interface=EthClientes new-connection-mark=\
    ether1_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:6/2
    add action=mark-connection chain=prerouting comment=ether5_conn disabled=no \
    dst-address-type=!local in-interface=EthClientes new-connection-mark=\
    ether1_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:6/3
    add action=mark-connection chain=prerouting comment=ether6_conn disabled=no \
    dst-address-type=!local in-interface=EthClientes new-connection-mark=\
    ether2_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:6/4
    add action=mark-connection chain=prerouting comment=ether7_conn disabled=no \
    dst-address-type=!local in-interface=EthClientes new-connection-mark=\
    ether2_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:6/5
    add action=mark-routing chain=prerouting comment=\
    "Rota dos pacores to_ether1 e to_ether2" connection-mark=ether1_conn \
    disabled=no in-interface=EthClientes new-routing-mark=to_ether1 \
    passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    ether2_conn disabled=no in-interface=EthClientes new-routing-mark=\
    to_ether2 passthrough=no



  13. #213

    Padrão

    E ai CGonzaga.. tu ta usando modem roteado ne?

    Abraços

  14. #214

    Padrão

    Tiago,

    Não só coloquei os ips pq estava testando e queria acessar-los.. mas se vc ver as regras de Nat vai ver que estão direcionando para conexão do ppoe criado..

    qq duvida eh só falar !!

    []´s

    Gonzaga



  15. #215

    Padrão

    Certo amigo CGonzaga, vou testar aqui.. estou montando um micro so para o balanceamento..(estou com uma licença parada aqui).. vou testar e te digo..

    Ai como ta se portando?

    Abraços

  16. #216

    Padrão

    CGonzaga.. não achei as regras de nat ali em cima... podemos falar por mp?

    Abraços



  17. #217

    Padrão

    Amigos, uma dúvida:

    tenho 3 links ADSL:
    link 1 - DOWN 8Mb e UP 400Kb
    link 2 - DOWN 1Mb e UP 400Kb
    link 3 - DOWN 1Mb e UP 400Kb

    No caso da implantação do balanceamento da banda será enviado 8 vezes mais pacotes para o DOWNLOAD do link 1.
    Mas isso não irá enviar também 8 vezes mais pacotes para o UPLOAD do link 1?

    Abraço e desde já obrigado.

  18. #218

    Padrão

    Citação Postado originalmente por agrinfo Ver Post
    Amigos, uma dúvida:

    tenho 3 links ADSL:
    link 1 - DOWN 8Mb e UP 400Kb
    link 2 - DOWN 1Mb e UP 400Kb
    link 3 - DOWN 1Mb e UP 400Kb

    No caso da implantação do balanceamento da banda será enviado 8 vezes mais pacotes para o DOWNLOAD do link 1.
    Mas isso não irá enviar também 8 vezes mais pacotes para o UPLOAD do link 1?

    Abraço e desde já obrigado.
    Aqui não funcionou assim não. sobrecarregou o de 10 megas , e deixou vazio o de 100 megas.
    aqui ficou mais ou menos assim... (isso é o panorama do balanceamento + ou -)
    1mega full = 0kb dow 0kb up
    10 megas = 4500k down 700k up (sobrecarregado em relação aos outros)
    100 megas = 1200k dow 100k up

    vou tentar configurar denovo nessa semana.



  19. #219

    Padrão PCC Balance de 3 a 16 links - Por: M4D3

    tranquilo !!

    Sob o balanceamento ta funcionando muito bem !!

  20. #220

    Padrão

    Citação Postado originalmente por cgonzaga Ver Post
    Tiago,

    Não só coloquei os ips pq estava testando e queria acessar-los.. mas se vc ver as regras de Nat vai ver que estão direcionando para conexão do ppoe criado..

    qq duvida eh só falar !!

    []´s

    Gonzaga
    os dois adsl sao da mesma operadora? estou com problema tenho dois adsl de 1,5mega da oi so que tem o mesmo gatewae dai so o adsl que autentica primeiro funcionada.
    vou explicar melhor antes aqui era brasil telecom um adsl faz 2 anos que uso e outro faz 3 meses peguei depois que a oi comprou a brasil telecom . fazia ja quase dois meses que o balanceamento estava funcionando perfeito, na sexta feira renicie a rb 450 do PCC e dai ocorreu o problema. o que teria que fazer para resolver esse problema?