+ Responder ao Tópico



  1. #481

    Question Re: PCC Balance de 3 a 16 links - Por: M4D3

    Apos ler quase que por completo esse topico. E ver a duvida de geral acabei chegando nessa configuração que esta me atendendo bem.

    Código :
    add action=mark-routing chain=output comment="" connection-mark=conn_na disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb disabled=no new-routing-mark=to_rb passthrough=no
     
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_ma0 passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 passthrough=yes per-connection-classifier=both-addresses:2/1
     
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_ma0 disabled=no in-interface=EthClientes new-routing-mark=to_nra passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 disabled=no in-interface=EthClientes new-routing-mark=to_nrb passthrough=no
     
     
     
    / ip firewall nat 
     
    add action=masquerade chain=srcnat comment="MASCARAMENTO PCC" disabled=no out-interface=pppoe-out1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=pppoe-out2
     
     
     
    / ip route
     
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-out1 scope=30 target-scope=10
    add comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=pppoe-out2 scope=30 target-scope=10
     
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_nra scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=to_nrb scope=30 target-scope=10


    Pesquisando um pouco mais no forum e no wiki internacional do MK acabei me deparando com essa configuração aqui.

    Código :
    / ip firewall mangle
    add chain=prerouting dst-address=10.111.0.0/24  action=accept in-interface=LAN
    add chain=prerouting dst-address=10.112.0.0/24  action=accept in-interface=LAN
     
    add chain=prerouting in-interface=pppoe-out1 connection-mark=no-mark action=mark-connection \
        new-connection-mark=conn_na
    add chain=prerouting in-interface=pppoe-out2 connection-mark=no-mark action=mark-connection \ 
        new-connection-mark=conn_nb
     
    add chain=prerouting  in-interface=EthClientes connection-mark=no-mark dst-address-type=!local \ per-connection-classifier=both-addresses:2/0action=mark-connection new-connection-mark=conn_ma0
     
    add chain=prerouting  in-interface=EthClientes connection-mark=no-mark dst-address-type=!local \ 
        per-connection-classifier=both-addresses:2/1 action=mark-connection new-connection-mark=conn_mb1
     
    add chain=prerouting connection-mark=conn_na in-interface=EthClientes action=mark-routing \ 
        new-routing-mark=to_ra
    add chain=prerouting connection-mark=conn_nb in-interface=EthClientes action=mark-routing \
        new-routing-mark=to_rb
     
    add chain=output connection-mark=conn_na action=mark-routing new-routing-mark=to_ra     
    add chain=output connection-mark=conn_nb action=mark-routing new-routing-mark=to_rb
     
     
    / ip route
    add dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_ra check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=to_rb check-gateway=ping
     
    add dst-address=0.0.0.0/0 gateway=pppoe-out1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=pppoe-out2 distance=2 check-gateway=ping
     
    / ip firewall nat 
    add chain=srcnat out-interface=pppoe-out1 action=masquerade
    add chain=srcnat out-interface=pppoe-out2 action=masquerade

    minha duvida é. qual seria a difereneça de uma para a outra? por que ao analizar ela vejo que a marcação de pacotes são diferentes e algumas outras coisas.

    Desde ja agradeço pela atenção.

  2. #482

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Fala galera, estou aqui novamente!!!
    Bom meu PCC depois das ultimas duvidas q o Aka2005 e o Geek me resolveu em relacao a o DNS, esta perfeito desde janeiro.
    Volte e meia tenho problemas com alguns sites, mais ai tiro do balanceador e fica td ok.

    Bom eu estava aqui analisando, e percebi q o link DSL soh fica ruim, quando o upload sobe muito. Ex.: Aqui to usando um dedicado de 10mb up e down, e dois DSL de 8mb. Bom os DSL 8mb ele chega ate 800kbps de up, porem quando passa dos 400kbps ele sobe a latencia e o ping sobe e consequentemente, sobe de todos que estao saindo por ele no momento.

    Bom ai pensei, e se limitar o upload do DSL para 400kbps!!!? Como tenho 10mb de up no link dedicado, acho que nao terei problemas pois o PCC ira balancear o up!!
    Bom tentei aqui, criei uma QUEUE para o discador pppoe, nao deu certo! Criei tbm uma queue para a interface do DSL e tbm nao deu certo!
    Fui na interface, achei uma opcao de Bandwidth tentei limitar o upload em 400kbps e tbm nao deu certo!!!
    Esse nao deu certo que falo é que nem chegou a discar o pppoe para o DSL. É soh eu limitar a banda que ele nao disca!!

    Bom entao estou aqui perguntando a vcs, se tem como eu limitar a banda UP do meu link DSL que esta em modo bridge discando pppoe????
    Eu pensei em colocar uma RB antes para discar e limitar o PPPoE do DSL, mas nao fiz o teste ainda. Se caso ninguem souber como limitar o upload direto da router que disca, irei fazer esse teste com outra RB.

    Aguardo. Obrigado.



  3. #483

    Post Re: PCC Balance de 3 a 16 links - Por: M4D3

    Parabéns pelo tópico muito bem explicado.

    Tenho uma dúvida pois no meu caso tenho 3 Links dedicado + 1 link PTT na seguinte forma:

    Operadora A 50 Mbps
    Operadora B 50 Mbps
    Operadora C 30 Mbps
    Link PTT 20 Mbps

    Como posso fazer um loadbalance nesse caso pois todos meus clientes utilizam meus IPs de minha AS.

    Como fazer Loand Balance com BGP com 4 links diferentes usando IPs públicos de uma AS sem fazer mascarade ???

  4. #484

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Parabéns pelo tópico muito bem explicado.

    Tenho uma dúvida pois no meu caso tenho 3 Links dedicado + 1 link PTT na seguinte forma:

    Operadora A 50 Mbps
    Operadora B 50 Mbps
    Operadora C 30 Mbps
    Link PTT 20 Mbps

    Como posso fazer um loadbalance nesse caso pois todos meus clientes utilizam meus IPs de minha AS.

    Como fazer Loand Balance com BGP com 4 links diferentes usando IPs públicos de uma AS sem fazer mascarade ???



  5. #485

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Eduardo, procura pelos artigos do Julião Braga (abraço julião), tem material suficiente pra escrever um livro, ou pra resolver o seu problema se assim preferir.

    O alexandre também escreveu aqui no fórum sobre o prepeend no bgp, tem diversos artigos abordando isso aqui no underlinux.

    Valeu

  6. #486

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Olá a todos!
    Alguém pode me ajudar?
    tô com o seguinte problema, uso a rb1100, com 4 links adsl de 10mb, mas quase todo trafego sai pelo link 1, enquanto os outros 3 ficam baixissimo o consumo, e quando o link 1 ja esta no gargalo, causa lentidão na rede, e não puxa banda dos outros 3 links.
    não entendo muito bem como configurar o pcc mikrotik.
    alguém pode olhar minhas configurações e verificar onde está errado?
    segue o endereço com a tela mostrando as rotas e o trafego das interfaces;
    ImageShack

    segue também um export das minhas configurações ip/firewall;

    /ip firewall address-list
    add address=192.168.100.0/24 disabled=no list=rede-interna
    add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    add address=192.168.100.0/24 disabled=no list=loopback
    add address=189.72.217.102 comment="COLOCAR O IP PARA FICAR FORA DO BALANCE" disabled=no list=loopback
    add address=201.7.176.0/20 comment=Globo disabled=no list=loopback
    add address=201.88.207.50 disabled=no list=loopback
    /ip firewall connection tracking
    set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s tcp-close-wait-timeout=10s tcp-established-timeout=1d tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
    tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
    /ip firewall filter
    add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes
    add action=drop chain=virus comment="bloqueio de VIRUS conhecidos" disabled=no dst-port=445 protocol=tcp
    add action=drop chain=virus disabled=no dst-port=445 protocol=udp
    add action=drop chain=virus disabled=no dst-port=593 protocol=tcp
    add action=drop chain=virus disabled=no dst-port=1080 protocol=tcp
    add action=drop chain=virus disabled=no dst-port=1363 protocol=tcp
    add action=drop chain=virus disabled=no dst-port=1364 protocol=tcp
    add action=drop chain=virus disabled=no dst-port=1373 protocol=tcp
    add action=drop chain=virus disabled=no dst-port=1377 protocol=tcp
    add action=drop chain=virus disabled=no dst-port=1368 protocol=tcp
    add action=drop chain=virus disabled=no dst-port=1433-1434 protocol=tcp
    add action=drop chain=virus disabled=no dst-port=1024-1030 protocol=tcp
    add action=drop chain=virus disabled=no dst-port=1214 protocol=tcp
    add action=drop chain=virus comment="Drop Blaster Worm" disabled=no dst-port=135-139 protocol=tcp
    add action=drop chain=virus comment="Drop Messenger Worm" disabled=no dst-port=135-139 protocol=udp
    add action=drop chain=virus comment="Drop Blaster Worm" disabled=no dst-port=445 protocol=tcp
    add action=drop chain=virus comment="Drop Blaster Worm" disabled=no dst-port=445 protocol=udp
    add action=drop chain=virus comment=________ disabled=no dst-port=593 protocol=tcp
    add action=drop chain=virus comment=________ disabled=no dst-port=1024-1030 protocol=tcp
    add action=drop chain=virus comment="Drop MyDoom" disabled=no dst-port=1080 protocol=tcp
    add action=drop chain=virus comment=________ disabled=no dst-port=1214 protocol=tcp
    add action=drop chain=virus comment="ndm requester" disabled=no dst-port=1363 protocol=tcp
    add action=drop chain=virus comment="ndm server" disabled=no dst-port=1364 protocol=tcp
    add action=drop chain=virus comment="screen cast" disabled=no dst-port=1368 protocol=tcp
    add action=drop chain=virus comment=hromgrafx disabled=no dst-port=1373 protocol=tcp
    add action=drop chain=virus comment=cichlid disabled=no dst-port=1377 protocol=tcp
    add action=drop chain=virus comment=Worm disabled=no dst-port=1433-1434 protocol=tcp
    add action=drop chain=virus comment="Bagle Virus" disabled=no dst-port=2745 protocol=tcp
    add action=drop chain=virus comment="Drop Dumaru.Y" disabled=no dst-port=2283 protocol=tcp
    add action=drop chain=virus comment="Drop Beagle" disabled=no dst-port=2535 protocol=tcp
    add action=drop chain=virus comment="Drop Beagle.C-K" disabled=no dst-port=2745 protocol=tcp
    add action=drop chain=virus comment="Drop porta proxy" disabled=no dst-port=3127-3128 protocol=tcp
    add action=drop chain=virus comment="Drop Backdoor OptixPro" disabled=no dst-port=3410 protocol=tcp
    add action=drop chain=virus comment=Worm disabled=no dst-port=4444 protocol=tcp
    add action=drop chain=virus comment=Worm disabled=no dst-port=4444 protocol=udp
    add action=drop chain=virus comment="Drop Sasser" disabled=no dst-port=5554 protocol=tcp
    add action=drop chain=virus comment="Drop Beagle.B" disabled=no dst-port=8866 protocol=tcp
    add action=drop chain=virus comment="Drop Dabber.A-B" disabled=no dst-port=9898 protocol=tcp
    add action=drop chain=virus comment="Drop Dumaru.Y" disabled=no dst-port=10000 protocol=tcp
    add action=drop chain=virus comment="Drop MyDoom.B" disabled=no dst-port=10080 protocol=tcp
    add action=drop chain=virus comment="Drop NetBus" disabled=no dst-port=12345 protocol=tcp
    add action=drop chain=virus comment="Drop SubSeven" disabled=no dst-port=27374 protocol=tcp
    add action=drop chain=virus comment="Drop Kuang2" disabled=no dst-port=17300 protocol=tcp
    add action=drop chain=virus comment="Drop PhatBot, Agobot, Gaobot" disabled=no dst-port=65506 protocol=tcp
    add action=drop chain=input comment=FTP disabled=yes dst-port=21 protocol=tcp
    add action=drop chain=input comment=SSH disabled=no dst-port=22 protocol=tcp
    add action=drop chain=input comment=TELNET disabled=no dst-port=23 protocol=tcp
    add action=accept chain=input comment="Accept established connections" connection-state=established disabled=no
    add action=accept chain=input comment="Accept related connections" connection-state=related disabled=no
    add action=drop chain=input comment="Drop invalid connections" connection-state=invalid disabled=no
    add action=accept chain=input comment="Allow limited pings" disabled=no limit=50/5s,2 protocol=icmp
    add action=drop chain=input comment="Drop excess pings" disabled=no protocol=icmp
    /ip firewall mangle
    add action=accept chain=prerouting comment="out load DST" disabled=no dst-address-list=rede-interna in-interface=Clientes
    add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=Clientes
    add action=mark-connection chain=input comment="Make the packet leaves via same interface" connection-state=new disabled=no in-interface=LINK1-pppoe new-connection-mark=LINK1_conn \
    passthrough=yes
    add action=mark-connection chain=input connection-state=new disabled=no in-interface=LINK2-pppoe new-connection-mark=LINK2_conn passthrough=yes
    add action=mark-connection chain=input connection-state=new disabled=no in-interface=LINK3-pppoe new-connection-mark=LINK3_conn passthrough=yes
    add action=mark-connection chain=input connection-state=new disabled=no in-interface=LINK4-pppoe new-connection-mark=LINK4_conn passthrough=yes
    add action=mark-routing chain=output connection-mark=LINK1_conn connection-state=new disabled=no new-routing-mark=to_LINK1 passthrough=no
    add action=mark-routing chain=output connection-mark=LINK2_conn connection-state=new disabled=no new-routing-mark=to_LINK2 passthrough=no
    add action=mark-routing chain=output connection-mark=LINK3_conn connection-state=new disabled=no new-routing-mark=to_LINK3 passthrough=no
    add action=mark-routing chain=output connection-mark=LINK4_conn connection-state=new disabled=no new-routing-mark=to_LINK4 passthrough=no
    add action=mark-connection chain=prerouting comment="PCC Balance" disabled=no dst-address-type=!local in-interface=Clientes new-connection-mark=LINK1_conn passthrough=yes \
    per-connection-classifier=both-addresses:4/0
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=Clientes new-connection-mark=LINK2_conn passthrough=yes per-connection-classifier=\
    both-addresses:4/1
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=Clientes new-connection-mark=LINK3_conn passthrough=yes per-connection-classifier=\
    both-addresses:4/2
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=Clientes new-connection-mark=LINK4_conn passthrough=yes per-connection-classifier=\
    both-addresses:4/3
    add action=mark-routing chain=prerouting comment="Marking all the packets" connection-mark=LINK1_conn disabled=no in-interface=Clientes new-routing-mark=to_LINK1 passthrough=no
    add action=mark-routing chain=prerouting connection-mark=LINK2_conn disabled=no in-interface=Clientes new-routing-mark=to_LINK2 passthrough=no
    add action=mark-routing chain=prerouting connection-mark=LINK3_conn disabled=no in-interface=Clientes new-routing-mark=to_LINK3 passthrough=no
    add action=mark-routing chain=prerouting connection-mark=LINK4_conn disabled=no in-interface=Clientes new-routing-mark=to_LINK4 passthrough=no
    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment="place hotspot rules here" disabled=yes
    add action=masquerade chain=srcnat disabled=no out-interface=LINK1-pppoe
    add action=masquerade chain=srcnat disabled=no out-interface=LINK2-pppoe
    add action=masquerade chain=srcnat disabled=no out-interface=LINK3-pppoe
    add action=masquerade chain=srcnat disabled=no out-interface=LINK4-pppoe
    /ip firewall service-port
    set ftp disabled=no ports=21
    set tftp disabled=no ports=69
    set irc disabled=no ports=6667
    set h323 disabled=no
    set sip disabled=no ports=5060,5061
    set pptp disabled=no

    Por favor me ajudem!
    Desde ja muito Obrigado!
    bhyll



  7. #487

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Vou testar as regras em breve assim que minha RB450G chegar hehehe... Posto aqui os resultados.

    Abraço!

  8. #488

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Excelente post, balance funcionando 100% em uma rb750g com dois links ip telefonica...

    Att,
    Clistenes



  9. #489

    Question Re: PCC Balance de 3 a 16 links - Por: M4D3

    Luciano, coloquei as regras em uma RB750G funcionou numa boa, com 2 links ADSL 600k, como vi eles balanceiam, como poderia somar os dois link's e o acesso externo, seria a forma correta como os amigos aki ja falaram anteriormente? (só quero saber sua opnião, caso vc tenha alguma adição ao conteúdo abaixo, ficaria grato)

    Código :
    Para somar os links:
    both-address > para both-address and ports

    Código :
    Para o acesso externo:
    add action=accept chain=input comment="INPUT - IPs Gerenciamento -+-+-+" disabled=no src-address=0.0.0.0/0

    Parabéns pelo tuto super eficiente. Abraços!

  10. #490

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    segui a risca tudo que vc postou com exeção que no meu são apenas dois links e na 1°regra
    < add action=accept chain=prerouting comment="SEM BALANCE" disabled=no dst-address-list=sem_balance in-interface=EthClientes
    esta primera regra aceita as conexões para todos os ips de destino que se encontrarem na lista 'sem_balance' que irão sair pela rota padrão> quando ativo o dst-address-list=sem_balance, para tudo não consi nem pingar pra fora Será que vc pode me ajudar seu post foi o unico que eu entedi melhor.



  11. #491

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Fala galera, tenho um balance rodando aqui blz, mais to precisando fazer outro com links de cargas diferentes deu uma olhada aqui no post e a única coisa que não entendi muito bem foi essa parte.

    agora utilizando os classificadores (0,1,2 e portanto são 3) na interface de clientes criamos novas marcas de conexão (conn_ma0, conn_mb1, conn_mc2), notem que se tivessemos 4 links seria aquie que fariamos as alterações para (0,1,2,3 e portanto são 4) ficando 4/0, 4/1, 4/2, 4/3 ou ainda se tivessemos links assimétricos onde por exemplo:

    LinkX de 512k
    LinkY de 1024k
    LinkZ de 2048k

    somariamos todos os links e dividiriamos pelo valor do menor link então teriamos 3584k/512k=7 então teriamos 7 marcações de pcc indo de 7/0 até 7/6 das quais devemos direcionar a primeira pro link X, a segunda e terceira pro link Y e as quatro restantes para o link Z fazendo nosso sistema perfeitamente equilibrado, vale resaltar que sistemas do tipo ADSL não garantem a banda e portanto devemos fazer testes em cada um dos links para aferir as velocidades possíveis em cada um, já vi muitos casos onde um link desse tipo de 2Mb era melhor do que o de 4Mb da mesma operadora instalada no mesmo local, também se deve criar as marcações para input e output.




    será que alguem pode me ajudar a entender melhor essa parte, !!! que link recebe primeiro a conexão e tal????? não entendi muito bem como fazer o equiblíbrio de carga.

  12. #492

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    nota 10 para esse script fiz seguindo as orientações aqui sujeridas e tenho 4 links, 3 de 10Mb e 1 de 1Mb nao ficou 10... ficou espetacular funciona perfeitamente cargas dividas perfetamente coisa que eu pensava que nao funcionava PARABENS!!!



  13. #493

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    ola galera queria q vcs poderia me da uma força , como fazer um balanceamento entre 2 link em bridge , agradeço ajuda de vcs ...

  14. #494

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Bom dia,

    Tem como Implementar o Netwatch para monitorar quedas no link nesse exemplo de PCC? (para os outros links "assumirem")

    Obrigado.



  15. #495

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    pesquisei no forum e vi alguma coisa a respeito feito com script! muito bom e so da uma pesquisada ai!

  16. #496

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Amigos, só uma dúvida, ainda não testei, mas antes de iniciar gostaria apenas de saber o seguinte:

    Imagine o cenário onde tenho 2 links em que a operadora me entrega em 2 roteadores Cisco, destes roteadores eu ligo ruma RB fazendo PCC, em seguida distribuo para minha rede roteada com OSPF e na RB do POP quero entregar um IP publico de um dos links para algum cliente que autentica por PPPoE.

    Vai funcionar normalmente, este cliente vai automaticamente sair pelo link do IP designado a ele?

    Os demais clientes com IPs publicos vão sair balanceados?



  17. #497

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Boa noite Galera, uma duvida eu posso fazer um load alance dentro de outro load?? tipo tenho um load com dois link dedicado, em um bairro que tenho muitos clientes eu quero por um outro link adsl para desafogar um pouco, é possível ??

  18. #498

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Citação Postado originalmente por agatangelos Ver Post
    Boa noite Galera, uma duvida eu posso fazer um load alance dentro de outro load?? tipo tenho um load com dois link dedicado, em um bairro que tenho muitos clientes eu quero por um outro link adsl para desafogar um pouco, é possível ??
    Tudo é possível!



  19. #499

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    É sim, tem um tópico ai bem fácil mostrando como fazer load balance com cargas diferentes pode lhe ajudar a adicionar esse novo link no seu que já funciona.

  20. #500

    Padrão Re: PCC Balance de 3 a 16 links - Por: M4D3

    Gente preciso fazer com que um link da minha rede interna 192.168.100.100 saia sempre pelo link1 que esta na ether2, este link tem ip valido e tenho um sistema que só roda se ele acessar pelo ip valido ... alguém pode me ajudar ... Um abraço ... Rodrigo