Página 6 de 26 PrimeiroPrimeiro ... 234567891011 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #101

    Padrão

    Caro thiagotgc,

    suas regras estao aparentemente normais tmb, n uso as regras q o m4d3 fez as minhas é um pouco diferente da deles, não q a dele esta errado, mas acredito q é algo q posso estar confundindo, vou revisar sua estrutura e vou postar elas de acordo com as q faço e vc troca para vermos o q dá.

  2. #102



  3. #103

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    Ok Xará!!! estou esperando suas configs =)
    Amigo adptei suas regras de acordo com as qu eu faço, coloque e veja como q ficou.

    detalhe, pelo que vi em suas regras posso estar enganado mas me parece q vc esta atendendo cliente nela, pq vi umas marcações de proxy ai junto, se tiver o ideal seria vc fazer o balanceamento separado dos clientes. Caso as regras n derem certo nos relate o seu problema.

    Código :
    /ip firewall mangle
    add action=mark-connection chain=input comment=ether1_conn disabled=no in-interface=LINK1 new-connection-mark=ether1_conn passthrough=yes
    add action=mark-connection chain=input comment=ether2_conn disabled=no in-interface=LINK2 new-connection-mark=ether2_conn passthrough=yes
    add action=mark-routing chain=output comment=to_ether1 connection-mark=ether1_conn disabled=no new-routing-mark=to_ether1 passthrough=no
    add action=mark-routing chain=output comment=to_ether2 connection-mark=ether2_conn disabled=no new-routing-mark=to_ether2 passthrough=no
    add action=accept chain=prerouting comment="fora load DST" disabled=no dst-address-list=sem_balance in-interface=LOCAL
    add action=mark-connection chain=prerouting comment=ether1_conn disabled=no dst-address-type=!local in-interface=LOCAL new-connection-mark=\
        ether1_conn passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment=ether2_conn disabled=no dst-address-type=!local in-interface=LOCAL new-connection-mark=\
        ether2_conn passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment=to_ether1 connection-mark=ether1_conn disabled=no in-interface=LOCAL new-routing-mark=to_ether1 \
        passthrough=no
    add action=mark-routing chain=prerouting comment=to_ether2 connection-mark=ether2_conn disabled=no in-interface=LOCAL new-routing-mark=to_ether2 \
        passthrough=no
     
    /ip firewall nat
    add action=masquerade chain=srcnat comment=to_ether1 disabled=no out-interface=LINK1
    add action=masquerade chain=srcnat comment=to_ether2 disabled=no out-interface=LINK2
     
    /ip route
    add comment="BALANCEAMENTO DE CARGA - LINK1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=201.90.162.161 routing-mark=to_ether1 scope=30 target-scope=\
    10
    add comment="BALANCEAMENTO DE CARGA - LINK2" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=189.22.8.1 routing-mark=to_ether2 scope=30 target-scope=10
    add comment="LINK2 - TELEFONICA" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=189.22.8.1 scope=30 target-scope=10
    add comment="LINK1 - EMBRATEL" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=201.90.162.161 scope=30 target-scope=10

  4. #104

    Padrão

    Vlw xará, estarei testando AGORA

    Sobre o proxy, é apenas um teste, mas nao estou usando nao. pode desconsiderar.

    Jaja posto o resultado



  5. #105

    Padrão

    Blz.. testado.. e infelizmente nao aprovado =/

    http://img62.imageshack.us/img62/3294/95893852.png

    Me diz uma coisa Xara, qual diferença do seu para a do m4d3?
    E outra coisa... por que sera que continua taxando só um link?

  6. #106

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    Blz.. testado.. e infelizmente nao aprovado =/

    http://img62.imageshack.us/img62/3294/95893852.png

    Me diz uma coisa Xara, qual diferença do seu para a do m4d3?
    E outra coisa... por que sera que continua taxando só um link?
    Cara muito estranho... vc já testou esse link q esta dando menos somente em uma maquina para ver se ele esta dando os 2MB ?



  7. #107

    Padrão

    Amigo... sim testei.. ambos os links estao com 2mb....

  8. #108

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    Amigo... sim testei.. ambos os links estao com 2mb....
    Sem compromisso, se puder passar o IP, USER E SENHA para mim no msn ou email analiso para vc e postamos aqui qual é o problema, até eu quero ver agora q fiquei encucado....



  9. #109

    Padrão

    Ok, me add no emiéssiene

    thiago[contratack]hotmail.com

    Aguardo!!!

  10. #110

    Padrão

    Aí pessoal, meu balanceamento ficou beleza agora. Tinha incluído umas regras duas vezes e agora tá beleza. Fiz também o que o Tiago Matias me orientou de colocar as interfaces EthLinkx em pppoe-outx e assim sucessivamente. Só que agora não consigo acessar de fora a máquina. Como faço para, de fora, ir direto para o ip xxxxxxxx da máquina que quero sem passar pelo balanceamento?



  11. #111

    Padrão

    Citação Postado originalmente por m4d3 Ver Post
    Já, se você ler com atenção o que escrevi acima vai ver que o exemplo é citado e completo.


    Abraço

    Amigo tudo bem vejo que varias pessoas inclusive eu estou tendo problemas com a carga dos link, gostaria muito que como autor do topico pudesse analizar e dar uma força pra turma, no mais obrigado pela fornça.

  12. #112

    Padrão

    Ta fogo, sem o balanceamento.. só sobrecarregando um link só!!



  13. #113

    Padrão

    CONSEGUI

    Troquem de both-address para both-address and ports

    PERGUNTA:

    Amigos por que sera que quando deixo both-address para both-address and ports ele "soma os links" mas tem gente dizendo que ele ta dando problema com paginas...

    Se eu voltar both-address ele nao "soma" PQ?

    Ta ai:

    http://img18.imageshack.us/img18/6820/semttulowg.png
    Última edição por thiagotgc; 30-09-2009 às 17:03.

  14. #114

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    CONSEGUI

    Troquem de both-address para both-address and ports

    PERGUNTA:

    Amigos por que sera que quando deixo both-address para both-address and ports ele "soma os links" mas tem gente dizendo que ele ta dando problema com paginas...

    Se eu voltar both-address ele nao "soma" PQ?

    Ta ai:

    http://img18.imageshack.us/img18/6820/semttulowg.png
    Não pergunte a mesma coisa em topicos diferentes por favor.

    sua resposta veja aqui >>> https://under-linux.org/f128610-pcc-17#post438209

    Ps. se vc tivesse explicado desde o começo que queria SOMAR OS LINKS já teriamos resolvido seu problema, mas em todos os seu topicos vc so diz q não esta funcionando, e não que em um download não se soma todos os links.
    Última edição por tiagomatias; 30-09-2009 às 17:27.



  15. #115

    Padrão

    Tiago, em todo momento eu disse que ele só estava carregando apenas UM(1) LINK... eu até postei imagens.

    Mas td bem, o importante é que agora esta OK...

  16. #116

    Padrão

    Ajuda aí pessoal. Depois que coloquei o pcc o voip não funciona mais. Como faço para passar direto sem o pcc. E preciso também acessar de fora a maquina com o ip xxx.xx.xxx.xxx mas não tá passando pelo MK. Como faço? Ajuda aí galera.



  17. #117

    Padrão

    Sobre o VoIP eu nao sei o que voce precisa... Sobre o acesso ao MK tente isso

    add action=accept chain=input comment="INPUT - IPs Gerenciamento -+-+-+" disabled=no src-address=0.0.0.0/0
    Isso libera acesso ao MK de qualquer IP, ou seja... modifique a regra conforme sua necessidade

    Espero ter ajudado

  18. #118

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    Sobre o VoIP eu nao sei o que voce precisa... Sobre o acesso ao MK tente isso



    Isso libera acesso ao MK de qualquer IP, ou seja... modifique a regra conforme sua necessidade

    Espero ter ajudado
    OK Tiago, mas também tem que liberar em Nat além do mangle. Antes do balanceamento funcionava somente com a regra do nat, mas agora tem que usar em mangle tb. Pelo menos aqui só funcionou assim.



  19. #119

    Padrão

    Entao eu esqueci de dizer que a regra ali eh Filte Filter

    /ip firewall filter

    OK?

  20. #120

    Padrão

    Parou de funcionar. Estava funcionando com a regra quando coloquei em mangle e nat, mas agora parou. Tentei incluir tb em filter como disse, mas não funcionou. Alguém pode ajudar? E sobre o voip alguém tem alguma sugestão. Ajuda aí pessoal.