+ Responder ao Tópico



  1. Citação Postado originalmente por interhome Ver Post
    Quando se compara Ap com Rb estamos comparando alem dos sistema, que querendo ou não, o MK é o mais completo. Quanto a hardware. Sem duvida, o processamento e memoria de 1 Rb é muito superior.

    O problema que vc esta passando de cara pode ser 2 coisas, fonte ou canal.

    Outra coisa, o mk é tão completo que lhe permite por exemplo desconectar o cliente que possui o Ack alto.

    Segue Script:

    name="ack" owner="admin" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff last-started=jul/18/2009 16:29:15 run-count=9425
    source=
    # Defina abaixo o valor m\EDnimo de ACK
    : global ack 65;
    # Defina abaixo 1 para bloquear e 0 para n\E3o bloquear o cliente que estiver acima do valor m\EDnimo
    :global block 0;
    # Defina abaixo 1 para dropar e 0 para n\E3o dropar o cliente que estiver acima do valor m\EDnimo
    :global drop 1;

    # Defina abaixo a Interface
    :global interf "Est_Cbt_Pntscm_06";
    # =============================================================================
    # ATEN\C7\C3O ! SO FA\C7A ALTERA\C7\D5ES ABAIXO, SE TIVER CERTEZA DO QUE ESTA FAZENDO
    # =============================================================================
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info "Listando Clientes com ACK acima de $ack ms:";
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
    :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
    :log info ("COMENTARIO: " . [/interface wireless registration-table get $i comment] . " - MAC: " . [/interface wireless registration-table get $i ma>
    :set mac [/interface wireless registration-table get $i mac-address];
    :set cliente [/interface wireless access-list find mac-address=$mac];
    :if ($block = 1) do={
    /interface wireless access-list disable $cliente;
    };
    :if ($drop = 1) do={
    /interface wireless registration-table remove $i;
    };
    :set total total+1;
    };
    };
    :if ($total = 0) do={
    :log info "Parab\E9ns ! Nenhum Cliente com ACK acima de $ack ms encontrado.";
    };


    ------------------------------------------------------
    OUTRA REGRA
    ------------------------------------------------------

    # Defina abaixo o valor mínimo de ACK
    :global ack 46;
    # Defina abaixo 1 para bloquear e 0 para não bloquear o cliente que estiver acima do valor mínimo
    :global block 0;
    # Defina abaixo 1 para dropar e 0 para não dropar o cliente que estiver acima do valor mínimo
    :global drop 1;
    # Defina abaixo a Interface
    :global interf "MEGANET3";
    # =================================== =================================== =======
    # ATENÇÃO ! SO FAÇA ALTERAÇÕES ABAIXO, SE TIVER CERTEZA DO QUE ESTA FAZENDO
    # =================================== =================================== =======
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info "Listando Clientes com ACK acima de $ack ms:";
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
    :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
    :log info ("COMENTARIO: " . [/interface wireless registration-table get $i comment] . " - MAC: " . [/interface wireless registration-table get $i mac-address] . " - ACK: " . [/interface wireless registration-table get $i ack-timeout]);
    :set mac [/interface wireless registration-table get $i mac-address];
    :set cliente [/interface wireless access-list find mac-address=$mac];
    :if ($block = 1) do={
    /interface wireless access-list disable $cliente;
    };
    :if ($drop = 1) do={
    /interface wireless registration-table remove $i;
    };
    :set total total+1;
    };
    };
    :if ($total = 0) do={
    :log info "Parabéns ! Nenhum Cliente com ACK acima de $ack ms encontrado.";
    };



    Experimente criar o script através de ssh.

    /system script name=ackalto
    /system script edit ackalto source
    (copie e cole o script)

    em ssh execute ele para ver se dá algum problema :

    /system script run ackalto

    Outra coisa importante, para trocar de Ap para Rb foi necessário alterar o pigtail. Reveja os conectores, Veja se as soldas estão bem feitas. Qualidade do cabo, comprimento ....

    Para o sistema funcionar corretamente tem que haver um casamento ideal. Coisas que passam despercebidas como uma caixa de ferro, separada para Rb, melhora muito a qualidade do cliente.
    muito bom amigo vou tentar e posto o mais breve possivel, esses scripts só poderão entrar em vigor se os clientes estiverem cadastrados em access list?

  2. Citação Postado originalmente por Coliseu Ver Post
    muito bom amigo vou tentar e posto o mais breve possivel, esses scripts só poderão entrar em vigor se os clientes estiverem cadastrados em access list?
    Sim. Registrando no access list é possivel tomar algumas ações, 1 simples é evitar que o cliente se conecte na antena errada.



  3. Citação Postado originalmente por interhome Ver Post
    Sim. Registrando no access list é possivel tomar algumas ações, 1 simples é evitar que o cliente se conecte na antena errada.
    maravilha, consegui fazer o mk funcionar belezinha!!
    vamos lá: a potencia deixei em default:28dbm, a fonte continuou a do pc mesmo(para um cartão apenas foi constatado que tá de bom tamanho mesmo operando em 12V), adicionei o script do amigo+algumas pequenas modificações que achei garimpando na net, adicionei ele em SYSTEM>SCHEDULER, coloquei para rodar de 5 em 5 minutos, todos os clientes com ack acima de 55 ele desconecta e reconecta em seguida.
    com isso o sistema ficou do jeito que sempre quis....
    script:
    # Defina abaixo o valor mínimo de ACK
    :global ack 55;
    # Defina abaixo 1 para bloquear e 0 para não bloquear o cliente que estiver acima do valor mínimo
    :global block 0;
    # Defina abaixo 1 para dropar e 0 para não dropar o cliente que estiver acima do valor mínimo
    :global drop 1;
    # Defina abaixo a Interface
    :global interf "wlan1";
    # =================================== =================================== =======
    # ATENÇÃO ! SO FAÇA ALTERAÇÕES ABAIXO, SE TIVER CERTEZA DO QUE ESTA FAZENDO
    # =================================== =================================== =======
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info "Listando Clientes com ACK acima de $ack ms:";
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
    :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
    :log info ("COMENTARIO: " . [/interface wireless registration-table get $i comment] . " - MAC: " . [/interface wireless registration-table get $i mac-address] . " - ACK: " . [/interface wireless registration-table get $i ack-timeout]);
    :set mac [/interface wireless registration-table get $i mac-address];
    :set cliente [/interface wireless access-list find mac-address=$mac];
    :if ($block = 1) do={
    /interface wireless access-list disable $cliente;
    };
    :if ($drop = 1) do={
    /interface wireless registration-table remove $i;
    };
    :set total total+1;
    };
    };
    :if ($total = 0) do={
    :log info "Parabéns ! Nenhum Cliente com ACK acima de $ack ms encontrado.";
    };

    muito obrigado a todos, e a você que quer adquirir esse sistema, com essas modificações ele fica show valeu
    Última edição por Coliseu; 14-09-2009 às 12:04.

  4. A grande vantagem do mk, é essa capacidade de administracao que ele permite. Fico feliz que mudou a sua opniao quanto ao mk. A unica coisa que acho alto é o 28 dbm de potencia.

    Gosto do forum, porque são pessoas de todos os cantos somando idéias e experiencias. A grande recompensa é o agradecimento.



  5. Citação Postado originalmente por interhome Ver Post
    A grande vantagem do mk, é essa capacidade de administracao que ele permite. Fico feliz que mudou a sua opniao quanto ao mk. A unica coisa que acho alto é o 28 dbm de potencia.

    Gosto do forum, porque são pessoas de todos os cantos somando idéias e experiencias. A grande recompensa é o agradecimento.
    veja só quando estava com o radio senão (sl 2611 200mw) havia alguns clientes distantes que mesmo com o sinal baixo, conectava e acessava satisfatoriamente(tanto que nem me lembrava desses clientes a algum tempo)com a rb, o mesmo sinal digamos 39% (no software ralink) pings altissimos não conssegue navegação, mesmo com ack em 30(por conta das regras que apliquei que desconecta o cliente acima de 55)!

    1ºduvida cruel...em ambientes muito poluido, o ideal em uma antena omni seria colocar o maximo ou o minimo e ir almentando?

    se eu coloco o mesmo 200mw que tava, fica ruim,

    2ºduvida o sinal que pego no mk e sinal que recebo do cliente?
    porque as vezes baixo a potencia o sinal no mk fica na mesma, porém no cliente fica bem mais baixo.

    3º tenho uma duvida para que serve o periodic calibration, o que ele faz calibra o que? já tentei respostas na net más não deu para sanar minha duvida.

    obrigado quem poder me esclarecer essas duvidas agradeço desde de já.






Tópicos Similares

  1. Respostas: 0
    Último Post: 28-03-2009, 07:55
  2. Respostas: 1
    Último Post: 23-01-2009, 16:06
  3. Respostas: 15
    Último Post: 07-10-2008, 17:49
  4. Mikrotik Em AP-BRIDGE com squid! Duvida
    Por diox no fórum Redes
    Respostas: 21
    Último Post: 30-05-2008, 23:36
  5. Segurança Mikrotik como Ap Bridge
    Por delorto no fórum Redes
    Respostas: 1
    Último Post: 04-10-2006, 20:20

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L