+ Responder ao Tópico



  1. #1

    Padrão Direcionar a primeira navegação

    Gostaria de saber como faço para controlar a primeira navegação do usuario, para quando o usario abrir o navegar ir dereto para o site do provedor, alguem pode me ajudar...

  2. #2

    Padrão

    irmao tb to em busca disso.
    sem que existe uma regra facil para hotspot, mas aqui a situação eh essa:

    servidor-mkt amarrando ip+mac+queue para controle de banda-> 4 rbs em ap-bridge

    alguem ae pra dau uma maozinha pra nois ?



  3. #3

    Padrão

    Procurem por portal cativo, captura de página, ou captive portal. Boa sorte.

  4. #4

    Padrão

    respondendo.... é o seguinte, você tem que fazer assim, aplica esta regra em

    ip firewall nat

    add action=dst-nat chain=dstnat comment=Aviso connection-limit=!1,32 disabled=no dst-port=80 protocol=tcp src-address-list=redireciona to-addresses=192.168.254.9 to-ports=80

    onde: o src address vc coloca o endereço do cliente ( 192.168.10.5) em em to-addresses= VC COLOCA O IP E PORTA DO TEU SERVIDOR WEB.

    esta regra so funciona uma vez, ou seja quando o usuário, hoje de manhã por exemplo, abrir o navegador, ele será redirecionando para o site, somente uma vez.
    Depois vc pode programar o mk para resetar esta regra a cada 24 horas (exemplo) e novamente ela irá fazer o seu trabalho.

    para resetar a regra do nat, programa o scheduler como na imagem em anexo.

    Aqui no provedor eu utilizo para mandar uma mensagem de que "sua internet poderá ser cortada" para os clientes que estão em atraso no pagamente. o redirecionamento é a cada 6 horas.
    Até mais...


    Citação Postado originalmente por juniorbelisario Ver Post
    Gostaria de saber como faço para controlar a primeira navegação do usuario, para quando o usario abrir o navegar ir dereto para o site do provedor, alguem pode me ajudar...
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         scheduler.jpg
Visualizações:	264
Tamanho: 	26,5 KB
ID:      	5470  
    Última edição por byosni; 17-09-2009 às 06:56.



  5. #5

    Padrão

    Citação Postado originalmente por byosni Ver Post
    respondendo.... é o seguinte, você tem que fazer assim, aplica esta regra em

    ip firewall nat

    add action=dst-nat chain=dstnat comment=Aviso connection-limit=!1,32 disabled=no dst-port=80 protocol=tcp src-address-list=redireciona to-addresses=192.168.254.9 to-ports=80

    onde: o src address vc coloca o endereço do cliente ( 192.168.10.5) em em to-addresses= VC COLOCA O IP E PORTA DO TEU SERVIDOR WEB.

    esta regra so funciona uma vez, ou seja quando o usuário, hoje de manhã por exemplo, abrir o navegador, ele será redirecionando para o site, somente uma vez.
    Depois vc pode programar o mk para resetar esta regra a cada 24 horas (exemplo) e novamente ela irá fazer o seu trabalho.

    para resetar a regra do nat, programa o scheduler como na imagem em anexo.

    Aqui no provedor eu utilizo para mandar uma mensagem de que "sua internet poderá ser cortada" para os clientes que estão em atraso no pagamente. o redirecionamento é a cada 6 horas.
    Até mais...
    Bom dia amigo, algum tempo atras tentei usar estas regras citadas, ate que funcionou o unico problema foi que, ela se tornou a pagina inicial do cliente, sendo assim se o cliente tinha google.com.br como pagina inicial, o mesmo nao iria conseguir abri-lo nem em outra seção, todas as vezes que abria a pagina do ggole vinha esta pagina de aviso.. sera que fiz algo de errado?

  6. #6

    Padrão

    byosni, tava aqui pensando em colocar uma pagina index para que sempre que o cliente abri-se o I.E. ele ia pra index(site do provedor)
    Porem depois que li seu post(e se o codigo estiver correto como argumenta o leomj) tive uma ideia.
    Vou deixar o codigo que ja tenho aqui pra bloquear clientes em atraso...

    E este codigo que vc postou vou usar da seguinte forma(me diz se eu to viajando ou nao ...rs):

    O cleinte conecta pela primeira vez, ele cai no meu site(a principio uma index com a logo do provedor, um campo de busca do google, alguns atalhos uteis(como orkut, jornal da cidade, bancos, telefones uteis, mapa da cidade etc) algumas dicas como: "mantenha seu antivirus sempre atualizado" "mantenha data/hora do seu micro sempre atualziada" e mais alguns links(sites) que os clientes mais acessam. E abaixo de tudo um atalhozinho do tipo "quero esta pagina seja a minha pagina inicial"

    Pois tava pensando... ficaria meio repetitivo a cada nova pagina o meu site aparecer!
    ENtao vou deixar o cliente escolher se ele quer ou nao que minha pagina abra a cada clique do navegador. Porem vou dar um reset para que mesmo se o cliente nao setar a minha pagina como inicial, pelo menos uma vez por dia ele vai ter que me engolir!!!!

    Que acha ?



  7. #7

    Padrão

    amigo, particularmente eu acho injusto obrigar o cliente a ver a página do provedor, não seria legal vc fazer assim, fazer uma ´página de cobrança e fazer ela repetir a cada 3 horas para aquele "maildito" cliente que ja faz 2 meses que não paga. Agora cada cliente gosta da sua página inicial. A minha pro exemplo é a mikrotikfacil.com, não queria que meu provedor ficasse mandando eu todo dia abrir a página dele porque no entando manter uma página de provedor com novidades diárias leva tempo..

    Até mais...

  8. #8

    Padrão

    Citação Postado originalmente por byosni Ver Post
    amigo, particularmente eu acho injusto obrigar o cliente a ver a página do provedor, não seria legal vc fazer assim, fazer uma ´página de cobrança e fazer ela repetir a cada 3 horas para aquele "maildito" cliente que ja faz 2 meses que não paga. Agora cada cliente gosta da sua página inicial. A minha pro exemplo é a mikrotikfacil.com, não queria que meu provedor ficasse mandando eu todo dia abrir a página dele porque no entando manter uma página de provedor com novidades diárias leva tempo..

    Até mais...
    Hoje, apos 10 dias de atrazo, ja deixo a pagina de corte DIRETO(apenas com a logo da empresa e solicitando que o cliente entre em contato pelo fone tals, soh isso),ou seja, 10 dias de atrazo o cliente nao navega mais!!! e 60 dias de atrazo ja envio um comunicado da retirada dos equipamentos(soh trabalho com comodato)

    NO caso do que eu disse acima, respeito sua opiniao claro. Mas seria apenas a primeira pagina do dia(tenho pessoal pra atualizar a pagina do provedor com noticias , etc) mas eh claro que na realidade quero mesmo vender espaço publicitario.

    Costaria que os colegas do forum opnacem sobre o assunto...



  9. #9

    Padrão

    Muito bacana byosny,
    Fiz o procedimento aki no MK e realmente funciona ,só qe tem um porem .
    Aki uso Proxy em paralelo e tenho uma regra redirecionando a porta 80 para porta 3128 do proxy,
    entaum pra qe funcione esse redir de pagina tive qe desabilitar a regra do proxy , ai sim funfou beleza. Queria saber se vc tambem usa proxy cache Tanbem e se tem alguma outra forma para usar com proxy. obrigado.

    Citação Postado originalmente por byosni Ver Post
    respondendo.... é o seguinte, você tem que fazer assim, aplica esta regra em

    ip firewall nat

    add action=dst-nat chain=dstnat comment=Aviso connection-limit=!1,32 disabled=no dst-port=80 protocol=tcp src-address-list=redireciona to-addresses=192.168.254.9 to-ports=80

    onde: o src address vc coloca o endereço do cliente ( 192.168.10.5) em em to-addresses= VC COLOCA O IP E PORTA DO TEU SERVIDOR WEB.

    esta regra so funciona uma vez, ou seja quando o usuário, hoje de manhã por exemplo, abrir o navegador, ele será redirecionando para o site, somente uma vez.
    Depois vc pode programar o mk para resetar esta regra a cada 24 horas (exemplo) e novamente ela irá fazer o seu trabalho.

    para resetar a regra do nat, programa o scheduler como na imagem em anexo.

    Aqui no provedor eu utilizo para mandar uma mensagem de que "sua internet poderá ser cortada" para os clientes que estão em atraso no pagamente. o redirecionamento é a cada 6 horas.
    Até mais...

  10. #10

    Padrão

    aqui eu tenho o proxy em paralelo com o Mikrotik, e funciona perfeitamente a minha regra fica antes das regra que redirecionam para o proxy, lembrando: sempre deixa a regra de redirecionamento de proxy por ultima de todas as regras do NAT.

    Citação Postado originalmente por Tremedeira Ver Post
    Muito bacana byosny,
    Fiz o procedimento aki no MK e realmente funciona ,só qe tem um porem .
    Aki uso Proxy em paralelo e tenho uma regra redirecionando a porta 80 para porta 3128 do proxy,
    entaum pra qe funcione esse redir de pagina tive qe desabilitar a regra do proxy , ai sim funfou beleza. Queria saber se vc tambem usa proxy cache Tanbem e se tem alguma outra forma para usar com proxy. obrigado.



  11. #11

    Padrão

    È verdade byosny ,

    Coloqei minha regra de redirecionar pagina antes da do proxy ,ja qe essa regra nao é permanente o tempo todo para o cliente,só para o primeiro acesso , agora sim entendi.

    Valew a clareada Byosny ,abrço.

  12. #12

    Padrão problema igual

    Citação Postado originalmente por leomj Ver Post
    Bom dia amigo, algum tempo atras tentei usar estas regras citadas, ate que funcionou o unico problema foi que, ela se tornou a pagina inicial do cliente, sendo assim se o cliente tinha google.com.br como pagina inicial, o mesmo nao iria conseguir abri-lo nem em outra seção, todas as vezes que abria a pagina do ggole vinha esta pagina de aviso.. sera que fiz algo de errado?
    Entao Leon , tudo ok.
    Fiz o procedimento aki tambem e realmente funcionou ,porem me deparei com esse mesmo problema qe vc tem ai .VC encontrou alguma soluçao pra isso cara????
    Valew abraço.



  13. #13

    Padrão

    Citação Postado originalmente por byosni Ver Post
    respondendo.... é o seguinte, você tem que fazer assim, aplica esta regra em

    ip firewall nat

    add action=dst-nat chain=dstnat comment=Aviso connection-limit=!1,32 disabled=no dst-port=80 protocol=tcp src-address-list=redireciona to-addresses=192.168.254.9 to-ports=80

    onde: o src address vc coloca o endereço do cliente ( 192.168.10.5) em em to-addresses= VC COLOCA O IP E PORTA DO TEU SERVIDOR WEB.

    esta regra so funciona uma vez, ou seja quando o usuário, hoje de manhã por exemplo, abrir o navegador, ele será redirecionando para o site, somente uma vez.
    Depois vc pode programar o mk para resetar esta regra a cada 24 horas (exemplo) e novamente ela irá fazer o seu trabalho.

    para resetar a regra do nat, programa o scheduler como na imagem em anexo.

    Aqui no provedor eu utilizo para mandar uma mensagem de que "sua internet poderá ser cortada" para os clientes que estão em atraso no pagamente. o redirecionamento é a cada 6 horas.
    Até mais...
    Osni, blz ?

    Testei esta regra por aqui, funcionou legal, mas tem um porém, o site que o indivíduo digitou fica com cache do site de bloqueio, ai tem que ficar atualizando umas 10 vezes ou limpar o cache (bem que seria legal forçar o inadimplente a fazer isto, mas nem todos sabem fazer...) rsrsrs

  14. #14

    Padrão

    eu faço assim na página que coloco a mensagem existem um codigo em html mais precisamente uma tag que da ordem ao navegador para nao cachear a página.... rsrs

    Citação Postado originalmente por agpnet Ver Post
    Osni, blz ?

    Testei esta regra por aqui, funcionou legal, mas tem um porém, o site que o indivíduo digitou fica com cache do site de bloqueio, ai tem que ficar atualizando umas 10 vezes ou limpar o cache (bem que seria legal forçar o inadimplente a fazer isto, mas nem todos sabem fazer...) rsrsrs



  15. #15
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão Reset-Counters

    Aqui não rolou o reset-counters.

  16. #16

    Padrão

    Citação Postado originalmente por byosni Ver Post
    eu faço assim na página que coloco a mensagem existem um codigo em html mais precisamente uma tag que da ordem ao navegador para nao cachear a página.... rsrs
    Osni, qual seria esta TAG, pois somente achei para colocar em paginas asp e jsp, mas não em html.



  17. #17

    Padrão

    Não ta rolando a tag por aqui, o bendito navegador fica fazendo cache.... Por acaso, você teria este trecho do código disponível ai ?

    Valew!

  18. #18

    Talking

    olha a tag ai gente...........

    Pragma

    <meta http-equiv="pragma" content="no-cache" /> Informa que o navegador não deverá cachear a página.




    até mais...



  19. #19

    Padrão

    eu fiz assim system scheduler e fiz para funcionar a cada 6 horas

    /ip firewall nat { disable [ find comment=Aviso ] }; /ip firewall nat { reset-counters [ find comment=Aviso ] }; /ip firewall nat { enable [ find comment=Aviso ] };

    até mais...

    Citação Postado originalmente por minelli Ver Post
    Aqui não rolou o reset-counters.