+ Responder ao Tópico



  1. #1

    Padrão Falta pouco...

    Galera tudo bem com voces? Aqui tudo sussu, porem precisando muito da ajuda de voces.

    Seguinte . . .

    Em um cliente tenho 2 links de internet, com IP Fixo (Embratel e Telefonica) ambos estao rodando com Load Balance, cada conexão vai para um determinado IP, dependendo de cada porta.

    Porem... tenho 2 problemas...

    1º Problema => Tudo funciona quando os 2 links estao OK, porem quando um cai os clientes tambem ficam sem internet, ou seja. . . quero que quando um link cair (qualquer um) o outro assuma TODAS as conexões, dai quando ele voltar, tudo volta ao normal.

    2º Problema => Preciso que todas as portas e conexões estejam liberadas do mikrotik para um proxy da rede, e o proxy faça os bloqueios de porta. Bom até ai tudo bem... Porem, na maquina qualquer da rede, sempre que faço "tracert -d www.uol.com.br" ele SEMPRE sai pelo mesmo trajeto, ou seja, se tentar conectar no VNC dele, tem que ser SEMPRE pelo mesmo link, caso eu tente acessar a maquina dele pelo segundo link ele não consegue.... porem se eu desativar no ip>routes o link 1 dai eu consigo conectar o VNC com outro IP

    Por favor quem puder me ajudar!

  2. #2

    Padrão

    Galera vejam se minhas configs estao "boas" e se falta algo?

    /ip firewall nat

    add action=masquerade chain=srcnat comment="MASCARAMENTO LOCAL" disabled=no src-address=192.168.10.0/24
    add action=redirect chain=dstnat comment="REDIRECIONAR WEB PROXY" disabled=yes dst-port=80 in-interface=LOCAL protocol=tcp src-address=192.168.10.0/24 \
    to-ports=3128
    add action=accept chain=dstnat comment="N\C3O FAZER CACHE DINAMICO" content=":cgi-bin \\\\\?" disabled=no dst-port=80 in-interface=LOCAL protocol=tcp
    add action=accept chain=dstnat comment="" content=https:// disabled=no dst-port=80 in-interface=LOCAL protocol=tcp
    add action=dst-nat chain=dstnat comment="LIBERANDO TODAS AS PORTAS - LINK1" disabled=no dst-address=201.90.162.171 dst-port=0-65535 protocol=tcp \
    to-addresses=192.168.10.1 to-ports=0-65535
    add action=dst-nat chain=dstnat comment="LIBERANDO TODAS AS PORTAS - LINK2" disabled=no dst-address=189.22.8.100 dst-port=0-65535 protocol=tcp to-addresses=\
    192.168.10.1 to-ports=0-65535
    add action=accept chain=dstnat comment="SEM PROXY CONECTIVA" disabled=no dst-address=200.201.160.0/24
    add action=accept chain=dstnat comment="" disabled=no dst-address=200.201.173.0/24
    add action=accept chain=dstnat comment="" disabled=no dst-address=200.201.166.0/24
    add action=accept chain=dstnat comment="" disabled=no dst-address=200.201.174.0/24
    add action=accept chain=dstnat comment="SEM PROXY RADIO-UOL" disabled=no dst-address=200.221.8.0/24

    /ip firewall mangle

    add action=mark-connection chain=output comment="CACHE FULL" content="X-Cache: HIT" disabled=yes new-connection-mark=conn_squid-up passthrough=yes protocol=\
    tcp src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=conn_squid-up disabled=yes new-packet-mark=pacotes_squid-up passthrough=yes
    add action=mark-connection chain=prerouting comment="" disabled=yes dst-port=3128 new-connection-mark=conn_squid-down passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=conn_squid-down disabled=yes new-packet-mark=pacotes_squid-down passthrough=yes
    add action=mark-connection chain=prerouting comment="CONTROLE DO P2P" disabled=no new-connection-mark=conn-p2p p2p=all-p2p passthrough=yes
    add action=mark-packet chain=prerouting comment="" connection-mark=conn-p2p disabled=no new-packet-mark=pacotes-p2p passthrough=yes
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO TOTAL - LINK1" disabled=yes new-routing-mark=LINK1 nth=2,0 passthrough=yes protocol=tcp
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO TOTAL - LINK2" disabled=yes new-routing-mark=LINK2 nth=2,0 passthrough=yes protocol=tcp \
    routing-mark=LINK2
    add action=mark-routing chain=prerouting comment="ROTEAMENTO LINK1" disabled=no new-routing-mark=LINK1 nth=2,0 passthrough=yes src-address=192.168.10.0/24
    add action=mark-routing chain=prerouting comment="ROTEAMENTO LINK2" disabled=no new-routing-mark=LINK2 nth=2,0 passthrough=yes src-address=192.168.10.0/24
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO HTTP - LINK1" disabled=no dst-port=80 new-routing-mark=LINK1 nth=2,0 passthrough=yes \
    protocol=tcp
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO HTTP - LINK2" disabled=no dst-port=80 new-routing-mark=LINK2 nth=2,0 passthrough=yes \
    protocol=tcp routing-mark=LINK2
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO HTTPs - LINK1" disabled=no dst-port=443 new-routing-mark=LINK1 nth=2,0 passthrough=yes \
    protocol=tcp
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO HTTPs - LINK2" disabled=no dst-port=443 new-routing-mark=LINK2 nth=2,0 passthrough=yes \
    protocol=tcp routing-mark=LINK2
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO FTP - LINK1" disabled=no dst-port=21 new-routing-mark=LINK1 nth=2,0 passthrough=yes \
    protocol=tcp
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO FTP - LINK2" disabled=no dst-port=21 new-routing-mark=LINK2 nth=2,0 passthrough=yes \
    protocol=tcp routing-mark=LINK2
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO TS - LINK1" disabled=no dst-port=3389 new-routing-mark=LINK2 nth=2,0 passthrough=yes \
    protocol=tcp
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO TS - LINK2" disabled=no dst-port=3389 new-routing-mark=LINK2 nth=2,0 passthrough=yes \
    protocol=tcp routing-mark=LINK2
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO SMTP - LINK1" disabled=no dst-port=25 new-routing-mark=LINK1 nth=2,0 passthrough=yes \
    protocol=tcp
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO SMTP - LINK2" disabled=no dst-port=25 new-routing-mark=LINK2 nth=2,0 passthrough=yes \
    protocol=tcp routing-mark=LINK2
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO POP3 - LINK1" disabled=no dst-port=110 new-routing-mark=LINK1 nth=2,0 passthrough=yes \
    protocol=tcp
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO POP3 - LINK2" disabled=no dst-port=110 new-routing-mark=LINK2 nth=2,0 passthrough=yes \
    protocol=tcp routing-mark=LINK2
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO DNS - LINK1" disabled=no dst-port=53 new-routing-mark=LINK1 nth=2,0 passthrough=yes \
    protocol=tcp
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO DNS - LINK2" disabled=no dst-port=53 new-routing-mark=LINK2 nth=2,0 passthrough=yes \
    protocol=tcp routing-mark=LINK2
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO P2P - LINK1" disabled=no new-routing-mark=LINK1 nth=2,0 p2p=all-p2p passthrough=yes \
    protocol=tcp
    add action=mark-routing chain=prerouting comment="BALANCEAMENTO P2P - LINK2" disabled=no new-routing-mark=LINK2 nth=2,0 p2p=all-p2p passthrough=yes \
    protocol=tcp routing-mark=LINK2



  3. #3

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    Galera tudo bem com voces? Aqui tudo sussu, porem precisando muito da ajuda de voces.

    Seguinte . . .

    Em um cliente tenho 2 links de internet, com IP Fixo (Embratel e Telefonica) ambos estao rodando com Load Balance, cada conexão vai para um determinado IP, dependendo de cada porta.

    Porem... tenho 2 problemas...

    1º Problema => Tudo funciona quando os 2 links estao OK, porem quando um cai os clientes tambem ficam sem internet, ou seja. . . quero que quando um link cair (qualquer um) o outro assuma TODAS as conexões, dai quando ele voltar, tudo volta ao normal.

    2º Problema => Preciso que todas as portas e conexões estejam liberadas do mikrotik para um proxy da rede, e o proxy faça os bloqueios de porta. Bom até ai tudo bem... Porem, na maquina qualquer da rede, sempre que faço "tracert -d www.uol.com.br" ele SEMPRE sai pelo mesmo trajeto, ou seja, se tentar conectar no VNC dele, tem que ser SEMPRE pelo mesmo link, caso eu tente acessar a maquina dele pelo segundo link ele não consegue.... porem se eu desativar no ip>routes o link 1 dai eu consigo conectar o VNC com outro IP

    Por favor quem puder me ajudar!
    Respondendo a seu 1º Problema, Isso é normal, além do loadbalaced vc tera q fazer um FailOver, o mikrotik tem uma ferramenta q faz isso chamdo NETWATH de uma procurada aqui no forum q vai encontrar material sobre o assunto.

    Respondendo a seu 2º Problema, n postou as regras do /ip firewall filter rules e qual a porta de seu proxy para sabermos se tem algum bloqueio a seu proxy, pelo que vi em seu loadbalaced é uma mistura de nth com jogar trafego em cima de determinados serviços, e esse balanceamento vc esta forçando determinados serviços sair apenas por um link, por isso q n consegue ter acesso aos dois links ao mesm tempo, conseguindo apenas quando desativa um dos links vice-versa, esse se resolve com balanceamento PCC, e tmb já tem material no forum para qualquer um possa montar um.

    abraços

  4. #4

    Padrão

    Ola... obrigado pelo post, vou explicar mais ou menos como esta...

    Sobre o primeiro problema eu ja havia achado material sobre O NETWATCH, mas não consegui com que faça exatamente o que eu quero, quando um link cair o outro assume TUDO, e quando voltar, volta ao normal o balanceando... tem algum tuto sobre isso ??

    Sobre o segundo problema, eu no momento estou sem proxy, MAS VOU POR PROXY EM UM LINUX,
    Lliberar todas as portas para o proxy TUDO BEM (ja esta feito e funcionando) . . . porem... é o roteamento no cliente (windows) que "nao muda"

    tracert -d www.uol.com.br

    La sempre diz a MESMA rota, porem se eu desativar um link dai ele fica com a roda OK, mas se o link cair, ele nao funciona mais nada!!

    Realmente estou forçando alguns serviços sair por determinados links... e balancear outras portas (ftp, http, htpps)

    No final de tudo isso... voce acha que meu LB esta "meia boca" ? melhor eu começar do zero usando Balanceamento PCC?? ou "arrumar o que eu ja fiz" ??

    Abraços! e aguardo!!!
    Última edição por thiagotgc; 19-09-2009 às 16:48.



  5. #5

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    Ola... obrigado pelo post, vou explicar mais ou menos como esta...

    Sobre o primeiro problema eu ja havia achado material sobre O NETWATCH, mas não consegui com que faça exatamente o que eu quero, quando um link cair o outro assume TUDO, e quando voltar, volta ao normal o balanceando... tem algum tuto sobre isso ??

    Sobre o segundo problema, eu no momento estou sem proxy, MAS VOU POR PROXY EM UM LINUX,
    Lliberar todas as portas para o proxy TUDO BEM (ja esta feito e funcionando) . . . porem... é o roteamento no cliente (windows) que "nao muda"

    tracert -d www.uol.com.br

    La sempre diz a MESMA rota, porem se eu desativar um link dai ele fica com a roda OK, mas se o link cair, ele nao funciona mais nada!!

    Realmente estou forçando alguns serviços sair por determinados links... e balancear outras portas (ftp, http, htpps)

    No final de tudo isso... voce acha que meu LB esta "meia boca" ? melhor eu começar do zero usando Balanceamento PCC?? ou "arrumar o que eu ja fiz" ??

    Abraços! e aguardo!!!

    faça primeiro com PCC e deixe rodando, logo em seguida q estiver tudo ok, vc vai fazendo as exceções que vc quer.

  6. #6

    Padrão

    ok PCC rodando, porem sobrecarregando um UNICO link...



  7. #7

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    ok PCC rodando, porem sobrecarregando um UNICO link...
    Somente PCC sem mais nenhuma regra no mangle ? se sim, poste mangle e /ip route

  8. #8

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Somente PCC sem mais nenhuma regra no mangle ? se sim, poste mangle e /ip route
    Vou postar meu Mangle e Route.

    /ip firewall mangle
    add action=accept chain=prerouting comment="SEM BALANCE DE DESTINO" disabled=no dst-address-list=sem_balance in-interface=LOCAL
    add action=mark-connection chain=input comment="MARCACAO DE NOVAS CONEXOES" connection-state=new disabled=no in-interface=LINK1 new-connection-mark=conn_na \
    passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=LINK2 new-connection-mark=conn_nb passthrough=yes
    add action=mark-routing chain=output comment="MARCACAO DE ROTAS" connection-mark=conn_na disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb disabled=no new-routing-mark=to_rb passthrough=no
    add action=mark-connection chain=prerouting comment="MARCACAO DE NOVAS CONEXOES" disabled=no dst-address-type=!local in-interface=LOCAL new-connection-mark=\
    conn_ma0 passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=LOCAL new-connection-mark=conn_mb1 passthrough=yes \
    per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="MARCACAO DE INTERFACES" connection-mark=conn_ma0 disabled=no in-interface=LOCAL new-routing-mark=to_nra \
    passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 disabled=no in-interface=LOCAL new-routing-mark=to_nrb passthrough=no
    /ip route
    add comment="LINK1 - EMBRATEL" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=201.90.162.161 scope=30 target-scope=10
    add comment="LINK2 - TELEFONICA" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=189.22.8.1 scope=30 target-scope=10
    add comment="BALANCEAMENTO DE CARGA - LINK1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=201.90.162.161 routing-mark=to_nra scope=30 target-scope=\
    10
    add comment="BALANCEAMENTO DE CARGA - LINK2" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=189.22.8.1 routing-mark=to_nrb scope=30 target-scope=10