+ Responder ao Tópico



  1. #1

    Padrão Problemas que surgem após o PCC

    Olá pessoal.
    Gostaria de começar pelo meu principal problema de balanceamento via PCC.

    Primeiro.
    ---> foi a melhor solução que encontrei até hj para melhor aproveitamento de meus links (fiquei feliz por isso)

    Segundo
    minha estrutura é a seguinte:
    tenho 6links ADSL de 3.2MB---pendurados em uma RB493ah_PCC--que se torna o gateway de meu servidor Mikrotik que por sua vez tem um proxy em paralelo....
    Pois bem...
    Vamos ao que me aflinge.
    tenho tido problemas o redirecionamento de portas pois.
    preciso acessar este provedor remotamente pelas portas:

    8291 (winbox)
    2200 (ssh)
    7171 (gráficos Webproxy)
    810 (web_mikrotik)

    pelo fato do PCC nunca registrar um Gateway defalt para o Cliente DDNS, hora tenho acesso remoto pelo gatewayX, outra Hora pelo GatewayZ enfim... aleatóriamente,
    até ai tudo bem.
    criei regras de redirecionamento em todos os modens para a RB493ah e as conexões chegam na Routerboard (uma beleza) que por sua vez, esta rb redireciona todas as conexões pelas portas anteriormente citadas para o servidor MK.
    Criei as regras de redirecionamento do modem pra RB e da RB para o Servidor e até ai tudo bem.
    Criei as regras de acept no servidor e tudo certo novamente.
    Agora, o que me tirou mto tempo de tranquilidade foi o fato de o servidor não aceitar estas conexões, mesmo com as regras de acept pela porta X e pela interfaceY e dando um ACEPT em todas elas.
    hora ele aceita. hora ele não aceita
    isso tá me matando.
    Preciso de sugestões
    pq já queimei a cachola e nada.


    O LB_via PCC é uma beleza. recomendo a todos.
    tenho um sistema de gerencia via internted de meus provedores, este sistema usa a porta 2200 pra se conectar ao meu server.
    meu problemão é que o sistema não tem conceguido acessar o servidor.
    tbm né é tanto redirecionamento que tá me deixando tonto só de lembrar.

    "Estou pensando em mudar o script DDNS que está no servidor e colocar ele na RB.
    que tem seu gateway defalt fora do PCC. (sem balance)"
    mais não acredito que resolva meu problema.
    Espero ter sido claro com vcs.
    Abraço a todos.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         IMG_0280.JPG
Visualizações:	378
Tamanho: 	375,7 KB
ID:      	5727  

  2. #2

    Padrão

    Seus modens estao no modo Router?
    Desta maneira que vc sitou, funciona bacana, deixando a regra no PCC e do pcc redirecionando para seu servidor, e seu servidor para os demais...
    Tenho aqui funcionando, com apenas 2 links dedicados, e primeiro chega no pcc, ele redireciona as portas para o servidor, e este por sua vez, redireciona para o proxy, para os demais clientes sem problemas.
    Como disse ai em cima, pode colocar o ddns no pcc, e dele redirecionar para o servidor.

    qualquer duvida, posta ai.

    abraços,



  3. #3

    Padrão Resoluçao do problema para mim

    Eu resolvi um problema bem parecido, simplesmente setando a opçao connection-state=new nas regras que marcam a conexao para o PCC, veja exemplo abaixo, para 2 links:

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="Per Connection Classifier" connection-state=new disabled=no \
    dst-address-type=!local in-interface=local new-connection-mark=link1_conn passthrough=yes per-connection-classifier=\
    both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-type=!local \
    in-interface=local new-connection-mark=link2_conn passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="Policy Routing" connection-mark=link1_conn disabled=no in-interface=\
    local new-routing-mark=to_link1 passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=link2_conn disabled=no in-interface=local \
    new-routing-mark=to_link2 passthrough=no

    Espero ter colaborado.
    Att.
    Gabriel Siena

  4. #4
    Não Registrado
    Visitante

    Padrão

    Parabens pela sulução...



  5. #5

    Padrão

    O mikrotik vai atualizar o DDNS com um dos ips da WAN, ou seja dependendo do script serão interfaces aleatórias ... e como o seu modem está em Bridge vai cair direto na sua Rb, à não ser que vc faça uma regra de redirecionamento, em que toda a solicitação feita pela porta 8291 seja redirecionada para o servidor.

  6. #6
    Cweber-rs
    Visitante

    Padrão Problema de conexão em longa distancia.

    Bom dia a todos
    pessoal tenho uma wbs 2400, fiz a configuração e quando estou proximo da antena uns 20m ela conecta sem problema mas quado estou a 1km o sinal fica ótimo mas não conecta, alguem já teve esse problema?

    Obrigado.



  7. #7

    Padrão

    C-Weber RS.. Cara que isso tem a ver com pcc...
    Acho que tu deve ser novo no forum.. se for, cria um tópico so para isso.. tem muita gente que vai te ajudar.. aqui ajuda não falta.. Abraços

    Sobre o redirecionamento, teus modens são em bridge ou router?

    Se for router teria que dar um geito de fazer a conexão do ddns sempre pegar o ip de um dos modens (não sei se tem maneira) dai acho que teus problemas de redirecionamento ficariam menores!!

    Mas se possível poste suas regras da RB.. estou montando a mesma estrutura sua so que com modens em bridge..
    Grato desde já,

    Tiago

  8. #8

    Padrão

    estou com problemas parecido, tenho 2 adsl ip fixo, mudei o host reverso na operadora dos 2 ips, pois vou hospedar o site localmente, so que nao estou conseguindo fazer o redirecionamento dos 2 ips para o servidor linux aonde esta o site, criei as regras só que so 1 ip ele da o dns ok, minha estrutura esta mk_pcc----mk_clientes---linux criei uma regra no pcc mandando a porta 53 (udp) para o mk_clientes e a mesma regra mandando para o linux so que ele só da resposta de 1 ip do outro sempre da tempo limite abaixo segue as regras, interessante que 1 dos ips ele funciona ok, no outro nao

    Regra que coloquei no ip firewall nat do pcc
    action=dst-nat chain=dstnat comment="" disabled=no dst-address=(IP FIXO ADSL) dst-port=53 protocol=udp to-addresses=(IP DO MK CLIENTES) to-ports=53
    Regra que coloquei no ip firewall nat do mk que gerencia os clientes
    action=dst-nat chain=dstnat comment="" disabled=no dst-address=(IP DO MK CLIENTES) dst-port=53 protocol=udp to-addresses=(IP DO LINUX) to-ports=53