+ Responder ao Tópico



  1. #1

    Padrão Squid + windows live messenger 2009

    Pessoal tenho o squid autenticado e libero o msn por usuário mas depois de atualizar para a versão 2009 ele parou de funcionar em algumas máquinas do proxy ele até entra mas dá erro nos contatos e não os exibe em outras máquinas o msn nem entra..como posso resolver pois sei que isso está no squid?

  2. #2
    Não Registrado
    Visitante

    Unhappy baixar

    como se fax pra baixar o novo msn ja baixei so q eu entro ai derrepente ele sai



  3. #3

    Padrão

    eu baixo normal...só que no meu caso para instalar tenho que tirar a máquina do proxy depois coloco.

    Pessoal consegui da seguinte forma...coloquei a url contacts do msn numa acl que não precisa de autenticação ai funcionou.

  4. #4

    Padrão Como fazer a ACL???

    Olá!
    Essa dica de colocar a url dos contatos do MSN na acl torna a funcionabilidade do MSN mais rápida???Como fazer isso?Essa acl é adicionada no squid.conf???Aguardo resposta!!!



  5. #5

    Padrão

    não deixa as funcionalidade do msn mais rápida e sim libera o msn 2009 no squid. entendeu?

  6. #6

    Padrão

    amigo pode ser que não seje problema no seu server e sim uma falha no MSN mesmo.

    alguns clientes meus após atualizar automaticamento o MSN para versão 2009 não conseguiram mais conexão ou sumiram os contatos, e isso em clientes caseiros, sem firewall sem nada.



  7. #7

    Padrão

    consegui um instalador do novo MSN... são mais ou menos 30Mb...
    vou disponbilizar para download no link www.manosinformatica.com.br/msn.exe

  8. #8

    Thumbs down olha...ja adicionei varias regras no squid e nda

    ta ae as regras que adicionei em meu squid e mesmo assim continuo com o problema da mensagem
    Sua lista de contatos nao esta disponivel blablablabla

    acl msn urlpath_regex -i gateway.dll
    acl msnd dstdomain messenger.msn.com gateway.messenger.hotmail.com byrdr.omega.contacts.msn.com contacts.msn.com local-bay.contacts.msn.com by2.storage.msn.com
    acl msn1 req_mime_type application/X-msn-messenger

    http_access allow msnd
    http_access allow msn
    http_access allow msn1


    funcionava normal antes da atualização pra essa versao nova do msn
    alguem tem uma maneira de resolver isso ????????????????






  9. #9

    Post RESOLVIDO

    Galera...blz...seguinte....
    o problema do MSN 2009 consegui resolver...bastou adicionar as seguintes acls no meu squid:

    acl msncontatos dstdomain contacts.msn.com
    acl msncontatos2 urlpath_regex contacts.msn.com
    acl msn urlpath_regex -i gateway.dll
    acl msnd dstdomain messenger.msn.com gateway.messenger.hotmail.com byrdr.omega.contacts.msn.com contacts.msn.com local-bay.contacts.msn.com by2.storage.msn.com
    acl msn1 req_mime_type application/X-msn-messenger

    http_access allow msnd
    http_access allow msncontatos
    http_access allow msncontatos2
    http_access allow msn
    http_access allow msn1

    Cuidado com o local onde vai colocar elas ....pra o squid fazer a leitura delas primeiro e tal....
    mudo poka coisa das regras que colokei ali em cima....
    foi uma dica pega no mundoopensource ..... e mais umas dicas com o Marcelo ....

    Espero que seja de utilidade pra mais alguem tb
    Bom findi ae galera !!!!

    Última edição por Saoluizense; 24-10-2009 às 20:57. Razão: encontrei erros ....

  10. #10
    Lucianod01d3r4
    Visitante

    Padrão msn

    Citação Postado originalmente por Saoluizense Ver Post
    ta ae as regras que adicionei em meu squid e mesmo assim continuo com o problema da mensagem
    Sua lista de contatos nao esta disponivel blablablabla

    acl msn urlpath_regex -i gateway.dll
    acl msnd dstdomain messenger.msn.com gateway.messenger.hotmail.com byrdr.omega.contacts.msn.com contacts.msn.com local-bay.contacts.msn.com by2.storage.msn.com
    acl msn1 req_mime_type application/X-msn-messenger

    http_access allow msnd
    http_access allow msn
    http_access allow msn1


    funcionava normal antes da atualização pra essa versao nova do msn
    alguem tem uma maneira de resolver isso ????????????????



    aqui eu estava com o mesmo problema foi resouvido com o msn 8.5 ele ainda conecta



  11. #11

    Padrão

    Citação Postado originalmente por Saoluizense Ver Post
    Galera...blz...seguinte....
    o problema do MSN 2009 consegui resolver...bastou adicionar as seguintes acls no meu squid:

    acl msncontatos dstdomain contacts.msn.com
    acl msncontatos2 urlpath_regex contacts.msn.com
    acl msn urlpath_regex -i gateway.dll
    acl msnd dstdomain messenger.msn.com gateway.messenger.hotmail.com byrdr.omega.contacts.msn.com contacts.msn.com local-bay.contacts.msn.com by2.storage.msn.com
    acl msn1 req_mime_type application/X-msn-messenger

    http_access allow msnd
    http_access allow msncontatos
    http_access allow msncontatos2
    http_access allow msn
    http_access allow msn1

    Cuidado com o local onde vai colocar elas ....pra o squid fazer a leitura delas primeiro e tal....
    mudo poka coisa das regras que colokei ali em cima....
    foi uma dica pega no mundoopensource ..... e mais umas dicas com o Marcelo ....

    Espero que seja de utilidade pra mais alguem tb
    Bom findi ae galera !!!!

    Obrigado por ter postado a sua solução. Aqui comigo não resolveu 100%, mas com base nesse post consegui resolver o problema, Apenas fiquei monitorando o access.log, e liberei todos os sites que apareciam como bloqueados ao tentar iniciar o WLM... Veja abaixo mais alguns que precisei liberar para funcionar 100% do WLM 2009.

    acl msnd dstdomain byrdr.omega.contacts.msn.com local-bay.contacts.msn.com byfiles.storage.msn.com akhtm.nspmotion.com blufiles.storage.msn.com www.gowindowslive.com view.atdmt.com local-sn.contacts.msn.com ec.atdmt.com tkrdr.storage.msn.com livefiles19.vo.msecnd.net www.sqm.microsoft.com sqmserver.dll switch.atdmt.com rsi.hotmail.com nspmotion.com icover.com.br rad.msn.com rmd.atdmt.com t.msn.com
    Última edição por vaini; 17-11-2009 às 12:01.

  12. #12

    Padrão como fez pra monitorar ???

    ola vaini
    como vc faz pra monitorar os arquivos do access.log ????
    usa o comando tailf -f ?????



  13. #13

    Smile

    Citação Postado originalmente por Saoluizense Ver Post
    ola vaini
    como vc faz pra monitorar os arquivos do access.log ????
    usa o comando tailf -f ?????
    Uma boa pedida para o tail -f seria algo do tipo: tail -f /var/log/squid/access.log | grep 192.168.0.1

  14. #14

    Smile blz vaini

    kra...começou em algumas makinas dar novamente o problema de "sua lista de contatos...." mas dae consegui resolver com as minhas regras e complementei com o q vc postou aki....
    axo q agora ta blz....

    mas esse MSN 2009 hein .....
    e tipo .... pra monitorar os erros .... como o colega ae falou tail -f /var/log/squid/access.log | grep 192.168.0.1

    como vc conseguiu identificar o problema ??? pra saber q eram akeles sites q tinha q liberar .... so monitorando o arquivo ele aparece o erro? pode ser uma pergunta idiota mas eu nao sei como faz isso...por isso to perguntando .... rsrsrsrsrsrsrsrs




  15. #15

    Cool

    Amigo,

    Na verdade com o comando você ve melhor as conexões que ele faz HTTP, para fazer a liberação eu parti daqui:
    Código :
    http://support.microsoft.com/kb/960820/pt-br
    Entrar para o serviço Mensageiro TCP 80, 443, 1863
    [URL]https://Login.live.com[/URL] - O HTTP sobre autenticação SSL (HTTPS)....
    [URL]http://Login.live.com[/URL] - Autenticação HTTP com o Windows Live ID
    [URL]https://*.Contacts.msn.com[/URL] - Para obter a lista de contatos

    Espero que tenha ajudado amigo

  16. #16

    Wink

    A sim, já ia esquecendo

    Se você quiser uma forma mais eficaz, ai vai minha dica:
    Código :
    tail -f /var/log/squid/access.log | grep 192.168.1.1 | awk ‘{print $3 “  ” $8 “  ” $7}’

    Ou se você não tiver o ip:
    Código :
    tail -f /var/log/squid/access.log | awk ‘{print $3 “  ” $8 “  ” $7}’

    Abraços



  17. #17

    Smile qto a essa linha aki...

    1259072758.987 0 192.168.0.1 TCP_NEGATIVE_HIT/204 251 GET http://clients1.g
    oogle.com.br/generate_204 tk NONE/- text/html


    esse tcp_negative_hit é algum erro ???

    pq alguns clientes da rede reclamaram q as vezes colocam pesquisar no google e ele fica procurando e nao da resposta nenhuma..observei em uma das estações da rede que realmente aconteceu isso..... nao é sempre...mas acontece ....e outros sites abrem normalmente....

    embaixo do navegar fica assim
    \search e nao retornava resultado a pesquisa.....

    estranhnho nao ???
    alguem ja passou por isso ???


  18. #18

    Padrão

    Tive algo semelhante, só n lmbro a solução... e acontecia smpre com pagina inicial do usuario.
    O proxy é configurado tipo: proxy.teudominio.com.br ou é no IP ?



  19. #19

    Padrão IP

    o proxy é configurado no IP mesmo .......
    nao lembra a solução entao rsrsrsrsrsrs

    tentei procurar algo mas nda ainda....
    vamos ver ....se alguem puder ajudar ae
    se manifeste
    heheheh

  20. #20

    Padrão

    Bom, não sei se ajuda o que vou dizer, pois no meu caso uso servidor mikrotik e proxy-squid paralelo.

    Passei por esse problema com alguns usuários (o estranho é que é só com alguns).
    Adicionei essas acl´s no meu squid.conf mas tb não resolveu.
    Consegui resolver da seguinte forma: no servidor mikrotik, em /ip/proxy/direct, peguei as url´s que encontrei no endereço Re: [slack-users] Problemas no SQUID/MSN - Tiago Dib - com.googlegroups.slack-users-br - MarkMail, mais as url´s das acl´s que o pessoal postou aqui, e coloquei acesso direto da rede local para essas url´s.