+ Responder ao Tópico



  1. #1
    Analista de Sistemas Avatar de MDdantas
    Ingresso
    Apr 2007
    Localização
    Caruaru - Pernambuco
    Posts
    423

    Padrão BALANCEAMENTO DE LINKS PARA DUAS REDES

    Boa tarde pessoal,

    preciso da ajuda de vocês. Estou configurando um servidor mikrotik para duas redes com dois links. Estou querendo criar o balanceamento dos links da seguinte maneira: a rede A passe a utilizar o link 1 e a rede B utilize o link 2 sendo gerenciado pelo mesmo servidor mikrotik. Alguém pode disponibilizar por gentileza algum tutorial?

  2. #2

    Padrão

    Boa tarde, vc pode usar load Balance por grupos, ou pode usar um persistente tbm.....tem muito mareial aqui no forum sobre isso, se caso não conceguir achar nada eu te passo algumas dicas.....



  3. #3

    Smile

    amigo Como seria este metodo de marcacao persistente? Poste um exemplo para nos. Obrigado

  4. #4

    Padrão

    gustavinho69, pode-se fazer de duas formas, vc pode fazendo a marcação dos clientes na medida que eles vão se conectando e jogando para um determinado link e tbm pode colocar para que ele permanessa nesse link por 1d, no momento que é feito a marcação ele é jogado para o /ip address-list

    marcação para o link
    / ip firewall mangle
    add chain=prerouting in-interface=Saida src-address-list=link1 \
    action=mark-connection new-connection-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting in-interface=Saida src-address-list=link1 \
    action=mark-routing new-routing-mark=link1 passthrough=no comment="" \
    disabled=no

    coloca o cliente arrecem conectado como persistente no link por 1d

    add chain=prerouting in-interface=Saida connection-state=new nth=2,2,0 \
    action=mark-connection new-connection-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting in-interface=Saida src-address=192.168.0.0/16 \
    connection-mark=link1 action=add-src-to-address-list address-list=link1 \
    address-list-timeout=1d comment="" disabled=no
    add chain=prerouting in-interface=Saida connection-mark=link1 \
    action=mark-routing new-routing-mark=link1 passthrough=no comment="" \
    disabled=no

    ai só add o router e pronto....ta persistente....outra forma seria ja colocar ele em /ip address-list ai ele ficaria persistente por quanto tempo vc deixar ele la, no link que vc quizer.....

    se ficou meio vago, posta as duvidas que tento explicar melhor....



  5. #5

    Padrão E o Web-Proxy funciona junto com ele?

    Olá amigo, estou ha um tempo procurando o melhor Load Balance que funcione junto com o Web Proxy Cache do Mikrotik, porém todos me deram problemas ou não funcionaram, estou pensando em em usar o Linksys para fazer o load e o Mikrotik faz o resto , o que vc acha?

    Obrigado.

    Citação Postado originalmente por scinfovirtual Ver Post
    gustavinho69, pode-se fazer de duas formas, vc pode fazendo a marcação dos clientes na medida que eles vão se conectando e jogando para um determinado link e tbm pode colocar para que ele permanessa nesse link por 1d, no momento que é feito a marcação ele é jogado para o /ip address-list

    marcação para o link
    / ip firewall mangle
    add chain=prerouting in-interface=Saida src-address-list=link1 \
    action=mark-connection new-connection-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting in-interface=Saida src-address-list=link1 \
    action=mark-routing new-routing-mark=link1 passthrough=no comment="" \
    disabled=no

    coloca o cliente arrecem conectado como persistente no link por 1d

    add chain=prerouting in-interface=Saida connection-state=new nth=2,2,0 \
    action=mark-connection new-connection-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting in-interface=Saida src-address=192.168.0.0/16 \
    connection-mark=link1 action=add-src-to-address-list address-list=link1 \
    address-list-timeout=1d comment="" disabled=no
    add chain=prerouting in-interface=Saida connection-mark=link1 \
    action=mark-routing new-routing-mark=link1 passthrough=no comment="" \
    disabled=no

    ai só add o router e pronto....ta persistente....outra forma seria ja colocar ele em /ip address-list ai ele ficaria persistente por quanto tempo vc deixar ele la, no link que vc quizer.....

    se ficou meio vago, posta as duvidas que tento explicar melhor....

  6. #6

    Padrão

    Citação Postado originalmente por scinfovirtual Ver Post
    gustavinho69, pode-se fazer de duas formas, vc pode fazendo a marcação dos clientes na medida que eles vão se conectando e jogando para um determinado link e tbm pode colocar para que ele permanessa nesse link por 1d, no momento que é feito a marcação ele é jogado para o /ip address-list
    Obrigado pelo post...No caso tenho uma duvida....

    Faço o balanceamento por marcação de pacotes em 2 links, e no entanto tenho um terceiro link que não faz parte dessa marcação..........teria a possibilidade de eu fixar uma determinada rede a sair por somente este terceiro link?



  7. #7
    Analista de Sistemas Avatar de MDdantas
    Ingresso
    Apr 2007
    Localização
    Caruaru - Pernambuco
    Posts
    423

    Padrão

    Amigo por gentileza, poderia postar o exemplo para que eu possa direcionar cada rede para seu respectivo link, pois utilizei o tutorial do wiki daqui do forum e não funcionou.


    obg

  8. #8

    Padrão

    SempreOnLine, sim....funciona sim 100% com o webproxy do Mikrotik, funciona até com cache full.

    gustavinho69, no seu caso, para que um grupo de clientes fique em um unico link, eu nunca testei, mas usando a logica é só vc não fazer a ultima marcação onde joga os clientes para o address-list, e dai fixar os ips que vc quer que fique no address-list, pela lógica seria isso.

    MDdantas, então amigo, não tem segredo...depois de vc fazer o balance como passei na segunda resposta do post, é só vc ir em address-list e add um novo ip e colocar o nome do link onde vc fez a marcação....





  9. #9
    Analista de Sistemas Avatar de MDdantas
    Ingresso
    Apr 2007
    Localização
    Caruaru - Pernambuco
    Posts
    423

    Padrão

    scinfovirtual,

    Estou usando webproxy transparente, e preciso fazer o que te passei 2 links para 2 redes. Tem algum problema por que estou usando o webproxy transparente? Tens algum tutorial para me fornecer


    Atenciosamente,

    Moab Dantas

  10. #10

    Padrão

    não...neste tipo de load balance não tem conflito e nenhum problema com o webproxy, quanto ao tutorial não tenho nenhum....lembo que vi este load no wiki da mirktoik em ingles, mas não o achei mais....poste suas duvidas que eu te dou uma mão.....não é dificel....é o load mais facil que conheço...uso ele em alguns servers de clientes



  11. #11

    Padrão

    Citação Postado originalmente por scinfovirtual Ver Post
    SempreOnLine, sim....funciona sim 100% com o webproxy do Mikrotik, funciona até com cache full.

    gustavinho69, no seu caso, para que um grupo de clientes fique em um unico link, eu nunca testei, mas usando a logica é só vc não fazer a ultima marcação onde joga os clientes para o address-list, e dai fixar os ips que vc quer que fique no address-list, pela lógica seria isso.

    MDdantas, então amigo, não tem segredo...depois de vc fazer o balance como passei na segunda resposta do post, é só vc ir em address-list e add um novo ip e colocar o nome do link onde vc fez a marcação....

    Entendi...vou ver se faço alguns testes.....o que não entendi é este metodo de fazer com que os clientes vão para o adress-list......no caso quando se tem a rede criada, eles ja estão no address list.

    Por exemplo, aqui eu apenas faço a marcação dos serviços para sairem por determinado link.....e assim os clientes navegam passando pelos dois links.

    vlww

  12. #12

    Padrão

    não...os clientes não vão para /ip firewall address-list, mas quando vc faz a macção pelo mangle ai sim eles são mandados para o o /ip firewall address-list e se caso vc for deixar separado vc mesmo coloca no adress list coloca o ip do clientes e em Name vc coloca o link que é pra ele sair.....


    faça os testes e postes as duvidas



  13. #13

    Padrão Sobre conexão x-connect

    Nos últimos meses tem aparecido nos computadores dos clientes x-connect e as vezes z-connect e não conseguimos removê-la.. só formatando..
    Alguém já passou por esse problema???Aguardamos ajuda!!!

  14. #14

    Padrão

    Citação Postado originalmente por MDdantas Ver Post
    Boa tarde pessoal,

    preciso da ajuda de vocês. Estou configurando um servidor mikrotik para duas redes com dois links. Estou querendo criar o balanceamento dos links da seguinte maneira: a rede A passe a utilizar o link 1 e a rede B utilize o link 2 sendo gerenciado pelo mesmo servidor mikrotik. Alguém pode disponibilizar por gentileza algum tutorial?
    Alô Dantas,

    dá uma olhada nesse tópico, que poderá te ajudar !

    https://under-linux.org/f101292-bala...les-mas-eficaz

    Abç,



  15. #15

    Padrão

    Citação Postado originalmente por SempreOnLine Ver Post
    Olá amigo, estou ha um tempo procurando o melhor Load Balance que funcione junto com o Web Proxy Cache do Mikrotik, porém todos me deram problemas ou não funcionaram, estou pensando em em usar o Linksys para fazer o load e o Mikrotik faz o resto , o que vc acha?

    Obrigado.

    Amigo faça um Load balance em uma RB só pro LB ou um servidorzinhu ... pegue o link na saida do Load e trabalhe com ele como quiser no proxy qye não dá pau nao !