+ Responder ao Tópico



  1. #1

    Padrão VMware player - Ubuntu 7.10 apt-get nao funciona

    Boas!

    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------
    RESOLVIDO!

    O que eu fiz foi utilizar o VMware player 3, a nova versao, que permite criar imagens a partir de cd ou ficheiro iso.
    E baixei o ubuntu 9.10 e estou a ultiliza-lo no VMware!

    Obrigado na mesa pela ajuda e espero que o que esta a baixo e o que disse agora ajudem alguem.

    cumprimentos a todos
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------


    Estou a usar o ubuntu 7.10 no VMware player [em windows vista] e nao consigo instalar nenhum pacote.
    Alem disso estou na faculdade onde tenho de passar por um proxy.

    estou a fazer "sudo apt-get install snmpd"
    mensagem de erro >
    Package snmpd is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
    libsnmp10
    E: Package snmpd has no installation candidate


    ja tentei apt-get update e tambem na funciona.

    e a net da, usando o proxy no firefox.
    ah nao consigo pingar enderecos de fora!


    Sera que alguem me podia ajudar?

    tive ja ai a ver alguns posts mas nada funcionou comigo.

    e que preciso instalar o snmpd pra um trabalho e nao consigo.
    e nao queria instalar o ubuntu por agora que nao estou a usar o me PC

    obrigado desde ja.

    ps: se quiserem ver algum ficheiro de config ]e so dizerem
    Última edição por redhatlesi; 05-11-2009 às 01:49. Razão: resolvido o probelma.

  2. #2

    Thumbs up

    bom...
    se o proxy for transparente e não houver nenhuma restrição vc não vai encontrar problemas...

    o que pode estar acontecendo é que por ser a versão 7.04 os repositórios não estejam atualizados não existam mais ou não estão habilitados.

    o que vc deve fazer é editar o arquivo "/etc/apt/sources.list" e descomentar alguns repositórios
    ou trocar esses repositórios por novos.

    caso isso não funcione:

    eu estou usando o ubuntu 9.04 para vc ter uma base meu sources.list esta assim:


    Código :
    #deb cdrom:[Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1)]/ jaunty main restricted
    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.
     
    deb http://br.archive.ubuntu.com/ubuntu/ jaunty main restricted
    deb-src http://br.archive.ubuntu.com/ubuntu/ jaunty main restricted
     
    ## Major bug fix updates produced after the final release of the
    ## distribution.
    deb http://br.archive.ubuntu.com/ubuntu/ jaunty-updates main restricted
    deb-src http://br.archive.ubuntu.com/ubuntu/ jaunty-updates main restricted
     
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    deb http://br.archive.ubuntu.com/ubuntu/ jaunty universe
    deb-src http://br.archive.ubuntu.com/ubuntu/ jaunty universe
    deb http://br.archive.ubuntu.com/ubuntu/ jaunty-updates universe
    deb-src http://br.archive.ubuntu.com/ubuntu/ jaunty-updates universe
     
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    ## team, and may not be under a free licence. Please satisfy yourself as to 
    ## your rights to use the software. Also, please note that software in 
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    deb http://br.archive.ubuntu.com/ubuntu/ jaunty multiverse
    deb-src http://br.archive.ubuntu.com/ubuntu/ jaunty multiverse
    deb http://br.archive.ubuntu.com/ubuntu/ jaunty-updates multiverse
    deb-src http://br.archive.ubuntu.com/ubuntu/ jaunty-updates multiverse
     
    ## Uncomment the following two lines to add software from the 'backports'
    ## repository.
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    # deb http://br.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
    # deb-src http://br.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
     
    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    # deb http://archive.canonical.com/ubuntu jaunty partner
    # deb-src http://archive.canonical.com/ubuntu jaunty partner
     
    deb http://security.ubuntu.com/ubuntu jaunty-security main restricted
    deb-src http://security.ubuntu.com/ubuntu jaunty-security main restricted
    deb http://security.ubuntu.com/ubuntu jaunty-security universe
    deb-src http://security.ubuntu.com/ubuntu jaunty-security universe
    deb http://security.ubuntu.com/ubuntu jaunty-security multiverse
    deb-src http://security.ubuntu.com/ubuntu jaunty-security multiverse

    faça um backup de seu arquivo atual e troque o conteudo por este acima, depois:

    Código :
    apt-get update

    depois tente instalar o pacote desejado!

    espero que ajude!



  3. #3

    Padrão

    ajudou, ja ta a fazer o update! muito obrigado mesmo!

  4. #4

    Padrão

    Citação Postado originalmente por Lincoln Ver Post
    bom...
    se o proxy for transparente e não houver nenhuma restrição vc não vai encontrar problemas...

    o que pode estar acontecendo é que por ser a versão 7.04 os repositórios não estejam atualizados não existam mais ou não estão habilitados.

    o que vc deve fazer é editar o arquivo "/etc/apt/sources.list" e descomentar alguns repositórios
    ou trocar esses repositórios por novos.

    caso isso não funcione:

    eu estou usando o ubuntu 9.04 para vc ter uma base meu sources.list esta assim:


    Código :
    #deb cdrom:[Ubuntu 9.04 _Jaunty Jackalope_ - Release i386 (20090420.1)]/ jaunty main restricted
    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.
     
    deb http://br.archive.ubuntu.com/ubuntu/ jaunty main restricted
    deb-src http://br.archive.ubuntu.com/ubuntu/ jaunty main restricted
     
    ## Major bug fix updates produced after the final release of the
    ## distribution.
    deb http://br.archive.ubuntu.com/ubuntu/ jaunty-updates main restricted
    deb-src http://br.archive.ubuntu.com/ubuntu/ jaunty-updates main restricted
     
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    deb http://br.archive.ubuntu.com/ubuntu/ jaunty universe
    deb-src http://br.archive.ubuntu.com/ubuntu/ jaunty universe
    deb http://br.archive.ubuntu.com/ubuntu/ jaunty-updates universe
    deb-src http://br.archive.ubuntu.com/ubuntu/ jaunty-updates universe
     
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    ## team, and may not be under a free licence. Please satisfy yourself as to 
    ## your rights to use the software. Also, please note that software in 
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    deb http://br.archive.ubuntu.com/ubuntu/ jaunty multiverse
    deb-src http://br.archive.ubuntu.com/ubuntu/ jaunty multiverse
    deb http://br.archive.ubuntu.com/ubuntu/ jaunty-updates multiverse
    deb-src http://br.archive.ubuntu.com/ubuntu/ jaunty-updates multiverse
     
    ## Uncomment the following two lines to add software from the 'backports'
    ## repository.
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    # deb http://br.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
    # deb-src http://br.archive.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
     
    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    # deb http://archive.canonical.com/ubuntu jaunty partner
    # deb-src http://archive.canonical.com/ubuntu jaunty partner
     
    deb http://security.ubuntu.com/ubuntu jaunty-security main restricted
    deb-src http://security.ubuntu.com/ubuntu jaunty-security main restricted
    deb http://security.ubuntu.com/ubuntu jaunty-security universe
    deb-src http://security.ubuntu.com/ubuntu jaunty-security universe
    deb http://security.ubuntu.com/ubuntu jaunty-security multiverse
    deb-src http://security.ubuntu.com/ubuntu jaunty-security multiverse
    faça um backup de seu arquivo atual e troque o conteudo por este acima, depois:

    Código :
    apt-get update
    depois tente instalar o pacote desejado!

    espero que ajude!

    Boas! agora da me um erro ao instalar o snmpd

    E: Internal Error, Could not perform immediate configuration (2) on libc6

    sabem do que podera ser?

    obrigado.



  5. #5

    Thumbs up

    amigo...
    qual é o seu processador?

    vc pode tentar instalar o libc6

    Código :
    apt-get install libc6

    antes da uma confirida nos pacotes que derivam desse libc6, me parece que variam de acordo com a arquitetura do processador.
    Código :
     apt-cache search libc6

    e depois tentar instalar novamente o snmpd
    Última edição por Lincoln; 04-11-2009 às 16:01.

  6. #6

    Padrão

    Citação Postado originalmente por Lincoln Ver Post
    amigo...
    qual é o seu processador?

    vc pode tentar instalar o libc6

    Código :
    apt-get install libc6
    antes da uma confirida nos pacotes que derivam desse libc6, me parece que variam de acordo com a arquitetura do processador.
    Código :
     apt-cache search libc6
    e depois tentar instalar novamente o snmpd

    Processador> intel core 2 duo T7500, 2.2GHz

    mas estou no vmware e so encontro imagem 7.10 do ubuntu pra vmware player

    sudo apt-cache search libc6
    apt - Advanced front-end for dpkg
    apt-utils - APT utility programs
    libtext-iconv-perl - converts between character sets in Perl
    debian-policy - Debian Policy Manual and related documents
    libapt-rpm-pkg-libc6.7-6-2 - APT for RPM library
    libcompfaceg1 - Compress/decompress images for mailheaders, libc6 runtime
    libcompfaceg1-dev - Compress/decompress images for mailheaders, libc6 devel
    manpages-ja-dev - Japanese version of the manual pages (for developers)
    manpages-pt-dev - Portuguese Versions of the Manual Pages
    ubuntu-policy - Debian Policy Manual and related documents
    libc6 - GNU C Library: Shared libraries
    libc6-amd64 - GNU C Library: 64bit Shared libraries for AMD64
    libc6-dbg - GNU C Library: detached debugging symbols
    libc6-dev - GNU C Library: Development Libraries and Header Files
    libc6-dev-amd64 - GNU C Library: 64bit Development Libraries for AMD64
    libc6-i686 - GNU C Library: Shared libraries [i686 optimized]
    libc6-pic - GNU C Library: PIC archive library
    libc6-prof - GNU C Library: Profiling Libraries
    libc6-xen - GNU C Library: Shared libraries [Xen version]

    ja tentei instalar o libc6 e da o mesmo erro.
    E: Internal Error, Could not perform immediate configuration (2) on libc6



  7. #7

    Thumbs up

    ok...
    tente instalar o libc6-dev e o libc6-i686

    e depois destes desinstale o snmpd e instale de novo.

    perguntinha:

    esse erro ocorre quando vc faz exatamente o que ?

  8. #8

    Padrão

    Citação Postado originalmente por Lincoln Ver Post
    ok...
    tente instalar o libc6-dev e o libc6-i686

    e depois destes desinstale o snmpd e instale de novo.

    perguntinha:

    esse erro ocorre quando vc faz exatamente o que ?
    ocorre o erro ao fazer update, upgrade, instalar qualquer coisa, inclusive instalar os referidos libc6-......
    mas ja resolvi o assunto como ta descrito no inicio do topico.
    Muito obrigado mesmo assim!
    Última edição por redhatlesi; 05-11-2009 às 09:59.