Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. E ai meu amigo... uma coisa é certa.. ele so vai fazer entrar pela rota padrão (a primeira a ser discada)...
    Aqui tbm.. eu solucionei de uma maneira bem simples..

    Fiz 3 regras de ddns, uma para cada conexão que tenho..
    dai na hora do acesso eu tenho as 3 salvas aqui.. (conexão1.chanip - conexão2.changeip e assim por diante)

    Dai eu testo para ver qual esta padrão no momento..

    Sempre consigo acesso...

    E resolvi as paradas do acesso ao servidor e as rbs com redirecionamento, o qual ja postei no topico do luciano.. pcc 3 a 7 links...

    sucesso ai

  2. Ahhh... pra ajudar a galera vou postar aqui minhas regras de script que estão na rb_pcc.. e as regras de redirecionamento NAT que tbm estao na rb_pcc..

    DDNS

    add name=HomingBeacon-Simple policy=\
    ftp,reboot,read,write,policy,test,winbox,password source="# Dynamic DNS Upd\
    ate / Simple Edition\r\
    \n# Written by Sam Norris, ChangeIP.com\r\
    \n# Copyright ChangeIP.com 2009\r\
    \n# For support send mail to Support@ChangeIP.com\r\
    \n#\r\
    \n# 2009-06-22 RouterOS 3.25 Tested\r\
    \n# 2009-10-05 RouterOS 4.01rc1 Tested\r\
    \n#\r\
    \n# OVERVIEW: %\r\
    \n# This script will update a ChangeIP.com dynamic dns hostname\r\
    \n# with an ip address located directly on an interface.\r\
    \n# %\r\
    \n# NOTES: %\r\
    \n# IF THIS SCRIPT DOES NOT PRODUCE ANY OUTPUT PLEASE COPY AND PASTE IT\r\
    \n# AGAIN. THERE PROBABLY IS A LINE BREAK IN THE WRONG PLACE! Once you\r\
    \n# have created this script and tested that it works by running it\r\
    \n# manually you can schedule it to run every few minutes.\r\
    \n# %\r\
    \n# CONFIGURATION FIELD DEFINITIONS:\r\
    \n# ddnsuser: Enter your ChangeIP.com user id.\r\
    \n# ddnspass: Enter your ChangeIP.com password.\r\
    \n# ddnshost: Enter the hostname (Example Web Page) to update.\r\
    \n# ddnsinterface: Enter a list of interface names - case sensative.\r\
    \n# %\r\
    \n# %\r\
    \n# %\r\
    \n# %\r\
    \n# % % %\r\
    \n# % % %\r\
    \n# % % %\r\
    \n# %\r\
    \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
    \n# EDIT YOUR DETAILS / CONFIGURATION HERE\r\
    \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
    \n:global ddnsuser \"SEU USER CHANGE IP\"\r\
    \n:global ddnspass \"SUA SENHA CHANTE IP\"\r\
    \n:global ddnshost \"SEU SITE.changeip.org\"\r\
    \n:global ddnsinterface \"NOME DE SUA CONEXÃO _ NORMALMENTE PPPOE\"\r\
    \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
    \n# END OF USER DEFINED CONFIGURATION\r\
    \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
    \n\r\
    \n:global ddnssystem (\"mt-\" . [/system package get [/system package find \
    name=system] version] )\r\
    \n:global ddnsip [ /ip address get [/ip address find interface=\$ddnsinterf\
    ace] address ]\r\
    \n:global ddnslastip\r\
    \n\r\
    \n:if ([:len [/interface find name=\$ddnsinterface]] = 0 ) do={ :log info \
    \"DDNS: No interface named \$ddnsinterface, please check configuration.\" }\
    \r\
    \n\r\
    \n:if ([ :typeof \$ddnslastip ] = \"nothing\" ) do={ :global ddnslastip 0.0\
    .0.0/0 }\r\
    \n\r\
    \n:if ([ :typeof \$ddnsip ] = \"nothing\" ) do={\r\
    \n\r\
    \n:log info (\"DDNS: No ip address present on \" . \$ddnsinterface . \", pl\
    ease check.\")\r\
    \n\r\
    \n} else={\r\
    \n\r\
    \n :if (\$ddnsip != \$ddnslastip) do={\r\
    \n\r\
    \n :log info \"DDNS: Sending UPDATE!\"\r\
    \n :log info [ ut [/tool dns-update name=\$ddnshost address=[ick \$d\
    dnsip 0 [:find \$ddnsip \"/\"] ] key-name=\$ddnsuser key=\$ddnspass ] ]\r\
    \n :global ddnslastip \$ddnsip\r\
    \n\r\
    \n } else={ \r\
    \n\r\
    \n :log info \"DDNS: No changes necessary.\"\r\
    \n\r\
    \n }\r\
    \n\r\
    \n}"



    REGRA DE REDIRECIONAMENTO - NAT (LEMBRAR DE TROCAR A PORTA DO SERVIDOR OU DAS RBS PARA TER ACESSO... CADA UMA TEM QUE TER UMA PORTA DIFERENTE...

    PARA MUDAR A PORTA ENTRAR EM IP>SERVICES

    add action=dst-nat chain=dstnat comment=\
    "DIRECIONA WINBOX E HTTP PARA SERVIDOR" disabled=no dst-port=8080 (essa é a porta que vc configura no servidor para http) \
    protocol=tcp to-addresses=(aqui tu coloca o ip do servidor) to-ports=8080
    add action=dst-nat chain=dstnat comment="" disabled=no dst-port=8291(essa é a porta do winbox!) protocol=\
    tcp to-addresses=(aqui tu coloca o ip do servidor) to-ports=8291


    tomara que ajude vcs.. abraço e sucesso a todos!



  3. Citação Postado originalmente por tmelooliveira Ver Post
    Ahhh... pra ajudar a galera vou postar aqui minhas regras de script que estão na rb_pcc.. e as regras de redirecionamento NAT que tbm estao na rb_pcc..

    DDNS

    add name=HomingBeacon-Simple policy=\
    ftp,reboot,read,write,policy,test,winbox,password source=\"# Dynamic DNS Upd\
    ate / Simple Edition\r\
    \n# Written by Sam Norris, ChangeIP.com\r\
    \n# Copyright ChangeIP.com 2009\r\
    \n# For support send mail to Support@ChangeIP.com\r\
    \n#\r\
    \n# 2009-06-22 RouterOS 3.25 Tested\r\
    \n# 2009-10-05 RouterOS 4.01rc1 Tested\r\
    \n#\r\
    \n# OVERVIEW: %\r\
    \n# This script will update a ChangeIP.com dynamic dns hostname\r\
    \n# with an ip address located directly on an interface.\r\
    \n# %\r\
    \n# NOTES: %\r\
    \n# IF THIS SCRIPT DOES NOT PRODUCE ANY OUTPUT PLEASE COPY AND PASTE IT\r\
    \n# AGAIN. THERE PROBABLY IS A LINE BREAK IN THE WRONG PLACE! Once you\r\
    \n# have created this script and tested that it works by running it\r\
    \n# manually you can schedule it to run every few minutes.\r\
    \n# %\r\
    \n# CONFIGURATION FIELD DEFINITIONS:\r\
    \n# ddnsuser: Enter your ChangeIP.com user id.\r\
    \n# ddnspass: Enter your ChangeIP.com password.\r\
    \n# ddnshost: Enter the hostname (Example Web Page) to update.\r\
    \n# ddnsinterface: Enter a list of interface names - case sensative.\r\
    \n# %\r\
    \n# %\r\
    \n# %\r\
    \n# %\r\
    \n# % % %\r\
    \n# % % %\r\
    \n# % % %\r\
    \n# %\r\
    \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
    \n# EDIT YOUR DETAILS / CONFIGURATION HERE\r\
    \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
    \n:global ddnsuser \\"SEU USER CHANGE IP\\"\r\
    \n:global ddnspass \\"SUA SENHA CHANTE IP\\"\r\
    \n:global ddnshost \\"SEU SITE.changeip.org\\"\r\
    \n:global ddnsinterface \\"NOME DE SUA CONEXÃO _ NORMALMENTE PPPOE\\"\r\
    \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
    \n# END OF USER DEFINED CONFIGURATION\r\
    \n# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~\r\
    \n\r\
    \n:global ddnssystem (\\"mt-\\" . [/system package get [/system package find \
    name=system] version] )\r\
    \n:global ddnsip [ /ip address get [/ip address find interface=\$ddnsinterf\
    ace] address ]\r\
    \n:global ddnslastip\r\
    \n\r\
    \n:if ([:len [/interface find name=\$ddnsinterface]] = 0 ) do={ :log info \
    \\"DDNS: No interface named \$ddnsinterface, please check configuration.\\" }\
    \r\
    \n\r\
    \n:if ([ :typeof \$ddnslastip ] = \\"nothing\\" ) do={ :global ddnslastip 0.0\
    .0.0/0 }\r\
    \n\r\
    \n:if ([ :typeof \$ddnsip ] = \\"nothing\\" ) do={\r\
    \n\r\
    \n:log info (\\"DDNS: No ip address present on \\" . \$ddnsinterface . \\", pl\
    ease check.\\")\r\
    \n\r\
    \n} else={\r\
    \n\r\
    \n :if (\$ddnsip != \$ddnslastip) do={\r\
    \n\r\
    \n :log info \\"DDNS: Sending UPDATE!\\"\r\
    \n :log info [ ut [/tool dns-update name=\$ddnshost address=[ick \$d\
    dnsip 0 [:find \$ddnsip \\"/\\"] ] key-name=\$ddnsuser key=\$ddnspass ] ]\r\
    \n :global ddnslastip \$ddnsip\r\
    \n\r\
    \n } else={ \r\
    \n\r\
    \n :log info \\"DDNS: No changes necessary.\\"\r\
    \n\r\
    \n }\r\
    \n\r\
    \n}\"



    REGRA DE REDIRECIONAMENTO - NAT (LEMBRAR DE TROCAR A PORTA DO SERVIDOR OU DAS RBS PARA TER ACESSO... CADA UMA TEM QUE TER UMA PORTA DIFERENTE...

    PARA MUDAR A PORTA ENTRAR EM IP>SERVICES

    add action=dst-nat chain=dstnat comment=\
    \"DIRECIONA WINBOX E HTTP PARA SERVIDOR\" disabled=no dst-port=8080 (essa é a porta que vc configura no servidor para http) \
    protocol=tcp to-addresses=(aqui tu coloca o ip do servidor) to-ports=8080
    add action=dst-nat chain=dstnat comment=\"\" disabled=no dst-port=8291(essa é a porta do winbox!) protocol=\
    tcp to-addresses=(aqui tu coloca o ip do servidor) to-ports=8291


    tomara que ajude vcs.. abraço e sucesso a todos!

    amigo essa regra eu posto ela é no servidor ou na RB que faz o balance pcc?


    add action=dst-nat chain=dstnat comment=\
    "DIRECIONA WINBOX E HTTP PARA SERVIDOR" disabled=no dst-port=8080 coloquei essa porta no meu servidor http) \
    protocol=tcp to-addresses=172.16.10.1 ip do mei servidor to-ports=8080
    add action=dst-nat chain=dstnat comment="" disabled=no dst-port=8291 porta do winbox protocol=\
    tcp to-addresses=172.16.10.1 ip do mei servidor to-ports=8291

    pesso desculpas por tantas perguntas é q nao consegui fazer funcionar

  4. Amigo achu que uma regra que se encaixa é a mesma que uso para acessar a rb da minha torre, nao foi eu que criei eu peguei aqui no forum mas nao lembro aonde, ela ta na minha rede assim:

    Servidor:
    /ip firewall nat
    add action=dst-nat chain=dstnat comment=Torre disabled=no dst-port=3 protocol=tcp to-addresses=192.168.112.3 to-ports=8291

    Obs.: 192.168.112.3 é o ip da minha rb na torre, e 3 é a porta que eu uso para entrar nela.

    RB torre.

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.112.1 scope=30 target-scope=10

    Obs.: 192.168.112.1 ip do meu server.


    Eu nao terminei meu pcc pois to com um problema de comunicação do pcc com o servidor mas assim que terminar vo testar essas regras minhas.

    E sobre o DDNS como eu uso WebMikrotik , ele gera meu ddns, vou colocar apenas a porta de direcionamento e pelo que imagino vai funcionar.

    Me desculpa se falei alguma bobeira, ate porque não esta em uso em pcc as regras.



  5. Citação Postado originalmente por dimensaonet Ver Post
    amigo essa regra eu posto ela é no servidor ou na RB que faz o balance pcc?


    add action=dst-nat chain=dstnat comment=\
    "DIRECIONA WINBOX E HTTP PARA SERVIDOR" disabled=no dst-port=8080 coloquei essa porta no meu servidor http) \
    protocol=tcp to-addresses=172.16.10.1 ip do mei servidor to-ports=8080
    add action=dst-nat chain=dstnat comment="" disabled=no dst-port=8291 porta do winbox protocol=\
    tcp to-addresses=172.16.10.1 ip do mei servidor to-ports=8291

    pesso desculpas por tantas perguntas é q nao consegui fazer funcionar
    Amigo sua regra está certa. Porém vc tem que ter colocar no computador onde está sendo a rota default no mikrotik.






Tópicos Similares

  1. Respostas: 2
    Último Post: 26-09-2014, 10:41
  2. DDNS com modem routeado no MK
    Por lhonay no fórum Redes
    Respostas: 9
    Último Post: 08-11-2013, 00:43
  3. Respostas: 1
    Último Post: 24-08-2010, 08:04
  4. DDNS + PCC + Modem Bridge + Mk 3.x = Problema
    Por admskill no fórum Redes
    Respostas: 3
    Último Post: 23-11-2009, 22:07
  5. CONFIGURAR ADSL NO CL8 COM MODEM ALCATEL SPEED TOUCH
    Por rdsat no fórum Servidores de Rede
    Respostas: 1
    Último Post: 31-07-2003, 21:21

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L