+ Responder ao Tópico



  1. #1

    Padrão Limite de download por velocidade - Connection Rate

    Depois de muito tempo de aprender com este maravilhoso fòrum vou tentar colaborar um pouco.

    Antes de começar, eu quero que você saiba que eu sou de Formosa (Argentina) e meu Português é horrível.
    Desculpe minha horrores de ortografia.

    Vamos aprender a controlar downloads com 2 opções de mangle: "connection-byte" y "connection-rate"
    Connection Rate esta desde a versão 3.30 e permite marcar o tráfego com base em sua velocidade atual.


    Você pode criar regras no mangle fazendo que, se uma conexão após de "X" Kbytes contínua a "Y" Kbps de velocidade é marcado e pode atribuir uma prioridade mais baixa.


    Um exemplo para melhor compreensão:

    Link: 3 M
    Plano Cliente: 256 kbps Download / 128 kbps Upload
    -------------------------------------------------------------------------------------
    As regras para Mangle

    /ip firewall mangle
    add chain=forward action=mark-connection connection-mark=!trafego_pesado_conn \
    new-connection-mark=all_conn
    add chain=forward action=mark-connection connection-bytes=1000000-0 \
    connection-mark=all_conn connection-rate=200k-100M \
    new-connection-mark=trafego_pesado_conn protocol=tcp
    add chain=forward action=mark-connection connection-bytes=1000000-0 \
    connection-mark=all_conn connection-rate=200k-100M \
    new-connection-mark=trafego_pesado_conn protocol=udp
    add chain=forward action=mark-packet connection-mark=trafego_pesado_conn \
    new-packet-mark=trafego_pesado passthrough=no
    add chain=forward action=mark-packet connection-mark=all_conn \
    new-packet-mark=other_traffic passthrough=no



    Explicação:

    add chain=forward action=mark-connection connection-bytes=1000000-0 \
    connection-mark=all_conn connection-rate=200k-100M \
    new-connection-mark=trafego_pesado_conn protocol=tcp
    add chain=forward action=mark-connection connection-bytes=1000000-0 \
    connection-mark=all_conn connection-rate=200k-100M \
    new-connection-mark=trafego_pesado_conn protocol=udp

    Estas 2 regras fazen que cada conexão que, após o primeiro 1 Mbyte continuar a uma velocidade de 200kbps ou superior, são marcadas como "tráfego pesado"

    -----------------------------------------------------------------------------------------------------------------------
    As regras para Queue Tree

    /queue tree
    add name=upload parent=Internet max-limit=3M
    add name=other_upload parent=upload limit-at=2M max-limit=3M \
    packet-mark=other_traffic priority=1
    add name=trafego_pesado parent=upload max-limit=1M \
    packet-mark=trafego_pesado priority=8
    add name=download parent=Clientes max-limit=3M
    add name=other_download parent=download limit-at=2M max-limit=3M \
    packet-mark=other_traffic priority=1
    add name=heavy_download parent=download max-limit=1M \
    packet-mark=trafego_pesado priority=8




    Todo o "tráfego pesado" da rede (Conexões que mantêm ritmo acelerado por longos períodos de tempo como P2P, HTTP - FTP donwloads) sempre terá no máximo 1M, para ser compartilhado entre todos os clientes da rede.
    Deste modo pode ser dada prioridade a outro tràfego por exemplo VOIP, navegação HTTP e jogos online

    Saudações

  2. #2

    Padrão

    Boa tarde, chefia...meus conhecimentos são meios limitados....rsrsrs, tentei fazer isso com a versão 2.9.27 generica mas não concegui....poderia me ajudar a migrar este Controle para a minha versão do mk?


    Anderson Junior



  3. #3

    Padrão

    Connection Rate esta desde a versão 3.3, não pode ser usado no versão 2.9.27.

    Eu agora estou usando para limitar a velocidade de download a 64k para cada usuário que fez download mais de 5M a toda a velocidade.
    Apenas limite de downloads... a navegação continua a toda velocidade

  4. #4

    Padrão

    sim...sei...mas será que não tem alguma forma de fazer nesta versão que eu to usando? usar algum outro recurso do mk 2.9.27 tipo o conection bytes?



  5. #5

    Padrão

    Na versão 2.9.x não pode ser feito controle com base no velocidade de conexão, na forma como faz connection rate

    Você pode usar o QOS FREEZER, que de acordo com a quantidade de tráfego baixa a velocidade de conexão.


    Eu estou preparando um outro post, que mostra como fazer limite de velocidade com base na extensão (*.exe, *.rar, *.iso.....) usando proxy paralelo. Funciona para qualquer versão.


    Espere, talvez é útil para você

  6. #6

    Padrão

    ok...vou aguardar meu amigo....obrigado pela sua atenção.



  7. #7

    Padrão

    Citação Postado originalmente por CarlosAdrian Ver Post
    Na versão 2.9.x não pode ser feito controle com base no velocidade de conexão, na forma como faz connection rate

    Você pode usar o QOS FREEZER, que de acordo com a quantidade de tráfego baixa a velocidade de conexão.


    Eu estou preparando um outro post, que mostra como fazer limite de velocidade com base na extensão (*.exe, *.rar, *.iso.....) usando proxy paralelo. Funciona para qualquer versão.


    Espere, talvez é útil para você

    MONTA AI PARCEIRO . ESTOU NO AGUARDO TBM BLZ

  8. #8

    Padrão

    Citação Postado originalmente por CarlosAdrian Ver Post
    Eu estou preparando um outro post, que mostra como fazer limite de velocidade com base na extensão (*.exe, *.rar, *.iso.....) usando proxy paralelo. Funciona para qualquer versão.
    Pode ser util, alguma noticia?



  9. #9
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão

    Amigo desculpe mas não está faltando os conceitos para que o pessoal aprenda a fazer e não a copiar?

  10. #10

    Padrão

    Citação Postado originalmente por minelli Ver Post
    Amigo desculpe mas não está faltando os conceitos para que o pessoal aprenda a fazer e não a copiar?
    Pois é Minelli, eu adoro regras com explicações do porque das coisas. Só colar, da uma falsa segurança. Se der qualquer incompatiblilidade é um sufoco para saber onde ocorreu.
    Se ao postar regras, o forista perder um tempinho para acrescentar uma didática, creio que logo, logo teremos muitos progredindo no MK. Eu me coloco nestes, pois muitas regras eu não entendo bem e fico com medo de usar. Principalmente para mim que não venho do linux.



  11. #11
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão

    Sim, exato a falta de conceito realmente dificulta.
    Mas veja no meu Blog do under-linux atualizarei o que está lá.
    Última edição por minelli; 10-03-2010 às 18:45.

  12. #12

    Padrão Re: Limite de download por velocidade - Connection Rate

    Sei que esse tópico foi criado há muito tempo, mas preciso da ajuda de vocês. Atualmente na versão 5 e 6 do Mikrotik, o connection-rate mudou a forma de inserir os dados. Antes era connection-rate=200k-100M. Hoje os valores são inseridos em bytes? kbytes? Obrigado desde já.



  13. #13
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão Re: Limite de download por velocidade - Connection Rate

    Acredito que aqui esteja o que procura.
    http://wiki.mikrotik.com/wiki/Manual:Connection_Rate

    Sent from my SM-G925I using UnderLinux mobile app