+ Responder ao Tópico



  1. #1

    Padrão Bloquear Sites pelo Firewall

    Como vão colegas, hoje venho com uma pequena dulvida, consigo bloquear sites na minha rede somente pelo firewall? (sem usar WEB PROXY). Se consigo fazer o bloqueio consigo criar uma black list para ter um conrtole facil por palavras especificas no endereço e não pelo IP? Se tiver esta posibilidade e alguem postar como se faz ficarei agradecido!!!

    Um abraço!!!

  2. #2

    Padrão

    Tenho esse bloqueio aqui no meu servidor funcionando perfeitamente.

    /ip firewall filter
    add action=drop chain=forward comment="Bloqueio do Orkut" content=orkut

    Ele bloqueia só o site do orkut. se quizer bloquear outro site é só trocar o content de orkut para outro.

    ex: /ip firewall filter
    add action=drop chain=forward comment="Bloqueio do Youtube" content=youtube



  3. #3

    Padrão

    Essa regra funciona msm se vc tiver usando um proxy?
    Pq no meu servidor mk eu coloquei essa msm regra + dpois que eu habilitei o proxy ela parou de funcionar.

    Citação Postado originalmente por lwwkas Ver Post
    Tenho esse bloqueio aqui no meu servidor funcionando perfeitamente.

    /ip firewall filter
    add action=drop chain=forward comment="Bloqueio do Orkut" content=orkut

    Ele bloqueia só o site do orkut. se quizer bloquear outro site é só trocar o content de orkut para outro.

    ex: /ip firewall filter
    add action=drop chain=forward comment="Bloqueio do Youtube" content=youtube
    Última edição por LOWSDYVE; 13-01-2010 às 13:00.

  4. #4

    Padrão

    Citação Postado originalmente por LOWSDYVE Ver Post
    Essa regra funciona msm se vc tiver usando um proxy?
    Pq no meu servidor mk eu coloquei essa msm regra + dpois que eu habilitei o proxy ela parou de funcionar.


    Vc usa um servidor proxy externo ou usa o proxy do Milrotik mesmo???



  5. #5

  6. #6

    Padrão

    provavelmente a "chain=forward" só funcione sem proxy mas utilize a "chain=input" que vai funcionar mesmo com proxy ativado.



  7. #7

    Unhappy Pergunta ?

    Olá pessoal !
    Eu sou novato em Mk, tenho um servidor aki na minha cidade !
    Um amigo meu montou aki pra min, só que ficou aberta a minha rede qualquer um acessa !
    Tem algum precedimento tipo criptografia, para fazer controle, tipo regras na mk ??

    Por favor me ajudem .
    Abrass !!

  8. #8

    Padrão

    Cara tem uma coisa bem bacana que vc pode fazer, primeiro: vc usa Mk nas torres tambem??? E com respeito ao servidor a maneira mais segura de vc ter os clientes é usando o PPPoE, e vc bloqueia na interface a arp, e se vc usa Mk nas torres vc tambem pode bloquear na acces list de modo que so mac cadastrado ali vai poder conectar naquele ap e com o servidor configurado para os clientes usarem pppoe e bloqueando na interface a arp somente quem tem usuario e senha cadastrados vão poder navegar. Cryptografia não é segurança não, se quebra facil, mas vc pode usar cryptogracia tambem.

    Citação Postado originalmente por Radio Ver Post
    Olá pessoal !
    Eu sou novato em Mk, tenho um servidor aki na minha cidade !
    Um amigo meu montou aki pra min, só que ficou aberta a minha rede qualquer um acessa !
    Tem algum precedimento tipo criptografia, para fazer controle, tipo regras na mk ??

    Por favor me ajudem .
    Abrass !!



  9. #9

  10. #10

    Padrão

    alguem sabe como bloquar donwload pelo firewal?



  11. #11

    Padrão

    Ola . a todos ... eu hoje utilizo o bloqueio de sites atravez da opção CONTENT do firewall e funciona perfeitamente ... porem estava querendo diminuir a quantidade de regras ( ex .. 1 cliente meu pediu para bloquear - orkut - youtube - sexo - redtube ) ja tentei colocar 2 palavras na função CONTENT .. porem nao funciona .. existe uma forma de escrever na abba CONTENT para a regra abranger + palavras ? No aguardo .
    Clique na imagem para uma versão maior

Nome:	         content..jpg
Visualizações:	235
Tamanho: 	51,0 KB
ID:      	9935

  12. #12

    Padrão

    Olá a todos escontrè este script no mikrotik wiki que faz o bloqueio de sites atravez do firewall

    Primeiro você deve configurar o roteador para captar todos os pedidos de DNS:

    /ip firewall nat
    add action=redirect chain=dstnat comment=DNS dst-port=53 protocol=tcp to-ports=53
    add action=redirect chain=dstnat dst-port=53 protocol=udp to-ports=53

    No firewall adicionar:

    /ip firewall filter
    add chain=forward dst-address-list=restricted action=drop

    Colocamos o script no scheduler para executar, por exemplo, a cada 30 segundos

    Script:

    :foreach i in=[/ip dns cache find] do={
    :local bNew "true";
    :local cacheName [/ip dns cache all get $i name] ;
    # ut $cacheName;

    :if (([:find $cacheName "rapidshare"] != 0) || ([:find $cacheName "youtube"] != 0)) do={

    :local tmpAddress [/ip dns cache get $i address] ;
    # ut $tmpAddress;

    # if address list is empty do not check
    :if ( [/ip firewall address-list find ] = "") do={
    :log info ("added entry: $[/ip dns cache get $i name] IP $tmpAddress");
    /ip firewall address-list add address=$tmpAddress list=restricted comment=$cacheName;
    } else={
    :foreach j in=[/ip firewall address-list find ] do={
    :if ( [/ip firewall address-list get $j address] = $tmpAddress ) do={
    :set bNew "false";
    }
    }
    :if ( $bNew = "true" ) do={
    :log info ("added entry: $[/ip dns cache get $i name] IP $tmpAddress");
    /ip firewall address-list add address=$tmpAddress list=restricted comment=$cacheName;
    }
    }
    }
    }

    Manual:Scripting-examples - MikroTik Wiki



  13. #13

    Padrão Re: Bloquear Sites pelo Firewall

    Tenho um bloqueio aqui do jeito que penso que vc quer. Vá em Ip > Firewall > Address list crie um nome que deseja com um ip qualquer exemplo facebook
    Depois va em Ip > Firewall > Rules + add , chain=forward protocolo=tcp action=Add dst to list embaixo vc poe Address List=facebook Advanced Content=facebook.com Ok,pronto agora confere em Ip>Firewall >Address List ele vai pegando todos os ip´s a medida que os usuários vao acessando e vc confere ai ele sendo preenchido com os ip´s. Depois vá Ip > Firewall > Rules + add , chain=forward protocolo=tcp action=drop Advanced Dst Address = facebook ok, ps: faça uma lista com range de ip´s que deseja bloquear e use em Src. Address List

  14. #14

    Padrão Re: Bloquear Sites pelo Firewall

    Quero dar os parabens para vcs... pois essas regras funciona muito bem;
    agora preciso de uma ajuda para desbloquear uma classe de rede pra ter acesso total... alquem pode ajudar



  15. #15

    Padrão Re: Bloquear Sites pelo Firewall

    Como eu disse acima vc pode ir em Ip >Firewall > Address List > e poe o range de ip´s que ache necesário, ou na hora de bloquear vc usa algo do tipo 192.168.0.0/16 , no qual o que esta após a barra serve para a classe.