+ Responder ao Tópico



  1. #1

    Padrão Cache full maluco

    amigos , aqui roda a versao 3.22 , implantei hotspot , funciona mto bem , o proxy também funciona legal , implantei cachefull que o amigo CATV postou aqui no forum , porem , o que acontece , ele funciona legal , funciona de verdade , mas estoura a banda toda , inclusive eu implantei com a regra RETURN que ele postou , mas não resolveu o problema de estouro da banda .

    gostaria de saber se há uma solução pro meu problema ,

    aproveitando o ensejo , eu também implantei uma regra no queues que libera a banda depois de 00:00 , mas como o hotspot gera queues dinamicamente , nao consigo mais colocar a regra de liberação lá pra cima , alguma sugestão ?

    desde ja agradeço .

  2. #2

    Padrão

    uma solução que gostei para isso foi usar o mk-auth, já vem tudo pronto



  3. #3

    Padrão

    Citação Postado originalmente por rjwifi Ver Post
    amigos , aqui roda a versao 3.22 , implantei hotspot , funciona mto bem , o proxy também funciona legal , implantei cachefull que o amigo CATV postou aqui no forum , porem , o que acontece , ele funciona legal , funciona de verdade , mas estoura a banda toda , inclusive eu implantei com a regra RETURN que ele postou , mas não resolveu o problema de estouro da banda .

    gostaria de saber se há uma solução pro meu problema ,

    aproveitando o ensejo , eu também implantei uma regra no queues que libera a banda depois de 00:00 , mas como o hotspot gera queues dinamicamente , nao consigo mais colocar a regra de liberação lá pra cima , alguma sugestão ?

    desde ja agradeço .

    Já utilizei a versão 3.22 e gerou muito problema com o Proxy e travamento do Servidor.
    Quando atualizei para a versão 3.30 resolveu completamente todos os problemas. O rendimento do Proxy é muito superior.

  4. #4

    Exclamation

    Amigo, conseguiu resolver?

    Somente após ler esse tópico descobri pq alguns usuarios saiam por fora do controle de banda.
    Desativei as regras do cache full em mangle voltou ao normal.

    Eu estou usando a versão 4.3. Será q se voltar para 3.30 resolve, alguem já passou por isso tb?

    Valew.



  5. #5

    Padrão

    Citação Postado originalmente por lrmurad Ver Post
    Amigo, conseguiu resolver?

    Somente após ler esse tópico descobri pq alguns usuarios saiam por fora do controle de banda.
    Desativei as regras do cache full em mangle voltou ao normal.

    Eu estou usando a versão 4.3. Será q se voltar para 3.30 resolve, alguem já passou por isso tb?

    Valew.

    Depois que atualizei para a v3.30, todas as ferramentas que utilizo funcionam perfeitamente.
    Quando surge versão nova, eu só atualizo depois que me certifico de várias outras estarem utilizando a um tempo razoável e não tiverem problemas. Mas pelo que eu tenho visto aqui no fórum, a versão 4.xx ainda está com vários bugs.

    Então eu aconselho voltar para a 3.30. Mas antes de fazer o downgrade de uma versão 4.xx para 3.xx, pesquise aqui no fórum sobre a perda da licença, para não acontecer com o seu software.
    Última edição por lessa; 31-12-2009 às 00:11.

  6. #6

    Padrão

    ainda nao consegui resolver , vou migrar pra 3.30 pra ver se resolvo o estouro de banda



  7. #7

    Padrão

    Olhem nesse tópico: https://under-linux.org/f132462-nao-...-da-versao-4-x

    "NAO FAÇAM O DOWNGRADE DA VERSAO 4.X PARA ABAIXO DA 3.25 QUE SUA RB PERDERA A LICENCA IGUAL A MINHA PERDEU HEHEHE."

    "pode fazer sim so lembre de copiar a chave antes de subir a versao nova, quando fazer o down tem a chave ta tranquilo. Aqui funcionou ehhehe"

  8. #8

    Padrão

    migrei pra 3.30 e continua me roubando a banda toda , alguem tem alguma sugestão ?



  9. #9

    Padrão

    Das pesquisas que fiz aqui no fórum notei algumas maneiras diferentes de fazer a marcação de pacotes para cache full. aí mudei a minha ficou assim:

    chain=output action=mark-connection new-connection-mark=conn_squid-up passthrough=yes protocol=tcp src-port=3128 content=X-Cache: HIT dscp=4

    tem tutorial que não manda por nada em dscp, como tem tutorial que não fala pra colocar nada em content. na minha regra já havia o content, mas o dscp. Parece que melhorou. Mas ainda não afirmo estar 100%. Preciso ficar de olho por mais tempo.

    Tenta alterar sua marcação de pacotes de cache full pra ver q bicho dá. E se puder posta o resultado.

  10. #10

    Padrão

    Citação Postado originalmente por lrmurad Ver Post
    Das pesquisas que fiz aqui no fórum notei algumas maneiras diferentes de fazer a marcação de pacotes para cache full. aí mudei a minha ficou assim:

    chain=output action=mark-connection new-connection-mark=conn_squid-up passthrough=yes protocol=tcp src-port=3128 content=X-Cache: HIT dscp=4

    tem tutorial que não manda por nada em dscp, como tem tutorial que não fala pra colocar nada em content. na minha regra já havia o content, mas o dscp. Parece que melhorou. Mas ainda não afirmo estar 100%. Preciso ficar de olho por mais tempo.

    Tenta alterar sua marcação de pacotes de cache full pra ver q bicho dá. E se puder posta o resultado.
    rapaz , eu tentei outra maneira que um amigo me enviou , mas não deu certo , estoura tudo , posta pra mim a sua configuração , quem sabe aqui funciona , isso virou um lema , tem configuração que roda mas estoura o link , tem configuração que o arquivo vem do proxy , mas não vem a full e tem configuração que nada muda .

    da um help ai pro amigo !!

    um abraço !!



  11. #11

    Padrão

    eu reparei que tanto a marcação do cache full como a do P2P fazem com q o cliente saia por fora controle da simple queue.
    no fim eu desativei essa marcação do cache full e pronto, pelo menos agora não fica um roubando a conexão de todos.

    Minhas regras do cache full são as seguintes:
    /ip firewall mangle> print
    X ;;; Cache Full
    chain=output action=mark-connection new-connection-mark=conn_squid-up passthrough=yes protocol=tcp src-port=3128 content=X-Cache: HIT dscp=4

    16 X chain=output action=mark-packet new-packet-mark=pacotes_squid-up passthrough=yes connection-mark=conn_squid-up

    17 X chain=output action=return connection-mark=conn_squid-up

    18 X ;;; Cache Full
    chain=prerouting action=mark-connection new-connection-mark=conn_squid-down passthrough=yes protocol=tcp dst-port=3128

    19 X chain=prerouting action=mark-packet new-packet-mark=pacotes_squid-down passthrough=yes connection-mark=conn_squid-down

    20 X chain=output action=return connection-mark=conn_squid-down

    /ip firewall filter> print
    0 ;;; BLOQUEIO DO PROXY EXTERNO
    chain=input action=drop protocol=tcp in-interface=LinkTelefonica dst-port=3128

    1 ;;; ACEITAR CONEXOES PROXY
    chain=input action=accept protocol=tcp in-interface=Rede Local dst-port=3128

    /queue tree> print
    0 name="CACHE-FULL - Download" parent=global-in packet-mark=pacotes_squid-down limit-at=0 queue=default priority=1 max-limit=0 burst-limit=0
    burst-threshold=0 burst-time=0s

    1 name="CACHE FULL - Upload" parent=global-out packet-mark=pacotes_squid-up limit-at=0 queue=default priority=1 max-limit=300k burst-limit=0
    burst-threshold=0 burst-time=0s

    Essas são as regras que tenho aqui, mas como pode ver, em mangle eu desativei. To pensado em por um proxy paralelo, ouvi falar q funcinona melhor o cache full.

    Mas se funcionar aí da um alô pra gente depois.

    Valew.