+ Responder ao Tópico



  1. #1

    Padrão Problemas com ACK

    Amigos gostaria de uma ajuda quantoa a um comportamento que venho notado em uma torre que tenho aqui ela tem na media 10 clientes conectadas a ela ..
    normalemtne ... o ack da turma fica em 30....
    mas to vendo aqui tenho tido problemas com uns 3 clientes que quando conectam na torre entram com ack de tipo 260 elevando o ack da torre .. e fica lento ... enquanto que no restante dos clientes a media é 30
    bom quanto a distancia estes cliestes estao a no maximo 1,5 km,,,

    Ja achei bastante coisa pela net a respeito do ack mas quado tendo definilo manual ai que fica uma porcaria mesmo ... no momento esta automatico em meu mk ..

    tem alguma maneira de mander o ack mais baixo .. mas porem dinamico .. e sei la se caso nao for possivel ter um ack mais baixo o cliente nem associa na torre ??

  2. #2

    Padrão

    Voce pode usar esse script, nao me recordo agora que fez esse escript porem ele deve te ajudar!

    #Informacoes:
    #
    #Variavel ack -> deve ter o valor do ack MAXIMO permitido.
    #Variavel cut -> deve ser 0 ou 1, 0 somente mostra, 1 mostra e desconecta a estacao.
    #####################################################################
    #Configuracoes das variaveis
    :local ack 50;
    :local cut 0;
    ######################### Script - NAO ALTERAR ###########################
    :local mac "";
    :local uack "";
    :local removido "";
    :log warning ("[ackchk] Procurando clientes com ACK maior que " . $ack);
    #pega a lista de interfaces AP wireless ativas, e que tenham ack dinamico
    :foreach i in=[ / interface wireless find mode="ap-bridge" ack-timeout="dynamic" running] do={
    :local intname [ / interface wireless get $i name ];
    :log warning (" Interface: " . $intname);
    :foreach x in=[/interface wireless registration-table find interface=$intname] do={
    :set uack [/interface wireless registration-table get $x ack-timeout];
    :set removido "";
    :if ($uack > $ack) do={
    :set mac [ / interface wireless registration-table get $x mac-address];
    :if ($cut = 1) do= {
    :set removido " removido...";
    / interface wireless registration-table remove $x;
    };
    :log warning (" mac: " . $mac . "@" . $intname . " [" . $uack . "]" . $removido);
    };
    };
    };
    ################################## FIM #################################



  3. #3
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    O problema não é o ACK... Ele é o sintoma. É necessário ajustar os clientes que ocorrem o problema e posso garantir com certeza absoluta que não será no Mikrotik ROS que irá conseguir acertar isso.

  4. #4

    Padrão

    o Sérgio ta certo, porem um ack elevado f...... todos os clientes, dropando acks altos ja é de grande ajuda, dependendo do caso claro.



  5. #5

    Padrão

    Cara, concordo com o Sérgio, isso é sintoma.O mais provável é uma instalação com problemas ou o equipamento estar apresentando algum dano. seta o ACK para um valor tipo 100 e tudo que for acima disso ele corta.

  6. #6

    Padrão

    quer dizer que se eu definir 100 a baixo disto ele aceita ???



  7. #7

    Padrão

    Se vc definir 100 como ACK o MK vai negociar apenas nesse valor. Portanto regularize os clientes que estão com problemas e após isso vai baixando o valor desse ACK até chegar em um valor satisfatorio pra vc, tem gente aqui no fórum que se dá muito bem com ACK a 32 e tem outros com ACK 100. Isso vai depender da qualidade do sinal e distância dos clientes.

  8. #8

    Padrão

    Concordo contigo efrenjunior, de que se deva realizar a manutenção para se descobrir o cliente quando é nosso. Quando é alguém tentanod conectar já é mais complicado. O calor de 100 foi um valor hipotético mesmo, cada caso é um caso, mas 100 é um bom limite máximo. E quem fica acima disso não consegue conectar, fazendo com que a torre estabilize.