+ Responder ao Tópico



  1. #1

    Padrão Duvida Redirecionar portas

    Olá Pessoal Tenho o seguinte cenario

    Duas redes separadas - Rede A e Rede B

    Um Servidor que tem duas placas de rede uma conectada a Rede A e a outra a Rede B

    Acontece que tenho q fazer o seguinte uma maquina da Rede A tenque acessar um FTP da Rede B e receber resposta dessa solicitaçao e tudo como posso fazer ??

    Por Exemplo a maquina da rede A 10.0.0.5 Precisa acessar a Rede B na maquina 192.168.1.76 a porta 5050 ??

    Grato pessoal

  2. #2

    Padrão

    Bom Dia, especifique um pouco melhor qual a sua estrutura entre estas duas máquinas.... tem um Firewall? aguardo.... att



  3. #3

    Padrão

    Oi

    Estas duas redes tão separadas a única coisa q liga elas duas ;e um servidor linux que esta conectado em ambas as redes

    Grato

  4. #4

    Padrão

    Esta máquina esta com o Gateway de ambas? se não estiver crie rotas tipo a 10.0.0.5 para acessar 192.168.1.76 tenha como rota o ip deste Servidor, e vice-versa... existe algum Iptables ou firewall rodando nesta máquina linux (a que esta no meio)?



  5. #5

    Padrão

    Citação Postado originalmente por Lynx Ver Post
    Esta máquina esta com o Gateway de ambas? se não estiver crie rotas tipo a 10.0.0.5 para acessar 192.168.1.76 tenha como rota o ip deste Servidor, e vice-versa... existe algum Iptables ou firewall rodando nesta máquina linux (a que esta no meio)?
    hmm não entendi bem essa do gateway

    mas tem o iptables nessa maquin linux. ja tentei algumas configuracoes mas sem sucesso.

  6. #6

    Padrão

    essa máquina linux, é o gateway da rede 10.0.0.5 e da rede 192?? se for, e em em /proc/sys/net/ipv4/ip_forward você tiver um numero 1 (isto possibilita a comunicaçao entre as placas de redes no linux..) e se suas polices do iptables estiverem ACCEPT, a conexao entre estas maquinas deve estar ok...

    entao verifique esses detalhes citados... se na quele aquivo tiver um 0 colo o numero 1 e por aew vai... defina suas polices Forward e Input para ACCEPT e defina essa máquina linux como gateway das maquinas de redes diferentes... ou crie rotas nesse sentido...

    Vai postando ai...

    Att



  7. #7

    Padrão

    Citação Postado originalmente por Lynx Ver Post
    essa máquina linux, é o gateway da rede 10.0.0.5 e da rede 192?? se for, e em em /proc/sys/net/ipv4/ip_forward você tiver um numero 1 (isto possibilita a comunicaçao entre as placas de redes no linux..) e se suas polices do iptables estiverem ACCEPT, a conexao entre estas maquinas deve estar ok...

    entao verifique esses detalhes citados... se na quele aquivo tiver um 0 colo o numero 1 e por aew vai... defina suas polices Forward e Input para ACCEPT e defina essa máquina linux como gateway das maquinas de redes diferentes... ou crie rotas nesse sentido...

    Vai postando ai...

    Att

    Olá Amigo

    Pois é a maquina linux não é gateway das redes e acho que nem posso colocar ela como gateway

    tem outra forma sem precisar colocar o gateway ??

    Obrigado

  8. #8

    Padrão

    ola amigos boa tarde a todos meu problema não é bem esse do amigo acima mas como o post fala de redirecionamento acho q vcs podem me ajudar tenho uma rede simples com mikrotik ontem consegui meu cache full fucionar mas os pcs só navegam se eu colocar proxy no navegador, isso acontece assim q ligo o redirecionamento da porta 80 para a 3128, a regra original era essa mas não fucionava

    /ip firewall nat
    add action=redirect chain=dstnat comment=\
    "-" redirecionamento porta 80 para webproxy 3128" disabled=\
    no dst-port=80 protocol=tcp src-address=192.168.2.0/24 to-ports=3128

    então troquei o chain por pre-hotspot e fucionou meu cache mas apenas com proxy no navegador!
    creio q o problema esta em redirecionamento. sera que alguem me daria essa luz?



  9. #9

    Padrão

    Citação Postado originalmente por asthi Ver Post
    ola amigos boa tarde a todos meu problema não é bem esse do amigo acima mas como o post fala de redirecionamento acho q vcs podem me ajudar tenho uma rede simples com mikrotik ontem consegui meu cache full fucionar mas os pcs só navegam se eu colocar proxy no navegador, isso acontece assim q ligo o redirecionamento da porta 80 para a 3128, a regra original era essa mas não fucionava

    /ip firewall nat
    add action=redirect chain=dstnat comment=\
    "-" redirecionamento porta 80 para webproxy 3128" disabled=\
    no dst-port=80 protocol=tcp src-address=192.168.2.0/24 to-ports=3128

    então troquei o chain por pre-hotspot e fucionou meu cache mas apenas com proxy no navegador!
    creio q o problema esta em redirecionamento. sera que alguem me daria essa luz?
    Amigo creio que se o problema não e bem o mesmo acho mais interessante criar outro post até pra outras pessoas mais entendidas verem ok.


    Referente a minha resposta de cima, creio que não posso trocar o gateway pelo seguinte uma das interfaces de rede é uma VPN que tem outro gateway ok

    Grato

  10. #10

    Padrão

    seguinte, vc entendeu a parte de colocar 1 no arquivo especificado e colocar o iptables dessa maquina linux para aceitar INPUT e FORWARD dessas outras maquinas certo?

    vc naum precisa colocar essa maquina linux como gateway, apenas citei pois se ja fosse, seria mais facil...

    Vc precisa criar a seguinte rota.... no pc 10.0.0.x vc cria uma rota, que para chegar em 192.xxx ele deve ir para o IP da maquina linux (pois esta conhece a rede 192) e no pc de rede 192.xxx. indique que para alcançar a rede 10.0.0.x o pacote de ser direcionado para a maquina linux...

    entende.... resumindo... indique que para alcançar a outra rede o pacote vá ateh a maquina linux.... isso nas 2 maquinas...

    naum esqueça da primeira parte.... 1 no arquivo do /proc/sys.... e do iptables....

    att



  11. #11

    Padrão

    Citação Postado originalmente por Lynx Ver Post
    seguinte, vc entendeu a parte de colocar 1 no arquivo especificado e colocar o iptables dessa maquina linux para aceitar INPUT e FORWARD dessas outras maquinas certo?

    vc naum precisa colocar essa maquina linux como gateway, apenas citei pois se ja fosse, seria mais facil...

    Vc precisa criar a seguinte rota.... no pc 10.0.0.x vc cria uma rota, que para chegar em 192.xxx ele deve ir para o IP da maquina linux (pois esta conhece a rede 192) e no pc de rede 192.xxx. indique que para alcançar a rede 10.0.0.x o pacote de ser direcionado para a maquina linux...

    entende.... resumindo... indique que para alcançar a outra rede o pacote vá ateh a maquina linux.... isso nas 2 maquinas...

    naum esqueça da primeira parte.... 1 no arquivo do /proc/sys.... e do iptables....

    att
    Olá Amigo

    mas no caso uma das maquinas é windows não e linux

    tem como eu adicionar uma rota nela mesmo assim ?/

    Grato

  12. #12

    Padrão

    sim... sim é possivel configurar rotas no windows sim... ele naum eh tão fechado assim... hehe

    EX: route ADD 10.10.10.0 MASK 255.255.255.0 192.168.1.12


    a sintaxe pode ser essa.... primeiro a rede a ser acessada, depois a mascara desta rede e por ultimo o ip da maquina linux (pc que conhece a rede em questão).

    Tenta aew..

    Att