+ Responder ao Tópico



  1. #1

    Exclamation Problema com clonagem de ip e mac

    gente uso hotspot+cache full+ leases

    mas estou sabendo que um vizinho clonou o mac+ip aqui

    bom vamos ao caso

    eu fiz um teste aqui em casa clonando um ip e mac de um cliente aqui,ele tava logado,quando clonei o ip dele e o mac eu navaguei sem prescisar de login e senha


    como procedo nas regras para bloquear esse tipo de fraude

    agradeço a todos da under vivendo,lendo e aprendendo e compartilhando idéias e informaçoes

    Deus esteja com todos

    grato jean

  2. #2
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Não existe regra para bloquear isso. Esse é o padrão do hotspot. Implemente criptografia wpa2+aes em sua rede, pois é a única forma de fechar a mesma.

    Aqui no forum tem vários posts que explicam como se faz isso. Só pesquisar.



  3. #3

    Padrão

    Citação Postado originalmente por sergio Ver Post
    Não existe regra para bloquear isso. Esse é o padrão do hotspot. Implemente criptografia wpa2+aes em sua rede, pois é a única forma de fechar a mesma.

    Aqui no forum tem vários posts que explicam como se faz isso. Só pesquisar.
    eu estou criando um certificado digital 1204 btis isso ajudaria,porq tenho muitos clientes em minha rede ,isso levaria muito tempo,tem somente essa forma ,agradeço desde já

  4. #4

    Padrão

    Não é uma solução que bloqueia 100%.
    Veja o que procuro proporcionar para os meus clientes(onde eu presto serviços, não cliente final).
    Configuro dhcp fixo;
    hotspot;
    script;
    Com o script pego todos online no hotspot e faço uma verificação do hostname, como, pelo o que eu vejo sempre, dois pcs com o mesmo hostname na rede dá conflito, caso seja diferente, ele vai bloquear para aquele ip. Você poderá criar uma pag personalizada no hotspot para isto.

    Já falei, não é uma solução 100%. Estou por fazer uma solução que será, pelo que eu já andei testando, 100% anti clones usando pppoe.



  5. #5

    Padrão Re: Problema com clonagem de ip e mac

    vc tem pelomenos um script que da para ver se estam clonando o MAC e IP de algum cliente na rede, fico no aguardo, se puder postar fico grato.

  6. #6
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: Problema com clonagem de ip e mac

    https://under-linux.org/f116/falecim...-mr-rg-138845/

    Citação Postado originalmente por unibraz Ver Post
    vc tem pelomenos um script que da para ver se estam clonando o MAC e IP de algum cliente na rede, fico no aguardo, se puder postar fico grato.



  7. #7

    Padrão Re: Problema com clonagem de ip e mac

    Lamento mesmo pela morte do Daniel. Tive um irmão que também morreu de acidente de moto. Bom deixando as coisas triste, eu peguei um script no Forum do MK internacional, se alguém poder testar agradeço:
    Código :
     
    :local hosts [:toarray "comp1,comp2"]
    :local host;
    :local ipnum;
    :local unum;
    :local usr;
    :local i;
     
    :foreach host in=$hosts do={
       :foreach i in= [/ip dhcp-server lease find host-name=$host] do={
          :set ipnum [/ip dhcp-server lease get $i address];
          :set unum [/ip hotspot active find address=$ipnum];
          :set usr [/ip hotspot active get $unum user];
          :log warning ($host . " " . $ipnum . " " . $usr);
          /ip hotspot active remove $unum
          /ip dhcp-server lease remove [/ip dhcp-server lease find host-name=$host]
       }
    }

  8. #8

    Padrão Re: Problema com clonagem de ip e mac

    Falto o outro script, são dois. Um monta a lista e o outro compara de x em x segundos conforme programado, deem uma pesquisada que iram encontrar



  9. #9

    Padrão Re: Problema com clonagem de ip e mac

    Citação Postado originalmente por int21 Ver Post
    Falto o outro script, são dois. Um monta a lista e o outro compara de x em x segundos conforme programado, deem uma pesquisada que iram encontrar

    POsta ai pra gente amigo, não custa nada. Nos ajude

  10. #10

    Padrão Re: Problema com clonagem de ip e mac

    Set up a schedule to run this script every few minutes
    Code:
    :local hosts [/ip dhcp-server lease find]
    :local pcname ""
    :local pcnum 0
    :global hacklist ""
    # To log the value of $hacklist each hour, make debug 1 (if $hacklist is blank, nothing will be logged)
    :local debug 1

    :foreach h1 in=$hosts do={
    :local host [/ip dhcp-server lease get $h1 host-name]
    :if ([:len $host] >0) do {
    :set pcname ($pcname . "," . $host)
    :set pcnum ($pcnum + 1)
    }
    }

    :local pcnameArr [:toarray $pcname];

    :foreach h2 in=$pcnameArr do={
    :local hh 0
    :if (!([:find $hacklist $h2]>=0)) do={
    :foreach k in=$pcnameArr do={ :if ($k=$h2) do={:set hh ($hh + 1) } }
    :if ($hh>2) do={
    :if ([:len $hacklist] >0) do {:set hacklist ($hacklist . "," . $h2)} else={:set hacklist $h2}
    }
    }
    }

    # monitor results in logfile once an hour
    :local timer [ick [/system clock get time] 3 5]
    :if (($debug > 0) || ($timer >= "58")) do={
    :if ([:len $hacklist] >0) do={
    :log warning ("New Hacklist: " . $hacklist)
    }
    }



    Set up a schedule to run this every 20 seconds. (Which is the period of time a hacker will be able to remain active before they get kicked off, therefore this value can be increased if you want to reduce CPU utilisation or you are not worried that the hacker stays connected for longer. Your decision! Do not reduce time below 15 seconds, otherwise script could still be running when it gets called again by scheduler.)

    Code:
    :local host
    :local ipnum
    :local unum
    :local usr
    :local i
    :global hacklist

    :foreach host in=$hacklist do={
    :foreach i in= [/ip dhcp-server lease find host-name=$host] do={
    :set ipnum [/ip dhcp-server lease get $i address]
    :set unum [/ip hotspot active find address=$ipnum]
    :if ([:len $unum] >0) do {
    :set usr [/ip hotspot active get $unum user]
    :log warning ($host . " " . $ipnum . " " . $usr)
    /ip hotspot active remove $unum
    }
    }
    }
    Última edição por int21; 06-08-2010 às 23:16.



  11. #11
    Alguem
    Visitante

    Padrão Re: Problema com clonagem de ip e mac

    basta ir la nos profiles do hotspot e colocar apenas 1 em shared user

    Assim não tem como duas pessoas navegarem com o mesmo MAC

    Dá certo por que não tem como duas pessoas pegarem o mesmo IP no DHCP portanto o hotspot só permitirá que um ip utilize aquele MAC

    Vc pode colocar no cadastro do user o MAC que ele usa habitualmente e se livrar desses intrusos sem problemas

    Para garantir use o tempo de cookie bem longo.

    Mais que isso, só se você instalar certificado pra que ninguem fique snifando as senhas que são digitadas na hora de um eventual login.

  12. #12

    Padrão Re: Problema com clonagem de ip e mac

    Caros sou novo nesse mundo de mikrotik, hoje utilizo o monowall para gerenciar o meu provedor, mas como ele é muito limitado comprei uma RB750. Hoje não coloco chave na rede wireless, deixo aberta para que o cliente veja minha propaganda. Comprei o mikrotik para fazer com que o usuario só tenha acesso se bater login senha e endereço mac, isso é possível no mikrotik?



  13. #13

    Padrão Re: Problema com clonagem de ip e mac

    Esse é o papel do mk amigo, tem muitos topicos abordando isso aqui com receitas prontas, da uma pesquisadinha ai que vc vai achar tudo que deseja.