+ Responder ao Tópico

  1. Olá Gosulator... Só hoje acessei minha conta no Under.
    Eu não recebi sua MP, você poderia me mandar ela de novo?
    Valeu, até mais.

  2. Caro Freitas

    Este seu programa funciona para RB450G v4.11..... O balanceamento que ela faz é PCC? Hoje tenho um server MK v2.9 fazendo PPPoe nos clientes, como faria para usar esta confg. de balanceamento para 4 links ADSL fazendo autenticação por tela do navegador?? poderia me ajudar nesta config, nao sou experto em MK... um abraço Andrade




  3. Bom surfyrex eu usei esse programa pra gerar o loadbalance e estou usando em duas RB450 uma está com a versão 4.5 fazendo LoadBlance saindo para um Servidor Mikrotik versão 3.30 que faz Hotspot pros clientes que está perfeito sem problemas de sites de bancos entre outros que o pessoal diz.

    A outra RB450 está com a versão 4.11 que eu estou usando na minha casa com loadbalance e está rodando perfeito o LoadBalance feito por esse programa. da pra usar com 4 Links ADSL com modens em Bridge e fazendo Hotspot do jeito que você quiser só depende de voce ter 5 portas de rede disponivel 4 pra os 4 Links ADSL e 1 pra sair Internet pros Clientes.

    OBS: o bom se você tiver é fazer o LoadBalance em uma RB450 ou qual quer uma que tenha 5 Redes disponivel e passar a internet pro seu Servidor MK 2.9 fazer o restante pra ficar show igual eu fiz no meu provedor como te disse acima.

    Me passa a seu endereço ip da rede que vai pros clientes ex: 192.168.0.1
    Me passa as Velocidade de cada ADSL ex: 4096Kbps 2048Kbps 1024Kbps 512Kbps
    Suas interface deveram ficar com os nomes assim ether1, ether2, ether3, ether4, ether5
    Me passa os seu dois DNS que sua operador fornece ex: OiVelox é Primário 200.149.55.140, Secundário 200.165.132.147

    Me passa essas informações para eu gerar o script pra você fazer e ver se dar certo vlw.
    Última edição por freitascs; 16-01-2011 às 13:07.

  4. Ai vai o script pra LoadBalance de 2 ADSL Modens em Bridge.

    é só você botar um ADSL na Porta ether4 e outro ADSL na Porta ether5.

    ai você cria as duas conexões PPPOE uma com o nome adsl_ether4 e a outra adsl_ether5 se liga nessas conexões PPPOE que você criar na Aba Dial Out tem que deixar desmarcada Add Default Routee Use Peer DNS

    aonde está em vermelho você colocar seu ip de rede dos clientes

    E por ultimo faça toda essa configuração Manualmente no seu MK não copie e cole que isso não vai funcionar vai por mim.

    # ip dns statico------------------------
    /ip dns static add address=192.168.180.3 comment="" disabled=no name=192.168.180.3.cyberscan.com.br ttl=1d

    # ip firewall Filter------------------------
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=velox.user.com.br disabled=no
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=speed.user.com.br disabled=no

    # ip firewall nat--------------------------
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_ether4
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_ether5
    # ip firewall mangle------------------------
    # LoopBack por link-------------------------
    / ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK0 in-interface=ether1 new-connection-mark=Sites0 passthrough=yes
    / ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites0 disabled=no in-interface=ether1 new-routing-mark=Rota0 passthrough=no
    / ip route add gateway=adsl_ether4 routing-mark=Rota0
    / ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK1 in-interface=ether1 new-connection-mark=Sites1 passthrough=yes
    / ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites1 disabled=no in-interface=ether1 new-routing-mark=Rota1 passthrough=no
    / ip route add gateway=adsl_ether5 routing-mark=Rota1
    /ip firewall address-list add address=201.7.176.0/20 comment="Vídeos - Globo" disabled=no list=LINK0
    /ip firewall address-list add address=208.84.247.0/24 comment="Vídeos - terratv" disabled=no list=LINK0
    /ip firewall address-list add address=200.154.56.0/24 comment="Vídeos - terratv" disabled=no list=LINK0
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=64.38.29.0/24 comment="RapidShare" disabled=no list=LINK1

    # Fim LoopBack por link----------------------
    /ip firewall mangle add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" disabled=no protocol=tcp dst-port=443 in-interface=ether1
    /ip firewall mangle add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=ether1
    /ip firewall mangle add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" disabled=no new-ttl=set:30 protocol=icmp
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_ether4 new-connection-mark=adsl_ether4_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_ether5 new-connection-mark=adsl_ether5_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_ether4_conn disabled=no new-routing-mark=to_adsl_ether4 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_ether5_conn disabled=no new-routing-mark=to_adsl_ether5 passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=ether1 new-connection-mark=adsl_ether4_conn passthrough=yes per-connection-classifier=both-addresses:2/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=ether1 new-connection-mark=adsl_ether5_conn passthrough=yes per-connection-classifier=both-addresses:2/1
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_ether4_conn disabled=no in-interface=ether1 new-routing-mark=to_adsl_ether4 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_ether5_conn disabled=no in-interface=ether1 new-routing-mark=to_adsl_ether5 passthrough=yes

    # ip route----------------------------------
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_ether4 routing-mark=to_adsl_ether4 comment="Link0"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_ether5 routing-mark=to_adsl_ether5 comment="Link1"
    /ip route add comment="Link0" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_ether4 scope=30 target-scope=10
    /ip route add comment="Link1" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=adsl_ether5 scope=30 target-scope=10
    # ip firewall address-list-----------------------------
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/20 comment="Vídeos - Globo" disabled=no list=loopback
    /ip firewall address-list add address=208.84.247.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.154.56.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    /ip firewall address-list add address=200.201.166.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.173.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.174.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.141.207.3 comment=Detran disabled=no list=loopback

    # /system script--------------------------------------
    /system script add name=Link0Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link0\"] disabled=yes;"
    /system script add name=Link1Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link1\"] disabled=yes;"
    /system script add name=Link0Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=no;\r\ \n/ip route set [find comment=\"Link0\"] disabled=no;"
    /system script add name=Link1Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=no;\r\ \n/ip route set [find comment=\"Link1\"] disabled=no;"
    Última edição por freitascs; 17-01-2011 às 02:01.

  5. Freitas onde vc conseguiu o surfyrex







Tópicos Similares

  1. Respostas: 24
    Último Post: 25-03-2014, 07:52
  2. script para gerar tabelas dos logs???
    Por tomelin no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 26-06-2006, 09:25
  3. programa para testar segurança do firewall
    Por johnny no fórum Servidores de Rede
    Respostas: 9
    Último Post: 01-11-2005, 13:48
  4. problemas para gerar modulo do tomcat
    Por mcclaudio no fórum Servidores de Rede
    Respostas: 2
    Último Post: 03-09-2004, 10:07
  5. Programa para gerenciar configuração!!!
    Por Algoritmo_PB no fórum Servidores de Rede
    Respostas: 2
    Último Post: 24-07-2004, 15:10

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L