+ Responder ao Tópico

  1. Boa tarde!

    Se vc tem Ip e Gateway, no caso, na hora de colocar os ips no programa vc usar a opção internet dedicado....

    foi a unica coisa que vi que poderia ser o problema.

    OBS: Já fiz teste usando a mesma configuracao para adsl, mas usei dedicado no programa e funcionou legal ...

    t++


    Citação Postado originalmente por clecioe Ver Post
    faz tempo que estou tentando colocar o meu load balance para funcionar tanto em bridge ''pppoe" como em route e nenhuma das duas tentativas não deu certo.

    1º adsl ip: 192.168.200.3, gateway: 192.168.200.2 (modo roteado)
    1º adsl ip: 192.168.100.3, gateway: 192.168.100.2 (modo roteado)

    IP Clientes Saida: 192.168.254.3
    Obs:. já setei os ip de dns 208.67.222.222 e 208.67.220.220 / ja tentei 192.168.254.2 e 192.168.254.5 e nada de funcionar internet não sai nada, mas pinga para fora pelo terminal tem comunicação. se alguem tiver alguma solução me der uma luz tenho uma rb450g.

    email: clecioe@hotmail.com
    msn: clecioe@hotmail.com

    segue o codigo gerado, sei que todo mundo colocou para funcionar !!! eu vou ser o primeiro que não consigo.

    /ip address add address=192.168.254.2/24 interface=local
    /ip dns set primary-dns=192.168.254.2
    /ip dns set secondary-dns=192.168.254.5
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/20 comment="Vídeos - Globo" disabled=no list=loopback
    /ip firewall address-list add address=208.84.247.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.154.56.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    /ip firewall address-list add address=200.201.166.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.173.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.174.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.141.207.3 comment=Detran disabled=no list=loopback
    /ip firewall mangle add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=local
    /ip dhcp-client add add-default-route=yes comment="" default-route-distance=0 disabled=no interface=wan1 use-peer-dns=yes use-peer-ntp=yes
    /ip dhcp-client add add-default-route=yes comment="" default-route-distance=0 disabled=no interface=wan2 use-peer-dns=yes use-peer-ntp=yes
    /ip firewall nat add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan1
    /ip firewall nat add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan2
    /ip firewall filter add action=accept chain=input comment="" disabled=no in-interface=!wan1 src-address=192.168.254.0/24
    /ip firewall filter add action=accept chain=input comment="" disabled=no in-interface=!wan2 src-address=192.168.254.0/24
    /ip firewall mangle add action=mark-connection chain=input comment="" disabled=no in-interface=wan1 new-connection-mark=wan1_conn passthrough=yes
    /ip firewall mangle add action=mark-connection chain=input comment="" disabled=no in-interface=wan2 new-connection-mark=wan2_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output comment="" connection-mark=wan1_conn disabled=no new-routing-mark=to_wan1 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output comment="" connection-mark=wan2_conn disabled=no new-routing-mark=to_wan2 passthrough=yes
    /ip firewall mangle add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=local new-connection-mark=wan1_conn passthrough=yes per-connection-classifier=both-addresses:2/0
    /ip firewall mangle add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=local new-connection-mark=wan2_conn passthrough=yes per-connection-classifier=both-addresses:2/1
    /ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=wan1_conn disabled=no in-interface=local new-routing-mark=to_wan1 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=wan2_conn disabled=no in-interface=local new-routing-mark=to_wan2 passthrough=yes
    /ip route add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1 routing-mark=to_wan1
    /ip route add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan2 routing-mark=to_wan2
    /ip route add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1 scope=30 target-scope=10
    /ip route add check-gateway=ping comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2 scope=30 target-scope=10


  2.    Publicidade


  3. Netuai!

    Não sei se meu adsl é diferente, mas aqui, eu uso em Bridge e o mesmo me passa um ip / gateway fixo, mas o modem pega o ip dinamico...

    neste caso, eu estou configurando tudo com ip dedicado no programa pcc, e funciona blz, fassa o teste.....

    OBS: Agora se o ip que vai para o seu MK é dinamico, neste caso, o programa PCC ainda esta em faze de testes e não sei lhe informar se a codificação esta ok, frizo que se alguem encontrar erros é só falar que eu reprogramo o sistema e disponibilizo a versão nova.

    t++

  4. Scan,

    Tenho 3 Links, só que esses links saem somente por uma interface "Internet"...

    essa interface "Internet" e ligada a uma switch onde essa switch esta ligada os modens
    192.168.2.254
    192.168.2.253
    192.168.2.252

    como ficaria o balanceamento usando somente uma interface, onde tem 3 links nessa interface ?

  5. parabéns pela iniciativa vou testat

  6. Olá pessoal!
    Estou gostando muito do programa, já 2 balanceamentos!
    O primeiro foi entre um ADSL e um Dedicado (coloquei os 2 como dedicado no programa pq a ADSL estava como roteada e não bridge)
    Agora fiz outro com 3! 2 ADSL e 1 Dedicada, do mesmo modo de antes.
    Só queria avisar a respeito de uma coisa! Não sei se é realmente um Bug de todos, ou se só o meu que deu isso.
    Quando eu fiz o balancemento dos 3 links, verifiquei que só 2 estava realmente passando dados, q eram as 2 adsl, aí começei a pesquisar dentro do winbox o que poderia ser, e descobri, que por algum motivo, o programa não criou as rotas (gateway normal e gateway com marcação de conexão). Elas estavam lá no firewall e talz, mas não foram criadas lá em route, aí é claro, fui lá e criei um gateway normal para a dedicada e criei a otra rota com a marcação de conexão e daí funcionou blz.
    O programa está muito bom! Falei isso, só para verificarem, pois quem sabe isso acontece com todo mundo só o pessoal talvez não tenha visto!

    Muito obrigado pelo programa!!!




Tags para este Tópico

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L