+ Responder ao Tópico



  1. Bom dia galera, bom para o balanceamento alguns sites nao aceitam a troca de IP, entao é necessario a criaçao de ADDRESS LIST, e tbm os SITES SUROS (ex. bancos) nao aceitam troca de ips... entao pra resolver isso eu uso aki 2 regras... pra sempre deixar sair pela ROTA DEFAULT, os sites seguros... e a lista de sites q necessitam..
    1 regra para sites seguros:
    Código :
    /ip firewall mangle add chain=prerouting protocol=tcp dst-port=443 action=accept comment="Sites Seguros"
    2 regra cria o direcionamento dos sites pra rota principal do servidor.
    Código :
    /ip firewall mangle add chain=prerouting dst-address-list=sem_balance  action=accept comment="Sem Balanceamento" disabled=no
    Segue abaixo a lista de IPS dos sites q utilizo aqui. se servir pra alguem tai:
    201.77.87.0/24 Sicredi
    201.49.161.0/24 www.seplam.mt.gov.br
    200.252.127.0/24 check check
    200.246.0.0/16 Bradesco
    200.232.0.0/16 Bradesco
    200.212.0.0/16 Bradesco
    200.205.0.0/16 Bradesco
    200.173.0.0/16 Bradesco
    200.155.0.0/16 Bradesco
    170.66.0.0/16 Bradesco e Brasil
    200.201.0.0/16 CMT CAIXA
    200.152.233.0/24 HSBC
    161.133.0.0/24 HSBC
    200.152.32.0/24 INSS 5017
    193.32.34.0/24 American Express
    12.29.100.0/24 American Express
    170.66.11.0/24 Banco BB
    161.148.231.0/24 REceita da Fazenda

  2. estava pensando em montar um balanceamente bem montado, mas primeiro nao sei como fazer, e segundo que tipo de hardware vai suportar um enorme trafego?
    Minha arquitetura é:
    1 adsl de 3.2 que chega sempre 2.8
    1 adsl de 2.8 que chega sempre 2.5
    1 adsl de 8.0 que chega sempre 6.5
    1 dedicado de 2.0 chega sempre 1.999

    tenho atualmente 300 clientes, a maioria assina 200 e 400k

    Muito trafego dividido em 2 servidores



  3. Citação Postado originalmente por netuai Ver Post
    estava pensando em montar um balanceamente bem montado, mas primeiro nao sei como fazer, e segundo que tipo de hardware vai suportar um enorme trafego?
    Minha arquitetura é:
    1 adsl de 3.2 que chega sempre 2.8
    1 adsl de 2.8 que chega sempre 2.5
    1 adsl de 8.0 que chega sempre 6.5
    1 dedicado de 2.0 chega sempre 1.999
    Uma RB mesmo faz o PCC amigo.. 3 adsl e 1 dedicado, ela aguenta normal, ja montei 2 fazendo 15 adsl.... ai o servidor so recebe o link balanceado ja.

  4. Citação Postado originalmente por aka2005 Ver Post
    Bom dia galera, bom para o balanceamento alguns sites nao aceitam a troca de IP, entao é necessario a criaçao de ADDRESS LIST, e tbm os SITES SUROS (ex. bancos) nao aceitam troca de ips... entao pra resolver isso eu uso aki 2 regras... pra sempre deixar sair pela ROTA DEFAULT, os sites seguros... e a lista de sites q necessitam..
    1 regra para sites seguros:
    Código :
    /ip firewall mangle add chain=prerouting protocol=tcp dst-port=443 action=accept comment="Sites Seguros"
    2 regra cria o direcionamento dos sites pra rota principal do servidor.
    Código :
    /ip firewall mangle add chain=prerouting dst-address-list=sem_balance action=accept comment="Sem Balanceamento" disabled=no
    Segue abaixo a lista de IPS dos sites q utilizo aqui. se servir pra alguem tai:
    201.77.87.0/24 Sicredi
    201.49.161.0/24 www.seplam.mt.gov.br
    200.252.127.0/24 check check
    200.246.0.0/16 Bradesco
    200.232.0.0/16 Bradesco
    200.212.0.0/16 Bradesco
    200.205.0.0/16 Bradesco
    200.173.0.0/16 Bradesco
    200.155.0.0/16 Bradesco
    170.66.0.0/16 Bradesco e Brasil
    200.201.0.0/16 CMT CAIXA
    200.152.233.0/24 HSBC
    161.133.0.0/24 HSBC
    200.152.32.0/24 INSS 5017
    193.32.34.0/24 American Express
    12.29.100.0/24 American Express
    170.66.11.0/24 Banco BB
    161.148.231.0/24 REceita da Fazenda
    Amigo não estou tendo sucesso em conf aquela regra para redirecionar um site para um link que não seja a ROTA DEFAULT.

    Meu Link-1 e a ROTA DEFAULT, queria colocar alguns sites como youtube, 4shared etc...

    Só para ir com link-2 testei a resgra ki vc posto e nada tentei de tudo ki e forma.

    Os teste ki fiz foi como amigo " scan " Falow usando o meuip.com.br, testei tb usando o omeuip.com, sem sucesso sempre pegava o ip do link-1 tb.

    Agora a regra de sempre ir pelo link ROTA DEFAULT fuciona normal.



  5. Ok, essas regras q eu falei, funcionando quando no Balance.. vo tem suas rotas criadas, e fazendo marcaçao de ROTAs, vamos supor q vc tem 3 links, 2 adsl e 1 dedicado,... em /ip route, vc vai cria 3 rotas e marcalas.. mas uma delas vai ser default.... entao tudo q for acessado ira passar pelas 3 rotas, so q quando criado no mangle, la as regras q eu falei, ele vai passa os sites q tao marcados e a porta de sites seguros direto sem passar pelo PCC, saindo entao pela rota Default....

    Youtube, nao tem como marca o ip, sao dinamicos os servidores deles, so ha como fazer cache com o youtube, mas redirecionar ele, nao.. pelo menos nunca consegui, ou axei quem conseguiu.

  6. Citação Postado originalmente por aka2005 Ver Post
    Uma RB mesmo faz o PCC amigo.. 3 adsl e 1 dedicado, ela aguenta normal, ja montei 2 fazendo 15 adsl.... ai o servidor so recebe o link balanceado ja.
    mas qual seria a melhor routerbord para esta função



  7. aka2005.

    Então so tem como redirecionar para ROTA DEFAULT?

    Só um duvida se redirecionar sites para ROTA DEFAULT o link-1 num vai ficar congestionado não?
    Ou o PCC vai indentificar ki ele esta com conexões de mais e vai jogar para link-2. ?

  8. Citação Postado originalmente por netuai Ver Post
    mas qual seria a melhor routerbord para esta função

    Amigo um RB450 e muito boa mas se quiser uma mais forte RB450G.



  9. Citação Postado originalmente por eduarlei Ver Post
    Amigo um RB450 e muito boa mas se quiser uma mais forte RB450G.
    RB 450 tem 5 portas, e a memoria é 32mb de RAM;
    RB 450G tem 5 portas e 256mb RAM;
    RB 493 tem 9 porttas e 64mb RAM;
    RB493AH tem 9 portas e 128mb RAM;
    Eu utilizo a RB 493AH nos meus LOADS... Ja testei nelas durante meses, 15 links, ate 37 links... show..
    mas agora vo da um up aki pra RB1100... Devido minha demanda.

    Agora tem a RB 800 com 3 portas e 256mb RAM, e sua EXTENSAO RB-816 com 16 portas.

    E tem a RB 1100 com 13 portas e 512mb RAM, é um CPU praticamente. rs..

    Questao de CUSTO, RB493AH, questao de Desempenho devido a Estrutura RB1100.

  10. Citação Postado originalmente por eduarlei Ver Post
    Então so tem como redirecionar para ROTA DEFAULT?
    Os sites q nao estao passando pelo balanceamento caeem direto na DEFAULT, mas se vc criar outra regra no MANGLE pra q eles saiam por uma ROTA, ai sim tem como manda pra outra rota. ex.:
    /ip firewall mangle add chain=prerouting dst-address=IP_DO_SITE action=mark-routing new-routing-mark=NOME_DA_MARCACAO_ROTA passthrough=no
    Só um duvida se redirecionar sites para ROTA DEFAULT o link-1 num vai ficar congestionado não?
    Ou o PCC vai indentificar ki ele esta com conexões de mais e vai jogar para link-2. ?
    Isso a ROTA DEFAULT sera forçada.. pq tem os sites q tao indo pra ela mais o PCC q joga pra ela.. por isso é bom vc marca uma ROTA BOA.. no caso dedicado se tiver.



  11. Citação Postado originalmente por aka2005 Ver Post
    Os sites q nao estao passando pelo balanceamento caeem direto na DEFAULT, mas se vc criar outra regra no MANGLE pra q eles saiam por uma ROTA, ai sim tem como manda pra outra rota. ex.:
    /ip firewall mangle add chain=prerouting dst-address=IP_DO_SITE action=mark-routing new-routing-mark=NOME_DA_MARCACAO_ROTA passthrough=no
    Isso a ROTA DEFAULT sera forçada.. pq tem os sites q tao indo pra ela mais o PCC q joga pra ela.. por isso é bom vc marca uma ROTA BOA.. no caso dedicado se tiver.
    E amigo fiz os Testes aki com esta regra ai no site meuip.datahouse.com.br não oitive sucesso...

  12. Netuai,

    O ideal seria um rb450G ou para mais links um RB1100 ou uma RB493HA sem cartões, apenas usando as ethernets.



  13. Bom dia a todos... Resolvi o problema com ajuda e um amigo, fiz os teste e fuciono 100%... Vou passa as regras...

    Ai Scan seria interesante vc add esta regra em seu programa e colocar um opção de usar ou não ela, tipo ja conf os sites ki vam sair por tal link etc...


    /ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=SITES_LINK-2 in-interface=Interface de saida new-connection-mark=Sites passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites disabled=no in-interface=Local new-routing-mark=Rota_Sites passthrough=no
    /ip route add gateway=Gateway do link a ser redirecionado routing-mark=Rota_Sites

    Pode ativar o check gateway se caso ouver queda do link o outro assumir.


    CREDITOS A joao.paulo@microwavetec.com.br.
    Este contato e o msn dele tb.
    Última edição por eduarlei; 11-06-2010 às 09:09.

  14. bom dia Eduarlei!
    conserteza irei adicionar esta regra no programa, logo logo estarei disponibilizando o programa com algumas correções e com esta opção nova...

    t++

  15. Se tiver como, ja faz tipo ...

    um opção de selecionar o gateway para saida e um lugar ki ja add os sites ki for sair por ele, para quanto fou gerar o script ja gerar com sites e a regra pronta.

    Não sei se e um erro na hora de gerar o script, ou foi vc ki add assim msm, mas todos site que li sobre o load PCC as regras " criar as marcações das rotas" no caso seria as 3º e 4º regra, o passthrough esta "yes e todos topicos explica como no" e nas utimas regras tb.

    E como ja foi ate falado aki no tópico msm o uso do "connection-state=new nas conexões em cada interfaces" no caso e as duas primeira regra ajuda muito.

    Eu uso ela tb na regra dos classificadores.
    Última edição por eduarlei; 11-06-2010 às 12:57.

  16. Segue nova versão do programa PCC ver. 1.2!

    OBS: nesta versão ainda não foi implementado as regras de loopback direcionado para link escolhido, função esta que ainda estou a verificar melhor maneira de implementar no programa..
    A versão abaixo foi adicionado o connection-state=new conforme mencionado por Eduarlei ...

    já estou estudando a implementação das funções novas e logo logo disponibilizarei...

    Att.: Scan

    http://www.saocarlosnet.com.br/PCC_1.2.zip

  17. Citação Postado originalmente por scan Ver Post
    aqui eu uso sem problemas... MK 4.9
    Bom dia, eu tenho 1 link dedicado e 3 adsl, vc recomenda colocar both-addresses-and-port ou apenas both-address?

  18. Citação Postado originalmente por scan Ver Post
    Segue nova versão do programa PCC ver. 1.2!

    OBS: nesta versão ainda não foi implementado as regras de loopback direcionado para link escolhido, função esta que ainda estou a verificar melhor maneira de implementar no programa..
    A versão abaixo foi adicionado o connection-state=new conforme mencionado por Eduarlei ...

    já estou estudando a implementação das funções novas e logo logo disponibilizarei...

    Att.: Scan

    http://www.saocarlosnet.com.br/PCC_1.2.zip
    Assim que sair a nova versão com todas as funcionalidades sera bom, eu so não estou entendendo as funções do programa, mas se vc quiser me ajudar posso fazer um manual em PDF para que os outros colegas possam usar o programa

  19. bom dia Netuai!

    Assim que eu disponibilizar a versão 1.3 do programa, irei disponibilizar imagens monstrando o que cada função faz, com isso fica facil a utilização e montagen do manual em PDF posteriormente...

    agradeço a iniciativa e logo logo postarei o programa com estas imagens para podermos disponibilizar o PDF.

    at.:Scan

  20. Citação Postado originalmente por scan Ver Post
    bom dia Netuai!

    Assim que eu disponibilizar a versão 1.3 do programa, irei disponibilizar imagens monstrando o que cada função faz, com isso fica facil a utilização e montagen do manual em PDF posteriormente...

    agradeço a iniciativa e logo logo postarei o programa com estas imagens para podermos disponibilizar o PDF.

    at.:Scan
    Não entendo nada de Mikrotik, comparado a vocês, mas tenho boa vontade em ajudar, assim que vc tiver os detalhes eu monto o PDF para vc dispor ele aqui, acho que é o minimo que eu posso fazer






Tópicos Similares

  1. Respostas: 24
    Último Post: 25-03-2014, 06:52
  2. script para gerar tabelas dos logs???
    Por tomelin no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 26-06-2006, 08:25
  3. programa para testar segurança do firewall
    Por johnny no fórum Servidores de Rede
    Respostas: 9
    Último Post: 01-11-2005, 12:48
  4. problemas para gerar modulo do tomcat
    Por mcclaudio no fórum Servidores de Rede
    Respostas: 2
    Último Post: 03-09-2004, 09:07
  5. Programa para gerenciar configuração!!!
    Por Algoritmo_PB no fórum Servidores de Rede
    Respostas: 2
    Último Post: 24-07-2004, 14:10

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L