+ Responder ao Tópico



  1. No Balance Peplink encontramos uma opção de balanceamento bastante interessante.
    Onde podemos repassar os IPs públicos recebidos em uma das WAN

    veja: http://www.peplink.com/index.php?view=faq&id=69&path=18
    http://www.peplink.com/index.php?vie...id=176&path=34

    Ou seja, é possível repassar os ips públicos recebidos na WAN1 e ao mesmo tempo utilizar as outras WAN e fazer o balance.
    Durante o balanceamento, caso o trafego saia pela WAN1, cada host da rede vai usar o IP público recebido.
    Caso o trafego saia pelas outras WAN, ele irá fazer NAT.

    Alguém, alguma vez, já implementou um balance onde fosse possível repassar os IPs públicos recebidos em uma WAN igual a como o Peplink faz?

  2. Boa tarde!

    Venho por meio desta informar que os links para download do programa PCC já foram corrigidos.

    Att.: Scan



  3. Boa tarde!

    Sobre o comentário do nosso amigo mascaraapj no qual ele cita uma ferramenta que faz a questão de balancemento e repasse de endereços públicos, já fasso esta jogada aqui mesmo usando balanceamento de carga PCC, para tanto é nescessário levantar umas questões.

    No meu caso, somente clientes com endereços dinamicos estão realmente usando link balanceado.
    Já os clientes com endereços públicos, eles não são balanceados, passam direto, pois ao meu ver, o balanceamento inviabiliza um acesso externo para este cliente usando endereço público.

    Numa proxima versão do PCC incluirei a função de gerar códigos para repasse de endereços públicos.

    Att.: Scan

  4. Citação Postado originalmente por scan Ver Post
    Boa tarde!

    Sobre o comentário do nosso amigo mascaraapj no qual ele cita uma ferramenta que faz a questão de balancemento e repasse de endereços públicos, já fasso esta jogada aqui mesmo usando balanceamento de carga PCC, para tanto é nescessário levantar umas questões.

    No meu caso, somente clientes com endereços dinamicos estão realmente usando link balanceado.
    Já os clientes com endereços públicos, eles não são balanceados, passam direto, pois ao meu ver, o balanceamento inviabiliza um acesso externo para este cliente usando endereço público.

    Numa proxima versão do PCC incluirei a função de gerar códigos para repasse de endereços públicos.

    Att.: Scan
    No caso do Balance Peplink, podemos usar o balance normalmente... repassando IP publico quando o trafego sair pela WAN1 e fazendo NAT quando sair pelas demais WAN.
    O acesso externo a esses IPs publico funcionam normalmente.

    Ainda não testei, mas Pelo que andei estudando do balance e das regras que são criadas com esse programa, atualmente ele já faz marcação de tudo que entra em cada WAN, para que aquele trafego não volte por outra WAN.
    Acredito que as regras atuais (com alguns pequenos ajustes para a WAN1) devam funcionar normalmente.
    Para todo caso, talvez seja possível apenas implementar mais uma regra na firewall filter: accept conexões estrablished

    --------------
    Aproveitando que irá fazer uma nova versão.
    Poderia acrescentar a opção no ADSL de receber o IP por DHCP-Client.
    Visto os cliente NET Virtua recebem o IP via DHCP e não por PPoE.



  5. galera boa noite , sou novo aqui no forum , fiz tudo certiho , cheguei ate resetar o mk e fazer do zero porem

    o mk usa somente um link por ves e nao os 2 ao mesmo tempo

    segue as regras to ficando logo jah
    # ip address --------------------------
    /ip address add address=192.168.100.1/24 interface=LAN
    /ip address add address=192.168.200.2/24 interface=WAN2

    # interface pppoe-client ---------------
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=WAN1 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_WAN1 password=32651074 profile=default service-name="" use-peer-dns=no user=2732651074@telemar.com.br

    # ip dns --------------------------------
    /ip dns set primary-dns=8.8.8.8
    /ip dns set secondary-dns=8.8.4.4
    /ip dns set allow-remote-requests=yes

    # ip dns statico------------------------
    /ip dns static add address=192.168.100.1 comment="" disabled=no name=192.168.100.1.AdNet ttl=1d

    # ip firewall Filter------------------------
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=velox.user.com.br disabled=no
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=speed.user.com.br disabled=no
    /ip firewall filter add action=accept chain=input disabled=no in-interface=!WAN2 src-address=192.168.100.0/24

    # ip firewall nat--------------------------
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_WAN1
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=WAN2

    # ip firewall mangle------------------------

    # LoopBack por link-------------------------
    / ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK0 in-interface=LAN new-connection-mark=Sites0 passthrough=yes
    / ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites0 disabled=no in-interface=LAN new-routing-mark=Rota0 passthrough=no
    / ip route add gateway=adsl_WAN1 routing-mark=Rota0
    / ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK1 in-interface=LAN new-connection-mark=Sites1 passthrough=yes
    / ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites1 disabled=no in-interface=LAN new-routing-mark=Rota1 passthrough=no
    / ip route add gateway=192.168.200.1 routing-mark=Rota1

    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment="BRADESCO" disabled=no list=LINK0
    /ip firewall address-list add address=200.220.186.0/24 comment="" disabled=no list=LINK0
    /ip firewall address-list add address=200.220.178.0/24 comment="" disabled=no list=LINK0
    /ip firewall address-list add address=64.38.29.0/24 comment="RapidShare" disabled=no list=LINK1
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=LINK1
    # Fim LoopBack por link----------------------

    /ip firewall mangle add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" disabled=no protocol=tcp dst-port=443 in-interface=LAN
    /ip firewall mangle add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=LAN
    /ip firewall mangle add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" disabled=no new-ttl=set:30 protocol=icmp
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_WAN1 new-connection-mark=adsl_WAN1_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=WAN2 new-connection-mark=WAN2_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_WAN1_conn disabled=no new-routing-mark=to_adsl_WAN1 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=WAN2_conn disabled=no new-routing-mark=to_WAN2 passthrough=yes
    /ip firewall mangle add action=accept chain=prerouting disabled=no dst-address=192.168.200.0/24 in-interface=LAN
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=adsl_WAN1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:3/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=adsl_WAN1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:3/1
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=WAN2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:3/2
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_WAN1_conn disabled=no in-interface=LAN new-routing-mark=to_adsl_WAN1 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=WAN2_conn disabled=no in-interface=LAN new-routing-mark=to_WAN2 passthrough=yes

    # ip route----------------------------------
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_WAN1 routing-mark=to_adsl_WAN1 comment="Link0"
    /ip route add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.200.1 routing-mark=to_WAN2 comment="Link1"
    /ip route add comment="Link0" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_WAN1 scope=30 target-scope=10
    /ip route add check-gateway=ping comment="Link1" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.200.1 scope=30 target-scope=10

    # ip firewall address-list-----------------------------
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/20 comment="Vídeos - Globo" disabled=no list=loopback
    /ip firewall address-list add address=208.84.247.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.154.56.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    /ip firewall address-list add address=200.201.166.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.173.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.174.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.141.207.3 comment=Detran disabled=no list=loopback

    # /system script--------------------------------------
    /system script add name=Link0Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link0\"] disabled=yes;"
    /system script add name=Link1Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link1\"] disabled=yes;"
    /system script add name=Link0Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=no;\r\ \n/ip route set [find comment=\"Link0\"] disabled=no;"
    /system script add name=Link1Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=no;\r\ \n/ip route set [find comment=\"Link1\"] disabled=no;"






Tópicos Similares

  1. Respostas: 24
    Último Post: 25-03-2014, 06:52
  2. script para gerar tabelas dos logs???
    Por tomelin no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 26-06-2006, 08:25
  3. programa para testar segurança do firewall
    Por johnny no fórum Servidores de Rede
    Respostas: 9
    Último Post: 01-11-2005, 12:48
  4. problemas para gerar modulo do tomcat
    Por mcclaudio no fórum Servidores de Rede
    Respostas: 2
    Último Post: 03-09-2004, 09:07
  5. Programa para gerenciar configuração!!!
    Por Algoritmo_PB no fórum Servidores de Rede
    Respostas: 2
    Último Post: 24-07-2004, 14:10

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L