+ Responder ao Tópico



  1. #401

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    ola Mascaraapj

    Testei os 200.19.215.1 e 200.202.17.1, ficou pior aki
    Estou montando outra MkLB irei fazer tudo novo para ter certeza se não é a minha configuração, mais valeu pela dica

  2. #402

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    Ola scan qual distro vcs estao usando nesse server, pra o dns



  3. #403

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    Citação Postado originalmente por sidneiadriano Ver Post
    Gustavinho, tenho uma maquina com Bind, estou testando ainda não percebi nenhuma diferença na rede , estou sempre acompanho na casa dos clientes o desempenho.
    Precisa configurar o dns cache para surgir efeito.

    O alexandre Correa colocou umas configurações de DNS aqui no forum que mostra o tempo das respostas nas consultas.

    Quanto a distro acredito que seja uma qualquer de sua preferencia, pois no caso de usar o bind ele roda em diversas distro.

  4. #404

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    Vejam o que vocês conseguem com este tutorial

    "Otimizando o serviço de DNS até a tampa."
    BrazilFW Firewall and Router • View topic - Otimizando o serviço de DNS até a tampa.



  5. #405

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    ola amigos.
    gostaria da ajuda dos mestre no assunto pcc.
    usei o programa versao 1.2, gostaria de agradecer ao amigo por disponibilizar para todos.
    coloquei para rodar e aparente estar tudo certo, so que um conhecido deu uma olhada e disse que minha configuraçao pcc estava toda bugada. nao falou onde nem pq.
    uso 3 adsl e a unica coisa que notei aqui e que um consome menos do que os outros. no momento estar assim ether2-10.8 ether3-7.4 e ether4-9.7
    minha configuraçao segue abaixo, se alguem puder encontrar o pq estar "toda bugada" eu agradeço
    Última edição por zipfile; 18-07-2010 às 00:02.

  6. #406

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    tentei postar, mais nao foi, entao segue aqui.
    configuracao.txt



  7. #407

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    Gustavinho

    ok, obrigado , irei pesquisar mais.
    Detalhe apos ler o topico mencionado pelo amigo Gustavinho, use o programa DNS Benchmark, houve uma melhora muito amigavel.
    Fiz o seguinte processo, fiz nos modens separados num note para saber o melhor dns, depois com os modens no MKLB, testei no lb usando o modem da cada vez, anotei o dns com melhor desempenho fiz as alterções e nessa semana irei ficar atento para o desempenho.

  8. #408
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.095
    Posts de Blog
    15

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    O Mk faz cache de Dns. Para quem quer melhor desempenho monte um Servidor Dns em seu provedor. Não tendo que resolver nomes externamente. Procurem Bind - Dns. Referência: Linux: DNS com BIND [Artigo]
    http://img.vivaolinux.com.br/imagens.../thumb_dns.JPG



  9. #409

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    Citação Postado originalmente por interhome Ver Post
    O Mk faz cache de Dns. Para quem quer melhor desempenho monte um Servidor Dns em seu provedor. Não tendo que resolver nomes externamente. Procurem Bind - Dns. Referência: Linux: DNS com BIND [Artigo]
    http://img.vivaolinux.com.br/imagens.../thumb_dns.JPG
    se o mk faz cache de dns... ao fazer uma consulta, setando o mk como servidor dns... a consulta ja nao é resolvida ali mesmo (se o endereco consultado estiver no cache)?

  10. #410
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.095
    Posts de Blog
    15

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    Citação Postado originalmente por mascaraapj Ver Post
    se o mk faz cache de dns... ao fazer uma consulta, setando o mk como servidor dns... a consulta ja nao é resolvida ali mesmo (se o endereco consultado estiver no cache)?
    Se estiver no cache, sim. Caso não esteja, ele irá nos ips setados no campo DNS a procura de resolver o nome. Isso através da internet. Uma vez que os ips setados são de servidores que não se encontram no seu site. O artigo em referência é para instruir a configurar o seu próprio servidor DNS.



  11. #411

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    Debian Lenny 5

  12. #412
    diogenesneto
    Visitante

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    Não estou conseguindo realizar acesso externo quando coloco a saída diretamente pela Interface.
    A única forma que está funcionando comigo é quando coloco o Gateway manualmente na configuração.
    O Balanceamento está funcionando normalmente e o FailOver também.

    Minha configuração da Rota está assim:

    add check-gateway=ping comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=ether1-gateway



  13. #413
    diogenesneto
    Visitante

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    Meus dois Links são via Cable Modem.

    Os dados são:

    Rede interna: 192.168.88.0/24
    Link1: IP e GW dinâmicos
    Link2: IP e GW dinâmicos

    Segue abaixo o arquivo gerado pelo programa e que não está funcionando neste caso:

    -------------------------------

    # ip address --------------------------
    /ip address add address=192.168.88.1/24 interface=ether2-local

    # ip dns --------------------------------
    /ip dns set primary-dns=192.168.88.1
    /ip dns set allow-remote-requests=yes

    # ip dns statico------------------------
    /ip dns static add address=192.168.88.1 comment="" disabled=no name=192.168.88.1. ttl=1d

    # ip firewall Filter------------------------

    # ip firewall nat--------------------------
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=ether1-gatewayadsl
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=ether3-gatewayadsl

    # ip firewall mangle------------------------
    /ip firewall mangle add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" disabled=no protocol=tcp dst-port=443 in-interface=ether2-local
    /ip firewall mangle add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=ether2-local
    /ip firewall mangle add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" disabled=no new-ttl=set:30 protocol=icmp
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=ether1-gatewayadsl new-connection-mark=ether1-gatewayadsl_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=ether3-gatewayadsl new-connection-mark=ether3-gatewayadsl_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=ether1-gatewayadsl_conn disabled=no new-routing-mark=to_ether1-gatewayadsl passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=ether3-gatewayadsl_conn disabled=no new-routing-mark=to_ether3-gatewayadsl passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=ether2-local new-connection-mark=ether1-gatewayadsl_conn passthrough=yes per-connection-classifier=:2/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=ether2-local new-connection-mark=ether3-gatewayadsl_conn passthrough=yes per-connection-classifier=:2/1
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=ether1-gatewayadsl_conn disabled=no in-interface=ether2-local new-routing-mark=to_ether1-gatewayadsl passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=ether3-gatewayadsl_conn disabled=no in-interface=ether2-local new-routing-mark=to_ether3-gatewayadsl passthrough=yes

    # ip route----------------------------------
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ether1-gatewayadsl routing-mark=to_ether1-gatewayadsl comment="Link0"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ether3-gatewayadsl routing-mark=to_ether3-gatewayadsl comment="Link1"
    /ip route add comment="Link0" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ether1-gatewayadsl scope=30 target-scope=10
    /ip route add comment="Link1" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=ether3-gatewayadsl scope=30 target-scope=10

    # ip firewall address-list-----------------------------
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/20 comment="Vídeos - Globo" disabled=no list=loopback
    /ip firewall address-list add address=208.84.247.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.154.56.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    /ip firewall address-list add address=200.201.166.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.173.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.174.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.141.207.3 comment=Detran disabled=no list=loopback

    # /system script--------------------------------------
    /system script add name=Link0Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link0\"] disabled=yes;"
    /system script add name=Link1Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link1\"] disabled=yes;"
    /system script add name=Link0Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=no;\r\ \n/ip route set [find comment=\"Link0\"] disabled=no;"
    /system script add name=Link1Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=no;\r\ \n/ip route set [find comment=\"Link1\"] disabled=no;"

    ---------------------------------------

  14. #414

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    Citação Postado originalmente por scan Ver Post
    Debian Lenny 5
    Vlw



  15. #415

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    Citação Postado originalmente por diogenesneto Ver Post
    Não estou conseguindo realizar acesso externo quando coloco a saída diretamente pela Interface.
    A única forma que está funcionando comigo é quando coloco o Gateway manualmente na configuração.
    O Balanceamento está funcionando normalmente e o FailOver também.

    Minha configuração da Rota está assim:

    add check-gateway=ping comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=ether1-gateway


    Se for acesso externo veja se server esse:
    https://under-linux.org/f143/tutoria...46/index8.html
    ou
    https://under-linux.org/f210/tutoria...dicado-124912/

  16. #416

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    Alguem esta tendo dificuldade em abrir a fazendinha do orkut



  17. #417

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    Boa tarde a todos!

    Segue nova versão do programa PCC, versão 1.3.
    http://www.saocarlosnet.com.br/downloads/pcc_1.3.zip

    OBS: pode ser necessário a instalação do midas.dll, segue abeixo link para o instalador do mesmo.
    http://www.saocarlosnet.com.br/downloads/Midas10.zip

    OBS:
    Nesta versão a estrutura do programa mudou bastante, foi adicionado loopback por link, multiplos dns reverso, etc.
    o código usado para loopback por link, foi exemplificado por Eduarlei, usuário do site Underlinux.com.br, portanto não sei dizer se funciona pois o mesmo não testei por não ter essa necessidade mas por pedido foi adicionado a função.

    OBS: ao excluir uma rede, antes de excluir a mesma deve-se excluir os loopbacks dos links, e depois o link para depois excluir a rede.
    é preciso fazer isso porque o programa ao excluir a rede, não exclui suas dependencias.
    erro este que já estou analizando para correção.
    caso não seja feito o que foi pedido acima, não vai aparecer menssagem de erro, mas ao adicionar uma nova rede a mesma vai aparecer com links, loopback, etc da rede anterios como sendo da atual que esta sendo criada.

    O sistema novo usa xml como base de dados, portanto não é precisso carregar configurações e posteriormente salvalas, pois o sistema abre e salva automaticamente.

    OBS: as configurações da versão 1.2 foram mantidas, e adicionadas as atuais, mas pode acontecer de uma ou outra função ter cido alterada, neste caso é só me alertar que eu corrigo.

    att.:Scan

  18. #418

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    já estou elaborando um manual para utilização da nova versão do programa, pois, pode seu um pouco confuso o manuseio do mesmo.



  19. #419

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    Bom dia a todos!

    Segue abaixo um simples manual do sistema.

    http://www.saocarlosnet.com.br/downloads/manual.zip

    att.: Scan

  20. #420

    Padrão re: Programa para Gerar Configuração do Balanceamento PCC

    Valeu Scan, baixando tudo e conferindo.
    obrigado