+ Responder ao Tópico

  1. Olha o script criado com 3 adsls, a marcação ficou errada na parte de per-connection-classifier...

    # ip address --------------------------
    /ip address add address=172.30.255.1/24 interface=OUT

    # interface pppoe-client --------------------------
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=LINK-1 max-mru=1480 max-mtu=1480 mrru=disabled name=LINK-1adsl password=USER profile=default service-name="" use-peer-dns=no user=USER
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=LINK-2 max-mru=1480 max-mtu=1480 mrru=disabled name=LINK-2adsl password=USER profile=default service-name="" use-peer-dns=no user=USER
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=LINK-3 max-mru=1480 max-mtu=1480 mrru=disabled name=LINK-3adsl password=USER profile=default service-name="" use-peer-dns=no user=USER

    # ip dns -------------------------------------------
    /ip dns set allow-remote-requests=yes


    # ip firewall Filter-----------------------------------

    # ip firewall nat---------------------------------------
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=LINK-1adsl
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=LINK-2adsl
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=LINK-3adsl

    # ip firewall mangle---------------------------------
    /ip firewall mangle add action=mark-connection chain=prerouting disabled=no in-interface=LINK-1adsl new-connection-mark=LINK-1adsl_conn passthrough=yes
    /ip firewall mangle add action=mark-connection chain=prerouting disabled=no in-interface=LINK-2adsl new-connection-mark=LINK-2adsl_conn passthrough=yes
    /ip firewall mangle add action=mark-connection chain=prerouting disabled=no in-interface=LINK-3adsl new-connection-mark=LINK-3adsl_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=LINK-1adsl_conn disabled=no new-routing-mark=to_LINK-1adsl passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=LINK-2adsl_conn disabled=no new-routing-mark=to_LINK-2adsl passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=LINK-3adsl_conn disabled=no new-routing-mark=to_LINK-3adsl passthrough=yes
    /ip firewall mangle add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=OUT new-connection-mark=LINK-2adsl_conn passthrough=yes per-connection-classifier=dst-address-and-port:2/0
    /ip firewall mangle add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=OUT new-connection-mark=LINK-3adsl_conn passthrough=yes per-connection-classifier=dst-address-and-port:2/1
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=LINK-1adsl_conn disabled=no in-interface=OUT new-routing-mark=to_LINK-1adsl passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=LINK-2adsl_conn disabled=no in-interface=OUT new-routing-mark=to_LINK-2adsl passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=LINK-3adsl_conn disabled=no in-interface=OUT new-routing-mark=to_LINK-3adsl passthrough=yes

    # ip route---------------------------------------
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LINK-1adsl routing-mark=to_LINK-1adsl comment="Link0"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LINK-2adsl routing-mark=to_LINK-2adsl comment="Link1"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LINK-3adsl routing-mark=to_LINK-3adsl comment="Link2"
    /ip route add comment="Link0" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LINK-1adsl scope=30 target-scope=10
    /ip route add comment="Link1" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=LINK-2adsl scope=30 target-scope=10
    /ip route add comment="Link2" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=LINK-3adsl scope=30 target-scope=10
    Uma dúvida nas regras onde se faz o new-routing-mark o passthrough que esta yes, não deveria estae no, pois comparando com o script do Wiki da Mikrotik nessa parte do PCC esta em no


  2.    Publicidade


  3. boa tarde rogeriodj!
    Tipo, realmente no wiki da mikrotik nessa parte do PCC esta em no, nas primeiras versões do programa esta opção estava no, mas no decorrer das versões algumas coisas foram modificadas na procura de melhorar o desempenho. "se não me engano esta modificação foi uma dica do Gsiena", assim como várias outras modificações, se vc comparar a risca o código do Wiki com este vc vai notar que tem mais coisas diferentes...

    qualquer coisa é falar ...
    t++

  4. blz JorgeAldo!
    Tipo, sei que não é aqui mas fazer o que né, eu testei o código para conexão e o mesmo não compila com a função MKTelnet.SSHLogin:= true; pois a mesma não recebe parametros mas retorna um booleano, tirando esta função o programa roda mas não funciona....

    OBS: quanto a fazer um Wizard, por que não, quanto mais ajuda melhor...

    t++

  5. Certo Scan, vc viu o pq o programa gerou o codigo errado, pois aqui usei 3 link adsls, 1 de 2mgs, 1 de 4mgs e outro de 8mgs, e o programa gerou somente para dois links iguais!!!

    Citação Postado originalmente por scan Ver Post
    boa tarde rogeriodj!
    Tipo, realmente no wiki da mikrotik nessa parte do PCC esta em no, nas primeiras versões do programa esta opção estava no, mas no decorrer das versões algumas coisas foram modificadas na procura de melhorar o desempenho. "se não me engano esta modificação foi uma dica do Gsiena", assim como várias outras modificações, se vc comparar a risca o código do Wiki com este vc vai notar que tem mais coisas diferentes...

    qualquer coisa é falar ...
    t++

  6. agora eu entedi o que vc quiz dizer, no post anterio entendi errado o que vc tinha dito...

    tipo, salva a configuração ai e me manda, pois acabei de fazer o teste aqui e fechou legal o código gerado..

    OBS: mas encontrei um erro, tipo ao alterar alguma informação a mesma não esta indo quando é gerado o código, aparece os dados anteriores e com isso o código gerado é errado, já estou verificando aqui para resolver este problema..

    t++




Tags para este Tópico

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L